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INTRODUCING MAYA: ESSENTIALS
Thank you for buying Maya—Alias|Wavefront’s award-winning computer
animation package. The following pages describe how to approach the Maya
documentation so you can learn and use your software most effectively.

About the Essentials book
Using Maya: Essentials provides a guide to the Maya user interface and basic
tools, and a general introduction to the Maya software. Using Maya:
Essentials covers the following:
•

Chapter 1, Working in Maya, describes how you do things in Maya. It shows
you how to use menus, shelves, hotkeys, and windows. It also introduces the
Hotbox and marking menus—two customizable tools for quickly accessing
menus and action.

•

Chapter 2, Viewing Your Scene, describes Maya’s XYZ coordinate system. It
also includes information on the various tasks you can perform using Maya
viewing tools.

•

Chapter 3, Editing Objects, describes how to edit objects in Maya. It covers
how to delete, select, instance, copy, group, and parent objects. It also
describes Maya’s undo, redo, and repeat functions.

•

Chapter 4, Transforming Objects, shows you how to scale, rotate, and move
your objects to position them in 3D space.

•

Chapter 5, Displaying Objects, describes the tools and actions you use to
display or hide objects and attributes. You can use these tools to customize
your working environment and reduce workspace complexity.

•

Chapter 6, Modeling Aids, shows you some of the modeling features you can
use to help you build and position objects.

•

Chapter 7, Managing Files and Projects, describes how to open and save files,
import and export files, how to create and edit projects, and what files
formats are supported by Maya.
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•

Chapter 8, Setting Environment Variables, explains the use of the Maya.env
file to set environment variables. It also lists the available Maya environment
variables.

•

Chapter 9, Using Maya Editors, describes Maya editors, including: several of
the General Editors, the Relationship Editor, the Attribute Editor, the
Channel Box, and the Outliner.

•

Chapter 10, Using the Hypergraph, shows you how to use the Hypergraph to
view the relationship between components of a scene graphically.

•

Chapter 11, Sets and Partitions, explains how to use sets (collections of objects
and components) and partitions (collections of related sets).

•

Chapter 12, Using Artisan Paint Tools, introduces the paint tools included in
Maya (formerly Artisan paint tools). The tools use an intuitive paint and
sculpting-based interface to deliver high quality and otherwise complex
results in minimal time.

•

Chapter 13, Script and Attribute Paint Tools, describes how to use the
advanced Artisan tools: Script Paint Tool and Attribute Paint Tool.

•

Chapter 14, Setting Preferences, describes preferences you can set to
customize Maya to the way you work. You can change general color
definitions, the way manipulators display, and the appearance of the Shelf,
menu bars, and panels.

•

Chapter 15, Customizing Shelves, Marking Menus, and Hotkeys, describes how
to tailor these tools to your own needs.

•

Chapter 16, Working with Panels and Layouts, shows you how to customize
your workspace using panels (areas in the main Maya window consisting of
interface elements) and layouts (groups of panels).

About the Maya documentation set
Whether you use Maya Unlimited, Maya Builder, or Maya Builder, you
receive a full set of documentation. Since Maya ties together several different
kinds of software, we’ve included a lot of different books to describe how to
use it.

Where do I begin?
The following paragraphs should help you decide where to start reading
and learning about Maya.
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1

When you install Maya Complete, Maya Unlimited, or Maya Builder, refer
to one of the installation guides for guidance.
For example, see Installing Maya 3.0 on Windows NT if you’re installing Maya
Complete or Unlimited on an NT or Windows 2000 system.

Important
In response to customer requests, we’ve changed the licensing procedure
in Maya 3.0, Please read the installation instructions from cover to cover,
even if you have installed previous versions of Maya.
2

If you’ve used Maya before and want an overview of new features, see
What’s New in Maya 3.
This booklet provides a summary of new features across all modules.
Next, you may want to review the Maya 3.0 Release Notes for brief
descriptions of limitations in the software and successful ways to work
around them.

3

If you’re a first-time Maya user, see Learning Maya for a comprehensive,
step-by-step tour of the Maya software before you read any other
documentation.
A CD included at the back of the book contains online documentation of the
tutorials as well as all required image and Maya support files. Additional
copies of this book are also available from your local technical bookstore.
The remaining documentation assumes that you have at least a working
familiarity with Maya, so it’s important to start with Learning Maya.

4

Now, you’re ready to move on to the Using Maya series.

The Using Maya series
The Using Maya books describe how you can use Maya’s user interface to
create professional 3D graphics animations and visual effects. Each book is
devoted to a different area of the software.
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The Using Maya series includes these books:
Essentials

provides a guide to Maya’s user interface and basic tools. Using Maya:
Essentials also defines a number of concepts that are common to all of Maya.
Using Maya: Essentials was called Using Maya: Basics in previous releases.

NURBS
Modeling

describes Maya's spline modeling system and tells you how to get the most
out of it.

Polygonal
Modeling

describes how to interactively create, modify, and color polygonal models.

Subdivision
Surfaces
Modeling

describes the enhanced subdivision surfaces modeling tools which are
available only in Maya Unlimited.

Character Setup

tells how to use Maya’s deformer, skeleton, skinning, constraint, and
character features.

Animation

describes Maya's basic animation software, which is based on keyframes and
motion paths. This book also provides information on motion capture and
introduces other Maya animation techniques, such as character setup.

Dynamics

describes how to animate using natural forces. You can use dynamics to
make effects such as tumbling dice, waving flags, and exploding fireworks.

Rendering

describes how to prepare for rendering, render a scene, and view your
rendered images. This book also describes how to create light, shadow, and
light effects, shade and texture surfaces. It also tells you how to set up
cameras and views and create a background. The information in Using Maya:
Rendering is arranged by production task.
The online book, Maya Reference: Rendering describes Maya’s renderingrelated menu options, attributes, and windows. The information in this book
is organized around the user interface

Paint Effects

describes how to use Paint Effects to paint real-time rendered strokes onto or
between 3D objects or onto a 2D canvas.

Cloth

describes how to create and animate realistic clothing using Maya
Unlimited’s Cloth software. This book includes four tutorials to get you
started, as well as a complete user’s guide.

USING MAYA: ESSENTIALS
xxiv

Fur

describes how to use Maya Unlimited Fur to create realistic, self-shadowing
fur and short hair on multi-surface models.

Live

describes how to use Live, Maya Unlimited’s automated match-moving tool.
You can use Live to match Maya scenes with live footage by reconstructing
3D locations and camera or object movement from a shot.

The Maya Technical Library
When you’re ready to use Maya to its fullest potential, you’ll want to explore
the technical library. These documents tell how to use Maya’s powerful
command language and expressions. They also provide information that will
help you use Maya with other software packages.

Note
The books in the Maya Technical Library are not included in a printed
document set. However, html files for all of these documents are provided
on your product CD for online viewing. PDF files are also provided unless
otherwise specified.

MEL

describes how to use the Maya Embedded Language (MEL) to enter
commands and write scripts.

MEL Command
Reference

includes technical descriptions of the individual MEL commands. MEL
commands are provided in html format only, no PDF files are supplied.

Expressions

describes how to use expressions to control attributes. Expressions are ideal
for controlling attributes that change incrementally, randomly, or
rhythmically over time. They are also useful for linking attributes between
different objects—where a change to one attribute affects the behavior of the
other.

DG Node
Reference

is for technical users who want more information on the DG node attributes.
The DG Node Reference is provided in html format only, no PDF files are supplied.
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Maya File Formats

is for technical users with programming experience who want to either edit
Maya files or write translators to or from the Maya file formats.

Maya Developer’s
Tool Kit

describes how to use the Maya API to load, write, and edit plug-ins. This
book includes instructions for creating your own plug-ins. The Maya
Developer’s Tool Kit also features on-line links to example plug-ins.

Maya Translators

is for people who are bringing data into Maya or exporting data to other
software packages.

Maya Game
Translators

describes how to install and use Maya game translators. Information is
provided for VRML2 and GE2, as well as the RTG file format. This book also
includes information on using the MDt API.

Rendering Utilities

describes how to use command-line and stand-alone utilities that are part of
Maya, such as fcheck, as well as the options for the command line renderer.
Rendering Utilities was called Utilities in previous releases.

Using Maya’s online documentation
For your convenience, the Maya documentation is online in html format.
(This help requires version 4 or higher of either Netscape Communicator or
Internet Explorer.) We include the complete Maya Unlimited documentation
set, no matter what version of the software you have purchased.
Printing online books
To allow you to print copies of the documentation, we’ve provided PDF files
of most documents. These files require the Adobe Acrobat reader.
To print the online books, insert your Maya CD, navigate to the pdf
directory, and open library.pdf.
The Glossary
For 3.0, we’ve provided an online glossary so you can look up meanings of
words you encounter which are new or confusing.
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Search tools
Due to customer requests, we’ve provided an enhanced Library search tool
in Maya 3.0. You can use the Library Search tool without installing the
documentation files on a server. To access the Library Search tool, return to
the main Maya Library page and select Library Search.
A Book Search tool is also provided in the left frame of most books. Use this
tool to look for an item in the book you are viewing currently.
Online indexes
When you are viewing a specific book, you can access that book’s index. You
can also use the Global Index to view entries throughout the document set
(except the MEL Command Reference and the DG Node Reference.)

Using Maya’s printed documentation
A complete printed documentation set includes the following
documentation:
•

Installing Maya — describes how to install and license your software

•

Learning Maya — provides comprehensive step-by-step tutorials

•

Maya Release Notes — lists limitations in the software and suggests
workarounds for them

•

What’s New in Maya — describes the new features we’ve added for this
release

•

Maya Quick Reference Card — a guide to Maya’s most frequently used
keyboard shortcuts. The Quick Reference Card also outlines the steps you
use to create your own hotkeys.

•

Troubleshooting Rendered Images — a quick reference card to help you
identify problems with rendered images

•

Books in the Using Maya series — as listed on page xxiii

•

Maya Global Index for print —which provides page numbers for entries in the
printed document set. This book is different from the online index.
Printed documentation conventions
The printed documentation follows these conventions:
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•

MEL commands, program code, expressions, and error messages appear in
courier font:
This is computer code

•

Items in cascading menus are identified by an arrow. For example, “select
Particles > Make Collide” means “select the Add Goal option from the Make
Collide menu.”
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WORKING IN MAYA
Throughout Maya you’ll find a consistent interface and a style of working
that is both fast and easily customizable. This chapter presents these
methods of working so you can quickly launch into your projects.
•

“Starting Maya” on page 2

•

“Main window” on page 4

•

“Maya workspace” on page 9

•

“Streamlining the interface” on page 12

•

“Working with objects” on page 13

•

“Working with tools and actions” on page 17

•

“MEL commands” on page 20

•

“Using the Hotbox” on page 20

•

“Using marking menus” on page 25

•

“Scene management” on page 28

•

“Getting help” on page 29
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STARTING MAYA
You can start Maya by either double-clicking the Maya desktop icon or by
typing maya at a command prompt. On Windows NT, you can also select
Start > Programs > Maya (Complete or Unlimited) 3.0 > Maya.

Command line options
If you start Maya from the command line, there are various startup options
you can specify. For example, you can open a file at startup using the -file
flag:
maya -file filename

To see the available startup flags, type the following:
maya -help

To execute Maya commands without the interface, use either -prompt or batch. The -prompt flag issues a MEL prompt for you to type commands.
Type quit to exit the prompt mode.
Use the -batch flag to run commands without user input, such as in shell or
batch scripts. The -batch flag starts Maya, executes any commands you
specify, and then close Maya. For example, you could create a script to open
a file from a prior version of Maya in order to update it to the current
version:
maya -batch -file someMayaFile.ma -command "file -save"

Notes
The -batch command is not used for batch rendering. Instead, use the
Render command. However, -batch does check out a render-only license
instead of a full Maya license.
On Windows NT, type mayabatch when using the -batch flag. The mayabatch
command runs within the command prompt window, whereas the maya
command starts a separate window.
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Running prior versions of Maya
In some cases, you may want to run a prior version of Maya. On Windows
NT, simply choose the prior version from the Start menu.
On IRIX, you need to use a symbolic link pointing to the installation
directory of the prior version. To add a symbolic link, log in as root and type
the following commands:
cd /usr/sbin
ln -s /usr/aw/mayaX.X/bin/maya mayaXX

where XX is the version number. Now you can type mayaXX to run the prior
version.

Environment variables
At startup, Maya uses a number of environment variables to set the
environment. Many of the variables are included in the Maya program and
are set automatically when you start Maya. To configure Maya further, you
can set additional environment variables. See Chapter 8, “Setting
Environment Variables” for more information.
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MAIN WINDOW
Read this section for a brief summary of the main interface elements. As you
read, keep in mind the following:
•

The critical part of the interface is in the workspace panel; see the next topic,
“Maya workspace” on page 9 for details.

•

You can hide all the interface elements and instead use Maya’s quick
command features: the Hotbox, Marking Menus, and hotkeys. For an
introduction to this topic, see “Streamlining the interface” on page 12.
Title bar

Shelf

Channel Box

Menu bar
Status Line
Minibar
Layer bar

Workspace

Time Slider
Range Slider
Command Line
Help Line
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Menu Bar
The menus in Maya are grouped into menu sets. Each menu set corresponds
to a module of the software: Animation, Modeling, Dynamics, and
Rendering. Maya Unlimited has additional modules: Cloth and Live. As you
switch between menu sets, the right-hand menus change, but the leviathan
menus remain the same; these are the common menus.
To switch between menu sets, use the Status Line pull-down or hotkeys. The
hotkeys are: F2 (Animation), F3 (Modeling), F4 (Dynamics), and F5
(Rendering).

Select the
area you want
to work in
... and see these menus change

... while the common menus stay the same

Status Line
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The Status Line has a variety of commands, mostly used for modeling. For
example, the central group of buttons are used to select objects and
components. See “Working with objects” on page 13 for an introduction to
this topic. Also see Chapter 6, “Modeling Aids,” which describes most of the
options on the Status Line.
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For better organization, the buttons are broken into groups that you can
expand and collapse, as shown in the following illustration.

Click the arrow bar to expand

Click the expanded bar to collapse

Minibar and Shelf
The Minibar and Shelf work together. The Minibar contains common tools as
well as the currently selected tool. The Shelf is a collection of tools and other
commands that you can customize for your specific needs.
By creating custom shelves, you can organize commonly used actions and
tools into groups. For example, you can create modeling, animating, and
rendering shelves with appropriate tools and actions for each option. You
can also store the same tool more than once, but with different settings. For
information on creating, editing, and deleting shelves, see “Creating and
editing shelves” on page 493.
To switch between shelves, click the tab icon, as shown in the following
illustration.
Click to switch between shelves

Pull down menu for shelfrelated options
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Layer Bar
Layering is a method of grouping objects so you can easily hide them from
view, use them as a template, or render them in a separate pass. The Layer
Bar provides the main controls for creating layers, adding objects to layers,
and making layers visible or invisible. See “Using display layers” on page
139 for more information.
Note that the Layer Bar is hidden by default; you can display it by choosing
Display > UI Elements > Layer Bar.

Workspace
The main purpose of the workspace is to view your scene, but that’s not all.
You can also display various editors and arrange the workspace panels in
different layouts. For further discussion, see the next topic “Maya
workspace” on page 9.

Channel Box
Most of Maya’s interface elements are common to 3D software packages, but
the Channel Box is a unique and powerful feature. It gives direct access to
the building blocks of Maya: attributes and nodes. Specifically, it shows the
keyable attributes, also known as channels. (A keyable attribute means you
can set animation keyframes for it.) For further discussion, see “Object
attributes” on page 15.

Time and Range Sliders
The two sliders are for controlling the frames in your animation. The Time
Slider includes the playback buttons (also called transport controls) and the
current time indicator. The Range Slider includes start and end times,
playback start and end times, the Range Slider bar, the Auto Key button, and
the Animation preferences button.
For information on using the animation controls, see Using Maya: Animation.
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Time Slider

Current time indicator

Range Slider

Playback end time

Current character
End time

Start time
Playback start time

Playback buttons

Auto Key button

Animation preferences button

Command Line
Another powerful feature of Maya is the MEL command language, and the
Command Line is your pipeline to it. Notice that it has two halves.

Enter MEL command with required arguments

Command response

The left side is where you can type MEL commands. For example, you can
type a command to quickly create a sphere with a specific name and radius.
For a longer series of commands, use the Script Editor, which you can
launch from the icon on the far right.
The right half displays system responses, error messages, and warnings. It
can also show echoes of all commands if you turn on Edit > Echo All
Commands from the Script Editor.

Help Line
Like several other applications, you can look at the help line for descriptions,
instructions, and other useful information. For full details, see “Help Line”
on page 30.

Main window and floating windows
Maya has several editors that launch as floating windows separate from the
main window. To manage these windows, note the following tips.
On IRIX, use Window > Raise Application Windows to display open
windows hidden by the main window.

USING MAYA: ESSENTIALS
8

PART 1

WORKING IN MAYA | 1
Maya workspace

On Windows NT, floating windows stay on top of the main Maya window
by default. In order to bring the main window on top, you can detach each
floating window from the main window. Click the icon in the upper-left
corner of the floating window ( ) and turn off Attach to Main Window.
Tear-off menus
You can display menus as separate windows. This is helpful when you use a
menu repeatedly. Pull down the menu and click the tear-off line at the top.
The tear-off menus always display on top.
Click here to
tear off menu

Drag the
window to a
new location

MAYA WORKSPACE
The main purpose of the workspace is to view your scene, but that’s not all.
You can also display various editors and arrange the workspace panels in
different layouts.
Most of the commands for using the workspace are on the menu bar at the
top of the workspace panel. In particular, the Panels menu contains
commands for changing views, displaying editors, and arranging panel
layouts.

BASIC FEATURES
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Viewing your scene
The view panel is really the view seen through a virtual camera. There are
four default views: perspective, front, side, and top. Select a view from the
Panels menu.
To look around the scene, you move the camera. The main commands are
shown in the following table:

Hold

Drag

To...
Tumble

Alt
L

(Tumbling does not work
in orthographic windows.)
Alt

Track
M

Dolly

Alt
L M
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Hold
Ctrl

Drag

To...
Bounding Box Dolly

+ Alt
L

Drag right to dolly in and
left to dolly out.
This navigation is available in several editors too, like the Graph Editor and
Hypergraph. Additional view commands are available under the View
menu.
Layout options
You can split the workspace into a multi-panel layout. For example, press
and release the Spacebar to switch to the default, four-panel layout. (Press
and release the Spacebar again to expand the active panel to full screen.)

In addition, you can display various editors in any panel, giving you the
capability of arranging layouts to suit a specific workflow. Default layouts
are listed under the Panels > Saved Layouts submenu. You can also use the
Panels editor (Panels > Panel Editor) to create your own.

BASIC FEATURES
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STREAMLINING THE INTERFACE
You can easily customize the Maya interface to suit your work style. One of
the recommended ways of streamlining the interface is to hide the interface
elements like menus and tools and devote more space to your scene
window.
To hide or display elements, use the Display > UI Elements submenu. You
can quickly hide all UI elements except the workspace panels by choosing
Display > UI Elements > Hide UI Elements. For example, you can maximize
the scene view while working on detailed models.
In place of menus and toolbars, use hotkeys, the Hotbox, Marking Menus,
and popup menus. The following are descriptions of each.
Hotkeys

Hotkeys are also known as keyboard shortcuts. There are several default
hotkeys, and they appear on the menu label next to the corresponding menu
command. You can change these hotkeys and assign new ones using the
Hotkey Editor (Window > Settings/Preferences > Hotkeys). For information
on assigning hotkeys, see “Assigning hotkeys” on page 526.

Hotbox

The Hotbox is a way to quickly navigate the Maya menus without using the
menu bar. It pops up when you press and hold Spacebar. It puts all of the
Maya menus in quick reach, instead of at the top of the screen. Unlike the
main menu bar, you can control which menu sets display in the Hotbox. For
details, see “Using the Hotbox” on page 20.

Marking Menus

Like the Hotbox, Marking Menus are a pop-up menu that puts commands in
quick reach, including commands not on menus. For example, with nothing
selected, you can right-click in the workspace and choose Select All. You can
also modify Marking Menus to suit your workflow. For details, see “Using
marking menus” on page 25.

Pop up menus

Several Maya editors display popup menus when you right click in them.
Typically, they include commands from that editor’s menu. For example, the
popup menu in the Outliner gives you controls for what types of
information display.
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WORKING WITH OBJECTS
The scenes you create in Maya consist of objects, and objects consist of
components, such as control vertices (CVs), edit points, patches, polygonal
faces, and so forth.
In Maya, you work with objects in either object or component selection
mode. Object mode is the default and is for manipulating objects as a whole.
Component mode displays and lets you edit the object’s components. You
switch between object and component mode from the Status Line. You can
also switch between modes with the hotkey F8.
The following illustration shows a torus in object mode and the same torus
modified by moving CVs in component mode.

Object mode

Component mode

Selection masks
To select just the object or component types you want to edit, you use
selection masks, also called pick masks. Pick masks are available on the Status
Line and also as Marking Menus when you right click on an object.
For example, right click on a NURBS sphere, choose Control Vertices from
the Marking Menu, and the CVs display for you to edit.
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For more information, see “Limiting selections” on page 157.

Object display
By default, objects appear in wireframe display. To view objects with shaded
surfaces, choose a shade mode from the Shading menu on the view panel.
The hotkeys for these options are shown in the following table:
4

Wireframe

5

Smooth Shade

6

Smooth Shade with Hardware Texturing

For NURBS objects (objects created from NURBS curves), you can also
control how smooth the surface appears using the commands under Display
> NURBS Smoothness. (This affects display only, not how the object
renders.) The hotkeys are in the following table:
1

Rough

2

Medium

3

Fine

For more information on object display, see Chapter 5, “Displaying Objects.”
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Object attributes
All object and component characteristics are stored as attributes. When you
model, animate, assign materials, and do any kind of manipulation on
objects, you are changing attribute values.
You can see and edit attributes directly in the Channel Box or the Attribute
Editor. The Channel box contains the keyable attributes for one or more
objects. The Attribute Editor contains all attributes for any single object.
Entering values
A simple example of working with object attributes is to change its
translation. In the Channel box, the Translate X, Y, Z attributes appear at the
top. To quickly position an object at the coordinates 1, 1, 1, select all three
attributes, type 1, and press Enter. (In general, typed values do not go into
effect until you press Enter or exit the field.)
Using the
Channel box
to change
translate
attributes

Note
When you change values, Maya inserts characters by default. On Windows
NT, you can also overtype (replace existing characters) as you type. Press
the Insert key for overtype mode.
Numeric Input field
An alternative way to enter values for moving, scaling, or rotating is to use
the Numeric Input field in the Status Line. Enter the numbers in the order of
X-axis, Y-axis, and Z-axis, with a space between each number. (Do not use
any punctuation between the numbers.) You can enter positive and negative
real numbers.
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Numeric Input field
on Status Line

For more information on using the Numeric Input field with the
transformation tools, see “Entering numeric values” on page 95. Also see
“Selecting objects by name” on page 55 for information on using the
Numeric Input field to select objects.

Attributes and nodes
As you work with attributes, you need to be aware of Maya’s node
architecture. Unlike other software packages, Maya lays bare its underlying
programming structure. The building blocks are nodes, which are groups of
related attributes. For example, the attributes describing an object’s
transformation are in a transform node.
Why should you care about nodes? At a minimum, simply be aware that
attributes are grouped together in this way. In general, nodes fall into one of
these types: transform (object position), shape (component positions), input
(object construction), and shading (object materials).

Transform
node

Shading
node

Shape
node

Input
node
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With more experience, you can take advantage of nodes to make your own
connections. For example, you could link the animation of two orbiting
spheres by connecting the rotation attributes of those objects’ nodes.
For more information, see Chapter 10, “Using the Hypergraph.” (The
Hypergraph graphically depicts the objects and nodes in your scene so you
can easily examine and modify connections.)

WORKING WITH TOOLS AND ACTIONS
We’ve described how you can edit object attributes by typing values, but
you’ll do most of your object manipulation using tools and actions. An
example tool is the Move tool, which translates objects. An example action is
Edit > Duplicate. The distinction is not crucial, but you should know how
each works.

Using actions
An action refers to the standard software operation of picking an object, and
selecting a menu item to perform an action. For example, if you want to
create a revolved surface, first select the profile curve you want to use, then
select Revolve from the Surfaces menu.
In Maya, many of the actions you perform have associated options. For
example, you may want to set the pivot point before you revolve the curve.
To set options, first open the option box (if available). Option boxes appear
as a square to the right of the menu label (❐). When you have completed the
option box, click the action button or Apply button at the bottom.
Most of the settings in option boxes correspond to object attributes, so you
can edit them later as well.

Tip
You can return to the factory option settings by choosing Edit > Reset
Settings in the option box menu.
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Using tools
Working with tools in Maya is like working with a real artist’s tool. You pick
the tool and manipulate items with it until you complete the operation.
There are visual cues to let you know that you have picked a tool:
•

the word Tool appears on the menu label

•

the tool is highlighted on the Minibar, next to the Shelf

•

in most cases, the cursor changes or a manipulator appears around the object

•

instructions appear on the Help Line to guide you through the operation

CV Curve tool help

Tools have options you can set to control their behavior. Like actions, there
is a box to right of the menu label that opens a window with all the options.
You can also double-click icons on the Maya window’s Minibar to display a
settings window for the tool represented by that icon. For instance, if you
double-click the following icon in the Minibar, Maya displays a settings
window for the Rotate tool:

Double-click here to display a settings window for the Rotate tool.
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Manipulators and handles
Many tools have manipulators for modifying objects. All of the transform
tools, for example, have manipulators with three handles—one for each axis.
Manipulator handles are typically used to control the direction of
transformation. For example, you can click on just one handle of the Move
tool to constrain movement to that axis. This is the active handle and it is
colored yellow. For more information on transform manipulators, see “Using
manipulators” on page 72.
Y handle
Center handle
X handle

Z handle

Some objects have manipulators associated with them. For example, cameras
and lights have manipulators to control their center of interest and other
settings. These manipulators also have a Cycling Index. You can click the
Cycling Index to cycle through the available manipulator controls.

Pivot
Clipping Panes

Center of Interest

Clipping Panes

Cycling Index
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For more information on displaying camera and light manipulators, see
“Displaying camera and light manipulators” on page 137. For information
on using manipulators to modify an object’s construction history, see “Using
the Show Manipulator tool” on page 91.

MEL COMMANDS
MEL is Maya's scripting language. Here are some examples of things you
can do with MEL:
•

Use MEL commands to bypass Maya's user interface, quickly create
shortcuts, and access advanced features.

•

Enter exact values for attributes, bypassing any restrictions to precision
imposed by the interface.

•

Customize the interface for specific scenes, changing default settings to
settings you prefer for a particular project.

•

Create MEL procedures and scripts that carry out custom modeling,
animation, dynamics, and rendering tasks.
There are several ways to enter MEL commands; using the Script Editor or
Command Line are the most common. You can also execute commands in
script files, .ma files, shelf icons, hotkeys, and expressions.
See Using Maya: MEL for an introduction to using MEL commands and
scripts.

USING THE HOTBOX
The Hotbox is a customizable collection of menu sets that you can make
appear by holding down the Spacebar on the keyboard. Once you customize
the Hotbox, it provides quick access to the menus you use, hiding menus
that are irrelevant to your work. You can customize the Hotbox at any time
to accommodate changing needs.
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The Hotbox has five zones: North, South, East, West, and Center. They are
defined by diagonal lines.
North zone

East zone

West zone
Center zone

South zone

Each zone contains marking menus. Use these menus to change selection
masks, control panel visibility, and panel types. For information on marking
menus, see “Using marking menus” on page 25.
To display the Hotbox:
Press and hold the Spacebar. The Hotbox appears at the location of the
pointer. The default Hotbox looks like the following (if you customized it, it
will look different):

Common menus
Panel menus (depends
on the active panel)
Recent main menu
selections
Functional menu set(s)
Used to customize
Hotbox appearance
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Note
If you press the Spacebar briefly but do not hold it down, Maya changes
the number of views displayed. For example, if you are in a perspective
view, then press the Spacebar, Maya displays the four basic views.

Displaying recent selections
The Hotbox lets you display up to 16 previously selected menu items (also
available from Window > Recent Commands). This saves working through
hierarchial or cascading menus and lets you quickly repeat a selection. (To
display more than 16 menu selections, use a MEL script. For more
information, see Using Maya: MEL.)
Click here

Select recent
command
here
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Changing the appearance and contents of the Hotbox
You can change the appearance and the contents of the Hotbox while you
are working. While pressing the Spacebar, click Hotbox Controls and drag to
select an option.

Customizing which menus show in the Hotbox
The top portion of the Hotbox Controls lets you choose which menu sets you
want to appear. For example, choose Show Animation > Show/Hide
Animation to turn on or off the Animation menu set display. You can also
hide all menu sets except the one you want displayed; for example, choose
Animation Only.

The display controls for other menus are in the bottom portion of the Hotbox
Controls, including menus for Maya Cloth and Live.
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Changing the transparency
You can make the Hotbox more or less transparent. Select Hotbox
Controls > Set Transparency and choose a new percentage.

Changing the style of the Hotbox
Use the Hotbox Style option to change the display of the Hotbox. Select
Hotbox Controls > Hotbox Style and drag to select one of the following
styles:
Zones and Menu Rows

Make all of the menu rows visible.
Zones Only

Display just the five marking menu zones. Menu sets are not available.

Center Zone Only

Make only the center zone (A|W) active everywhere. North, South, East,
and West Zones and menu sets will not be available.

Center Zone RMB Popups

Turn this option on to display menus for the selected menu set when you
right-click on the workspace. The menu set appears as a pop-up instead of a
row. Note that the functional menu sets do not display when this option is
on, even if you have selected to show them.
Setting window options from the Hotbox
To increase your screen space, you can hide the main and view menu bars
and use the Hotbox menus instead. Select the Hotbox Controls > Window
Options submenu and turn off Show Main Menubar or Show Pain
Menubars.
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Disabling the Hotbox
You can disable the Hotbox so it does not appear when you press the
Spacebar.
To disable the Hotbox:
1

Select Window > Settings/Preferences > Hotkeys. The Hotkeys window
opens.

2

Scroll down to the Miscellaneous section (near the bottom of the window).

3

Under Miscellaneous, select Pop Hotbox, then click the Unmap Key button.
Maya changes (Space) to (none) and removes the word Press from the
window. This turns off the hotkey functionality.

4

Click the Save button, then the Close button. Now when you press the
Spacebar, the Hotbox does not display.

USING MARKING MENUS
Marking menus are customizable menus that let you quickly access various
tools and actions. You can use them from any part of the Maya workspace.
You can display marking menus by doing any of the following:
•

Clicking in each zone in the Hotbox. (See “To use a marking menu in the
Hotbox:” on page 25.)

•

Pressing hotkeys and the left mouse button. (See “To use a marking menu
with a hotkey:” on page 27.)

•

Clicking in the workspace with the right mouse button. (See “To use a
marking menu with the right mouse button:” on page 28.)
You can customize marking menus to run scripts you have written. For
information, see “Creating and editing marking menus” on page 509.
To use a marking menu in the Hotbox:

1

Press and hold the Spacebar. Maya displays the Hotbox.
The Hotbox has five zones: North, South, East, West, and Center. They are
defined by diagonal lines. (For an illustration, see “Using marking menus”
on page 25.)
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2

Still holding down the Spacebar, left click in a zone then drag to select a
menu item and release the Spacebar.
In each of the five zones, the Hotbox supports a different marking menu for
each mouse button. This lets you create three menus per zone, for a total of
fifteen marking menus and approximately 120 selections.
You can customize a marking menu using the Marking Menu editor. For
more information, see “Creating and editing marking menus” on page 509.
Default marking menus
The following marking menus are the default settings for each of the five
zones.

North zone

Changes to a new window layout.

South zone

Changes a view in the current panel.

East zone

Turns parts of the interface display on and off.
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West zone

Switches between preset selection masks.

Center zone

Switches between views.

To use a marking menu with a hotkey:
Many hotkeys have a marking menu associated with them. For example, the
default hotkey “w” is associated with the Move tool.
1

Select an object.

2

Press and hold the hotkey on the keyboard, then click the left mouse button.
For example, when you press the w key, the following menu appears.

3

Drag to make your selection then release the hotkey.
If you choose the Translate XYZ option, the move tool’s center handle is
selected. You can then move the object anywhere within the view plane. If
you choose the Translate X, Translate Y, or Translate Z option, the move
tool’s appropriate handle (either X, Y, or Z) is selected.
For more information on using marking menus with hotkeys, see “Assigning
marking menus to hotkeys” on page 515.
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To use a marking menu with the right mouse button:
1

If you have not selected an object, press the right mouse button to display a
pop-up menu.

2

Choose Select All.
or
If you have selected an object, press the right mouse button anywhere in the
view.
The type of object you are working with determines which marking menu
appears. For example, in the following illustration, a polygonal cylinder is
selected.

SCENE MANAGEMENT
Throughout Maya, there are various features for organizing the elements in
your scene and for optimizing the scene file size. The following list
summarizes some of the main scene management features.
Groups

You can group objects for quick selection and manipulating them as a whole.
See “Working with groups” on page 63.
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Sets and Partitions

Sets are like groups, but they have the advantage of working with
components as well. A partition is a collection of sets. It is used primarily to
prevent two sets from having overlapping members. See Chapter 11, “Sets
and Partitions.” Note that other Maya features, such as the Character >
Create command, utilize sets as a way of grouping objects.

Layers

Layering is a method of grouping objects so you can easily hide them from
view, use them as a template, or render them in a separate pass. The Layer
Bar provides the main controls for creating layers, adding objects to layers,
and making layers visible or invisible. See “Using display layers” on page
139 for more information.

Scene optimization Before you save, we recommend that you optimize scene size for improved

performance, memory use, and reduced use of disk space (File > Optimize >
Scene Size ❐). For details, see “Optimizing scene size” on page 212.
Deleting construction history (if you have it enabled) is recommended when
you finish modeling and are ready to animate. (Construction history, as the
name implies, is a record of the information used in constructing an object.)
To delete it, select the object and choose Edit > Delete by Type > History.
You may want to avoid construction history altogether to optimize
performance. To do this, click the Construction off in the Status Line.

GETTING HELP
There are various types of online help provided with Maya.
Popup Help
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When you pass your mouse over an icon or button, a description of it
appears. This feature is on by default, but you are able to disable it (Help >
Popup Help).
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Help Line

The Help Line at the bottom of Maya’s window shows information about
tools, menus, and objects. Like the popup help, it displays descriptions when
you pass the mouse over icons, as well as menu items. It also displays
instructions when you select a tool; for example:

When you transform objects, the Help Line displays the object coordinates;
for example:

X axis

Y axis

Z axis

Product Information Choose Help > Product Information to see Maya’s version and release date.
Online Library

Also under the Help menu are selections for the online documentation
library. This help requires version 4 or higher of either Netscape
Communicator or Internet Explorer. Several of these documents are
available in printable PDF format, readable from the Maya CD-ROM.

Help on...

For some Maya editors, you can open help about the editor directly by
choosing Help > Help on EditorName.

Find Menu

To find the location of a main menu item, choose Help > Find Menu and
type the menu item name. The search is not case-sensitive. It accepts
wildcard characters (*), but if the menu was renamed or removed, type the
name in full. The search is limited to the main menu selections.
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VIEWING YOUR SCENE
This chapter describes Maya’s XYZ coordinate system. It also includes
information on the various tasks you can perform using Maya viewing tools.
Additionally, it explains how to hide nodes to improve Maya’s playback
speed.
The following topics are described in this chapter:
•

“Orienting the XYZ system” on page 31

•

“Working with cameras” on page 34

•

“Setting a perspective view” on page 40

•

“Setting an orthographic view” on page 41

•

“Lighting your scene” on page 42

•

“Arranging views” on page 43

•

“Marking a view” on page 47

•

“Enabling and disabling nodes” on page 49

ORIENTING THE XYZ SYSTEM
Maya’s 3D coordinate system lets you create characters and scenes with
dimensionally accurate values. In the XYZ coordinate system, the origin is
the center with coordinates 0,0,0. All points are defined by one coordinate
along the X-axis, the Y-axis, and the Z-axis. You can orient the XYZ
coordinate system in either Y-up or Z-up.

Y-up
A Y-up world has X set up as the horizontal and Z as the depth of the scene.
This orientation is often used by animators (and games developers) who
have evolved from the 2D world of vertical (Y) and horizontal (X) to include
movement toward or away from the camera (Z).
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Y-up character model

Y-axis

X-axis

Z-axis

Z-up
A Z-up world begins with a ground plane that represents the X and Y
directions, with Z representing the up direction. This orientation is used by
designers, whose main concern is the ground plane where their plans are
placed.

Z-up character model

Z-axis

Y-axis
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Changing the orientation/up axis
You can change the scene orientation in the preferences or with a MEL
command. Note that, along with changing the up axis, every menu action or
tool has an equivalent line command.
To specify the scene orientation in the preferences:
1

Select Window > Settings/Preferences > Preferences, Settings category.

2

Under World Coordinate System, select Y or Z.
To specify the scene orientation with a MEL command:

1

To change the orientation to Z-up, enter the following in the Command line:
upAxis -ax z

2

To change the orientation to Y-up, enter the following in the Command line:
upAxis -ax y

For more information on using MEL commands, see Using Maya: MEL.

World coordinates
World coordinates represent space in the view. For example, when you
move a camera you move it in terms of world coordinates. The center of the
world coordinate system is located at the Origin.
World space is a coordinate system used to represent an object in terms you
define. For example, a model car might be defined in terms of millimeters.
World coordinates are also known as “modeling coordinates.”

Local coordinates
Local coordinates represent the space around an entity. The origin of a local
coordinate system is the center of that entity.
One way to understand local coordinates is to imagine an object sitting
within a box. All of the points on the object’s surface are then given with
respect to one corner of the box. If you pick up the entire box and move it
around the room, the coordinates of the object—with respect to the box—do
not change: the coordinates of the box with respect to the room are changing.
Focus on the two different descriptions: the object with respect to the box
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(the object’s local coordinates), and the box with respect to the room (the
position of the object’s coordinate system with respect to the world
coordinate system).

WORKING WITH CAMERAS
In Maya, you are always looking through a camera for either perspective or
orthographic views. Think of it as being a director on a movie set and looking
through a camera lens. Your field of view is restricted to what you can see
through that lens. If you wanted to view the scene from another angle, you
could move the camera you are looking through, but then you would have
to move it back again. Instead, you could create, orient, and look through a
second camera.
It’s the same in Maya. Whatever part of a scene you see depends on the
camera you are looking through. You can also use the Look Through
Selected option to look through a light or object. For example, if you look
through a light you can display its exact area of illumination. You could also
select an object such as a character’s eyes and animate a scene through their
view.
When setting up output resolution, aspect ratio, and image planes, you
should be aware of what each setting on the camera represents and how it
relates to the real world.
Focal length
The focal length of a lens is defined as the distance from the lens to the film
plane. The shorter the focal length, the closer the focal plane is to the back of
the lens. Lenses are identified by their focal length. Focal length is expressed
in millimeters or, on occasion, in inches (1 inch is approximately 25mm).
For every shot, you must decide how big an object is in the frame. For
example, should a shot include an entire character or just its head and
shoulders? There are two ways to make an object larger in the frame. You
can either move the camera closer to the object or adjust the lens to a longer
focal length.
Focal length is directly proportional to the object’s size in the frame. If you
double the focal length (keeping the distance from the camera to the object
constant), the subject appears twice as large in the frame. The size of the
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object in the frame is inversely proportional to the object’s distance from the
camera. If you double the distance, you reduce the size of the object by half
in the frame.
Angle of view
As you adjust the camera’s focal length, the angle of view narrows and
expands. This is what causes objects to get larger or smaller in the frame. As
you extend the focal length, the angle of view gets narrower. As you shorten
the focal length, the angle of view gets larger.
Perspective
Since there are two ways to change the size of objects in the frame, what is
the difference between moving the camera and changing the focal length?
Why choose one over the other? The answer is that by moving the camera,
you change the perspective. Objects far from the camera change in relative
size at a slower rate than objects which are close to the camera. When you
change the focal length, or zoom, perspective does not change. All objects in
the frame change size at the same rate. Perspective could be thought of as
the rate that objects change in size in the frame as their distance from the
camera changes.
Camera aperture
In a real camera, aperture is the film back’s width and height in millimeters.
The camera aperture relates to the focal length in that different film backs
have different “normal” lenses. A normal lens has a focal length that is not
telephoto or wide angle. It closely approximates normal vision. As the size of
the camera aperture increases, a longer focal length is required to achieve
“normal” perspective. For example, a 35mm camera uses a 50mm lens as a
normal lens. On a 16mm camera, the same 50mm lens appears telephoto in
nature. A 25mm lens is required to achieve “normal” perspective on a 16mm
camera.
This can be demonstrated in Maya by changing to different film backs
without changing the focal length. The camera appears to zoom in and out
with different film backs even though you are not changing focal length.
For more information on camera tools and settings, see Using Maya:
Rendering.
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Creating a new camera
By default, a new scene has four cameras: a perspective camera (persp), and
three orthographic cameras (top, front, side). If you change a view by either
tumbling, tracking, dollying, or zooming in and out, you are still looking at
the scene or object through the same camera. To look at the scene or object
through a second camera, first change the view, then create the camera
(Panels > Perspective > New).
For more information on saving camera views, see “Marking a view” on
page 47.

Moving the camera
You can move a camera to get a different view of the object without creating
a new camera. To move the current view camera, you can use the
View > Camera Tools menu or the mouse with the Alt key. You can also
display the camera as an object in your workspace and use the camera
manipulators to move it. For more information on camera manipulators, see
“Displaying camera manipulator controls” on page 137.
To display the current camera as an object, select Display > Show > Cameras.
It may be easier to work with the camera as an object when you are moving
through a scene and you want to see the camera’s path.

Camera tools
Tumble Tool

Revolves the camera by varying the azimuth and elevation angles in the
perspective window. You can also press Alt and the left mouse button.

Track Tool

When tracking across the display, slides the view either horizontally or
vertically. You can also press Alt and the middle mouse button.

Dolly Tool

Moves into or away from the view. You can also press Alt and the left and
middle mouse buttons together. You can use the Dolly tool in both a
perspective or orthographic view.

Zoom Tool

Changes the focal length on a camera. Zooming in is like using a telephoto
lens. Zooming out is like using a wide angle lens. You can use zoom in both
a perspective or orthographic view. To move in or out without changing the
viewing angle, use the Dolly tool.

Roll Tool

Rotates the display around its horizontal axis.
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Azimuth Elevation Tool

Revolves the camera about the center of interest in the perspective view.
Yaw Pitch Tool

Changes from an orthographic view to a perspective view.

Fly Tool

The Fly Tool lets you navigate your scene as if you were playing a 3D firstperson perspective game. The camera flies through your scene without being
constrained by any geometry.
To use the Fly Tool, press-and-hold the Ctrl key, then drag with the left
mouse button. Drag up to fly forward and down to fly backward. To change
the camera direction, release the Ctrl key and drag the left mouse button.

Note
The tumble, track, and dolly commands are available while the fly tool is
active.
To use a camera tool:
•

Select the tool you want to use from the View > Camera Tools menu and
drag the left (or middle) mouse button.
For information on changing a tool’s properties, see “Specifying tool
settings” on page 248.
or

•

Press the Alt key and drag the appropriate mouse button(s). See “Camera
tools” on page 36.

Note
To select the Roll, Zoom, Azimuth Elevation, and Yaw-Pitch tools, use the
View > Camera Tools menu. You cannot select these tools with the mouse
and the Alt key.

Looking through a camera
If you have more than one camera, you can switch which camera you view
your scene through.
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To look through a camera:
1

Select Panels > Perspective.

2

Select a camera.

3

Select Panels > Look Through Selected.

Note
You can also use the Look Through Selected command to view your scene
from the point of view of a selected light or object.

Tip
You can also use the Hypergraph to select a view. In the Hypergraph
window, select the name of a view, then select Panel > Look Through
Selected. For more information, see “Using the Hypergraph” on page 319.

Changing camera settings
To change camera settings, select View > Camera Settings and select one of
the following settings:
Perspective

Toggle Perspective on so that the camera uses a perspective view. This
means that the lines converge at infinity. If toggled off, the camera uses an
orthographic view.

Journal

Toggle Journal on to copy camera view actions, such as tumble, track, and
zoom, to the MEL journal making the commands undoable. Normally, the
camera command view actions are not copied to the MEL journal and they
are not undoable. For more information on the MEL journal, see Using Maya:
MEL.

No Gate

Displays no frustrum. This is the default.

Film Gate

Displays the viewable frustum according to the film back size. The aspect
ratio of the window (or rendering resolution) determines what you actually
see. Also sets the camera Overscan attribute to 1.5. The following illustration
shows the film gate representing the maximum viewable (or renderable)
area.
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Film Back Gate

Resolution Gate

Displays the renderable frustum for the current resolution specified in
Render Globals. This often specifies a more exact rendered image than the
Film Gate option. Also sets the camera Overscan attribute to 2.0.

Note
If the aspect ratio between the film back and the resolution is the same,
then the two resulting rendered images match.
Field Chart

Toggle Field Chart on to display a grid that represents the twelve standard
cell animation field sizes. The largest field size (number 12) is identical to the
rendering resolution (the resolution gate). Render Resolution must be set to
NTSC dimensions for this option to have meaning.

Safe Action

Toggle this option on to display a box defining the region that you should
keep all of your scene’s action within if you plan to display the rendered
images on a television screen. The safe action view guide represents 90% of
the rendered resolution (the resolution gate). Render Resolution must be set
to NTSC dimensions for this option to have meaning.

Safe Title

Toggle this option on to display a box defining region that you should keep
titles (text) within if you plan to display the rendered images on a television
screen. The safe title region represents 80% of the rendered resolution (the
resolution gate). Render Resolution must be set to NTSC dimensions for this
option to have meaning.
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Fill

Automatically selects a horizontal or vertical fit so that the selected image
fills the render frame.

Horizontal

Selects a horizontal fit for the selected image in the render frame.

Vertical

Selects a vertical fit for the selected image in the render frame.

Overscan

Selects a slightly larger fit for the selected image in the render frame.

SETTING A PERSPECTIVE VIEW
Each workspace view is linked to a camera that “looks” at your scene. The
camera’s position, orientation, and attributes determine what you see
through that particular camera. This is a perspective view. Unlike an
orthographic view, a perspective view shows depth.
You can switch to a perspective view and you can create new perspective
views.
To switch to a perspective view:
Select Panels > Perspective and select the appropriate camera view.

Creating new perspective views
When building an object or scene, it is often useful to view the object from
several different perspectives. Use the Panels > Perspective > New option to
create a new perspective camera.
To create a new perspective camera view:
1

Change the view of the object.
For example, if you want to tumble the display, press the Alt key and use the
left mouse button to drag the view.

2

Select Panels > Perspective > New. Maya creates a new camera in the default
home perspective position.

•

To view through the original perspective camera, select View > Previous
View or View > Default Home.

•

To view through the new perspective camera, select Panels > Perspective.
and select the new perspective view.
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Name of the new perspective view

SETTING AN ORTHOGRAPHIC VIEW
An orthographic camera shows the 3D workspace from the top, front, and
side views. These views offer the most analytical view of the world space.
However, they do not show depth.
You can switch to an orthographic view and you can create new
orthographic views.
To switch to an orthographic view:
Select Panels > Orthographic and select front, side, or top as the active
camera view.

Creating new orthographic views
When building an object or scene, it is often useful to view the object from
the top, front, or sides. Use the Panels > Orthographic > New option to
create a new orthographic camera view. For example, you may want a
zoomed in top view.
To create a new orthographic view:
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1

Select Panels > Orthographic > New and select a new view: Front, Side, or
Top. Maya creates the view.

2

Select Panels > Orthographic. The view you just created appears in the
Orthographic menu.
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New orthographic view

LIGHTING YOUR SCENE
Use commands on the Lighting menu to select which lights or groups of
lights to use in your scene. These options include:
Use Default Lighting

Lights the scene using only a single point light situated at the camera.
Use All Lights

Uses all lights in the scene, to a maximum of eight lights. This option gives
you a representation of what the lights will look like when the image is
rendered.

Note
This option does not include the default light.
If there are no lights in the scene, the scene renders as an all black image.
Use Selected Lights Uses only selected lights. If you change the light selection, the lighting also

changes respectively.
Use Previously Specified Lights

Select this option to use the lights selected with the Specify Selected Lights
option. This option is grayed until you choose Specify Selected Lights. If you
select a different set of lights when this option is selected, the scene will still
use the previously selected lights.
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Note
This menu item can be turned off by picking any of the items above it.
Two Sided Lighting

Toggle this option on to illuminate both sides of an object. Note that Maya’s
performance may decrease on some systems.

Specify Selected Lights

Lets you use a preset selection of lights. Select the lights you want to use
then select Specify Selected Lights. Once specified, toggle on Lighting > Use
Previously Specified Lights to use this light selection. Unlike Use Selected
Lights, if you change the light selection, the scene will still use the
previously selected lights.

ARRANGING VIEWS
Use the Panels menu to change a camera view or to view a scene or object
through a selected camera.

Perspective

Lets you change to a perspective view or create a new perspective view. For
details, see “Creating new perspective views” on page 40.

Orthographic

Lets you change to an orthographic view or create a new orthographic view.
For details, see “Creating new orthographic views” on page 41.

Look Through Selected

Lets you look through a selected camera, object, or light. For details, see
“Looking through a camera” on page 37.
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Panel

Displays a menu with the following commands.
Outliner – Opens the Outliner, where you can view objects and their

attributes hierarchically. For more information, see “Using the Outliner” on
page 297.
Graph Editor and Dope Sheet – Opens the Graph Editor and Dope Sheet,
respectively, where you can edit keys, motion tangents, and animation
curves. For more information, see Using Maya: Animation.
Hypergraph – Opens the Hypergraph, which gives you an overview of your

entire scene, all objects it contains, and the relationships between those
objects. For more information, see “Using the Hypergraph” on page 319.
Hypershade – Opens the Hypershade, which you can use to create and edit

rendering nodes, and to view and edit rendering (or shading) networks. For
more information, see Using Maya: Rendering.
Visor – Opens the Visor, which you can use to show images of shading

nodes you can create, those already in your scene, and those in online
libraries, in a visual outline form. For more information, see Using Maya:
Rendering.
Texture View – Opens the Texture View window, which you use to map

textures to a polygonal model. For more information, see Using Maya:
Polygonal Modeling.
Multilister – Opens the Multilister. For more information, see Using Maya:

Rendering.
Render View – Opens the Render View window, where you can test render

single frames and interactively tune rendering attributes. For more
information, see Using Maya: Rendering.
Blend Shape – Lets you create character deformations. For more information,

see Using Maya: Character Setup.
Dynamic Relationships – Lets you view or edit connections between
dynamics elements such as particle emitters, collisions, etc. For more
information, see Using Maya: Dynamics.
Devices – Lets you use external tools and plug-ins for special devices, such

as Motion Capture.
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Relationship Editor – Opens the Relationship Editor, which you can use to

group and manipulate objects as sets and assign shading groups to
geometry. For more information, see “Using the Relationship Editor” on
page 255.
Reference Editor – Opens the Reference Editor, which you can use to specify
settings for importing files by reference. For more information, see “Using
the Reference Editor” on page 192.
Layouts

Lets you specify how different camera views are arranged spatially in the
Maya window.

Saved Layouts

Lets you select a panel layout. For more information, see “Selecting panel
layouts” on page 539.

Tear Off

Moves the current camera view into a separate window. The current view is
replaced with the next view in the Panels list (to see this list, select
Panels > Panel Editor).

Tear Off Copy

Copies the current camera view into a separate window.

Panel Editor

Opens the Panel window, where you can create new panels, re-label existing
panels, rename layouts, and change layout configurations. For more
information, see “Using the Panel Editor” on page 533.

Displaying the workspace only
Select the following options on the Display > UI Elements submenu to
quickly display only the workspace.
Hide UI Elements •

Temporarily hides all UI elements except the workspace panels. For
example, you can maximize the scene view while working on detailed
models.

Restore UI Elements •Displays the UI elements that were hidden.

Laying out the views
Because much of your 3D work takes place in a modeling view window, you
want to be able to view an object from the top, front, side, and in
perspective. In 3D, it is sometimes difficult to see exactly where an object
lies. The four views enable you to confirm the positioning of objects from
more than one camera angle.
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Use the Window > View Arrangement option to control how Maya displays
the four basic views. The top, front, and side views are 2D orthographic
views that allow you to view your work analytically. The fourth view is
perspective and allows you to view the scene in 3D. You can also access the
same view arrangement settings from the Panels > Layouts option.
You can place any tool in a view. For more information, see “Creating
layouts” on page 540.
In the following example, the display is changed to a 3 Left Split layout.
To set the views:
Select Panels > Layouts or select Window > View Arrangement and select
the view layout you want.
For example, if you select 3 Left Split Layout, you get the following view
layout.
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Notes
If you want one view to occupy the entire Maya window, select the view,
then press the space bar quickly. (If you press the space bar for too long,
Maya displays the HotBox.)
To rename and delete a camera, use the Outliner. See “Using the Outliner”
on page 297.

MARKING A VIEW
You can use bookmarks to mark a view for future use. This lets you maintain
a variety of camera views for any scene. Maya has four predefined
bookmarks: Perspective, Front, Top, and Side. You can change your view to
any of these predefined bookmarks, or you can create your own bookmarks.

Note
You cannot change positions for the predefined bookmarks.
Changing the view to a predefined bookmark:
Select View > Predefined Bookmarks and select the default view you want to
change to.

Creating a bookmark
You can create your own custom bookmarks to mark views other than
Perspective, Front, Top, and Side.
To create a new bookmark:
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Select an object and change the view.

2

Select View > Bookmarks > Edit Bookmarks. The Bookmark Editor opens.
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Type new bookmark
name here

3

In the Name box, type the new bookmark name press Enter.

4

Type a description of the view in the Description box.

5

Close the Bookmark Editor.

Tip
To create a bookmark with a system-assigned name, select
View > Bookmarks > Edit Bookmarks and click New Bookmark.
Maya assigns the view to the first bookmark under the name cameraView1.
To delete a bookmark:
1

Select View > Bookmarks > Edit Bookmarks. The Bookmark Editor opens.

2

Select the bookmark you want to delete and click the Delete button.

Selecting custom bookmarks
If you have created custom view bookmarks, you can select them as follows.
To view custom bookmarks:
Select View > Bookmarks and select the bookmark you want to view the
object through.
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Renaming a bookmark
You can rename custom bookmarks at any time.
To rename a bookmark:
1

Select View > Bookmarks > Edit Bookmarks. The Bookmark Editor opens.

2

Select the bookmark you want to change.

3

In the Name box, change the bookmark name then press Enter. The modified
bookmark appears in the Bookmarks menu.

Adding a bookmark to a shelf
You can add any bookmark to a shelf for easy access.
To add a bookmark to a shelf:
1

Select the shelf you want to add the bookmark to.

2

Select View > Bookmarks > Edit Bookmarks. The Bookmark Editor opens.

3

Select the bookmark you want to add to the shelf and click the Add To Shelf
button. The bookmark is added to the shelf. It appears as a MEL command.

ENABLING AND DISABLING NODES
You can disable animation nodes in your scene to improve playback speed
while you view animations.
For example, suppose you create a scene that includes a keyframed bouncing
ball in addition to several particle emitters. Because particle emission
requires much processing time, your animation playback may be slow. You
can disable particle nodes to temporarily disable the emitted particles. This
makes the animation of the bouncing ball play faster, so the ball’s motion
more closely resembles the final rendered motion.
To enable or disable nodes, select Modify > Enable Nodes or Disable Nodes.
You can enable or disable the following nodes:
IK solvers

See Using Maya: Character Setup for more information on inverse kinematic
tools.

Constraints

See Using Maya: Character Setup for more information on basic constraints.

BASIC FEATURES

USING MAYA: ESSENTIALS
49

VIEWING YOUR SCENE | 2
Enabling and disabling nodes

Expressions

See Using Maya: Expressions for more information.

Particles

See Using Maya: Dynamics for more information.

Rigid Bodies

See Using Maya: Dynamics for more information.

Snapshots

See Using Maya: NURBS Modeling for more information on Animation
Snapshots.
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EDITING OBJECTS
Use the Edit menu to delete, select, instance copy, group, and parent objects.
This chapter describes how you edit objects in Maya. It also describes
Maya’s undo, redo, and repeat functions.
It describes the following topics:
•

“Selecting objects” on page 51

•

“Deleting objects” on page 55

•

“Duplicating and instancing objects” on page 58

•

“Working with groups” on page 63

•

“Creating object hierarchies (parenting)” on page 66

•

“Undoing and redoing actions” on page 68

•

“Editing object attributes” on page 69
The following Edit menu options are not described in this chapter:
Keys – Displays the available keys. For more information, see Using Maya:

Animation.
Sets – A set is a collection of related objects or components. Examples of

items that can be in a set include geometric objects, NURBS, CVs, polygonal
vertices, skin points, cluster points, and polygonal faces. For more
information, see “Sets and Partitions” on page 367.

SELECTING OBJECTS
There are several ways to select objects in Maya. You can:
•

select objects individually

•

select all objects in the scene

•

select objects of a specified type
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•

select objects of a specified name

•

select all objects in a set

•

select all objects in a display layer
When you select objects, they become highlighted. Note that you can change
the highlight color. For details, see “Changing default colors” on page 482.

Selecting objects individually
You can select objects individually from the scene, the Outliner, the
Hypergraph, and the Relationship Editor.
To select an object:
•

Click on the object, or click-drag a box around it.
or

•

In the Outliner or Hypergraph, click on the object name. For information
about the Outliner, see “Using the Outliner” on page 297. For information
about the Hypergraph, see “Using the Hypergraph” on page 319.
or

•

In the Relationship Editor, highlight the object and on the Edit menu, click
Select Highlighted. For more information about the Relationship Editor, see
“Using the Relationship Editor” on page 255.
To select more than one object individually:
Shift-click on each object.

Selecting all objects in a scene
Use Select All on the Edit menu to select root objects and all visible
dependency nodes in a scene. You can then treat them as a virtual group
without actually having grouped them.

Note
To select several objects individually, Shift-click on each object. The last
selected object is highlighted with a different color than the other objects
(default, green).
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To select all displayed objects:
Select Edit > Select All. Maya selects all objects.

When you select a transformation tool, the manipulator for that tool displays
on the last selected object (the one highlighted in a different color, default,
green). When you transform the selection, the selected objects move as a
group.
To deselect all objects, click anywhere on the view.

Selecting objects by type
Use Select All By Type to select all objects of a specific type. In the following
example, we select all joints associated with the giraffe.
To select all objects by type:
1

BASIC FEATURES

Select the object.
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2

Select Edit > Select All by Type > Joints. Maya selects the joints on the object.
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Selecting objects by name
You can select objects and nodes by typing their name or a portion of the
name. In the Numeric input field on the Status Line, choose Quick Selection
from the pulldown menu and type the name. Using wildcard characters
(* and ?), you can select several items with the same string in their names.
Numeric Input field
on Status Line

Choose
Quick Selection

Selecting all objects in a set
Edit > Quick Select Set is a fast way to select all objects in a particular set
without having to open the Relationship Editor.
To place an item into a quick selection set, select it, then select Edit > Sets >
Create Quick Select Set. You can place items such as dependency graph
nodes, CVs, or lattice points, in a set. Once you name and create the set, you
can select it with Edit > Quick Select Set > setName.

Selecting all objects in a display layer
To select all objects in a display layer, on the layer bar, click the ▼ Layer
menu button to the left of the layer and select Select All in Layer. For
information about layers, see “Using display layers” on page 139.

DELETING OBJECTS
Use the Delete, Delete by Type, and Delete All by Type options on the Edit
menu to:

BASIC FEATURES

•

delete single objects

•

delete object components by type

•

delete all objects by type
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Deleting a single object
Use Edit > Delete to delete a selected object or component.
In the following example, we delete a cylinder from the scene.
To delete an object:
1

Select the object(s) you want to delete.
To delete more than one object or component, Shift-click each object you
want to delete, or click-drag a box around the object(s).

2

Select Edit > Delete. Maya removes the object and the associated Channel
Box or Attribute Editor from the display.

Tip
You can also delete selected objects with the Backspace or Delete keys on
the keyboard.

Deleting object components by type
Delete by Type lets you delete objects of a particular type or characteristic
(for example, channels). If many objects are selected and you select Delete by
Type > Channels, only the Channels attached to the selected objects are
deleted. Similarly, if you select Delete by Type > History, any history nodes
attached to the selected objects are deleted.
You can delete the following component types:
•

History

•

Channels (channels that describe how the object’s animation parameter
changes values over time)

•

Static Channels (channels that are not animated)

•

Motion Paths

•

Expressions

•

Constraints

•

Sounds

•

Rigid Bodies
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To delete an object’s components:
1

Select the object with the component you want to delete.

2

Select Edit > Delete by Type > componentType.
For Channels, Static Channels and Expressions, the components are deleted
according to the selected delete channel options.
To specify delete options:

1

Select Edit > Delete by Type > Channels ❐, Static Channels ❐, or
Expressions ❐. The Delete Options window opens.

2

Set the following options and click Save.

Hierarchy

To delete the component from the selected object only, choose Selected. To
delete the component from the selected object and all objects below it in the
DAG hierarchy, choose Below.

Channels

To delete all channels attached to all the selected object’s keyable attributes,
select All Keyable. To delete channels attached to those attributes selected in
the Channel Box, select From Channel Box.

Driven Channels

Toggle this option on to delete driven channels attached to the selected
object’s set driven key attributes.

Control Points

Toggle this option on to delete channels attached to lattice, polygon, and
NURBS curves and surface CVs. If you select All Keyable, this is
automatically toggled on. The default is off.

Shapes

Removes the object's geometry channels. If you select All Keyable, this is
automatically toggled on. The default is off.

Deleting all objects by type
Use Delete All Objects by Type to delete all occurrences of a type of object or
component in the scene (for example, joints).
To delete all objects by type:
Select Edit > Delete All By Type > type. This deletes all of the selected type of
components or objects in the scene.
To undelete the component, select Edit > Undo.
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DUPLICATING AND INSTANCING OBJECTS
There are two ways to copy objects:
•

With the Duplicate option—Maya actually copies the geometry or lights in a
scene.

•

With instances—Maya just redisplays the geometry being instanced. Copies
of the selected geometry are not created. Since instances are not actual copies
of the original geometry, they take up less system memory than actual
copies.

Duplicating objects
Use the Duplicate command to create copies of geometry or lights in a scene.
You can duplicate more than one object at a time. You can duplicate objects
as many times as you like. This means that you do not have to build a new
object every time you need a copy.

Note
To create more than one copy of the object at the same time, select
Duplicate ❐. For more information, see “Setting duplicating options” on
page 59.
To duplicate an object:
1

Select the object you want to duplicate.
If you want to duplicate more than one object, click-drag a box around the
objects or Shift-select the desired object.

2

Select Edit > Duplicate. Maya positions the copy of the object behind the
original object. You cannot see it until you move it.

3

To move the duplicate object from behind the original, select the Move tool
from the Minibar. The object displays four manipulators.

4

Drag the object to move it from behind the original object. Maya deselects
the original object.
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If you specified more than one copy (see “Setting duplicating options” on
page 59), click on the original with the Move tool and drag the manipulators.
Repeat until all copies appear in the view.

Setting duplicating options
Use the Duplicate Options window to position, scale, and rotate objects as
you make copies. You can also specify how may copies are made.
Setting a duplicate option:
1

Select Edit > Duplicate ❐. The Duplicate Options window opens.

2

Set the following options and click Save.

Translate, Rotate, Scale

Specify the offset values for X, Y, and Z. Maya applies these values to the
copied geometry. You can position, scale, or rotate objects as Maya
duplicates them.

Note
The default for Translate and Rotate is 0.0000. The default for Scale is
1.0000. With the default values, Maya places the copy on top of the original
geometry. You can specify offset values (positive or negative floating
point) for translation, rotation, and scaling that are then applied to the
copied geometry.
Number of Copies

Specify the number of copies to create. The range is from 1 to 1000.

Geometry Type

Select how you want the selected object(s) duplicated.
Copy – Make a copy of the geometry being duplicated.
Instance – Create an instance of the geometry being duplicated. When you

create an instance, you do not create actual copies of the selected geometry.
Instead, Maya redisplays the geometry being instanced. For more
information, see “Creating instances of objects” on page 60.
Group

BASIC FEATURES

Toggle Group on to put the duplicates under a new group node.
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Smart Transform

Toggle Smart Transform on so that when you duplicate and transform a
single copy or instance of the object (without changing the selection), Maya
applies the same transformations to all subsequent duplicates of the selected
duplicate.

Duplicate Upstream Graph

Toggle this option on to force the duplication of all upstream nodes leading
up to the selected object. Upstream nodes are defined as all nodes with
connections feeding into selected nodes.
For example, if A, B, and C are the upstream nodes connecting to D...
A > B > C > D
...and you select D and use the Duplicate Upstream Graph option, the
resultant graph will be as follows:
A1 > B1 > C1 > D1
(where A1, B1, C1, and D1 are duplicates of A, B, C, and D respectively).
Duplicate Input Connections

Toggle this option on so that in addition to duplicating the selected node, the
connections feeding into the selected node are also duplicated.
For example, if A, B, and C are connections feeding into C...
A > B > C
...and you select C and use the Duplicate Input Connections option, then the
resultant graph will be as follows:
A > B > C and
A > B > C1
(where C1 is a duplicate of C).

Creating instances of objects
When you create an instance, you do not create actual copies of the selected
geometry. Maya redisplays the geometry being instanced on the screen.
An instance is always identical to the original geometry, although each
object can have a unique translation, scaling, and rotation factor applied to it.
Therefore, individual instances can be picked as objects independent of one
another.
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Note
If you move a CV on the original geometry, it affects the shape of all
instances of that object.
Instanced geometry does not display CVs or hull structure. The form of an
instance can only be altered from the original geometry.
You can create several instanced copies of the original object, rather than just
copying it. If you then make a change to the original object, all instanced
copies automatically reflect the same change.
Since instances are not actual copies of the original geometry, they take up
less system memory than actual copies. In large or complex model scenes,
instancing can speed up refresh time, reduce the size of data files, and
improve rendering times.
Limitations
There are a few limitations when using instancing:

BASIC FEATURES

•

Instanced lights have no effect.

•

Instances share the same shader as the original geometry and cannot be
assigned independent shaders.

•

Some functions, such as extrude and insert, cannot be used on instanced
items. In these cases, you must make a true copy of the instanced geometry
that you want to manipulate, then continue with the function.

•

You can only apply clusters and deformation frames to the original
geometry—you cannot assign them independently to instances. To use
clusters and deformations on copies, you must make a true copy of the
geometry.

•

There is always at least one non-instanced transformation node between the
instance nodes and the actual geometry nodes.

•

When you create an instance of an already instanced node, Maya does not
create a new level.
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DAG nodes and instancing
When Maya creates an instance, the software also creates an extra DAG node
level. The top DAG node is the transformation node and the lower DAG
level is the geometry node.

Instanced cone
parented to sphere

When Instance is toggled on in the Duplicate Options window, Maya creates
an extra DAG node level to be created.
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WORKING WITH GROUPS
Grouping makes it easier for you to apply an action to multiple objects. Use
the Group, Ungroup, and Create Empty Group options on the Edit menu to:
•

group objects

•

ungroup objects

•

create empty groups (groups with null objects)

Grouping objects
Grouping lets you group a number of objects into a more complex object so
that transformations can be applied to all of them at once—in effect, treating
many objects as a single object for transformation purposes.
To group objects together:
1

Select the objects you want to group together.

2

Select Edit > Group. The objects are now part of a group, according to the
defined grouping options.

Setting grouping options
Use the Group Options window to specify options for grouping objects. You
can specify how the objects, as well as their pivot points, are grouped.
Setting groupings option:

Group Under

1

Select Edit > Group ❐. The Group Options window opens.

2

Set the following options and click Save.
Group objects under one of the following:
Parent – Groups the selected objects under their lowest common parent in

the hierarchy. For example, selecting a single object and grouping puts the
group node immediately above the selected object in the hierarchy.
Selecting objects that are in different hierarchies puts the group under the
world since they don’t share a common parent.

BASIC FEATURES
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Selecting objects in different parts of the same hierarchy puts the objects
under their lowest common parent. If you go from each selected object, the
new group will be placed under the first node containing all the selected
objects.
World – Puts the new group under the world (at the top level of the

hierarchy).
Select where you want the pivot point for the group to be.

Group Pivot

Center – Puts the new group’s pivot point at the center of the bounding box

of the grouped objects.
Origin – Puts the new group’s pivot point at the origin of the new group’s

coordinate system.
Preserve Position

Toggle this option on to modify the selected object’s matrix so that Maya
preserves the overall world-space position of the object. If toggled off, the
matrix of grouped objects are changed and the object’s world-space position
changes when grouped.

Ungrouping objects
Ungroup lets you separate parts of a group and remove nodes from a
hierarchy. You can then work with each object on an individual basis.
To ungroup objects:
1

Select a group.

Tip
If your scene is comprised of many groups, use the Hypergraph to help
you select a group. See “Using the Hypergraph” on page 319.
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2

Select Edit > Ungroup. Maya puts all objects at world level.

3

Click anywhere in the display to deselect the objects.
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Creating an empty group
Select Edit > Create Empty Group to create a new group (transform node)
without children. These empty or null objects are useful because they can be
used to control other objects through expressions. Moving the unrendered,
empty object triggers expressions that move other parts of the model. In
other words, they can act as constraint nodes.

Tip
You can also create an empty group by selecting Edit > Group with no
objects selected.

CREATING OBJECT HIERARCHIES (PARENTING)
You use parenting to establish a hierarchy in your scenes. The Edit menu
provides these parenting options:
Parent

Moves objects from one hierarchy to another and creates instances.

Unparent

Returns a parented hierarchy to its original state.
Use Parent to move objects between hierarchies and create instances.

Note
In the Outliner and Hypergraph, you can drag and drop one object on top
of another to parent it.

Parenting objects
When you parent an object, you make it part of a hierarchy.
To create a parent:
1

Select the objects you want to make up the parent/child relationship. Select
the children first, and the parent last.

2

Select Edit > Parent ❐. The Parent Options window opens.

3

Set the following options and click Parent.
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Select what you want done with the selected object:

Parent Method

Move Objects – Move the object from its current parent to the new parent
(the last selected object).
Add Instance – Create an instance under the new group instead of moving

the object.
Preserve Position

Toggle Preserve Position on to preserve the overall world-space position by
changing the parented objects’ transformation matrix.

Note
If two objects are selected, the first object goes under the one selected last.

Unparenting objects
When unparenting an object from a group, you can remove it from the
hierarchy and put it into world space. If it is an instance, you can delete it
altogether.
To unparent an object:
1

Select the child object.

2

Select Edit > Unparent ❐. The Unparent Options window opens.

3

Set the following options and click Unparent.

Unparent Method

Select how you want to unparent the selected object:
Parent to World – Remove the object from its current parent and place it
under the world.
Remove Instance – Remove a particular instance instead of moving the

object.
Preserve Position

BASIC FEATURES

Toggle Preserve Position on to preserve overall world-space position by
modifying the parented objects’ transformation matrix.
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UNDOING AND REDOING ACTIONS
You can undo the last action you performed and redo if you change your
mind. You can also repeat your last actions.

Undoing your last action
Undo reverses the last action you performed on a selected object. It also
reverses any action you performed from the Edit menu.
For example, you can transform an object to a new position, then return it to
its original position using the Undo command.
To reverse an action:
Select Edit > Undo.

Note
To set how many levels of Undo you want, select Window >
Settings/Preferences > Preferences, Undo category, and set the Queue Size.
Note that a large Queue Size slow Maya’s performance.

Redoing and repeating actions
Select Edit > Redo to perform the last action that you reversed. For example,
if you delete an object and then use Undo to display it, Redo deletes the
object again.
Select Edit > Repeat to echo the last menu item you selected. You can only
repeat selections from menus on the main Maya menu bar. You cannot
repeat selections from the shelf, channel box, or any of the secondary
window menus.
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EDITING OBJECT ATTRIBUTES
An attribute is a characteristic of an object in a scene. There are many ways
to set attributes in Maya—with the Attribute Editor, Channel Box, Attribute
Spreadsheet, menu selections, and expressions. You can set attributes to
control virtually anything in your models and animation. For information on
editing attributes, see:

BASIC FEATURES

•

“Using the Attribute Editor” on page 262

•

“Using the Channel Box” on page 280

•

“Using the Attribute Spread Sheet” on page 241

•

Using Maya: Expressions

•

“Painting attribute values” on page 454
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TRANSFORMING OBJECTS
After you build your curves, surfaces, and objects, you are ready to position
them in 3D space. This chapter describes how you scale, rotate, and move
your objects.
It includes information on these topics:
•

“Selecting transformation tools” on page 72

•

“Using manipulators” on page 72

•

“Using axes and pivot points” on page 73

•

“Moving objects” on page 79

•

“Rotating objects” on page 85

•

“Scaling objects” on page 89

•

“Using the Show Manipulator tool” on page 91

•

“Entering numeric values” on page 95

•

“Combining transformations” on page 97

•

“Using proportional modification” on page 99

•

“Creating locators” on page 105

•

“Using Measure tools” on page 107
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SELECTING TRANSFORMATION TOOLS
The Minibar provides five basic tools: Select, Move, Rotate, Scale, and Show
Manipulator. The last tool you used occupies the last position in the row.
Rotate
Move
Scale Show Manipulators
Select

space for the active or
last tool used

q

w

e

r

t

y

Equivalent keys

The q, w, e, r, t, and y hotkeys correspond to the Minibar icons, as shown
above.
When you press the w key and drag with the left mouse button, a marking
menu appears for the Move manipulator. Similarly, you can display marking
menus for using the e key (for Rotate) and r key (for Scale). The marking
menu options are another way to select manipulator handles.

USING MANIPULATORS
Manipulators provide a visual and interactive way to change an object’s
parameters. You use manipulators to directly position and scale objects in
the workspace.
Many tools have manipulators. Usually, a tool creates a manipulator when
you open the tool and deletes the manipulator when you exit it. (However,
there are some exceptions to this.)
When you use a manipulator to change parameter values, the Help Line
displays the values as they change.
You can also change parameter values by entering them in the Numeric
Input field (at the top right of the window). For details, see “Entering
numeric values” on page 95.
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Y handle

Z handle

Center handle
X handle

About manipulator handles
Each manipulator has several handles. You move these handles to change
parameters. For example, the Move manipulator has a center handle, plus
handles you use to move it in X, Y, and Z.
If you want, you can make these handles larger or smaller using the
manipulator display preferences in Window > Settings/Preferences >
Preferences. For the transform manipulators, you can also use the + and keys on the keyboard to change handle size.

The active (current) handle
When you click-drag a manipulator handle, it becomes active. This means
you can now use the middle mouse button to move the handle without
having to reselect it. If you click away from the handle and drag, it still
moves the manipulator. The default color of the active handle is yellow.
You can keyframe the attribute that corresponds to this active handle by
setting keys on the current manipulator handle (Animation menu set,
Animate > Set Key ❐). For more information, see Using Maya: Animation.

USING AXES AND PIVOT POINTS
There are various ways you can define where your objects are transformed
from. You use the location of the pivot point or axes to transform in a
specific direction from a specific point in local or world space.

BASIC FEATURES
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What are pivot points?
Objects are transformed based on a specific point in 3D space known as a
pivot. When you rotate a primitive, for example, the pivot point represents
the center of the rotation axis; when you scale, the pivot point represents the
fixed point around which scaling occurs.
By default, the pivot point is set so that the rotational and scale pivots are
located at the point of origin for an object (0, 0, 0). The point of origin is the
center of the object. You can change an object's pivot and you can also pin it
to a fixed location.
To quickly display an object’s pivot point:
1

Select the object, then select the transformation tool.

2

Press the Insert key on the keyboard to toggle to and from an edit mode. Edit
mode displays a manipulator for moving the pivot.

Manipulator for moving pivot

To display an object’s pivot point using the Attribute Editor:
1

Select the object.

2

Open the Attribute Editor (Window > Attribute Editor) and click the object’s
transform tab.

3

Expand Pivots, and toggle on Display Rotate Pivot or Display Scale Pivot.
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Moving pivot points
You can move the pivot point to set the point you want to move, scale, or
rotate the object from. Use the Insert key on the keyboard to display the
pivot point, then use any of the transformation tools. In the following
example the Rotate transformation tool is selected.
To move pivot points:

BASIC FEATURES

1

Select an object active, select a transformation tool, then press the Insert key.
The manipulator appears.

2

Drag the manipulator to move the pivot point.
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3

Press the Insert key again to display the rotate manipulator, drag to rotate
the object.

To move the pivot point using the Attribute Editor:
1

Select the object, open the Attribute Editor and in the Pivots section, toggle
Display Rotate Pivot or Display Scale Pivot on, depending on which pivot
you want to move.

2

In the Local or World Space sections, enter X, Y and Z values for Rotate
Pivot or Scale Pivot and press Enter. In the following example, the rotate
pivot is moved 5.0 units in the Z direction in absolute local space. You can
now rotate the object from that pivot point location.
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Rotate pivot point
moved 5.0 in Z

Pinning component pivot points
Maya creates a temporary pivot point for object components you select while
in Component selection mode. The pivot point is centered with respect to the
selected components. If you select additional components after moving a
temporary pivot, the pivot automatically moves back to the original position.
To prevent it from moving, you can “pin” the temporary pivot to a location
you define in edit mode.
To pin a pivot point:
1

In component selection mode, select the components.

2

Press the Insert key to enter edit mode.

3

Drag the pivot point to move it to a new location.

4

Still in edit mode, click the pivot target. The pivot locks to the current
position.

Unpinned
pivot point

BASIC FEATURES

Pinned
pivot point
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Note
The component pivot remains pinned in its position until you return to
edit mode (using the Insert key) and unpin it.
To “unpin” (or unlock) a pivot and return it to default auto-centering
mode, click the pinned pivot manipulator.

What is an axis?
An axis is a straight line that indicates the origin and direction. For example,
by using two axes, a plane is defined: the XY plane is defined by placing X
and Y axes so they intersect at the origin. Three dimensions are defined by
using three axes: X, Y, and Z.

Displaying the axis indicators
There are two types of axes: the global axes, and the local axes.
The global axes display in the view. You can display the global axes at the
origin in the perspective view (Display > Heads Up Display > Origin Axis)
and you can display the global axes at the bottom left of each view
(Display > Axes > View Axis).
The local axes displays at the origin of the active object in all views. To
display the local axis, open the Attribute Editor. Click the transform tab for
the object, and in the Display section, toggle on Display Local Axis.
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Axes and rotation
When you rotate an object, the outcome is partially dependent on the
rotation order of the object’s axis. The default rotation order is xyz, but you
can change it as needed. For more information, see “Changing the rotation
order and axis orientation” on page 88.

Toggling the axes origin from the Command Line
You can also type the following commands in the Command Line to toggle
the global axis display on and off in the 3D views.

Command

Action

toggleAxis -o true;

displays the axis at the origin

toggleAxis -o false;

hides the axis at the origin

toggleAxis -v true;

displays the axis at the bottom left of each view

toggleAxis -v false;

hides the axis at the bottom left of each view

MOVING OBJECTS
The following procedure describes how you use manipulators to move an
object:
To move an object using the Move tool:

BASIC FEATURES

1

Click the Move icon in the Minibar.

2

Select the object you want to move. Maya displays a manipulator with four
handles—one to move along each axis and one to move anywhere within the
plane.
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Click-drag this handle
to move in Y direction

Click-drag the center handle
to move in any direction

Click-drag this handle
to move in Z direction

Click-drag this handle
to move in X direction

3

Click-drag one of the handles, as follows. The selected handle changes color
when active. The default color is yellow.

•

To move the object along a single axis, select and drag the handle for that
axis.

Tip
Another way to restrict movement to one axis is to press the Shift key and
drag using the middle mouse button. This is faster than clicking on the
manipulator to switch between specific handles.
•

To move the object freely along all axes, select and drag the center handle in
the middle of the manipulator.

Tip
For all manipulators, the middle mouse button controls the active
manipulator handle.
By default, the Move manipulator moves along the plane of the view. In the
perspective view, you also use it to move in the XY, YZ, or XZ planes.
•

To move in the XZ plane, Ctrl-click the Y handle.
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The “current plane” for the center handle becomes the XZ plane. The center
handle now moves the object in the XZ plane (keeping the Y translation
value constant).
•

To move in the YZ plane, Ctrl-click the X handle

•

To move in the XY plane, Ctrl-click the Z handle.

•

If the current plane is the XZ plane (or YZ or XY) and you want to move in
the view plane, Ctrl-click the center handle.
When a snap mode is turned on, the manipulator center changes to a circle.
This indicates that the manipulator snaps instead of moving freely in the
current plane.
Moving tips
Here are a few tips to help you move an object:

•

The Selection Mask options window controls what types of items you can
move. For example, if CVs are toggled on and all other components are
toggled off, only CVs can be selected and moved.

•

To change an object’s shape, you can move CVs independently of the objects
they are in.

Moving the translate pivot point
When you transform an object, the center of the manipulator is the center of
the current selection’s bounding box. It acts as a temporary pivot. You can
move an object’s pivot in edit mode.
To move the pivot:

BASIC FEATURES

1

Select the object.

2

To switch to edit mode, press the Insert key. Maya displays a Translate
manipulator that you can use to move the scale or rotation pivot.

3

Drag the manipulator to the desired area within the object.

4

Press Insert again to resume translating the object.
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Note
When you are in Component selection mode, you can “pin” the pivot point
to its new location. For information, see “Pinning component pivot points”
on page 77.

Choosing a coordinate system for the Move tool
Use the Tool Settings options window to specify the coordinate system for
the Move tool.
To specify an option:
1

Double-click the Move icon in the Minibar.
or
Select Modify > Transformation Tools > Move Tool ❐.
The Tool Settings window opens.

2
Object

Select one of the following options and click Close.
Moves an object in object space coordinate system. Axis orientation includes
rotations on the object itself. If several objects are selected, each object moves
the same amount relative to its own object space coordinate system.
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Local

Aligns the object to the rotation of the parent object. Movement is
constrained to those axes in the local space coordinate system. The object is
aligned to the rotation of the parent object and does not include the rotations
on the object itself. If several objects are selected, each object moves the same
amount relative to its own object space coordinate system.

World

Moves in the world space coordinate system. The object is aligned to the
world space axis. This is the default.

Normal

Moves selected CVs on a NURBS surface in the U or V direction of the
surface. Typically you would use this option for small sets of CVs. The
manipulator indicates the surface Normal, U, and V directions.

When you select Normal, the Update [UVN] Triad option displays. Toggled
on, this option causes the manipulator orientation to reflect the moved
surface rather than the original surface. This is the default. Toggled off, the
manipulator retains the orientation for the original surface.

Note
For quick access, you can also use the Modify > Transformation Tools >
Move Normal Tool. It is the same as selecting the Normal option for the
Move tool.

Moving curves on surfaces
Curves on surface (along with their edit points) have a special Move
manipulator. When you move a curve on surface, the manipulator constrains
the curve on surface to the surface and allows for movement in the UV
direction separately.

BASIC FEATURES
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Move curve on surface manipulator

You can also move a curve on surface entirely off the surface. Since it is
mapped only to the UV parameter space of a surface, once the curve or any
portion of the curve is moved off the surface, it is no longer displayed.
Similarly, if you move an edit point on a curve on surface element off the
surface, the edit point and curve spans affected by that edit point are no
longer displayed.

Moving a path animation marker
Motion path markers also have a special manipulator. You can add a marker
to a path animation to change the animation timing. If you have a position
marker along a path animation, you can use the Move tool to motion the
position marker to another point along the motion path. For more
information, see Using Maya: Animation.
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ROTATING OBJECTS
Use the Rotate tool to rotate objects. The Rotate manipulator consists of four
rings, plus a “virtual sphere” enclosed by the rings.

Drag to rotate
about local Z-axis

Drag to rotate
about local X-axis
Drag on outer
ring to rotate
about view axis

Click-drag to rotate
about local Y-axis

Drag on virtual sphere
area to rotate in X, Y
and Z

You use the X, Y, and Z rings to perform constrained rotations. You use the
outer ring to rotate relative to the view.
For example, in the front view, the view ring rotates the object in the XY
plane. The virtual sphere is used to rotate in X, Y, and Z.

Note
When you rotate a component, Maya rotates it about a temporary pivot
which is initially set to the center of the component’s bounding box. For
information on moving the pivot, see “Moving the rotate pivot point” on
page 86.

BASIC FEATURES
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To rotate an object:
1

Select the Rotate icon in the Minibar.

2

Select the object you want to rotate. Maya displays a rotate manipulator in
the shape of a sphere (or arc ball).

Click-drag to rotate
in the Z direction

Click-drag to
rotate in the
X direction

Click-drag to rotate
in the Y direction

3

Rotate the object by pressing the left mouse button and dragging.

Note
The object’s rotational pivot point determines the effect of a rotation.

Moving the rotate pivot point
Maya uses the rotate pivot to position the Rotate manipulator.
To move the rotate pivot:
1

To switch to edit mode, press the Insert key. Maya displays the manipulator
for moving the pivot. This temporary pivot is initially at the center of the
component’s bounding box.
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Translate manipulator

2

Drag the manipulator to the desired area within the object.

3

Press Insert again to resume rotating the object.

Note
When you are in Component selection mode, you can “pin” the pivot point
to its new location. For information, see “Pinning component pivot points”
on page 77.

Changing the rotation order
The Rotate manipulator respects the key object’s rotation order, that is, the
order in which X, Y, and Z rotations are applied.
To change the rotation order of an object, open the Attribute Editor. The
rotation order option is under the scale/rotate/translate attributes. This is
most useful with the Gimbal manipulator. See “Animating rotation
channels” on page 89.

Choosing a rotate mode
You use the Tool Settings options window to specify the behavior for the
Rotate tool.
To specify an option:
1

BASIC FEATURES

In the Minibar, double-click on the Rotate icon. The following window
opens.
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2

Specify a rotate mode:

Local

Rotates the object about the object space axes.

Global

Rotates the object about the world space XYZ axes. Notice that in this mode
the rings never change.

Gimbal

Changes only the X, Y, or Z rotation value. In the local and global modes, the
XYZ constraint rings may change more than one of the rotation XYZ
channels.

Changing the rotation order and axis orientation
In the Transform Attributes section of the Attribute Editor, you can change
the rotation order of the axes for an object by selecting an order from the
Rotate Order pop-up menu. You can also enter values in the Rotate Axis X,
Y, or Z boxes to rotate the axes in a specific direction, and to rotate the object
around a different axis.

Keep in mind that these attributes have a combined effect with the Rotate
Mode settings in the rotate Tool Settings.

USING MAYA: ESSENTIALS
88

PART 1

TRANSFORMING OBJECTS | 4
Scaling objects

Animating rotation channels
With the world and object space rotation manipulator, you can change
multiple rotation channels at one time, even when using one of the X, Y, or Z
rings. For animation, rotations are interpolated on a per channel basis and the
rotation channels are not independent.
The rotation channels are applied in a specific order. This ordering impacts
the animation of these channels. (To change the rotation order, use the
Attribute Editor.) For this reason, interpolating all three rotation channels on
a single object usually does not result in a smoothly animated rotation.
Instead, use the gimbal rotation manipulator. It lets you change and control
individual rotation channels without affecting the other rotation channels. It
also gives more predictable results. For modeling purposes, or with
animations that don't include rotation channels, use any of the rotate
manipulators.
When you animate components such as CVs, you are actually animating
their position. Rotating some CVs and setting keys does not produce an arc
because it is the CV positions that are interpolated. In this case, it does not
matter which rotate manipulator is used.

SCALING OBJECTS
Use the Scale tool to change the size of objects by scaling proportionally in
all three dimensions. You can also scale non-proportionally in one
dimension at a time.
To scale an object:

BASIC FEATURES

1

Choose the Scale icon from the Minibar.

2

Select the object you want to scale. Maya displays a scaling manipulator that
consists of four handles. The colors of the handles correspond to the XYZ
axes.
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Click-drag to scale
in the Y direction
Click-drag to scale
proportionally

Click-drag to scale
in the X direction

Click-drag to scale
in the Z direction

3

Scale the object by click-dragging a handle.

Tip
A useful shortcut for non-proportional scaling in X, Y, or Z is to use the
Shift key. Hold the Shift key down, then, using the middle mouse button,
drag along the direction of the axis you would like to scale in. This is faster
because you don't need to click directly on the specific handle to switch
between scaling in X, Y, or Z.
When you scale a component, Maya scales it about a temporary pivot, which
is initially set to the center of the active component’s bounding box. Note
that for components, it is the component position that is being changed.
By default, all geometry is assigned an initial scale factor of 1.

Moving the scale pivot point
Maya uses the scale pivot to position the scale manipulator.
To move the scale and rotate pivots:
1

To switch to edit mode, press the Insert key. Maya displays the manipulator
for moving the scale pivot.

2

Drag the manipulator to the desired area within the object.

3

Press Insert again to resume scaling.

USING MAYA: ESSENTIALS
90

PART 1

TRANSFORMING OBJECTS | 4
Using the Show Manipulator tool

Note
When you are in Component selection mode, you can “pin” the pivot point
to its new location. For information, see “Pinning component pivot points”
on page 77.

USING THE SHOW MANIPULATOR TOOL
Some functions display special manipulators that let you tailor a surface or
curve after a surface has been created. The Show Manipulator tool (Modify >
Transformation Tools > Show Manipulator Tool) lets you edit the
construction history of an operation or the attributes of an object itself. In
other words, this tool lets you access the input node of an object.
A manipulator is a good way to access the history of a surface created with
construction history (such as a beveled or revolved surface). Several
manipulators can be active at one time.
When the object is deselected, the manipulators disappear. Reselect the
object, and the manipulators reappear.
There are several ways to access and display manipulators using the Show
Manipulator tool. Before you start, make sure construction history is on
(click the Construction History icon on the status line).

BASIC FEATURES

USING MAYA: ESSENTIALS
91

TRANSFORMING OBJECTS | 4
Using the Show Manipulator tool

Selecting an item’s history node
The Show Manipulator tool displays a manipulator for the operation’s
history node. To access the manipulator, you must select the history node.
After you revolve an object, the revolve history node is active and the Show
Manipulator tool displays the Revolve manipulator. If you perform several
other operations and then want to edit the revolved surface, the
manipulators are no longer displayed. You have to select them using one of
the following methods.
To select the history node:
Select the surface then do one of the following:
•

Press the a key and the left mouse button. Drag to Select All History on the
marking menu that appears.

or
•

From the History list menu in the Status Line, select the history node.

or
•

From the Channel Box, select the history node.
In the following example, the history nodes for a revolved surface and the
curve used to construct it are selected. Click revolve1 to select the history
node for the revolved surface.
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Changing a curve’s parameter range
You can use the Show Manipulator tool to change the parameter range
(minimum and maximum value) on a subCurve.
A subCurve is created when you select the Partial option as the Curve Range
in some options windows (for example, Revolve Options, Loft Options,
Extrude Options, Boundary Options, Bevel Options, Project Curve Options).
This option lets you select a minimum and maximum parameter value on
the curve; only the part of the curve between those points is used to create
the surface. Most surface operations that use a curve as input include this
option.
A subCurve can also be the construction curve, or input curve, you use to
create surfaces, such as revolved or extruded surfaces.

Once you select the history nodes and the Show Manipulator tool,
manipulators display on the surface or the construction curve. To
interactively edit these nodes, click-drag the manipulator handles, or change
the values in the Channel Box or the Attribute Editor.

BASIC FEATURES
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Note
Some options windows include a Keep Original toggle (for example, Edit
Curves > Detach Curves). Toggle this on to access the manipulators.

Displaying manipulators for lights and cameras
Use the Show Manipulator tool to display manipulators for editing lights
and cameras. The appropriate manipulator for the camera or light you select
displays.
For example, if you select a light or a camera then click the Show
Manipulator tool on the Minibar, Maya displays the following manipulators:

Spotlight manipulators

Camera manipulators

For details, see “Displaying camera and light manipulators” on page 137.

Using the Default Object manipulator
The Default Object manipulator is the transform tool set to be used with the
Show Manipulator tool for an object. It can be the Move, Rotate, or Scale
tool. Even if the object has its own manipulator (for example, a light), the
transform manipulator is shown instead.
To set the default manipulator for the Show Manipulator tool:
Select Modify > Transform Tools > Default Object Manipulator >
transformTool. Set Default Object Manipulator to None to use the object’s
own manipulator, rather than a transform manipulator. This is the default.
This information is saved with the scene. It is also shown in the Attribute
Editor under the transform Display section.
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ENTERING NUMERIC VALUES
You can move, rotate, or scale an object by entering values in the Numeric
Input field or the Command Line.

Using the Numeric Input field
The Numeric Input field appears on the Status Line. You can enter absolute
values or relative values in the Numeric Input field. When typing values, do
not include commas to separate XYZ coordinates—use spaces. For example,
type:
1 3 5

...not
1,3,5

You can use decimal values.
Entering absolute values
Click the pulldown menu next to the Numeric Input field and select
Numeric Input: Absolute. The button changes to abs, to indicate that Maya
will interpret the values you enter as relative.
When you enter an absolute value, Maya moves or rotates the object to the
absolute world-space coordinates that you type in, or scales the object to the
absolute size value specified for each of the three axes.
For example, if an object is positioned at XYZ coordinates (4, 2, 2) and you
move the object by entering an absolute value of:
6 3 1

...in the numeric input field, the new position of the object is (6, 3, 1).
You can omit trailing zero values. For example, you can type:
2 3 0

or
2 3

...to move an object to (2, 3, 0).

BASIC FEATURES
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To move or scale an object on only one or two of the axes without affecting
the other axis, you must re-enter the current values you don’t want to affect.
For example, to move an object from its location at (2,3,1) to (4,4,1), enter the
absolute move values:
4 4 1

Similarly, if an object is scaled by a factor of 5 on all three axes and you want
to change the scale on the x-axis to a factor of 6, enter the scale factors:
6 5 5

Entering relative values
Click the pulldown menu next to the Numeric Input field and select
Numeric Input: Relative. The button changes to rel, to indicate that Maya
will interpret the values you enter as relative.
When you enter a relative value, Maya moves, rotates, or scales the object by
the specified amount on each axis, relative to the object’s current position or
scale factor.
For example, to move an object from (2,3,1) to a position 2 grid positions in
the positive X direction and one grid position in the positive Y direction,
enter the relative values:
2 1 0

...and press Enter.
The zero value for the z-axis results in no positional adjustment on this axis.
The object moves to (4,4,1).
You can omit trailing zero values. For example, you can type:
2 3 0

...or
2 3

...to move an object from (1,1,1) to (3,4,1).
To transform an object using the Numeric Input field:
1

Click the Move, Rotate, or Scale tool in the Minibar.

2

Select the object you want to move.
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Note
If you select more than one object, Maya displays the manipulator on only
one object. However, each object scales or rotates relative to its own pivot
point.
3

To move the object by an absolute amount (the default), type the XYZ
coordinates in the Numeric Input field and press Enter, or type -a before the
value and press Enter, for example:
-a 1 7 4

To move an object by a relative amount, click the abs button to toggle to rel,
then enter the value, or type -r before the value and press Enter, for example:
-r 2 6 3

Using the Command Line
The command line appears at the bottom of the Maya main window.
To transform an object with the Command Line:
To transform objects from the Command Line, you use the move, rotate, and
scale commands.
If you type -r before the numerical values on the Command Line, geometry
is translated relative to its current location. (-a, for absolute world space
coordinates, is the default.)
Type move
values and
press Enter

COMBINING TRANSFORMATIONS
You can use the combined Move/Rotate/Scale manipulator to switch
between moving, rotating, and scaling. When you first select this tool, only
part of each manipulator is displayed. To see the complete manipulator,
click on one of its handles.
BASIC FEATURES
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To move an object:
To display the full move manipulator (including the center handle), click on
one of the arrow handles. Then use the handles as described in the Move
tool.
•

To move along a single axis, click-drag the arrows in the direction of the
XYZ axes.

•

To move the object freely along all axes, click one of the arrow handles to
first display the center handle, then click-drag the center handle.

Click here to move
along Y-axis

Click here to move
along Z-axis

Click here to move
along X-axis

To scale an object:
•

To perform a non-proportional scale, select the box handle representing the
axis and drag in that direction.

•

To perform a uniform scale on the entire object, click one of the box handles
to display the center handle, then click-drag the center handle.~
Click here
to scale in Y

Click here to
scale in Z

USING MAYA: ESSENTIALS
98

Click here to
scale in X

PART 1

TRANSFORMING OBJECTS | 4
Using proportional modification

To rotate an object:
1

When you first select this tool, the XYZ constraint rings are not displayed. To
display the arc ball, select the outer constraint ring.

2

To rotate around a single axis, select the appropriate ring and drag in the
direction of the axis.

Click here
to scale in Y

Click here to rotate in
the view plane axis

Click here to rotate
along all axes
Click here to
scale in Z

Click here to
scale in X

Note
When you use the combined transformation tool, the transformations occur
with respect to object space only.

USING PROPORTIONAL MODIFICATION
You can use the Proportional Modification (propmod) tool to transform a
number of items proportionally, based on the distance from the manipulator
handle. Typically, you use this tool to transform CVs.
The propmod effect is usually based on the distance of the CV, or other
component, from the manipulator. The closest object exactly matches the
manipulator’s movement. Objects further away do not. This effect is
controlled by the Distance Cutoff setting.

BASIC FEATURES
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The manipulator for Proportional Modification is a combination of the move,
rotate, and scale manipulators. Click on the appropriate part of the
manipulator, depending on what type of transformation you want to
perform.

You can reposition the manipulator in another part of the scene to achieve
different effects on the selected objects.
Example of translating CVs:
1

Click the Select by Component Type icon and select the curves to see the
CVs.

Click this icon and
select the curves to
see the CVs

2

Shift-drag to select all the CVs in the center of the curves.
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3

Select Modify > Transformation Tools > Proportional Modification Tool.
Maya displays a manipulator.

4

Click-drag to position the manipulator, then drag the green handle to move
the CVs on the curves.

CVs move proportionally

Specifying proportional modification falloff
To set proportional modification options, either double-click on the icon, or
select Modify > Transformation Tools > Proportional Modification Tool ❐.
The options window opens.

Linear modification falloff
This is the default modification falloff. Maya performs the modification in a
linear fashion and displays the Distance Cutoff option.

BASIC FEATURES
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Distance Cutoff

Objects further away than this value are ignored. The distance is measured
in 3D from the manipulator handle.

Based on distance

The distance from the manipulator handle to the object directly influences
the modification factor. The distance will be computed along the selected
axes only. If any of these is toggled off, the distance used in the computation
of the propmod effect from the handle to the point will ignore that
component.

Power modification falloff
Using the Proportional Modification tool, you can set the degree to any
value between +5 and -5 and the falloff is non-linear (it forms a logistic
curve). However, if you set the degree to 1 the falloff is linear again.
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Distance Cutoff

Objects further away than this value are ignored. The distance is measured
in 3D from the manipulator handle.

Degree

Specifies the degree of effect in the U and V directions. A value of 0 applies
the transformation equally over the entire region.
A positive value decreases the effect of the transformation for objects further
away from the manipulator handle; the greater the degree, the greater this
dampening effect.
If Degree is negative, the effect of the transformation is increased for objects
further away from the manipulator handle.

Based on distance

The distance from the manipulator handle to the object directly influences
the modification factor. The distance is computed along the selected axes
only.

Script modification falloff
This method uses a MEL script to determine the falloff.
With the appropriate parameters set, you can choose the Script option and
type a command for the settings in the User defined script box to save the
current parameter settings without actually invoking the function. If you
want to use these settings again later, you can retrieve the tool’s script from
the Reference Editor.

User defined script

BASIC FEATURES

The script should return a modification factor. The inputs to the script are
“float” numbers. The first three represent the position of the manipulator
handle. The second three represent the position of the point manipulated.
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For example, the points for which this script returns 1 will move with the
manipulator handle. The points for which this script returns 0.5 will move
half as fast as the manipulator handle.
For more information, see “Using the PropMod script” on page 105.

Curve modification falloff
This option uses an animation curve to create the falloff. An animation curve
profile can be used to produce a modification factor.

User defined anim curve

Enter the name of an existing animation curve. Its vertical direction will map
into the modification factor. The distance maps to the anim curve time axis
(in seconds).
You can use the pull-down menu to the right of the box to list and choose all
the anim curves with names starting with propModAnimCurve. You can also
create one of those by choosing Create New from the same pull-down menu.
Based on distance

The distance from the manipulator handle to the object directly influences
the modification factor. The distance is computed along the selected axes
only.
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Using the PropMod script
The PropMod script is similar to the Move script except that it has additional
settings for the move distance. Using the Script option, you can compute
each object’s factor individually.
The user-defined script command considers both the position of the
manipulator and the object. The value returned by the script is used as a
multiplying factor for a specific object.
Example
Create myPropMove.mel file as:
global proc float myPropMove(float $mx, float $my,
float $mz, float $px,
float $py, float $pz)
}
return rand (1.0)
}

...which produces a random value between 0 and 1.
If you select myPropMove as the script name, you get a random
modification factor for all selected points.

CREATING LOCATORS
A locator marks a position in world space. A locator is displayed as a small
gnomon; its lines extend in each direction along the X, Y and Z axes (like the
directional rods of a sundial). You can use point snapping to snap to a
locator position.
Use Create > Locator to create a space or curve locator.

BASIC FEATURES
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To create and move a locator:
1

Select Create > Locator. A locator is created at the origin.

2

Move the locator in one of the following ways:

•

Use the transformation tools.

•

Change the transformation values in the Channel Box.

•

Click the locator# tab in the Attribute Editor and change the Transformation
values in that section of the editor.

Repositioning the locator in local space
You can reposition the locator in local space from the Attribute Editor
(Window > Attribute Editor).
Click the locatorShape# tab to open that section of the editor. Enter X, Y, or Z
values in the Local Position boxes.
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USING MEASURE TOOLS
The Create > Measure menu includes the Distance Tool, Parameter Tool, and
Arc Length Tool.

Using distance measures
Use the Create > Measure > Distance Tool to measure and display distances
between two specified points.
To display a distance measure:

BASIC FEATURES

1

Select Create > Measure > Distance Tool.

2

Click to select two points in space, or click on a curve or surface to display
the distance measure locator.
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The following example shows the distance locator when two points are
placed on a surface.

This shows the distance locator when one point is placed in world space and
the other is placed on the surface.

The following shows the distance locator when two points are placed on a
curve.

To snap a distance measure point:
To snap a locator to a curve or surface, use the Snap to curves icon and click
on the curve or surface. When you move the item, the distance measure
updates. This can be especially helpful if you want to measure the distance
between two curves.
1

Click the Snap to curves icon from the Status Line.
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2

Place a point on one curve and another point on the other curve.

3

Move one of the curves and the distance measure updates.

To move the distance locator:
Select the Move Tool, then click to select a locator and drag to where you
want to measure the distance between. The distance measure updates
interactively.
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Editing the distance locators using the Attribute Editor
You can specify the start and points of the distance measure in X, Y and Z
from the Attribute Editor (Window > Attribute Editor).
To specify the start and end points of the distance measure:
Click the distanceDimensionShape# tab to open that section of the editor.
Enter values in the Start Point and End Point boxes to specify the start and
end points of the distance measure in X, Y, and Z.

To reposition the distance locator in local space:
Click the locatorShape# tab to open that section of the editor. Enter values in
the Local Position boxes to reposition the distance measure in X, Y, or Z.
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Displaying parameter values
Use the Create > Measure > Parameter Tool to display parameter values on
curves and surfaces at a specified point. This locator also displays the
direction of the curve or surface and the normal to the curve or surface at a
specified point.

Normal
Normal
Curve direction
Surface direction

To display parameter values on a surface or curve:
1

Select Create > Measure > Parameter Tool.

2

Click-drag on a curve or surface to display the parameter values at a
specified point.
For curves, the parameter value in U at the specified point on the curve
displays.
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For surfaces, the parameter value in U and V at the specified point displays.

To move the parameter locator:
Select the Move Tool, then click-drag a locator over the curve or surface. The
parameter values update as you drag.

If you create another locator, the previous locator is dimmed. This means
that you can move it later if you need to.
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Editing the parameter locators in the Attribute Editor
You can specify the U and V parameters values from the Attribute Editor
(Window > Attribute Editor).
Click the arrow beside the Nurbs Geometry box to access the curve or
surface whose locator you want to edit.
To specify the U and V parameter values:
Click the paramDimensionShape# tab to open that section of the editor.
Enter new U and V Param values.

In the following example, the first figure shows the parameter locator on a
surface at the position where it was created. The second figure shows how
the locator is modified when you change the U and V Param values.
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Measuring arc lengths
Use the Create > Measure > Arc Length Tool to measure and display arc
lengths on curves and surfaces at a specified point. It also displays the
direction of the curve or surface and the normal to the curve or surface at a
specified point.

Normal

Surface direction

Normal

Curve direction

To display arc length values on a surface or curve:
1

Select Create > Measure > Arc Length Tool.

2

Click-drag over a curve or surface to display the parameter values at a
specified point.
For curves, the distance of the specified point from the start point of the
curve is measured.
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For surfaces, the specified point from the start point in both the U and V
direction is measured.

To move the arc length locator:
Select the Move Tool, then click-drag over the curve or surface. The
parameter values update as you drag.
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If you create another locator, the previous locator dims, meaning you can
select to move it later if you want.

Editing the arc length locators in the Attribute Editor
If you want, you can specify the U and V parameters values from the
Attribute Editor (Window > Attribute Editor).
Click the arrow beside the Nurbs Geometry box to access the curve or
surface for which you want to edit the locator.
To specify the U and V parameter values:
Click the arcLengthDimensionShape# tab to open that section of the editor
and enter new U and V Param values.

In the following example, the first figure shows the arc length locator on a
surface at the position where it was created. The second figure shows how
the locator is modified when the U and V Param values are changed.
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DISPLAYING OBJECTS
This chapter describes the tools and actions you use to display or hide
objects and attributes. You can use these tools to customize your working
environment and reduce workspace complexity. Topics include:
•

“Displaying items in Maya” on page 119

•

“Using a grid” on page 120

•

“Displaying axes, polygon count, and frame rate” on page 122

•

“Specifying how objects display” on page 122

•

“Hiding and showing objects” on page 125

•

“Isolating selected objects or components” on page 129

•

“Displaying object components” on page 131

•

“Displaying NURBS components” on page 132

•

“Displaying polygon components” on page 135

•

“Displaying camera and light manipulators” on page 137

•

“Working with templates” on page 139

•

“Using display layers” on page 139

•

“Using render layers” on page 147

DISPLAYING ITEMS IN MAYA
You use the Display menu to show or hide NURBS, polygons, tools,
components, and attributes. When you hide or show items, it affects the
workspace globally.

USING MAYA: ESSENTIALS
119

DISPLAYING OBJECTS | 5
Using a grid

If you want to hide or show these elements for just one view, use that view’s
Show menu. You can also use the Show menu to display specific types of
objects (joints, lights, meshes, surfaces, and so on) in a 3D view. For
information on Show menu options, see “Hiding and showing objects” on
page 125.

Tip
You can also control the display of many items from the Attribute Editor.
See “Using the Attribute Editor” on page 262.

USING A GRID
A grid is a 2D plane that represents 3D dimensions in the view. You can use
grids to help animate relative to a solid surface. For example, you could use
a grid to help plan the foot positions of a person walking on the ground. You
can also use a grid to construct skeletons, because you can snap grid
coordinates on and off to precisely position joints.
You can hide the grid when you need to reduce visual clutter. For example,
if you have animated a character walking across a floor and want to view the
surface texture, you can toggle off the grid when you’re ready to fine-tune
the placement of the character’s feet.

To turn the grid off and on:
Select Display > Grid. To toggle the grid back on, select Grid again.
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Note
The default grid is a 24 x 24 unit grid displayed in the XZ plane.

Setting grid options
Use the Grid Options window to specify how the grid looks on the screen.
When you change grid options, Maya changes the display immediately.

Tip
Have at least one modeling window open when changing the Grid option.
This lets you view the changes interactively.
To set grid options:
1

Select Display > Grid ❐. The Grid Options window opens.

2

Set the following options and click Apply.

Grid

Specifies the size of the grid or the spacing between major grid lines. The
default is 5. The smaller the number, the less space there is between major
grid lines.

Subdivisions

Specifies the number of divisions between major grid lines. Setting the
Subdivisions option to a value greater than 1 specifies that each main grid
interval will be subdivided by the amount specified. The default is 5.

Extent

Specifies how far the grid is drawn in each direction. If the extent is 50 cm,
Maya draws the grid 50 cm in the +X direction and 50 cm in the -X direction.

Style

Changes the style of the grid, including:
Outline – Displays only the outline of the grid.
Axes – Displays the outline and the XZ axes.
Grid – Displays the outline, the XZ axes, and the major grid lines.
All – Displays the outline, the XZ axes, major grid lines, and subdivisions.

This is the default.
To restore the options back to their original settings, click Reset.
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To change the color of the grid, select Window >
Settings/Preferences > Colors. For more information, see “Where Maya
stores preferences” on page 462.

DISPLAYING AXES, POLYGON COUNT, AND FRAME RATE
Maya includes useful tools under the Display > Heads Up Display submenu.
View Axis

Displays the global axis at the origin (0, 0, 0) within the perspective view.

Origin Axis

Displays the global axis in the bottom left corner of all views. This is the
default.

Display Poly Count Shows polygon statistics for the visible objects displayed in the view panel.

This feature is useful for games development.

Total
Frame Rate

Selected Components

Displays the frame rate in Hertz for the current port.

SPECIFYING HOW OBJECTS DISPLAY
The Shading menu provides a number of ways to look at your scene. The
quality can range from a simple wireframe display to a smooth- shaded
view.
Wireframe

Draws edges for polygon meshes and isoparametric curves for surfaces. This
is the default shading quality.

Smooth Shade All

Displays all surfaces, meshes, and particles as smooth-shaded objects.

Smooth Shade Selected Items

Displays selected items as smooth-shaded objects.
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Flat Shade All

Displays all surfaces and meshes as flat-shaded objects.

Flat Shade Selected Items

Displays selected items as flat-shaded objects.
Bounding Box

Shows objects as boxes that represent their bounding volumes. Bounding
boxes speed up Maya operations and can make a significant difference for
complex models.
The bounding box encompasses the hulls as well as the actual geometry. As
a result, the bounding box may have dimensions larger than those of the
geometry.

Note
To see bounding box coordinates, open the Attribute Editor, click on the
shape node tab, and open the Object Display section. It shows the
read-only minimum and maximum world space boundary coordinates of a
surface along the X, Y, and Z axes.
Points

Shows objects as groupings of individual points.

Shade Options

There are two display options for shaded objects.
Wireframe on Shaded – Superimposes a wireframe display on all shaded

objects in a view.

Wireframe isoparms
appear over the
shaded objects

X-Ray – Displays all shaded objects as semi-transparent. This can be useful

for seeing hidden parts of a model.
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Interactive Shading Controls the display of objects during interactive modes (such as

transformations, camera navigation, and playbacks). At the same time the
normal display can be in some sort of shaded mode. For example, the
normal display can be smooth-shaded while the interactive display is
bounding box. There are four interactive shading options:
Normal – Keeps the interactive mode the same as regular display mode.
Wireframe – Displays objects in wireframe mode during the interactive

mode.
Bounding Box – Displays objects as bounding boxes during the interactive

mode.
Points – Displays objects as points during the interactive mode.
Color Index Mode

On IRIX only, lets you manipulate a wireframe object in a complex scene
more quickly (for example, if you are using a full-color image plane while
working in wireframe mode).

Dense Wireframe Acceleration

On NT only, lets you manipulate a wireframe object in a complex scene
more quickly. For example, suppose you have created a saloon scene with
many objects. When you use the Move tool to move a bottle in the scene, it
moves slowly as you drag the mouse. You can improve the interactive
manipulation of the bottle with this menu option.

Tip
When you use the Dense Wireframe Acceleration option, be aware of the
following:

Back Face Culling

Results vary with the graphics card installed in your
workstation.

•

Manipulation of wireframe objects in simple scenes is
slower.

•

Camera tumbling is unaffected.

For objects displayed in smooth shade or flat shade mode, makes the object’s
back face transparent which helps speed the display or manipulation of
objects.
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Hardware Texturing Displays a hardware rendition of the texture applied to a material shading

an object.
Apply Current to All Applies the current 3D view's shading style to all objects in the scene.

HIDING AND SHOWING OBJECTS
Use Display > Hide to hide items you aren’t using and reduce visual clutter
by hiding objects you are not working on. This is handy if you want to
remove an object from the view, but do not want to delete it or move it.
To redisplay items, use the Display > Show submenu, which includes the
same selections as Display > Hide. The Hide menu items are:
Hide Selection

Hides selected object(s).

Hide Unselected Objects

Hides all unselected objects.
Hide Unselected CVs

To control the display of CVs, select the CVs that you want to remain visible,
and then use Display > Hide > Hide Unselected CVs to hide all the other
CVs on that surface. This will affect the display of CVs in component
selection mode, as well as CVs displayed in object selection mode by the use
of Display > NURBS Components > CVs.

Tip
It is possible to use selective CV display on more than one surface at a
time.
The selective CV display function operates exclusively from other Maya
Hide and Show commands, and therefore menu selections such as Display >
Show > All and others do not effect CVs whose display has been set using
selective CV display.
All

Hides all objects, whether they are selected or not.

Hide Geometry

Displays a menu that lets you select the type of geometry you want to hide.

Hide Kinematics

Displays a menu that lets you select the type of kinematics you want to hide.
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Hide Deformers

Displays a menu that lets you select the type of deformers you want to hide.

Hide Cloth

Available only if you have Maya Unlimited and are using Maya Cloth.
Hides cloth objects. For details, see Using Maya: Cloth.

Lights

Hides lights.

Cameras

Hides cameras.

Texture Placements Hides texture placements.
Planes

Hides planes.

Markers

Hides markers.

Light Manipulators

Hides light manipulators.

Camera Manipulators

Hides camera manipulators.

Hiding geometry
Geometry represents the properties and relations of points, lines, surfaces,
and objects. You can hide a variety of geometry components.
To hide geometry:
1

Select an object.

2

Select Display > Hide > Hide Geometry and select the geometry components
you want to hide. You can hide, NURBS Surfaces, NURBS Curves, Polygon
Surfaces, Deforming Geometry, and Subdiv Surfaces. If you select All, all
geometry is hidden, whether it is selected or not.
Maya displays the object with the specified component hidden.
In the following illustration, the NURBS surfaces associated with a sample
object are hidden.
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Before

After

Hiding kinematics
Kinematics is the study of motion without consideration to the cause of that
motion. You can hide and show kinematic components.
For information on kinematics, see Using Maya: Character Setup.
To hide a kinematic component:
1

Select an object.

2

Select Display > Hide > Hide Kinematics and select the components you
want to hide. You can hide Joints, and IK handles. If you select All, all
kinematic components are hidden, whether they are selected or not.
Maya displays the object with the specified component hidden.
In the following illustration, an object’s joints are hidden.
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Before

After

Hiding deformers
Deformers are operations you apply to one or more geometry objects to
change their shape. You use the Hide and Show Deformers menus to control
the display of the “influence objects” for some deformation types. This helps
reduce clutter when you're not actively editing those parts of your scene.
For information on deformers, see Using Maya: Character Setup.
To hide a deformer:
1

Select an object.

2

Select Display > Hide > Hide Deformers and select the components you
want to hide. You can hide Lattices, Sculpt Objects, Clusters, Nonlinears,
Wrap Influences, and Smooth Skin Influences. If you select All, all deformers
are hidden, whether they are selected or not.
Maya displays the object with the specified deformer hidden.
In the following illustration, the object’s clusters are hidden.
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Before

After

ISOLATING SELECTED OBJECTS OR COMPONENTS
Use the Isolate Select feature (Show > Isolate Select > View Selected) to
quickly isolate objects or components in a view panel. You simply select the
items, choose Show > Isolate Select > View Selected, and all other objects
and components in your scene become hidden.
Unlike the Display > Hide commands, which hide mostly objects, the Isolate
Select feature can also isolate components. For example, by selecting
polygonal faces, you could isolate the head of a model. Another difference is
Isolate Select affects screen display only, while Display > Hide commands
also affect rendering.
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Isolate Select works on a per-panel basis for any view panel (perspective or
orthographic). The components you can select for isolation are:
•

CVs of NURBS surfaces

•

faces of a polygon mesh

•

faces of a subdivision surface mesh
Other components cannot be selected for isolation, such as NURBS patches,
curve segments, particles, or lattice points. However, you can still see and
manipulate other component types within the items you have isolated.
Use the Show > Isolate Select menu to control the isolate select feature. The
menu options are described below.

Tip
Keep open at least one other workspace panel with isolate select turned off
so you can select other items. Also, tearing off the Isolate Select submenu
gives you quick access to these commands.
View Selected

Activates or deactivates the isolate select feature. When activated, the word
“Isolate” appears at the bottom of the panel and the current selection
becomes isolated.
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Auto Load Selected Objects

Turn on to automatically update the isolate select panel when you change
your selection. If turned off, you must use the Load, Add, or Remove
Selected Objects options to update the panel.
Load Selected Objects
Add Selected Objects
Remove Selected Objects

If you don’t have auto load on, you can use these options to control the
isolate select display. Select items from the isolate panel or another panel
and then load, add, or remove them as needed. Note that Load Selected
Objects replaces the display with the current selection, while Add Selected
Objects adds the current selection to the selections already displaying.
Enables you to bookmark an isolated selection. To create a bookmark, choose
Show > Bookmarks > Bookmark Current Objects. Choose the option box if
you want to name the bookmark; otherwise, a default name is used.

Bookmarks

To view bookmarked items, choose Show > Bookmarks > BookmarkName.
Choose it again to turn it off and return to the previous view. You can view
multiple bookmarks at the same time.
Bookmarks are saved with the scene as a set. You can manage them using
the Relationship Editor. For more information on sets, see Chapter 11, “Sets
and Partitions.”

DISPLAYING OBJECT COMPONENTS
To help control screen clutter and display performance, you can toggle the
display of specific object components, on an object-by-object basis.
To display an object’s components:

Backfaces

BASIC FEATURES

1

Select an object.

2

Select Display > Object Components and select one of the following options:
If you selected a polygonal object, toggles the display of the object’s
backfaces.
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Backfaces

No backfaces

Lattice Points

If you selected a lattice deformer (an L icon represents a lattice deformer
handle), toggles the display of the lattice points. For information on lattices,
see Using Maya: Character Setup.

Lattice Shape

If you selected a lattice deformer, toggles the display of the object’s lattice
shape. The lattice deformer toggles between displaying its lattices and the L
icon. For information on lattices, see Using Maya: Character Setup.

Local Rotation Axes Toggles the display of the object’s local rotation axes. For information on

axes, see “Using axes and pivot points” on page 73.
Rotate Pivots

Toggles the display of the object’s rotate pivots. For information on pivot
points, see “Using axes and pivot points” on page 73.

Scale Pivots

Toggles the display of the object’s scale pivots. For information on pivot
points, see “Using axes and pivot points” on page 73.

Selection Handles

Toggles the display of selection handles on manipulators. For information on
manipulator selection handles, see “About manipulator handles” on page 73.

DISPLAYING NURBS COMPONENTS
Non-Uniform Rational B-Splines (NURBS) are a special type of B-spline that
can have weighted control points. You can use these control points to create
smooth curves that Maya can read from many CAD/CAM systems. Use the
NURBS Components options to display the NURBS component for a
selected object.
For more information on modeling with NURBS components, see Using
Maya: NURBS Modeling.
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To display a NURBS object’s components:
1

Select an object.

2

Select Display > NURBS Components and select one of the following
options: CVs, Edit Points, Hulls, Normals (Shaded Mode), Patch Centers,
Surface Origins, or Custom.
Surface origin display
Displaying Surface Origins is helpful for alignment and placement of the
surface. The command highlights the first U and V isoparms and labels them
U and V. It also draws a line indicating the surface normal direction. The
colors used for Surface Origins are defined in Window >
Settings/Preferences > Colors > Components.

Setting custom NURBS component options
Select Display > NURBS Components > Custom ❐. The Display Control
Options window opens.
You can specify the scope of which NURBS objects display their components
using the Scope pull-down menu. The scope can be active objects, all objects,
new curves, or new surfaces.

Displaying NURBS smoothness
You can select the object’s smoothness: Hull, Rough, Medium, or Fine.
To specify a smoothness:

Hull

BASIC FEATURES

1

Select an object.

2

Select Display > NURBS Smoothness and select one of the following options:
Shows hulls only.
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Rough, Medium, Fine

Displays objects at preset levels of quality. Selecting Medium or Fine slows
the display and interactivity, but improves image precision.

Tip
The hotkeys for these settings are: 1 (Rough), 2 (Medium), and 3 (Fine).
Custom

Lets you customize the display quality.
In the following figure, an object’s smoothness is changed from a default
medium level of quality to a custom hull quality level.

Before

After

Setting custom NURBS smoothness options
Select Display > NURBS Components > Custom ❐. The Smoothness Options
window opens.
Geometry

To display all geometry, select Full. To display hulls only, select Hull.

Surface Div per Span U
Surface Div per Span V

Together, these settings subdivide the NURBS patches for display purposes
to give it the appearance of a finer mesh. The range is from 0 to 32.
Curve Div per Span

Specifies the number of curve divisions per span to give the curves a
rougher or smoother appearance. The range is from 1 to 128.
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Display Render Tessellation Geometry

Turn on to see the pattern of tesselation that the renderer will use for the
surface. You must be in shade mode to see this pattern.
Shaded Surface Div per Span

Specifies the number of surface divisions per span in shaded mode. The
range is from 0 to 32.
Hull Simplification U
Hull Simplification V

If you have the Geometry set to Hull, you can use these settings to control
the number of hull divisions displayed.

DISPLAYING POLYGON COMPONENTS
Polygons are shapes that consist of a sequence of line segments. You can use
polygons to construct and control objects.
Polygons are based on a standard B-Rep (Boundary Representation)
structure, unlike curves and surfaces which are NURBS-based.
For more information on modeling with polygon components, see Using
Maya: Polygonal Modeling.
To display an object’s components:
1

Select an object.

2

Select Display > Polygon Components and select one of the following
options: Vertices, Border Edges, Soft/All Edges, Face Centers, UVs,
Normals, Long Normals, Medium Normals, Short Normals.

Setting custom polygon options
You can customize the following polygon display options by selecting
Display > Custom Polygon Display ❐. For more information, see Using
Maya: Polygonal Modeling.
Vertices

Displays vertices.
Display – Displays vertices.
Normals – Displays vertex normals.
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Backculling – Backculling is used to select and only draw what is in front in

the 3D view. In effect, Maya displays vertices in areas where the normal is
pointing away from the camera.
Edges

Displays edges.
Standard – Displays all edges the same.
Soft/Hard – Displays soft edges as dotted lines, and hard edges as solid lines.
Only Hard – Shows hard edges only (makes soft invisible).

Highlight

Changes borders.
Border Edges – Makes outside edges thicker. This makes them more visible

for certain operations.
Texture Border – Displays a thick border to highlight the area a texture

affects per polygon or per vertex.
Border Width

Enter a value or use the slider to set the polygon border width. The range is
from 1 to 10.

Face

Displays object faces.
Centers – Places a small square to indicate the facet center.
Normals – Shows the normals at the center of each polygon.
Triangles – Shows all polygons as triangles for display.

Show Item Numbers Displays how many vertices, edges, faces, or UVs an object has. Numbers

display on the object depending on which component type you select.
Normals Size

Enter a value or use the slider to specify the normals display size. The range
is from 1 to 10.

Texture Coordinates Displays the UVs on your object.
UV – Displays UVs.
UV Topology – Displays unshared UVs and enables you to select them.

For details, see the “Displaying texture coordinates (UVs) and UV topology”
section in Using Maya: Polygonal Modeling.
Color

Toggle on Color in Shaded Display to prepare for an Apply Color operation.
Select a Color Material Channel from the pull-down menu to refine your
application. For details, see the “Coloring Polygons” chapter in Using Maya:
Polygonal Modeling.

USING MAYA: ESSENTIALS
136

PART 1

DISPLAYING OBJECTS | 5
Displaying camera and light manipulators

Backface Culling

Backface culling is used to select and only draw what is in front in the 3D
view. Click to select an option from the pull-down menu.
Off – Toggles backface culling off. This is the default.
On – Displays backface culling, causing surfaces to appear invisible in areas

where the normal points away from the camera. You can improve
performance on some systems by toggling on Backface Culling.
Keep Wire – Sets backface culling for all surfaces except wireframe outlines.
Keep Hard Edges – Sets backface culling for soft edges only.

DISPLAYING CAMERA AND LIGHT MANIPULATORS
If a camera or light is selected, you can toggle its manipulators on or off. For
more information on manipulators, see “Using manipulators” on page 72.

Displaying camera manipulator controls
Use the options on the Display > Camera/Light Manipulator menu to
display manipulator components for the selected camera.

Pivot
Center of Interest

Clipping Panes

Clipping Panes

Cycling Index

Center of Interest

Toggles the display of the camera’s center of interest manipulator.

Pivot

Toggles the display of the camera’s pivot.

Clipping Planes

Toggles the display of the camera’s clipping planes.
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Cycling Index

Toggles the display of the camera’s cycling index. By clicking on this control,
you can cycle through the available manipulator controls for the selected
camera one at a time.

Displaying light manipulator controls
Use the options on the Display > Camera/Light Manipulator menu to
display manipulator components for the selected light.

Decay regions
(numbered rings)

Pivot
Cone Angle

Center of Interest

Penumbra

Cycling Index

Center of Interest

Toggles the display of a light’s center of interest manipulator.

Pivot

Toggles the display of a light’s pivot.

Cone Angle

Toggles the display of a light’s cone angle.

Penumbra

Toggles the display of a light’s Penumbra.

Look through Barn Doors

Barn doors are doors or shutters fitted on the spotlight, which let you create
a square spot effect. Shows the view through the spotlight’s barn doors.
Decay Regions

Toggles the display of a light’s decay regions.
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Toggles the display of the light’s cycling index. By clicking on this control,
you can cycle through the available manipulator controls for the selected
light one at a time.

Cycling Index

WORKING WITH TEMPLATES
Templates are objects that you can see but cannot select. If you make an
object into a template, you cannot accidentally select it or modify it. You
could make a background object into a template and use it as a modeling
reference (the way a grid is used)..
To make an object into a template:
1

Select the object.

2

Select Display > Object Display > Template. The object appears as a lighter
colored wireframe to indicate it is a template. Any shading is turned off.
To return a template to its standard display:

1

Select the object in the Outliner.

2

On the main Maya menu bar, select Display > Object Display > Untemplate.

USING DISPLAY LAYERS
A display layer is a collection of objects that you can quickly select, hide, or
template separate from other, distracting objects in the scene. For example,
you can:
•

add a group of trees to a display layer and hide them so they don’t distract
you from viewing another part of the scene.

•

create a template layer for the house of some creatures you’re modeling so the
house is visible as a size reference, but is not selectable.
Maya also includes render layers, which work similar to display layers but
apply specifically to rendering. For more information, see “Using render
layers” on page 147.

BASIC FEATURES

USING MAYA: ESSENTIALS
139

DISPLAYING OBJECTS | 5
Using display layers

Types of display layers
•

default – Each scene has a default layer that consists of all objects that have

not been assigned to any other layer. When you remove an object from a
layer, it becomes a member of the default layer.
•

standard - When you create a new layer, it is standard, meaning objects

display normally.
•

template – Objects in a template layer are visible, but you cannot select them,

nor can you snap to them.
•

reference – Objects in a reference layer are visible and can be snapped to, but

you cannot select them or modify them.

Display layer tools
Typically, you use the Layer Bar to manage layers. If the Layer Bar is not
displayed, select Display >UI Elements > Layer Bar.

Switch
Create new
between
layer
Display and
Render
layers

Layer menu

Color box

Scroll arrows

As an alternative, you can choose to perform all layer management using the
Layers window. For simplicity, we give instructions using the Layer Bar. If
you prefer the Layers window, see “Using the Layer Editor” on page 145 for
details.
Whether you use the Layer Bar or Layers window, you must also use the
Relationship Editor if you need to remove objects from a layer. See
“Removing objects from display layers” on page 142.
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Creating and naming display layers
Follow these instruction to create and optionally name a layer.
To create a new layer:
1

On the Layer Bar, click the New Layer button. An icon for the new layer is
added to the Layer bar, with a default name, for example, layer1.
New Layer button

2

Assign objects to the layer; see the next topic “Assigning objects to display
layers.”

Note
You can turn on or off the Make New Layers Current when you right-click
on the Create Layer button. When this setting is on, you can add a new
layer and Maya changes it to be the current layer. When this setting is off,
the default layer remains the current layer, unless you choose a different
current layer in the layer attributes.
To name a layer:
1

In the Layer Bar, double-click the layer you want to name.
The Rename Layer window appears.

2

Type a new layer name and click OK.

Assigning objects to display layers
You can add selected objects to a layer, and you can move an object from one
layer to another. An object can belong to only one layer at a time.
To assign selected objects to a layer:
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1

Select the objects you want to assign to a layer.

2

In the Layer Bar, click the ▼ Layer menu button to the left of the target layer.

3

Select Assign Selected.
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Note
If the selected object already belongs to a layer, the object is transferred
from its layer to the newly assigned layer.

Assigning objects at creation time
If you want objects you create to be automatically assigned to the current
layer, turn on the Use Current Layer option. (The current layer is the one
shown highlighted in the Layer Bar or Layers window.) Right click the
Create Layer button on the Layer Bar and choose Use Current Layer from
the pulldown menu.

Removing objects from display layers
When you remove an object from a layer, it automatically becomes part of
the default layer. You cannot remove objects from the default layer.
These instructions involve using the Relationship Editor. For more
information, see “Using the Relationship Editor” on page 255.
To remove an object from a layer:
1

In the workspace or Outliner, select the object you want to remove.

2

In the Layer Bar, click the ▼ Layer menu button to the left of the layer you
want to remove the object from, then select Edit Membership.
The Relationship Editor opens.

3

In the Layers panel, click the layer containing the object.

4

Select Edit > Remove Selected Items.
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Display Layer commands
Click the ▼ Layer menu button to choose from the layer commands. As a
visual aid, the layer swatch is marked X if Visible is off, T if Template is on,
or R if Reference is on.

Visible

Use this command to quickly hide objects in a layer so that you can
concentrate on other objects in the scene.

Standard

This is the default state that allows you to select and snap to objects.

Template

Objects in a template layer are visible in the workspace, but you cannot
modify, pick or snap to them. Objects in a template layer appear in a
different color. For details, see “Working with templates” on page 139.

Standard objects

Template objects

Reference

Like template layers, objects in a reference layer are visible in the workspace,
but you cannot modify them. You can, however, snap to all objects in the
reference layer by snapping to curve. For information, see “Snapping to a
curve on surface or isoparm curve” on page 154. Vertices and edit points do
not display on reference layers.

Assign Selected

Adds objects to the current layer.

Select All in Layer

Use this command as a quick selection method and to see what objects are
contained in the layer.
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Layer Attributes

Use this selection to edit the layer attributes in the Attribute Editor . See
“Modifying display layer attributes” on page 146.

Edit Membership

Opens the Relationship Editor for removing or adding objects to layers.

Delete

Deletes the layer, but not the objects in the layer.

Changing the color of the display layer:
To help you identify the objects belonging a layer, you can assign a color to
the layer. Each object in the layer will display the assigned layer color in
wireframe display. You cannot change the color of objects in the default
layer.
To assign a layer color:
1

In the Layer Bar, double-click on the layer color box. The Layer Colors
window opens.

2

Click on the color you want to make all objects in the layer.
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Using the Layer Editor
As an alternative to the Layer Bar, you can choose to perform all layer
management using the Layers window. To open it, select Window >General
Editors > Layer Editor.

New Layer

Creates a new layer with a default name, for example layer1.

Color palette

Assigns a color to all objects in the currently selected layer.

Select Contents

Selects all objects in the layer. Use this command as a quick selection method
and to see what objects are contained in the layer.

Assign to Current

Adds selected objects to the currently selected layer.

Assign to Default

Removes all objects in the currently selected layer to the default layer. The
current layer becomes empty so you can assign other objects.

Layer Attributes

Opens the Attribute Editor for the layer. There are some attributes in the
Attribute Editor not available through the Layers editor or Layer Bar.
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Edit Membership

Click to remove objects from the layer. The Relationship Editor opens, where
you can select the objects you want removed and choose Edit > Remove
Selected Items.

Visible, Invisible

Turns the visibility of objects in the layer on or off.

Standard, Template, Reference

Standard allows normal selection of objects. Template and Reference restrict
selection while keeping objects visible. See “Display Layer commands” on
page 143 for more information.
Rename

Click to open the Rename Layer window and change the layer name.

Delete

Deletes the layer, but not the objects in the layer.

Modifying display layer attributes
To further control in layers, open the Attribute Editor by clicking the
▼ Layer menu button and choosing Layer Attributes.
Display Layer

Type the name of the layer.

Enable Overrides

Turn this option off to disable the effects of the layer. Objects in the layer
will appear and behave as though they do not belong to the layer.

Display Type

Select how the layer will display.
Normal – Objects in the layer display normally, according the settings for the

layer. Objects in the layer can be selected and snapped.
Template – Objects in the layer become templates. You can see template

objects in the workspace, but you cannot select them, nor can you snap them.
Reference – Objects in the layer can be snapped to, but you cannot select

them or modify them.
Level of Detail

Select the level of display detail for layer objects:
Full – Displays full detail for layer objects.
Bounding Box – Shows objects as boxes that represent their bounding

volumes. Bounding boxes speed up Maya operations and can make a
significant difference for complex models.
Shading

Toggle on to make layer objects appear shaded when in shaded display.

Texturing

Toggle on to show textures on layer objects when in shaded display.
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Playback

Toggle on to animate layer objects during playback. If you have several
characters in a scene and want to look at each character’s animation
separately, you can place each character in its own layer and play back the
animation of each character as desired.

Visible

Toggle on to make the objects in the layer visible.

Color

Select the color of all objects belonging to the layer.

Number

This is the number assigned to the layer.

Merging display layers when importing files
To facilitate the merging of layers when you read in files, select Window >
Settings/Preferences > Preferences, click the Display category, and in the
Display Layer section select one of the following options:
None

All layers read in will be put in a new layer, and renumbered and renamed,
if necessary to preserve uniqueness.

By Number

All layers read in that have the same index number as an existing layer will
be merged with that layer rather than creating a new layer.

By Name

All layers read in that have the same name as an existing layer will be
merged with that layer rather than creating a new layer.

USING RENDER LAYERS
A render layer is a collection of objects that you can quickly render in
separate passes, giving you more flexibility when the shot is composited.
Once you have render layers set up, you can take advantage of the Render
Layer/Pass Control settings in the Render Globals. For more information on
these settings, see Using Maya: Rendering.
Maya also includes display layers, which work similar to render layers but
apply specifically to how objects display in the scene view. For more
information, see “Using display layers” on page 139.

BASIC FEATURES

USING MAYA: ESSENTIALS
147

DISPLAYING OBJECTS | 5
Using render layers

Creating and naming render layers
Follow these instruction to create and optionally name a layer.
To create a new layer:
1

On the Layer Bar, click the New Layer button. An icon for the new layer is
added to the Layer bar, with a default name, for example, layer1.
New Layer button

2

Assign objects to the layer; see the next topic “Assigning objects to display
layers.”
To name a layer:

1

In the Layer Bar, double-click the layer you want to name.
The Rename Layer window appears.

2

Type a new layer name and click OK.

Assigning objects to render layers
You can add selected objects to a layer, and you can move an object from one
layer to another. An object can belong to only one layer at a time.
To assign selected objects to a layer:
1

Select the objects you want to assign to a layer.

2

In the Layer Bar, click the ▼ Layer menu button to the left of the target layer.

3

Select Assign Selected.

Note
If the selected object already belongs to a layer, the object is transferred
from its layer to the newly assigned layer.
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Removing objects from render layers
When you remove an object from a layer, it automatically becomes part of
the default layer. You cannot remove objects from the default layer.
These instructions involve using the Relationship Editor. For more
information, see “Using the Relationship Editor” on page 255.
To remove an object from a layer:
1

In the workspace or Outliner, select the object you want to remove.

2

In the Layer Bar, click the ▼ Layer menu button to the left of the layer you
want to remove the object from, then select Edit Membership.
The Relationship Editor opens.

3

In the Layers panel, click the layer containing the object.

4

Select Edit > Remove Selected Items.

Render Layer commands
Click the ▼ Layer menu button to choose from the layer commands.
Renderable

Controls whether the objects in the layer render. This command can be
useful for performing test renders, but the main controls for rendering layers
are in the Render Layer/Pass Control settings in the Render Globals. For
more information on these settings, see Using Maya: Rendering.

Assign Selected

Adds objects to the current layer.

Select All in Render Layer

Use this command as a quick selection method and to see what objects are
contained in the layer.
Render Layer Attributes

This selection opens the render layer attributes in the Attribute Editor. These
attributes are also found in the Render Layer/Pass Control settings in the
Render Globals. See Using Maya: Rendering.
Edit Membership

Opens the Relationship Editor for removing or adding objects to layers.

Delete

Deletes the layer, but not the objects in the layer.
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Changing the color of the render layer:
To help you identify the objects belonging a layer, you can assign a color to
the layer. Each object in the layer will display the assigned layer color in
wireframe display. You cannot change the color of objects in the default
layer.
To assign a layer color:
1

In the Layer Bar, double-click on the layer color box. The Layer Colors
window opens.

2

Click on the color you want to make all objects in the layer.
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MODELING AIDS
Maya has many features that help you build and position objects. This
section describes some of those features and tells how to use them. It
includes the following information:
•

“Snapping” on page 151

•

“Limiting selections” on page 157

•

“Freezing and resetting transformations” on page 169

•

“Locking transform tools and manipulators” on page 170

•

“Using construction history” on page 170

•

“Making objects live” on page 171

•

“Creating levels of detail” on page 173
For a comprehensive guide to modeling features, see the Using Maya:
NURBS Modeling and Using Maya: Polygonal Modeling.

SNAPPING
The snap options let you control an object or component’s position by
attaching it to a grid, point, curve, or view plane. As you draw, rotate, resize,
or drag the object, it snaps to the grid, point, curve, or view plane.

Snapping icons
Four icons in the Status Line control snap mode as you move or rotate
objects and create curves:
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Snapping

Snap to Grids

Snaps a vertex (CV or polygonal vertex) or pivot point to a grid corner. If
you select Snap to Grids before you create a curve, its vertices snap to the
grid corners. For more information on CVs, see Using Maya: NURBS
Modeling.

Snap to Curves

Snaps a vertex (CV or polygonal vertex) or pivot point to a curve or curve on
surface.

Snap to Points

Snaps a vertex (CV or polygonal vertex) or pivot point to a point.

Snap to View Planes Snaps a vertex (CV or polygonal vertex) or pivot point to a view plane.

To snap an object or object component to a grid, curve, point, or view
plane:
1

To snap to a grid, select Display > Grid to display a grid in your workspace.
or
To snap to a curve, create a curve.
or
To snap to a point, create an object with several CVs or vertices (for example,
a curve).
or
To snap to a view plane, select a view (perspective, top, front, or side).

2

Click the appropriate snap icon in the Status Line.

3

Select the object or object component you want to snap to the grid, curve,
point, or view plane.
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If you are snapping an object component (for example, a vertex, edit point,
hull, or curve on surface), use the Select by Component Type icon
on the
status line to select the component. For information on selecting by
component, see “Limiting selection by component type” on page 159.
Note that when you select several components, each component snaps to the
same point.
4

Select the Move tool.
When you select several components, the move manipulator is placed at the
center of the selection’s bounding box.

5

If you are snapping to a point, right-click on the object with the vertices you
are snapping to and select Control Vertex or Vertex, to display the vertices.

6

Use the middle mouse button to click and drag anywhere on the grid, curve,
points, or view plane.
The object snaps to the grid, curve, points, or view plane. You can now move
the object along the grid, curve, point, or view plane.

Snapping hotkeys
The hotkeys for snapping are:
•

x for grid snap

•

c for curve snap

•

v for point snap

To use the grid snap hotkey:
1

Select the object or component you want to snap and select the Move Tool.

2

Press and hold down the x key while click-dragging on the grid with the
middle mouse button.
To use the curve snap hotkey:
Select the object or component you want to snap and select the Move Tool.
Press and hold down the c key while click-dragging on the curve you want
to snap to with the middle mouse button.
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To use the point snap hotkey:
1

Select the object or component you want to snap and select the Move Tool.

2

Right-click the object with vertices (CVs or polygonal) that you want to snap
to (for example, a curve), and select Control Vertex or Vertex to display the
vertices.

3

Press and hold down the v key and click-drag the selected object with the
right mouse button to the point you want to snap to.

Snapping along a constraint axis
You can constrain object positioning along a particular axis.
If you toggle on snapping and drag a Move Tool manipulator arrow (as
opposed to dragging the pivot point), Maya uses a combination of the snap
and the axis constraint.
If you are using grid snap, Maya snaps to the nearest grid line along the
specified axis.
If you are using point snap and grab the end of the arrow, the manipulator
has an initial jump because the center of the manipulator (not the tip)
follows the mouse position.
It is useful to snap to an axis when you want to align a group of vertices to a
particular Y position.

Tip
To minimize the initial jump, click closer to (but not on) the center of the
manipulator. This is especially important if you are using a large arrow on
the manipulator.
To change the size of the manipulator arrows, press the = and - keys.

Snapping to a curve on surface or isoparm curve
A curve on surface is a curve you have either plotted directly onto a live
surface in UV parameter space, rather than a curve in world space or
projected onto a surface as a result of a project or intersect function.
Curves on surfaces are often used for trimming.
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You can use Snap to curves to snap to an isoparm curve or a curve on
surface. This is useful if you want to snap a pivot to the edge of a surface.
But if you are moving vertices on a surface (with curve snap on) you can
accidentally snap to a curve on surface.

Tip
To avoid unintentional snapping, use the c hotkey instead of the Snap to
curves icon in the Status Line. See “To use the curve snap hotkey:” on page
153.

Snapping aligning objects
Instead of using the Move and Rotate tools, you can easily move an object to
a specific point by snap aligning the object.
You can snap a point directly to any other point (where a point can be a
surface point, curve intersection point, vertex, locator, etc).
2 Select destination point

3 Snap Align Objects
Point to Point

1 Select snap point

If you select two points on each object, the points define an axis snap, which
means the object will be rotated as well as translated. This technique is
useful for orienting one object with another along some arbitrary axis.
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2 Select destination axis
3

4
1
3 Snap Align Objects
Two Points to Two Points
1 Select snap axis

2

To snap a point to another point:
1

Select the point that you want to snap to another point.

2

Select the point you want to snap the first point to.

3

Select Modify > Snap Align Objects > Point to Point. The first selected point
snaps to the second selected point. Note that the whole object is translated,
not just the select point. For example, if you used CVs as points, the selected
CV is not moved alone, but the entire surface is.
To snap two points to two points:

1

Select the first point on the snap axis.

2

Select the second point on the snap axis. This defines the snap axis.

3

Select the first point on the destination axis. The first point you selected in
step number 1 will snap to this point.

4

Select the second point to define the destination axis. This defines the
destination axis.

5

Select Modify > Snap Align Objects > Two Points to Two Points. The first
selected point snaps to the third selected point, and the axis defined in steps
1 and 2 lines up with the axis defined in steps 3 and 4.
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To snap three points to three points:
1

Select three points on an object.

2

Select three points on the destination object.
Select the points on the destination object in the order you want the snap to
occur. The first point should correspond to the first point selected on other
object, and so on.

3

Select Modify > Snap Align Objects > 3 Points to 3 Points.

LIMITING SELECTIONS
Because Maya works on a selection-based mode, picking items is critical to
modeling. If you forget what needs to be picked for a tool or an action, hold
and drag the mouse button over the menu item. The Help Line displays the
type of selection required for the current item.
You can limit the items you can select in the workspace to specific types of
objects, components, or hierarchy elements. By limiting object selection, you
can avoid unintentionally selecting a nearby object. Limiting object selection
is also known as creating a pick mask or selection mask.

Limiting selection by object type
You can limit selection to various types of objects, such as NURBS curves.
To select only a specific type of object:
1

Toggle on the following:

Select by object type
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2

Click the adjacent ▼ icon to display the pull-down menu and select All
Objects Off.

3

Toggle on one of the following icons:
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Joints Surfaces Dynamics
Handles

IK End Effectors, Locators,
and Dimensions
Curves
Rendering
Deformations

To further limit the items you can select, click the right mouse button on the
icon and toggle off the appropriate check boxes.
4

Select the object. You can only select the type of object you have specified.

5

To return to the default selection mask, click the left-most ▼ icon in the
Status Line and choose Initial Default.
Example
Suppose you’ve created a tubular object and want to select the joint chain
within the object.

Joint

1

Toggle on the Select by Object Type icon.

2

Click the adjacent ▼ icon to choose All Objects Off.

3

Toggle on the Joints icon.

4

Click the object’s root joint. The root and its children become the selected
objects.
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5

To return to Maya’s default selection mask, click the left-most ▼ icon in the
Status Line and select Initial Default.

Limiting selection by component type
You can limit your selection to a specific type of object component, such as
polygonal vertices.

Using the selection mask to select components
To select only a type of component:
1

Select the object that has the components you want to select.

2

Toggle on the Select by Component Type icon.
Select by Component Type

3

Click the adjacent ▼ icon to select All Components Off.

4

Toggle on one of the following icons.
Lines

Hulls

Handles

Points

Local Rotation Axes
and Image Planes

Parameter Points

Pivots
Faces

To further limit the items you can select, click the right mouse button on the
icon and toggle off the appropriate check boxes.
5

Select the component.
If you didn’t previously select the object containing the component, the
object’s components will be displayed but not selected. Select the component
again.
Maya selects only the specified type of component.

6
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To return to Maya’s default selection mask, click the left-most ▼ icon in the
Status Line and choose Initial Default.
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Using the Paint Selection Tool to paint-select components
You can select, unselect, and toggle vertices (CVs and polygonal vertices) by
painting over them with the Paint Selection Tool. This gives you much
greater control than you have ever had over vertices and enables you to
work much faster.
You can apply global selections to the entire selected surface. With the click
of a button, you can select, unselect, or toggle all the vertices on a surface or
along any of its edges.
The CVs in the following illustration were selected in seconds with a single
brush stroke.

You can also use the Paint Selection Tool to select faces and edges on
polygons.
To select, unselect, or toggle vertices:
1

Select the surface.

2

Select the Paint Selection Tool (Edit > Paint Selection Tool) and define tool
settings, if required. For details, see “To define Paint Selection Tool settings:”
on page 162.

3

Click-drag the brush across the surface.
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To select CVs along an edge of a NURBS surface:
1

Select the NURBS surface.

2

Select the Paint Selection Tool and open the Tool Settings editor (Edit > Paint
Selection Tool ❐).

3

In the Edge Operation section, click a button to select the vertices along the
left edge, top edge, or right edge of the surface. Note that the edges are
relative to U/V parameterization. For information on U/V parameterization,
see Using Maya: Modeling.
To select, unselect, or toggle vertices globally:

1

Select the surface.

2

Select the Paint Selection Tool and open the Tool Settings editor (Edit > Paint
Selection Tool ❐).

3

In the Global Selection section, click a button to select, unselect, or toggle all
the vertices on the selected surface.

Selected

Unselected

Surface with vertices selected

Surface after clicking the
Toggle All button

To select polygon faces:
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1

Select the polygonal surface.

2

Toggle on the Select by component type button.

USING MAYA: ESSENTIALS
161

MODELING AIDS | 6
Limiting selections

3

Right-click the Faces selection mask button and toggle Faces on.

4

Select the Paint Selection Tool (Edit > Paint Selection Tool) and define the
tool settings (Edit > Paint Selection Tool ❐), if required.

5

Click-drag the brush across the surface.
To select polygon edges:

1

Select the polygonal surface.

2

Toggle on the Select by component type button.

3

Right-click the Lines selection mask button and toggle Poly Edges on.

4

Select the Paint Selection Tool (Edit > Paint Selection Tool) and define the
tool settings (Edit > Paint Selection Tool ❐), if required.

5

Click-drag the brush across the surface.
To define Paint Selection Tool settings:
Select the Paint Selection Tool and open the Tool Settings editor (Edit > Paint
Selection Tool ❐). Maya switches to component mode automatically.

Tip
You can define hotkey combinations to change most of the settings without
opening the Tool Settings editor. For details on setting hotkey
combinations, see “Defining Artisan hotkeys” on page 410.
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Setting the stamp profile
Radius (U)

If you are using a stylus, set the upper or maximum possible radius for the
brush. No matter how hard you press the stylus, the brush radius will not
exceed this radius. If you are not using a stylus, this setting defines the
radius for the brush.

Radius (L)

If you are using a stylus, set the lowest or smallest possible radius for the
brush when pressure is applied to the stylus. If you are not using a stylus,
this setting is not used.

BASIC FEATURES
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Shape

Click on the shape of the brush. This determines the shape of the area
affected by the selection.

Note
The brush profile alignment affects how vertices are selected. For details on
changing the profile alignment, see “To set the brush stamp profile
alignment:” on page 402.
Choosing the selection type
In the Selection Type section, specify what you want to do with the surface
area you paint:
Add to Current Selection

By default, this option is toggled on so that each stroke adds to the previous
selection. This means you do not have to press the Shift key when you make
a brush stroke to select, unselect, or toggle more vertices. If you want each
stroke to override the previous one, toggle Add to Current Selection off.
Select

Selects vertices.

Tip
To unselect selected vertices while Select is chosen, press the Ctrl key and
paint over them.
Unselect

Unselects any selected vertices.
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Tip
To select unselected vertices while Unselect is selected, press the Ctrl key
and paint over them.
Toggle

BASIC FEATURES

Unselects selected vertices and selects unselected vertices.

USING MAYA: ESSENTIALS
165

MODELING AIDS | 6
Limiting selections

Limiting selection to hierarchy items
You can limit selection to the following hierarchy items:
•

root – a heirarchy’s top object

•

leaf– descendent object
For information about hierarchies, see “Understanding scene hierarchy
terminology” on page 322.
To select only a hierarchy root or leaf:

1

Toggle on the Select Hierarchy and Combinations icon.
Select Hierarchy
and Combinations

2

Toggle on the Root or Leaf icon.
Root

Leaf

or
Click the adjacent ▼ icon to select Root or Leaf.
3

Select the object. Notice you can select only a root or leaf object.

4

To return to Maya’s default selection mask, click the left-most ▼ icon and
choose Initial Default.

Limiting selection to template objects
You can limit your selections to template objects.
To select only a template object:
1

Toggle on the Select Hierarchy and Combinations icon.
Select Hierarchy
and Combinations
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2

Toggle on the Template icon.
Template

Alternatively, click the adjacent ▼ icon to select Template from a menu.
3

Select the object. Maya selects only a template object.

4

To return to Maya’s default selection mask, click the left-most ▼ icon in the
Status Line and choose Initial Default.

Limiting selection by task
You can limit your selection to the objects or components that pertain to
types of Maya tasks. For instance, you can limit selection to objects and
components relevant to dynamics tasks.
To limit selection by Maya task:
1

If it isn’t showing, open the Task Selection icon on the Status Line.

Click the bar to expand

2

Click the pulldown icon and choose one of these categories:

•

Animation

•

Polygons

•

NURBS

•

Deformations

•

Dynamics

•

Rendering
This creates a selection mask that limits selection to the objects and
components in the chosen category.

BASIC FEATURES

3

Do one of the following:

•

To select an object in the chosen category, drag a selection box around the
object.

•

To select a component in the chosen category, click the component directly.
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•

You usually need to display components before you can click-select them.
For example, to select CVs by clicking, first select Display > NURBS
components > CVs to display them.

•

If you display CVs on an object and the selection box surrounds any of them,
you select the CVs rather than the object. Drag the selection box on the object
where CVs aren’t displayed.
To use the default Maya selection limitations:
Click the ▼ icon in the Status Line to choose Initial Default.
To allow selection of all objects:
Click the ▼ icon in the Status Line to choose All Objects.

Tip
You can customize the priority of object or component selection for
situations where you drag a selection box around multiple objects or
components.
To prioritize object selection:
1

Select Window > Settings/Preferences > Preferences
and click the Selection category.

2

Select Custom from the PreSets menu.

3

Select an item in the Priority list.

4

Enter a priority number for the item in the data box.
Higher numbers have higher priority.

Moving selection limitations to the shelf
You can put your selection limitation choices on a shelf for future use.
To move selection limitations to a shelf:
1

Select a shelf tab.

2

Toggle on the object or component selection limitation icons.

3

Click the right mouse button on individual icons to Toggle on (or off) item
check boxes.
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4

Click the right-most ▼ icon in the Status Line to choose Save to Shelf.
An icon labeled MEL appears on the shelf. If you click this icon, the selection
limitations take effect. The Status Line icons show the selection limitations.
You can change the MEL icon, as described in “Changing shelf icons” on
page 502. If you want to add an icon label, see “Setting Shelf label options”
on page 506.

FREEZING AND RESETTING TRANSFORMATIONS
Before animating a model you just created, you may want to reset it’s
transformation, called freezing the transformations. Freezing sets the existing
translation, rotation, or scale for selected objects to be the initial state. The
result is that transform values change to zero (or one for scale), but the object
itself remains in place.
You can also reset an object’s transformations at any time. The reset
command transforms the object back to the translation, rotation, and scale it
was when created or last frozen.
You can apply these operations separately for translation, rotation, or scale.
To freeze or reset an object:
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1

Select one or more objects that you have moved, rotated, or resized.

2

Choose Modify > Freeze (or Reset) Transformations ❒.

3

In the option window, turn on or off Translate, Rotate, or Scale, as needed.

4

Click OK.
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LOCKING TRANSFORM TOOLS AND MANIPULATORS
If you are going to be using a single tool on an object for a long time, you can
lock the transform tools—Move, Rotate, Scale—and the Show Manipulator
tools. It is also useful to lock tools when you use a stylus input device.
After you lock a tool, you can’t use the left mouse button to select objects in
the workspace. The left mouse button works the same way as the middle
mouse button does during normal use of the Move, Rotate, Scale, or
Manipulator tools. If you need to select objects after locking a tool, use the
Outliner or Hypergraph.
To lock the Move, Rotate, Scale, or Show Manipulator tool:
1

Select the object.

2

Select the tool.

3

Toggle the Lock current selection icon on in the Status Line.
To unlock the tool and return to normal mouse usage, toggle off the icon.

USING CONSTRUCTION HISTORY
When you create an object surface using deformers or certain modeling
tools, Maya keeps a construction history for the object. A construction history
is a record of the options, geometry, and modeling actions that you used to
create the object.
You can use the construction history to modify an object by making simple
changes to the original elements of the history. You don’t have to repeat all
the steps that went into the object’s creation.
Construction history adds complexity to a scene and therefore slows Maya
operation. For this reason you might decide to toggle it off for some scenes.
You can toggle off the creation of construction history for all subsequent
modeling activities. If you do this, you won’t be able to tweak history
options and geometry for object surfaces you create afterwards.
Alternatively, you can delete a single object’s construction history.
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To toggle off construction history for all objects:
Toggle the Construction History icon off in the Status Line.

Tip
When you attach curves or animate CVs, toggle construction history off or
you may get unexpected results.
To delete an object’s construction history:
1

Select the object.

2

Select Edit > Delete by Type > History.

Tip
If you animate CVs on an object that was created with history, do not
delete the object’s history. The CV animation will not be correct and
unexpected results will occur.

MAKING OBJECTS LIVE
When you “make an object live,” you can use its surface as a construction
aid. You can make NURBS surfaces, poly meshes, and construction planes
into live objects. Making a NURBS surface live is one way to create a curve
on surface.

Note
Only one object can be live at a time. The live object displays in a special
green color in wireframe mode to indicate its status.
To make an object live:
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1

Select the object.

2

Select Modify > Make Live or click the Make Live icon on the Status Line.
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3

To toggle off a live object, select Make Live again.
To create a curve on surface by placing it onto a live surface:

1

Select the surface.

2

Select Modify > Make Live or click the Make Live icon on the Status Line.

3

Use any curve creation tool to draw the curve directly onto the surface.

Trim curve

Trimmed surface

All creation tools respect a live surface. Actions do not.
You can use Make Live to place particles on an object's surface or on joints
and polygons.
When an object is live and the Move tool is the current tool, the active object
snaps to the live object.
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CREATING LEVELS OF DETAIL
You can group geometry into a special Level of Detail group, which means
that depending on how far the group is from the camera, a different child, or
resolution, of the group is displayed.
An object can have any number of levels of detail, but typically 3 to 5 levels
are used in the creation of a game. Level 1 is drawn when the object is closest
to the camera and it typically has the most geometry. Level N is drawn when
the object is far away from the camera and has the least amount of geometry.
This level can be empty.
Creating levels of detail can involve one or more artists/programmers, and
two tasks. The first task is to create the models for each level. The second
task is to set up the order of the models (usually by complexity) and the
distances at which each level is drawn.

Notes
•

Setting up level of detail will not work if you specify
less than two levels of detail.

•

Different levels can come from different sets, layers,
and can be reference objects.

•

Level of Detail only supports discrete levels of detail.
For example, there is no blending between levels.

•

You can use NURBS, polygons, or subdivision surfaces
to create the different levels, and each level can use a
different geometry type if you want.

To create levels of detail:
1

Create models to represent different levels of detail, in order of geometric
complexity.
The models can be in different layers or sets, or they can be referenced
objects.

2
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Position the models together in a modeling view at approximately the
distance that you want the middle object to appear in the level of detail.
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Positioning the objects together helps you keep track of them in cases where
you have multiple groups and many models in the same scene.
3

Look through the camera to which you want to associate the level of detail
group.

4

Do one of the following:

•

Select the models in the order you want them to appear in the level of detail
group (either lowest to highest or highest to lowest), then select Edit > Level
of Detail > Group.

•

Select a camera and the models in the order you want them to appear in the
level of detail group, then select Edit Level of Detail > Group. The selected
camera is used in the level of detail group.
The objects are grouped under a new node, called lodGroup#, which is
linked to the camera you are looking through.

5

Preview the levels by zooming in and out.

Note
Only one of the levels is visible at a time. The levels switch as you zoom in
and out.

Changing the Threshold distances
You can change the distances at which the levels are switched using the
channel box.
To change a Threshold distance:
1

Select the level of detail group node in Hypergraph.
Its level of detail attributes are displayed in the Channel Box.

2

Edit the Threshold value for the object whose distance you want to change,
and press Enter.
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Re-ordering the levels
You can re-order the levels after you create a level of detail group.
To re-order the levels in the Outliner:
In the Outliner, use the middle mouse button to drag the object you want to
move into its new position within the group. This is the easiest way to reorder the levels.
To re-order the levels in the Hypergraph:
1

In the Hypergraph, use the middle mouse button to remove the object you
want to re-order from the group.
The other objects in the group move up the group hierarchy.

2

Use the middle mouse button to drag the removed object onto the lodGroup
node.
The object is added to the bottom of the lodGroup’s hierarchy.

Tip
You can also re-order a group by selecting Edit > Level of Detail >
Ungroup. Re-order the objects and create a new group.

Adding and editing levels
To add a new level:
1

Create a new object to add to the level of detail group.

2

Do one of the following:

•

In the Hypergraph, use the middle mouse button drag the new object onto
the lodGroup node.

•

In the Outliner, use the middle mouse button to drag the new object onto the
group.
The new object is added to the bottom of the lodGroup’s hierarchy.
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Tip
You can also re-order a group by selecting Edit > Level of Detail >
Ungroup. Re-order the objects and create a new group.

Previewing more than one object at the same time
You can preview different objects at the same time to compare them.
To view more than one object:
1

In the Hypergraph, select the level of detail group node.
The node’s attributes are displayed in the Channel Box. Each Display Level
has three possible settings: uselod, show, and hide.

2

Use the left mouse button to click on one of the Display Level’s uselod text.
A drop-down menu with the three options is displayed.

3

Select one of the options.
You can show or hide any combination of objects.

Tip
Reset the Display Levels to uselod to return to the regular level of detail
behavior.
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Notes about orthographic cameras and level of detail
Level of Detail displays one child of a level of detail group, depending on
the group’s distance to a camera. For perspective cameras, this means
measuring the distance between the camera position to the center of the
bounding box of the group.
For orthographic cameras, the distance is measured differently. This is
because zooming, panning and dollying in an ortho view does not change
the camera position, but instead changes the camera’s orthographic width. So
the distance is measured as:
distance = (default camera distance) * (camera’s
orthographic width)/(default orthographic width)

Substituting Maya’s default values in this equation results in the following:
distance = 3.333 * (camera’s orthographic width)
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MANAGING FILES AND
PROJECTS
Maya includes many features to help you manage your files and projects.
This chapter describes how to open and save files, import and export files,
how to create and edit projects, and what files formats are supported by
Maya.
•

“Opening a scene” on page 180

•

“Creating a new scene” on page 181

•

“Setting Open options” on page 181

•

“Importing files” on page 184

•

“Supported file formats” on page 196

•

“Saving files” on page 198

•

“Exporting files” on page 201

•

“Using plug-ins for exporting” on page 205

•

“Optimizing scene size” on page 212

•

“Managing projects” on page 213

•

“Editing the current project” on page 218

•

“Mapping missing directories” on page 218
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OPENING A SCENE
When you open a scene, Maya tries to read the scene’s contents through a
filter based on currently supported file formats. For a list of file types you
can open in Maya, see “Supported file formats” on page 196.
To open a scene:
1

Select File > Open Scene.
Maya displays a file browser. When you start up Maya, the file browser
automatically goes to the scenes directory of your current project. For
information on setting projects, see “Creating projects” on page 215.

2

To display all the file types you can open, select Best Guess from the Files of
Type pull-down menu (NT only).
or
To display specific file types, select the file type from the Files of Type pulldown menu (NT only).

3

Navigate to the file you want to open and click Open or double click on the
file.
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Note
Maya lists the files you have opened in the current Maya session on the
Recent Files sub-menu. You can open these files at any time during the
session by selecting File > Recent Files > filename. When you close Maya,
the list becomes empty.

CREATING A NEW SCENE
When you create a new scene file, the current scene file is closed and the file
changes to that of the newly opened file.
To create a new scene:
1

Select File > New Scene.
If you haven’t saved the current scene, a Confirm dialog box displays.

2

To save the contents of the current scene file, click Yes. To discard the
present scene file, click No.

SETTING OPEN OPTIONS
The Open Scene window lets you set some general options and some options
that are specific to file types.
To set Open options:
1

Select File > Open Scene ❐.
or

BASIC FEATURES

•

Select File > Open Scene and click the Options button in the Open window
(NT).

•

Select File > Open Scene and select Options > Options in the Open window
(IRIX). The options window opens.

2

In the Open Options window, you can set the options listed below. Click
Open to open a file or click Save to save the Open options without opening a
file.
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General options
File Type

Select the file format you want to use as a default for the next time you open
a file.
If you have a project set up, when you open a scene, the browser points to
the directory containing files of that type. On NT, it also sets the filter to
display only files of the selected type. See “Creating projects” on page 215
for information on setting up projects.
For example, if you set File Type to DXF, when you open a scene, the Open
window displays the contents of CurrentProject/DXF. On NT, it also sets
your filter type to DXF.
Depending on the File Type you select, various File Type Specific Options
are displayed.

Execute Script Nodes

Script nodes contain Mel scripts in mayaAscii or mayaBinary files. You can
designate a script node to execute its script when the node is read from a file,
or before or after rendering a frame. You can create and edit the script nodes
using the Expression Editor. See the chapter “Using Script Nodes” in the
Using Maya: MEL book for information on creating and editing script nodes.
User interface configuration information is stored inside the Maya scene file
as an attribute on a script node. If you disable the Execute Script Nodes
option, the UI script nodes are not executed. However, we recommend
disabling script node execution only if you have an error in your script.
Load Deferred References

Turn on Load Deferred References option to load referenced files that may
have been unloaded. When you unload a reference, Maya removes the
reference contents from the scene but “remembers” how the reference was
connected into the scene.
If you create a scene with references, unload some of them, and then save
the scene, you have created some deferred references. If you turn on the
Load Deferred References option, the deferred reference are loaded when
you open the scene. If you turn off Load Deferred References, the deferred
references are not loaded when you open the scene.
Turn on Load Deferred References when rendering a scene in which the
animators were working with only part of the scene loaded when they saved
the scene.
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mayaAscii, MayaBinary, and MEL. File Type Specific Options
Use Verbose Names

Displays the full names of node attributes in the file.
For example, if you select the Use Verbose Names option, attribute names
are listed as, setAttr.translate 0 0 0 when you open the Maya ASCII file in a
text editor. If you turn off the Use Verbose Names option, attribute names
are listed as setAttr .t 0 0 0.
OBJ File Type Specific Options
Create Multiple Objects

Specifies how shapes are created in OBJ files.
Select True to create individual shapes based on grouping information
specified in the OBJ file.
Select False to create one shape for the entire file, with object sets
corresponding to each of the specified groups.
You cannot have overlapping groups, If you do, Maya informs you that
overlapping groups exist, and re-reads the file as if the option were set to
false.
Sound File Type Specific Options
Sound File Offset

Specifies the time the sound should start playing.
For example, suppose you created an animation of a bird walking a
tightrope, and you wanted the sound file to play after the bird reached the
end of the rope. If you knew that the bird reached the end of the tightrope at
time 108, you would specify a sound file offset of 108.
Move files
You must import move files (see “Importing move files” on page 186).
Anim files
You must import anim files (“Importing animation curves” on page 188).
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IMPORTING FILES
Maya has built-in translators that let you import scenes and files created in
other applications into Maya. See “Supported file formats” on page 196 to
see the types of files you can import.
There are two ways to import a file:
•

You can copy the imported file into the current scene using File > Import.
See “Importing files by copying” on page 184 for details.

•

You can import the file by reference using File > Create Reference. When
you import by reference, Maya makes a link to the file rather than copying it.
See “Importing files by reference” on page 190 for details.

Using default nodes
Default nodes are built-in nodes that always exist in Maya. These nodes
represent global elements, such as camera positions, shader colors, and
current time frames.
When you import a file into an active scene, Maya uses the default nodes for
the active scene.
For example, if you changed a scene’s default shader color to red, this
change would be saved. However, if you imported this scene into another
scene, Maya would ignore the changed shader color and use the current
default shader color instead. This is to prevent default nodes from suddenly
changing.
Since default nodes are always present in Maya, you don’t need to create
them when you open a file. Only changes made to the defaults are saved.
For more information on default nodes, see Using Maya: Expressions.

Importing files by copying
Importing by copying makes it easier to transfer imported material from one
scene to another. However, copying increases the file size. If also means that
you must delete the imported objects and import the source scene again, if
you change it.
To import by copying:
1

Select File > Import.
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2

Navigate to the file you want to import.

3

Double-click the name of the file you want to import.
Maya copies the contents of the specified file into the current scene.

Setting import options
Import options are values you specify, that take effect whenever you import
a file into a scene. You can override the import options for a specific session.
To set import options:
1

Select File > Import ❐. The Import Options window opens.

2

You can set the following options:

Group

Specifies whether the imported objects are grouped under a single transform
when you import the file. Grouping makes it easier to work on the nodes of
imported objects. The default is off.

Use Namespaces

When you import or reference a scene with the Use Namespaces option
turned on, Maya creates a new namespace that contains the imported or
referenced data. Turning on the Use Namespaces option ensures that all
nodes are uniquely named.
A namespace is a grouping of objects under a given name. Each item in a
namespace is identified by its own name along with the namespace it
belongs to.
By default, the basename of the imported or referenced file is added to the
beginning of the imported or referenced object names, separated by colons.
For example, if you are importing a scene named foo.ma that contains an
object named ball, after it’s imported the ball is named foo:ball.
You can change the prefix by selecting Resolve clashing nodes with this
string and entering a prefix.
You can create, name, parent, and remove namespaces using the namespace
command. See the online documentation for MEL Commands for
information on the namespace command.
Namespaces do not effect selection, the DAG, the Dependency Graph, or any
other aspect of Maya.
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Resolve Name Clashes by

When you import a scene into another scene, naming conflicts occur if the
nodes share the same name and parent nodes.
To resolve these naming conflicts, you can rename only nodes with the same
name and parents (clashing nodes) or you can rename all nodes. You specify
whether to use the filename as the prefix (the default) or to create a prefix
string.
For more information on node hierarchy, see Using Maya: Expressions.

Tip
We recommend you use namespaces to resolve naming conflicts instead of
using the Name clash options when importing or referencing files.
Type is

Choose the file type you will be importing from the pull-down menu. If you
aren’t sure what type of file you will be importing, you can use the Best
Guess setting if you don’t know what type of file will be imported.
Depending on the file type you select, various file type specific options may
be displayed, see “Setting Open options” on page 181 for information on
these options.

Importing move files
When you import move files, you must list the attributes to import or export
in the text list in the move file option box.
The move file format is just list of numbers. No information on how those
numbers should be used is included in the move file. Instead, each row is
assumed to be a frame of data, and each column represents a single channel
of data.
This is the same move file format used by the Wavefront PreView program,
with the addition that comment characters (# or // ) at the beginning of a
line are allowed.
Since time data is not stored with the file, when exporting a move file, the
attribute’s value is written at each frame. The units of the file are your
current units in Maya. When importing a move file, the current time of the
scene is used as the starting point of the import.
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For both the import and export functions, all node naming clash and group
options are ignored.
To import a move file:
1

Select File > Import ❐. The Import Options window opens.

2

Select move from the File Type pull-down menu.

The following file type specific options apply to importing move files:
Attributes

Type the name of an attribute in the Attributes box and click Add to add the
attribute to the list of attributes to use when importing or exporting. If the
attribute is already included in the list, a duplicate is not made. To remove
an attribute, type the name of the attribute and click Remove. You can add
several attributes at one time by separating them with a space.

From Channel Box

Click From Channel Box to combine all of the selected objects in Maya, in the
order of their selection, with the channels selected in the channel box and
place them in the list. For example, if sphere and cone are selected, and tx, sx
are selected in the channel box, sphere.tx sphere.sx cone.tx and cone.sx are
added to the list of attribute to import and export.

Remove Selected

Click Remove Selected to remove all of the attributes selected in the list.

Remove All

Click Remove All to remove all of the attributes are removed from the list.

Precision

This is ignored in file export. For file import, this sets the precision of the file.
When you click import or export, the move file is written or read and only
the attributes in the list are affected.
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Importing Adobe Illustrator® and EPS files
You can import Illustrator and encapsulated postscript (EPS) files into Maya.
With this feature, you can create 3D models based on 2D graphics, such as
text or logos. Maya imports them as NURBS curves, which you can then
group into surfaces, convert to polygons, and so forth.
Support for Illustrator files extends from version 4 up to version 8. Any
versions before 4 or after 8 are not necessarily supported.
How curves are converted
The curves from Illustrator and EPS files are actually Bezier curve segments.
During import, Maya attaches the segments into a single curve. The Curve
Degree is set to 3 (cubic) and the Knot Spacing is set to Multiple End Knots.
To import an Illustrator or EPS file:
1

Choose File > Import.

2

In the file browser, navigate to the Illustrator or EPS file.

3

If needed, click the Options button (NT) or choose Options > Options (IRIX)
to set the following controls.

4

Scale Factor

Allows you to control the scale of the curves produced
from the import. It is the same operation as using the Scale
tool.

Group

Turn on this option to group the imported curves. It is the
same operation as using the Edit > Group option.

Click Import.

Importing animation curves
You can import animation curves from an anim file. To do this, you must
first select the objects you want to connect to the animation curves. If
nothing is selected the anim import will fail. Maya imports the animation
curve into the API clipboard and pastes it into the file.
To import animation curves from an anim file:
1

Select Window > Settings/Preferences > Plug-in Manager to verify that the
animImportExport plug-in is loaded.
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2

Open the file into which you want to import the animation curve.

3

Select the object which you want to connect to the animation curves.

4

Select File > Import.

5

Select animImport from the Read As pull-down menu (IRIX).
or
Select animImport from the Files of Type pull-down menu (NT).

6

Navigate to the file you want to import.

7

Double-click the name of the file you want to import.
Maya copies the contents of the specified file into the current scene.
To set anim import options:

1

Select File > Import ❐. The Export Selection Options window opens.

2

Select animImport from the File Type pull-down menu. The Export Options
window opens.
You set the following options in the Import Options window:

Time Range

Start – Imports the animation information to the selected objects so that the

animation starts at the time specified in the Start Time field.
Start/End – Imports the animation information to the selected object or

objects, scaling the animation to fit into the specified time range as entered in
the Start Time and End Time fields. Animation information from the keys
clipboard is
either scaled or clipped depending on the setting of the
Clipboard Adjustment option.
Current – Imports the animation information to the selected objects so that

the animation starts at the current time as displayed in the Animation
Controls.
Clipboard – Transfers the animation information to the selected object or

objects, preserving the duration and timing of the animation information on
the keys clipboard.
Copies – Specify how many copies of the anim curves you want imported.

Multiple copies are appended sequentially.
Help Images
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Turn on Help Images to display illustrations of the effects of the various
anim import options.
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Clipboard Adjustment
Preserve – Pastes the contents of the clipboard into their new positions on

the curve without any changes.
Scale – Becomes enabled when Start/End is selected. The complete contents

of the clipboard curves are stretched or compressed to fit into the specified
import Time Range.
Fit – Becomes enabled when Start/End is selected. The contents of the

clipboard are preserved (that is, not stretched or compressed) and as much
as will fit into the specified time range is pasted into the new area.
Paste Method

Insert – Places the clipboard contents before any existing keys in the

specified time range. The keys from the original curve that were after the
specified time range are shifted in time by the pasted range times.
Replace – Becomes enabled when Start/End or Clipboard is selected. The

clipboard contents overwrite any existing keys in the specified time range.
Merge – The clipboard contents are added to any existing keys on the curve.

In the case where a clipboard key is at the same time as an existing key, the
clipboard’s key replaces the existing key.
Replace Region

These buttons are enabled when Paste Method is set to Replace.
Time Range – Replace keys and curve segment information in the specified

time range with the contents of the keys clipboard.
Entire Curve – Is available only when the Time Range setting is Clipboard.

The Entire Curve setting replaces the animation curve(s) on the imported
attributes with the contents of the keys clipboard, in effect deleting any
existing animation curves on these attributes and applying the new curves
from the keys clipboard.
Connect

Adjusts the keys clipboard curves in value, so there’s no discontinuity in the
animation at the start of the pasted segment.

Importing files by reference
When you import a scene by reference, Maya makes a link from the current
scene to the source scene. This link points to the latest saved version of the
scene. You cannot rename, delete, or ungroup objects from a referenced file.
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You can develop the referenced file while you use it in other scenes. For
example, say you had three scenes in an animation that all used the same
props. In one scene, the chair is beside the table. In the second, the chair is
on top of the table. In the third, the chair is on the floor. If you imported the
files by reference, three animators could use the same props, saving file
space and sharing changes made to the surface characteristics and shading of
the objects.

Note
Node names from referenced files appear red in the Hypergraph. In
contrast, node names from non-referenced files appear black.
To specify a referenced file:
1

Select File > Create Reference.

2

In the file browser, navigate to the file to reference and click Reference.
You can also use this window to reference files on other systems (including
IRIX) on your network.
Maya loads the selected scene into the scene you are working on.

Tip
Turn on the Use Namespaces option if you referenced expressions that
include statements in MEL command format that include object names.
Statements in conventional expression format work whether or not you
include object names. The Expression Editor resolves name changes.

Setting Reference options
You can specify file reference options. Maya uses these options the next time
you import by reference. You can change the options as you work to
override existing import by reference options for only the current session.
To set reference options:
1
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Select File > Create Reference ❐. The Reference Options window opens.
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2

Set the options. See “Setting import options” on page 185 for information on
setting Group, Namespaces, Name clash, and File Type options.

Using the Reference Editor
You use the Reference Editor to specify settings for importing files by
reference. You can:
•

Create Reference (see “Importing files by reference” on page 190).

•

Import Reference (see “Importing a referenced scene” on page 193).

•

Export Selection As Reference (see “Exporting a selection as a reference” on
page 193).

•

Remove Reference (see “Removing a reference from a scene” on page 194).

•

Select Reference Contents (see “Selecting the contents of a referenced scene”
on page 194).

•

Load Reference/Unload Reference (see “Loading and unloading reference
files” on page 195.

•

Replace Reference (see “Replacing reference files” on page 195).

•

Clean up References (see “Cleaning up references” on page 196).
To use the Reference Editor:

1

Select File > Reference Editor. The Reference Editor opens.
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2

Select a referenced file.
When you select a referenced file using the Reference Editor, Maya displays
information about the file, called File Particulars.
File Particulars

Name

Displays the name of the file.

Type

Displays the file format.

Status

Indicates if the file has been changed in some way.

Load

Indicates is the referenced file is loaded or unloaded. See “Loading and
unloading reference files” on page 195.

Sub-type

Displays the sub-type of file.

I/O

Indicates if the file can be changed. Referenced files are always Read Only,
while files you create yourself are always Writable.

Rename Prefix

Displays a prefix that can be applied to object names in the event of name
clashes or namespaces.

Importing a referenced scene
You can import a scene that used to be referenced. This breaks the reference
connection.
To import a referenced file:
1

Select File > Reference Editor.

2

Click the arrow next to the scene name and select the referenced file to be
imported.

3

Select File > Import Reference.

Exporting a selection as a reference
This lets you export parts of the scene you are working on as a referenced
file. Exporting a referenced file is similar to File > Export Selection.
However, when exporting selections as a referenced file, the selections in the
Maya window exist only as referenced objects. If you make changes to the
new referenced file, the objects in the existing scene change. For more
information on exporting selections, see “Exporting files” on page 201.
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To export a referenced file:
1

Select objects in the scene file.

2

Select File > Reference Editor.

3

Select File > Export Selection as Reference.

4

Type the name of the referenced file, choose a file type from the Write As
pull-down menu, then click Export Reference.

Removing a reference from a scene
You can remove a referenced file from a scene if you do not need it anymore.
When you delete the referenced file, referenced objects disappear and all
connections are broken permanently. If you want to remove a reference and
keep the connections intact, see “Loading and unloading reference files” on
page 195.
To remove a referenced file:
1

Select File > Reference Editor.

2

Select a referenced file.

3

Select Edit > Remove Reference. Maya displays a message warning you that
this action cannot be undone.

4

Click Remove to remove the referenced file.

Selecting the contents of a referenced scene
You can select objects in your scene that come from a referenced file. This
lets you identify which objects exist in a referenced file without having to
open the source file.
To select objects from a referenced file:
1

Select File > Reference Editor.

2

Select a referenced file.

3

Select Edit > Select Reference Contents. The objects from the referenced file
are selected and displayed in a different color.
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Loading and unloading reference files
In a scene that contains reference files, you can unload a reference file if it is
not needed while you are working on a different part of the scene. This
improves the interactive performance of Maya. You load it back in when you
are ready for that part of the scene.
To unload a reference file:
1

Select File > Reference Editor.

2

In the Reference Editor, expand the scene name to display the reference files.

3

Highlight the reference file you want to unload.

4

Select Reference > Unload Reference.
The reference file no longer appears in the scene.
To load a reference file:

1

Select File > Reference Editor.

2

In the Reference Editor, expand the scene name to display the reference files.

3

Highlight the reference file you want to load.

4

Select Reference > Load Reference.
The reference file appears in the scene.

Replacing reference files
You can replace a reference file with another reference file. This is useful for
substituting high and low resolution geometry.
To replace a reference file:
1

Select File > Reference Editor.

2

In the Reference Editor, expand the scene name to display the reference files.

3

Highlight the reference file you want to replace.

4

Select Reference > Replace Reference.

5

Navigate to the replacement file and click Reference.
The reference file is replaced. All connections are maintained.
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Cleaning up references
When you use reference files, Maya records any changes to the reference file.
If you load, unload, or replace reference files, these changes may or may not
be used. When you clean up references, you remove any recorded changes
that aren’t being used.
For example, if you replace a high-resolution reference file with a lowresolution, Maya records the connections, dynamic attributes, changed
values, and disconnected attributes, which may not apply to the lowresolution version. When you substitute the high-resolution version again,
the connections and values are restored. However, if you don’t substitute the
high-resolution version, or you modify the high-resolution version before
you substitute it, the scene may have dangling connections and unused
values. When you clean up references, you eliminates this.
You should clean up reference when you are done swapping reference files.
To clean up references:
1

Select File > Reference Editor.

2

Select File > Clean Up Reference.

SUPPORTED FILE FORMATS
You can open and import the following file formats:

File
extension

Filename

Description

Program used by

Platform

.ma

Maya ASCII

Native ASCII file
format.

Maya

IRIX & NT

.mb

Maya Binary

Native binary file
format. This is the
default file format.

Maya

IRIX & NT
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File
extension

Filename

Description

Program used by

Platform

.mel

MEL

Maya Embedded
Language, the
scripting language
used by Maya.

Maya

IRIX & NT

.dxf

Drawing
Exchange File

Exchanges
geometric and
drawing
information
between microCAD
systems.

Auto CAD

IRIX & NT

.geo

ExploreGeo

Geometry files. Can
be imported only.
Note that blobs,
shaders, and groups
are not converted

Explore

IRIX only

.obj

object file

ASCII files that
define geometry
and other object
properties.

Advanced
Visualizer

IRIX & NT

.iges

Initial Graphics
Exchange
Specification

Standard for
exchanging
geometric
information.

CAD systems

IRIX & NT

.rib

RIB

RIB input/output of
geometry.

Renderman

IRIX & NT

.wire

aliasWire

Wire files.

PowerAnimator

IRIX only

audio
(various
extensions)

audio files such
as WAVE and
aiff

Audio files for
sampling in mono
or stereo.

Various

IRIX & NT
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File
extension

Filename

Description

Program used by

Platform

image
(various
extensions)

Alias, BMP,
CINEON, EPS,
IFF, GIF, JPEG,
Maya, RGB,
RLA,
SGI&nbsp,
SoftImage, 24or 32-bit Targa,
TIFF, and XPM

Image files for
textures or image
planes.

Various

IRIX & NT

.avi

AVI

Video for Windows
Microsoft

Various

NT only

An ASCII file that
stores the channel
data (such as x
translate, y
translate, and z
translate) from a
PreView scene file.

PreView

.mov

move

Note that this
is the only
movie file type
supported on
NT.
IRIX & NT

SAVING FILES
You use Save and SaveAs to save the current scene, save the current scene
using a new name, or convert a file to from Maya ASCII toe Maya Binary
and vice versa. To convert a file into formats other than Maya ASCII and
Maya Binary, use the Export option (“Exporting files” on page 201).
Before you save, we recommend that you optimize scene size for improved
performance, memory use, and reduced use of disk space (File > Optimize >
Scene Size ❐). For details, see “Optimizing scene size” on page 212.
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To save a scene file:
1

Select File > Save Scene.
If you have not specified a name for the scene, the Save As window appears:

2

Select mayaAscii or mayaBinary from the Write As pull-down menu (IRIX).
or
Select mayaAscii or mayaBinary from the Files of Type pull-down menu
(NT).
This selects the format for your scene.

•

Maya Binary files are usually smaller and load faster than Maya ASCII files.

•

Maya ASCII files have the same information as Maya Binary files, and you
can edit them using a text editor.
Both types of files work with the IRIX operating system and the Windows
NT operating system.

3

Type the name of the new file.
See the Save Scene As option called Default File Extensions – Adds the file
extension .ma to Maya ASCII filenames and .mb to Maya Binary filenames.
on page 200 for information on automatically adding file extensions to your
scene names.

Tip
If you plan to transfer files between IRIX and Windows NT, do not put
spaces in the filenames.
4

Click Save. Maya saves the contents of the file under the specified name.

Note
If your scene includes referenced files, the Save and Save Scene As option
save your current working file. The names of files you’ve imported by
reference do not change.
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To rename a scene file:
1

Select File > Save Scene As. The Save As window opens.

2

Type the name of the new file, then click Save.
Maya saves the contents of the file under the specified name.
To convert a file:

1

Open the scene file.

2

Select File > Save Scene As

3

Select mayaAscii or mayaBinary from Write As pull-down, depending on
how you want to convert the scene.
or
Select mayaAscii or mayaBinary from the Files of Type pull-down menu
(NT).

4

Click Save. Maya saves the scene in the specified format.

Setting save options
For your convenience, you can predefine some of the options that apply
when you use Save Scene and Save Scene As. You can override these
predefined options when you save the scene.
To set Save Scene As options:
1

Select File > Save Scene As ❐.

2

You can set the following options in the Save Scene As Options window:
File Type – Sets the File Type to mayaBinary or mayaAscii. The default is
mayaBinary.
Default File Extensions – Adds the file extension .ma to Maya ASCII
filenames and .mb to Maya Binary filenames.
Use Verbose Names – Displays the full names of node attributes. For more

information about using full names see, “Setting Open options” on page 181.
3

Click Save Scene As to save the scene or click Save to save the settings only.
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Tips for reducing file size
When you save a new scene file, Maya saves the user interface information
in the scene by default. The user interface file includes information about the
interface like the current visible window positions.
To decrease the size of files you create, you can turn the default setting off so
these user interface files are not created.
To turn user interface file creation off:
1

Select the Panels tab from the Window > UI Preferences window.

2

Set the Save File option in the Scene Configurations section to Never Save, as
shown in the following figure:

3

Click Save to close the UI Preferences window and preserve your changes.

EXPORTING FILES
You export files when you want to copy all of a scene’s contents (including
referenced files) into a single file. Export also lets you convert a file into
formats other than Maya ASCII and Maya Binary.
Export copies all of a scene’s contents into another file, regardless of how the
scene is divided into segments and references. In essence, Export collapses
the entire scene into one file. This is essential when you want to save the
scene’s contents to another file type, such as an IGES file, which doesn’t
support Maya references.
You can export scenes in several file formats depending on which export
plug-ins you have installed. For more information on export plug-ins, see
“Using plug-ins for exporting” on page 205.
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Note
If you export selected objects to an existing scene, it will overwrite the
contents of the target file. If you want to add the contents of a scene to
another scene, you must use File > Import. For more information, see
“Importing files by copying” on page 184.
When you export the contents of a scene, the entire contents of the scene,
including referenced files, are written to a single file.
To export the contents of a scene:
1

Select File > Export All.

2

Specify the name and file type you want to export the information to.
If Maya detects an existing file with the same name, it will ask if you want to
overwrite the existing file.
The options for exporting are the same as those you use to save a file, except
more export file types are available through plug-ins.

Note
New export file formats may be added through plug-ins. For more
information, see “Using plug-ins for exporting” on page 205.

Setting export options
You can set the default file format for exporting by selecting File > Export
All ❐. For Maya ASCII and Maya Binary formats, the Export All options are
the same as the Save Scene As options (see “Setting save options” on page
200). File formats you export to using plug-ins have different options (see
“Using plug-ins for exporting” on page 205.

Exporting scene elements
You may want to export certain elements of a scene (for example,
expressions). You can specify the scene elements that are included in the
export data.
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To export specific elements of a file:
1

Select File > Export Selection ❐. The Export Selection Options window
opens.

2

Set the following export preferences:
File Type – Sets the File Type to mayaBinary or mayaAscii. The default is

mayaBinary.
Default File Extensions – Adds the file extension .ma to Maya ASCII

filenames and .mb to Maya Binary filenames.
Keep Only a Reference – Turn on to keep a reference to the file and move all
of the selected nodes out of the current scene. You must first select the
objects in the scene.
Use Namespaces – When you reference a scene with the Use Namespaces

option turned on, Maya creates a new namespace that contains the
referenced data. Turning on the Use Namespaces option ensures that all
nodes are uniquely named. For more information on Namespaces, see
“Setting import options” on page 185)
Prefix with – Select the file name to use the filename as the namespace. Select
this string and enter a name to be used for the namespace.
Include These Inputs – Turn on to include or off to exclude any of the

following inputs:
History – Includes or excludes construction history of the selected nodes. See

Using Maya: Modeling for more information on construction history.
Channels – Includes or extrudes attribute values. See Using Maya: Animation

for more information on attribute values.
Expressions – Includes or excludes expressions. See Using Maya: Expressions
for more information on expressions.
Constraints – Includes or excludes constraints. See Using Maya: Animation for

more information on constraints.
Including Texture Info – Turn on to export rendering information. The default

is off.
Use Verbose Names – Specifies whether you want to use long flag names for

MEL commands and full attribute names in the ASCII text.
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Exporting move files
When you import move files, you must list the attributes to import or export
in the text list in the move file option box.
The move file format is just list of numbers. No information on how those
numbers should be used is included in the move file. Instead, each row is
assumed to be a frame of data, and each column represents a single channel
of data.
This is the same move file format used by the Wavefront PreView program,
with the addition that comment characters (# or // ) at the beginning of a
line are allowed.
Since time data is not stored with the file, when exporting a move file, the
attribute’s value is written at each frame. The units of the file are your
current units in Maya. When importing a move file, the current time of the
scene is used as the starting point of the import.
For both the import and export functions, all node naming clash and group
options are ignored.
To export a move file:
1

Select File > Export All ❐. The Export Selection Options window opens.

2

Select move from the File Type pull-down menu. The Export Options
window opens.
The following file type specific options apply to importing move files:

Attributes

Type the name of an attribute in the Attributes box and click Add to add the
attribute to the list of attributes to use when importing or exporting. If the
attribute is already included in the list, a duplicate is not made. To remove
an attribute, type the name of the attribute and click Remove. You can add
several attributes at one time by separating them with a space.

From Channel Box

Click From Channel Box to combine all of the selected objects in Maya, in the
order of their selection, with the channels selected in the channel box and
place them in the list. For example, if sphere and cone are selected, and tx, sx
are selected in the channel box, sphere.tx sphere.sx cone.tx and cone.sx are
added to the list of attribute to import and export.

Remove Selected

Click Remove Selected to remove all of the attributes selected in the list.

Remove All

Click Remove All to remove all of the attributes are removed from the list.
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This is ignored in file export. For file import, this sets the precision of the file.

Precision

When you click import or export, the move file is written or read and only
the attributes in the list are affected.

USING PLUG-INS FOR EXPORTING
Maya plug-ins provide translators for exporting to various file formats. For
more information about file conversions and file formats in general, see the
online documentation Maya File Formats and Translators.

Note
Maya plug-ins work only for the system type they were designed for.
Maya NT can use only NT plug-ins; Maya IRIX can use only IRIX plug-ins.
Before you can use a plug-in, you must load it into Maya using a MEL
command or the Plug-in Manager.
To load a plug-in:
1

Select Window > Settings/Preferences > Plug-in Manager.

2

Locate the plug-in and click the loaded button.

3

After the plug-in loads, click the i button to get information on the plug-in.

Exporting to Wavefront (OBJ)
The objExport plug-in lets you export Maya polygon data to the Wavefront
OBJ ASCII file format. It converts:
•

Maya texture coordinate and vertex normal information.

•

Maya renderable set information into material names.

•

Maya component set information into groups.
To export a file in OBJ format:

1
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Select Window > Settings/Preferences > Plug-in Manager to verify that the
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2

Select File > Export All or File > Export Selection.

3

Select OBJExport from the Write As pull-down menu (IRIX).
or
Select OBJExport from the Files of Type pull-down menu (NT).

Note
The objExport plug-in does not export OBJ formatted curves, surfaces,
smoothing groups, or point group materials. It also does not support
NURBS. Use the MayaToIgesDxf plug-in for scenes that contain NURBS
surfaces.
To set OBJ export options:
1

Select File > Export All ❐ or File > Export Selection ❐. The Export Selection
Options window opens.

2

Select OBJexport from the File Type pull-down menu.

3

Click to turn on or off exportation of Groups, Point groups, Materials,
Smoothing, and Normals.

4

Click Export or Export All.
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Exporting to IGES or DXF
The MayaToIgesDxf (NT) and MayaToAlias (IRIX) plug-ins let you export
Maya scene information to an IGES or DXF file, depending on which export
file format you select. For IRIX, it also lets you export to Alias Wire format.
To export a file in IGES or DXF format:
1

Select Window > Settings/Preferences > Plug-in Manager to verify that the
plug-in is loaded.

2

Select File > Export All or File > Export Selection.

3

Select IGESexport or DXFexport from the Write As pull-down menu (IRIX).
or
Select IGESexport or DXFexport from the Files of Type pull-down menu
(NT).

Exporting to Alias Wire
MayaToAlias is a Maya plug-in (IRIX) that exports Maya scene information
to an Alias wire (version 8.1).
To export a file in Alias wire format:
1

Select Window > Settings/Preferences > Plug-in Manager to verify that the
MayaToAlias plug-in is loaded.

2

Select File > Export All or File > Export Selection.

3

Select aliasWireExport from the Write As pull-down menu

Exporting to RenderMan
The ribExport plug-in lets you export scenes created in Maya to the RIB
(RenderMan) format.
The plug-in exports NURBS and polygonal geometry. All types of animation
in Maya are supported, including keys, expressions, path, deformations, and
motion blur.
The ribExport plug-in supports ambient, directional, point, and spot lights. It
does not support plug-in lights
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Simple non-textured shaders are supported, although only the shader color
is exported; all other shading attributes are ignored. Phong and Blinn
shaders are exported as “plastic” and Lambert shaders are exported as
“matte.” Per-face shading groups are not supported; only shading groups
that are assigned to objects or object instances are exported. Plug-in shaders
and textures are not supported.
When exporting Maya scenes into RIB, note that the # character is a special
formatting character in RenderMan image names (See the RenderMan user
manual for information on its formatting capabilities). If you want to include
a real # character in a RenderMan image name, you must use “##”.
The image name constructed by the ribExport plug-in includes the contents
of the “imageName” attribute of the renderable cameras. If you want to
include the special RenderMan formatting characters in an image, the
imageName attribute is the place those characters should be placed in
quotes.

Note
When you create a camera in PowerAnimator, it is automatically given a
name that ends with the “#” character and a number. When the
AliasToMaya translator converts these cameras into Maya cameras, the “#”
is kept in the imageName attribute. If you want to render these scenes with
RenderMan, the cameras will need to be edited, and the “#” characters in
the imageName attributes replaced with “##”.
To export a file to RenderMan format:
1

Select Window > Settings/Preferences > Plug-in Manager to verify that the
ribExport plug-in is loaded.

2

Select File > Export All or File > Export Selection.

3

Select RIBexport from the Write As pull-down menu (IRIX).
or
Select RIBexport from the Files of Type pull-down menu (NT).
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To set RenderMan export options:
1

Select File > Export All ❐ or File > Export Selection ❐. The Export Selection
Options window opens.

2

Select RIBexport from the File Type pull-down menu. The Export Options
window opens.

3

You can set the following options.
Default File Extensions – Specifies whether the .rib extension will be

appended to the specified file name. The .rib extension is not added if the
specified filename already contains that extension.
Single File Output – If on, each frame is written to a single file. If off, all

frames are written to one file.
Extension Padding – If the Single File Output option is turned off, then this

option specifies whether the RIB file extensions will be padded with 0’s.
Geometry Motion Blur – Specifies whether geometry motion blur information

is written to the RIB file.
Pixel Samples – Specifies the number of samples taken for each pixel. This

value will be used for both the X and Y directions.
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Exporting animation curves
You can export animation curves to an anim file. To do this, you must first
select the objects connected to the animation curves. If nothing is selected the
anim export will fail.
Maya copies the anim curve into the API clipboard and pastes it into the
new file.
To export animation curves to an anim file:
1

Select Window > Settings/Preferences > Plug-in Manager to verify that the
animImportExport plug-in is loaded.

2

Select the object whose animation curve you want to export.

3

Select File > Export All or File > Export Selection.

4

Select animExport from the Write As pull-down menu (IRIX).
or
Select animExport from the Files of Type pull-down menu (NT).
To set anim export options:

1

Select File > Export All ❐. The Export Selection Options window opens.

2

Select animExport from the File Type pull-down menu. The Export Options
window opens.
You set the following options in the Export Options window:

Precision

Sets the precision of the numbers stored in the file. The choices are:
Float – Eight digits of precision
Double – Seventeen digits of precision
Custom – A setting between 1 and 18.

File Contents

Use Node and Leaf Attribute Names – When the Use Node an Leaf Attribute
checkbox is selected, The node and leaf attribute names in the clipboard are
written to the file.

When the checkbox is not selected, only the full attribute name is written to
the file.
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Verbose Units – When the Verbose Units checkbox is selected, long unit
names are used in the file, otherwise short unit names are used.
Hierarchy

The Hierarchy setting provides control over which nodes will be copied
within a hierarchy. See Using Maya: Basics for information on hierarchy and
grouping of objects and nodes in Maya
Selected – Only the selected object’s animation copies to the keys clipboard.
Below – Copies the animation of the selected object and all objects below it to

the clipboard
Channels

This setting is available when you want to copy only attributes selected in
the Channel Box.
All Keyable – All keyable channels of the selected object’s animation are
copied to the clipboard
From Channel Box – Only those channels selected in the Channel Box are

copied to the clipboard
Control Points

This option enables or disables the copy action for all the CVs, polygon
vertices, and lattice points associated with a geometry shape (or transform
node hierarchically above the geometry shape).
Normally, when a control point is copied, only the selected control point is
copied. The Control Points option enables the copying for all the control
points associated with an object. This is useful when you are doing control
point-intensive animation and don’t want to select each control point to copy
the animation.

Shapes

This option determines if the animation of a shape attribute of an object as
well as the animation of the associated transform attribute are copied, or if
only the transform node’s animation is copied.
Generally, when an object is selected in a modeling window, the transform
node (above the shape hierarchically) is selected.
For example, if a camera, NURBS object, or light is selected, the associated
transform node is selected for copying.

Time Range

All – Copies all the animation information of the selected object or objects to

the keys clipboard.
Start/End – copies only the animation information in the range specified in

the Start Time and End Time fields of the selected object or objects to the
keys clipboard.

BASIC FEATURES

USING MAYA: ESSENTIALS
211

MANAGING FILES AND PROJECTS | 7
Optimizing scene size

Help Images

When checked, this option displays a diagram of the copy action, and in
particular represents graphically the two methods of copying animation
information.

Method

Keys – Copies only keys within the selected range to the keys clipboard.
Segments – Copies animation curve segments and any keys in the selected

range to the keys clipboard. Use the Segments method when the animation
information to be copied lies.

Note
The Segments method of copying keys will create keys for the copied
animation segment at the start and end times in order to preserve the
shape of the animation curve, if keys do not already exist at those points.
between keys.

OPTIMIZING SCENE SIZE
You can optimize the size of your scene by removing the following.
•

invalid NURBS surfaces and curves

•

empty sets, partitions, and transforms

•

unused animation and NURBS curves, cached data, deformers, expressions,
group ID, rendering, snapshot, and unit conversion nodes, locators, point
constraints, and referenced items
We recommend that you make a habit of optimizing scene size before you
save. Optimizing your scene size before saving can:

•

improve the overall performance of Maya (the improvement can be
significant)

•

improve Maya’s use of memory

•

reduce unnecessary waste of disk space
To optimize scene size:

1

Open the scene.
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2

Select File > Optimize Scene Size ❐. The Optimize Scene Size Options
window opens.

3

Select the items you want removed from the scene.

4

To optimize the scene using these settings, click Optimize.

5

To save the settings, click Save. When you select File > Optimize Scene Size,
the saved settings are used.

MANAGING PROJECTS
A project is a collection of one or more scene files. A project also includes
files related to the scene, such as texture files for rendering or geometry files
for modeling. It specifies the directories for the scene data and the search
paths to use when referencing files.
For example, if you were working on a project called Randy_the_Robot, you
could create a directory called robot to hold all the files related to that project,
including scene, sound, rendering, and animation. Placing all the files in one
directory makes it easier to manage the project, including referencing the
files.
When you start Maya for the first time, it creates a default directory called
“default.” This directory contains default settings for all the subdirectories
under default.

Default projects
directory
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Typically, these subdirectories contain information on all files associated
with a specific project. For example, the sound subdirectory contains all
sound files used by a scene. For more information on setting up projects, see
“Creating projects” on page 215.

Where Maya stores scene information
Maya stores scene information in three locations according to the type of
information:
•

Scene File Locations – Stores scene files.

•

Project File Locations – Stores files such as textures, lights, images, source

images, and rendering scenes.
•

Data Transfer File Locations – Stores files that are in other formats such as
.mel, .dxf, .obj, and plug-ins.

Using absolute and relative paths
You can specify either an absolute or relative path to a particular directory.

What is an absolute path?
An absolute path starts at the root of a file system and works down the
directory tree to the requested file. If you move a scene to a new directory,
any absolute paths you created become unusable. You must correct the paths
before Maya can read the scene again.
Note that Maya also supports UNC paths, if your network supports them.

Tip
Absolute paths must always start with a drive letter (Windows NT) or
slash (IRIX). For example, C:\username\maya\projects\Storm\wind.

What is a relative path?
Relative paths point to a directory by describing its relationship to the
current scene. For example, if you want to access all files in project Storm,
under directory hurricane, then type hurricane\Storm.
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If you change the name of the project directory, then all you have to do is
change the name of the directory. You do not have to change the entire path
to the associated project files.
Example of a relative path
Here is an example of a relative path that goes up two levels to the projects
directory, then down one directory to project hurricane\Storm.
..\..\projects\hurricane\Storm\Wind

Tip
Normally, you should use a relative paths. Special situations require an
absolute path—for example, if you want to place all lights for all projects in
the same directory.

Multiple project directory paths
If you have multiple locations for project files, including directories outside
your project area, you can list them all in the New Project or Edit Project
window. Separate the directories using a colon (IRIX) or semi-colon
(Windows NT). For example, you may have a local sourceimages directory
and one that is shared on the network, as shown in the following illustration.
Multiple
directories
(Windows NT
example)

You can mix relative and absolute paths, as the above example illustrates.
The entry sourceimages is relative to the project directory, while
g:\sharedimages is absolute. Make sure to start absolute paths with either a
slash (IRIX) or drive letter (Windows NT).

Creating projects
You can structure a project file to suit the requirements of a particular
project.
To create a new project:
1
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Select File > Project > New. The New Project window opens.
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~This will
change.
User interface
field is going
away

2

Enter the name of the new project in the Name box.

3

In the Location box., enter or browse to the directory that will contain the
new project.

4

You can click the Use Defaults button to let Maya assign the default names
for the following locations or you can set them explicitly by typing in the
location:
Scenes – Specifies the directory used to save scene files. This directory

normally contains only geometry information, unless you instruct Maya to
put all of the information on the file into this subdirectory. You can also use
this box to enter search criteria for scene information. For more information,
see “Multiple project directory paths” on page 215.
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Project Data Locations – Specifies the directories for files containing project

textures, lights, source images, images, and render scenes.
Data Transfer File Locations – These locations specify the paths to the

directories containing files in formats that may require conversion.

Note
The location directories can be expanded using plug-ins. Each time you
add a plug-in, the New Project window displays the addition. You can
then specify the path to the plug-in’s directory. For more information, see
“Using plug-ins for exporting” on page 205.

Note
If you leave a box blank, Maya does not create a subdirectory. If you create
a scene using an unspecified project setting, Maya saves the information in
the project location directory.
5

Click Accept.

Specifying the current project
Use Set Project to specify the current project.
To specify a current project:
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1

Select File > Project > Set. A file browser appears.

2

Select a project. Maya changes the path to the new project.

3

Click OK.
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Editing the current project
If any file location information has changed, use Edit Current to update the
directories. For example, you may have relocated your sound files to a new
directory and want to make sure that Maya is able to find them.

Note
You cannot change the name or location of the project file.
To edit a project:
1

Select File > Project > Edit Current. The following window opens.

2

Click on a triangle to open a section of directories related to the Scene,
Project, or Data Transfer file locations.

3

Make changes, then click Accept. Maya updates the information on the
project file.

MAPPING MISSING DIRECTORIES
The dirmap command lets you map a missing directory to a different nonmissing directory. This is most useful when you are moving scenes from
IRIX to NT.

Mapping from IRIX to NT
You can use the dirmap command to map your IRIX directory to your NT
directory. For example, if you enter the following commands:
dirmap -enable true;
dirmap -m "/home/linda/maya" "C:/aw/maya/linda"

These commands enable dirmap and add a mapping from /home/linda/maya
to C:/aw/maya/linda. Now, if you try to open the file on an NT:
file -open “/home/linda/maya/projects/default/scenes/
rose.ma";
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Maya is not able to find the directory so it uses the dirmap data and tries
again using:
file -open "C:/aw/maya/linda/projects/default/scenes/
rose.ma";

Mapping from IRIX to IRIX
You can also use the dirmap command to map IRIX directories to other IRIX
directories.
For example, suppose you are running out of disk space and add a new disk,
you can map your old directories to you new ones:
dirmap -enable true
dirmap -m "/home/linda/maya/projects" "/bigdisk/maya/
projects";

Note
This works only if the original directory is missing. If the directory is there
but the file is missing, you will get a normal “file not found” error.
See the dirmap command in the online MEL command documentation for
more information.
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SETTING ENVIRONMENT
VARIABLES
This chapter describes how to set environment variables using the Maya.env
file and lists standard Maya environment variables that you may want to
modify. It includes the following topics:
•

“About environment variables” on page 221

•

“Creating the Maya.env file” on page 222

•

“Modifying standard paths” on page 225

•

“Standard Maya environment variables” on page 226

ABOUT ENVIRONMENT VARIABLES
Environment variables are a useful way to modify the standard path
locations and behavior used by Maya. Typical examples include:
•

Setting MAYA_SCRIPT_PATH to point to a directory where you keep
custom scripts.

•

Setting TEMPDIR to point to an area with more disk space so that you have
enough room for temporary render cache files.

•

Setting MAYA_DISABLE_BACKSPACE_DELETE if you prefer that the
backspace key does not perform deletion.
Many of the variables used by Maya are set automatically when you start
Maya. To configure Maya further, you can set additional environment
variables.
There are two places you can set environment variables: in the Maya.env file
and in the operating system (through the IRIX command line, IRIX .cshrc
file, or NT registry). Using the Maya.env file is the recommended method
and is the subject of this chapter.
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The variables set in the operating system (through the IRIX command line,
IRIX .cshrc file, or NT registry) take priority over the settings in the
Maya.env file. However, when Maya verifies the environment settings, it
may add default settings.

CREATING THE MAYA.ENV FILE
While you can set environment variables in the operating system (such as
the IRIX .cshrc file or NT registry), you should use the Maya.env file in most
cases so you don’t clutter the standard environment settings.
Another advantage of using Maya.env occurs when you are performing
distributed rendering among several Windows NT machines. In this case,
you can set up Maya.env as a roaming profile to be shared by all the
machines. See your networking documentation for details on setting up
roaming profiles.
To create Maya.env:
1

Create Maya.env in a text editor (such as jot or Notepad).
For IRIX, make sure to use capital M for Maya.env.

2

Set each variable on a single line in the following form:
NAME = VALUE

where NAME is the name of the environment variable, and VALUE is its
value. For other formatting rules, see “Rules for Maya.env” on page 223.
3

Save the file to one of the following locations.

IRIX

Windows NT

~/maya/version

drive:\WinNT\Profiles\UserName\maya\version

or

or

~/maya

drive:\WinNT\Profiles\UserName\maya
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Note
These directory locations are the default. Use can use a different directory
if you specify it in the MAYA_APP_DIR environment variable, which must
be set outside of Maya and the Maya.env file. See “Standard Maya
environment variables” on page 226.

Rules for Maya.env
•

You can set any variable, including ones that you define yourself. The only
variables you cannot set in Maya.env are MAYA_APP_DIR and either
HOME (for IRIX) or USERPROFILE (for NT).

•

For directory paths, use backslash (\) for NT and forward slash (/) for IRIX.

•

To separate several paths, use semicolon (;) for NT and colon (:) for IRIX.

•

You can include blank lines or lines that begin with # (comment character).

•

Extra spaces around the NAME and VALUE are ignored.

•

You can use variable substitution by typing either $variable (IRIX) or
%variable% (NT). For example:
MAYA_PLUG_IN_PATH = $MAYA_APP_DIR/scripts/test (IRIX)
MAYA_PLUG_IN_PATH = %MAYA_APP_DIR%\scripts\test (NT)

This example uses $MAYA_APP_DIR, one of Maya’s standard environment
variables. You can also use variables that you define yourself, either in the
Maya.env file or in the operating system.
•

If you define your own variable, make sure it does not contain these
characters: Space Tab / : * " < > |

Note
Although we recommend using different formatting for NT and IRIX (such
as \ and ; for NT but / and : for IRIX), Maya does recognize both
formatting styles no matter what platform you use. It’s still best to keep a
platform-specific format to avoid possible errors.
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IRIX example:
The following example shows how you can define your own variable
(SHARED_MAYA_DIR) and use it to set the value of other Maya variables.
SHARED_MAYA_DIR = HostName:/usr/localhome/public/maya/3.0
MAYA_SCRIPT_PATH = $SHARED_MAYA_DIR/scripts:$MAYA_APP_DIR/scripts/custom
MAYA_PLUG_IN_PATH = $SHARED_MAYA_DIR/plug-ins
TMPDIR = /disk2/tempspace

Windows NT example:
This example is the same as IRIX, but with NT-specific formatting.
MAYA_SCRIPT_PATH = %MAYA_APP_DIR%\scripts\test
MAYA_PLUG_IN_PATH = %MAYA_LOCATION%\devkit\plug-ins;%MAYA_LOCATION%\devkit\test
TMPDIR = D:\tempspace

Where Maya looks for Maya.env
Maya looks for the Maya.env file in MAYA_APP_DIR/version or
MAYA_APP_DIR, which is an environment variable you may optionally set
outside of Maya and the Maya.env file. If you did not explicitly set
MAYA_APP_DIR, the following directories are used:

IRIX

Windows NT

~/maya/version

drive:\WinNT\Profiles\UserName\maya\version

or

or

~/maya

drive:\WinNT\Profiles\UserName\maya
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MODIFYING STANDARD PATHS
When Maya builds all the environment variable settings into its memory, it
makes some verifications and adjustments. For several path environment
variables, Maya adds a string of standard paths to the end of the variable
setting. The standard paths contain items Maya requires to run. The affected
environment variables are:
MAYA_PLUG_IN_PATH
MAYA_MODULE_PATH
MAYA_SCRIPT_PATH
XBMLANGPATH

If you set these variables, the path you give comes before the standard paths.
First priority is given to settings made through the operating system,
followed by Maya.env settings. Standard paths are always last. For a list of
the standard paths, see the specific environment variable in the section
“Standard Maya environment variables” on page 226.

Warning
Because your path settings take priority over standard Maya paths, a
conflict may occur and Maya may fail to load. In this case, try starting
Maya with only default settings by typing the following at the command
line: maya -default.

Other path settings
For the system PATH variable, Maya adds $MAYA_LOCATION/bin. On
IRIX, it also adds /usr/aw/com/bin.
Maya checks whether the directory specified by the HOME variable (IRIX)
or USERPROFILE variable (NT) exists and is writable. If not, Maya issues a
prompt for you to provide a writable home directory. Note that HOME and
USERPROFILE cannot be set in the Maya.env file.
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STANDARD MAYA ENVIRONMENT VARIABLES
This section lists the Maya environment variables you might typically use.
MAYA_APP_DIR

This variable defines your personal Maya application directory. This
directory contains your projects and other important items:
•

the prefs directory

•

the projects directory

•

mayaRenderLog.txt

•

mayaLog

•

mayaJournal

•

the scripts directory

•

(Maya.env, if you choose to create it, can also reside in this directory)
You can only set MAYA_APP_DIR from the operating system; you cannot
use Maya.env. If you do not set it, the default values are: ~username/maya
(IRIX) or drive:\WINNT\Profiles\username (NT).

MAYA_DEBUG_ENABLE_CRASH_REPORTING

When Maya encounters a fatal error, this variable writes a crash report file
(.crash) in the current working directory. This file contains a detailed
description of what Maya was doing when the failure occurred.
To enable this option, set the value equal to 1. To disable it, set the value to 0
(zero) or leave it undefined.
MAYA_DISABLE_BACKSPACE_DELETE

Disables the functionality of the backspace key. To enable this option, set the
value equal to 1. To disable it, set the value to 0 (zero) or leave it undefined.
MAYA_LOCATION

The path for the Maya installation directory. If it is not set, it defaults to /
usr/aw/mayaVersionNumber (IRIX) or drive:\AW\mayaVersionNumber (NT).
MAYA_MODULE_PATH

Defines the search paths for Maya module files. A module file describes the
install location for certain Maya components, such as subdivision surfaces.
Generally, you don’t need to set this variable. But, keep in mind that for each
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path extracted from the modules files, Maya appends the suffixes “plug-ins”,
“scripts” and “icons” and “icons,” and then adds the appended path to
MAYA_PLUG_IN_PATH, MAYA_SCRIPT_PATH, and XBMLANGPATH,
respectively.
The following table lists the default paths, which will always follow any
path that you specify.

Default for Windows NT

Default for IRIX

%MAYA_APP_DIR%\maya\3.0\modules
%MAYA_APP_DIR%\maya\modules
C:\AW\Modules\maya\3.0
C:\AW\Modules\maya

$MAYA_APP_DIR/maya/3.0/modules
$MAYA_APP_DIR/maya/modules
/usr/aw/modules/maya/3.0
/usr/aw/modules/maya

MAYA_NO_JITTER_FINAL_COLOR

If you are quantizing to 8-bit color, we apply some randomness, or jitter, to
the color. Set this variable for no jittering to occur. To enable this option, set
the value equal to 1. To disable it, set the value to 0 (zero) or leave it
undefined.
MAYA_OVERRIDE_UI

If this environment variable is set, Maya won’t load the file
initialLayout.mel, which creates the interface. You must specify an alternate
file to run (for example, MAYA_OVERRIDE_UI = test.mel). This variable
should only be specified if you want to completely replace Maya’s UI for
your own, custom-programmed interface.
MAYA_PLUG_IN_PATH

Search path for plug-ins. When a plug-in is specified by relative path name,
the directories in this path will be searched for the given plug-in name. This
path also determines which directories will be listed in the Plug-in Manager.
The following table lists the default paths, which will always follow any
path that you specify.
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Default for Windows NT

Default for IRIX

%MAYA_APP_DIR%\maya\3.0\plug-ins
%MAYA_APP_DIR%\maya\plug-ins
%MAYA_LOCATION%\bin\plug-ins

$MAYA_APP_DIR/maya/3.0/plug-ins
$MAYA_APP_DIR/maya/plug-ins
/usr/aw/userconfig/maya/3.0/plug-ins
/usr/aw/userconfig/maya/plug-ins
$MAYA_LOCATION/bin/plug-ins

MAYA_PROJECT

Defines the default location of your project. You can change the location at
any time by choosing File > Project. This variable simply defines the default.
MAYA_RENDERER_RT_BACKGROUND_COLOR

If you set this variable to 1, Maya includes the camera background in the
calculation of reflection and refraction rays. If you set this variable to 0 (zero)
or leave it undefined, Maya ignores the background color for these rays.
MAYA_SCRIPT_PATH

Colon-separated search path for Mel scripts. If an unresolved Mel procedure
is called, then this path will be searched for a script that implements it. Also,
if a Mel file is sourced without giving the full path, then this path will be
searched.
The following table lists the default paths, which will always follow any
path that you specify.
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Default for Windows NT

Default for IRIX

%MAYA_APP_DIR%\maya\3.0\scripts
%MAYA_APP_DIR%\maya\scripts
%MAYA_APP_DIR%\maya\3.0\prefs\shelves
%MAYA_LOCATION%\scripts\startup
%MAYA_LOCATION%\scripts\others
%MAYA_LOCATION%\scripts\AETemplates
%MAYA_LOCATION%\scripts\paintEffects
%MAYA_LOCATION%\scripts\cloth
%MAYA_LOCATION%\scripts\live
%MAYA_LOCATION%\scripts\fur

$MAYA_APP_DIR/maya/3.0/scripts
$MAYA_APP_DIR/maya/scripts
/usr/aw/userconfig/maya/3.0/scripts
/usr/aw/userconfig/maya/scripts
$MAYA_APP_DIR/maya/3.0/prefs/
shelves
$MAYA_LOCATION/scripts/startup
$MAYA_LOCATION/scripts/others
$MAYA_LOCATION/scripts/AETemplates
$MAYA_LOCATION/scripts/paintEffects
$MAYA_LOCATION/scripts/cloth
$MAYA_LOCATION/scripts/live
$MAYA_LOCATION/scripts/fur

MAYA_USE_V1_CAMERA

Allows you to revert to the old (Maya 1.0/1.5) camera model behavior.
Starting with Maya 2.0, we have fixed how the camera behaves when lens
squeeze is not 1.0, or when the resolution’s aspect ratio is not the same as the
x-resolution divided by the y-resolution. If you are in the middle of a job
started with Maya 1.0/1.5, you may need the old (incorrect) behavior for
continuity.
To enable this option, set the value equal to 1. To disable it, set the value to 0
(zero) or leave it undefined.
MAYA_USE_VERSION1_DISPLACEMENT

Allows you to revert to the old (Maya 1.0) displacement mapping behavior.
Starting with Maya 1.5/2.0, we significantly improved displacement
mapping. If you are in the middle of a job started using Maya 1.0, you may
need the old behavior for continuity.
To enable this option, set the value equal to 1. To disable it, set the value to 0
(zero) or leave it undefined.
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MAYA_USE_VERSION1_POLY_TANGENT

Allows you to revert to the old (Maya 1.0) polygon tangent calculation
behavior. For Maya 1.5/2.0 we significantly improved the way we calculate
tangents on polygon objects. This primarily affects bump-mapping. If you
are in the middle of a job started using Maya 1.0, you may need the old
behavior for continuity.
To enable this option, set the value equal to 1. To disable it, set the value to 0
(zero) or leave it undefined.
TMPDIR and TEMP

This variable specifies the directory location Maya uses for various
temporary files, such as:
•

temporary render cache files during a render

•

crash files if Maya crashes
On IRIX, set TMPDIR only. On NT, set both TEMP and TMPDIR. If not set,
the temporary directory is /tmp (IRIX) or C:/temp (NT).

XBMLANGPATH

For both IRIX and Windows NT, this variable specifies the location of icon
files, such as icons used for Shelf buttons. On IRIX, the syntax is slightly
different then other paths. For example:
XBMLANGPATH = "./icons/%B:$HOME/dev/icons/%B"

In this example, %B is acts as a placeholder that will be replaced by Maya
with the bitmap filename.
The following table lists the default paths, which will always follow any
path that you specify.
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Default for Windows NT

Default for IRIX

%MAYA_APP_DIR%\maya\3.0\prefs\icons
%MAYA_APP_DIR%\maya\prefs\icons
%MAYA_LOCATION%\icons
%MAYA_LOCATION%\icons\paintEffects
%MAYA_LOCATION%\icons\cloth
%MAYA_LOCATION%\icons\live
%MAYA_LOCATION%\icons\fur

$MAYA_APP_DIR/maya/3.0/prefs/icons/%B
$MAYA_APP_DIR/maya/prefs/icons/%B
/usr/aw/userconfig/maya/3.0/icons/%B
/usr/aw/userconfig/maya/icons/%B
$MAYA_LOCATION/icons/%B
$MAYA_LOCATION/icons/paintEffects/%B
$MAYA_LOCATION/icons/cloth/%B
$MAYA_LOCATION/icons/live/%B
$MAYA_LOCATION/icons/fur/%B

WINEDITOR

Allows you to override the Expression Editor and use your own editor. The
editor must be set to run in the foreground.
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USING MAYA EDITORS
The chapter describes Maya editors, including: several of the General
Editors, the Relationship Editor, the Attribute Editor, the Channel Box, and
the Outliner.
General Editors are tools you can use in a number of diverse workflows. One
of the General Editors, the Attribute Spread Sheet, lets you see and modify
attributes for multiple objects simultaneously. You use it to view and edit
attributes in a columnar layout, and to keyframe them.
The Relationship Editor provides a single place to work with memberships
for sets, deformer sets, character sets, partitions, display layers, shading
groups, and light linking. You can quickly see the relationships, and select
and remove items in those relationships.
The Attribute Editor is used to examine a particular object’s attributes in
more detail, and with a more explanatory interface. Its advantage is that it is
very detailed, and allows you to work on one object at a time. This is
particularly useful for dealing with particles.
The Channel Box is the primary, fastest, and most streamlined tool for
editing object attributes. It lets you quickly set keys, and lock, unlock, or
create expressions on attributes.
The Outliner lists the objects, lights, cameras, and other items in a scene. This
arrangement is called the scene hierarchy.
This chapter contains the following topics:
•

“Using General Editors” on page 236

•

“Using the Component Editor” on page 237

•

“Using the Attribute Spread Sheet” on page 241

•

“Specifying tool settings” on page 248

•

“Specifying performance settings” on page 249

•

“Loading and unloading plug-ins” on page 251
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•

“Using the Relationship Editor” on page 255

•

“Using the Attribute Editor” on page 262

•

“Using the Color Chooser” on page 276

•

“Using the Channel Box” on page 280

•

“Using the Outliner” on page 297

•

“Limiting the information shown in editors” on page 311
Maya includes several other editors not described in this chapter. For details,
refer to the following:

•

Reference Editor, see “Using the Reference Editor” on page 192

•

Hypergraph, see “Using the Hypergraph” on page 319

•

Layer Editor, see “Using display layers” on page 139

•

Rendering Editors, see Using Maya: Rendering.

•

Animation Editors, see Using Maya: Animation.

•

Render Globals, see Using Maya: Rendering

•

Hypershade, see Using Maya: Rendering

•

Visor, see Using Maya: Rendering

•

Expression Editor, see Using Maya: Expressions

USING GENERAL EDITORS
General editors are grouped together because they are useful across all
functional areas of Maya (Animation, Modeling, Dynamics, Rendering).
To select a general editor:
Select Window > General Editors and click the appropriate menu item:
Component Editor

Lets you edit data assigned to components. For example, you can use the
Component Editor to modify the weights assigned to individual CVs by
cluster deformers. See “Using the Component Editor” on page 237.

Attribute Spread Sheet

Lets you view and edit attributes for multiple objects at the same time. See
“Using the Attribute Spread Sheet” on page 241.
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Connection Editor

Lets you explicitly connect any two attributes. For example, you could use
the Connection Editor to connect a shader attribute to a texture attribute. See
the book Using Maya: Rendering.

Channel Control

Displays all of a node’s attributes and lets you make them keyable or not
keyable, editable or not editable (locked or unlocked). Since the Channel Box
lists only keyable attributes, you often use Channel Control to add attributes
to the items displayed in the Channel Box. For information on using Channel
Control, see Using Maya: Animation. For information on the Channel Box, see
“Using the Channel Box” on page 280.

Script Editor

Lets you edit a script. See Using Maya: MEL.

Command Shell

Lets you enter MEL commands directly through a command window. See
Using Maya: MEL.

Using the Component Editor
Use the Component Editor to edit data assigned to components. For
example, you can use the Component Editor to modify the weights assigned
to individual CVs by cluster deformers.

You can use the Component Editor to edit the component data of particles,
springs, NURBS CVs, polygonal vertices, and lattice points. For example,
you can edit the following component data with the Component Editor:
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•

the stiffness of individual springs

•

the colors of individual particles

•

polygonal vertex normals and colors
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•

the weights of CVs, vertices, or lattice points influenced by cluster deformers

•

the weights assigned to CVs, vertices, or lattice points after smooth or rigid
skinning

Editing component data
With the Component Editor, you can find out what data is currently
assigned to particular components, and then change that data.
To query component data:
1

Select the components whose data you want to edit.

2

Select Windows > General Editors > Component Editor. The Component
Editor opens.
The Component Editor displays the component data for currently selected
components in the workspace.
By default, the Component Editor updates dynamically as you select
components in the workspace. Also, as you select components in the
Component Editor, the workspace updates dynamically.
Click on tabs to
select component
types or influences
Objects influencing
component data
listed by column

Components
listed by rows

3

Component data is displayed for
editing in a spreadsheet fashion

Click the Springs, Particles, Polygons, AdvPolygons, Weighted Deformers,
SkinClusters, and JointClusters tabs to view component data.

Springs

Lists component data for springs, including stiffness and damping data.

Particles

Lists component data for particles, including color or velocity data.
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Polygons

Lists component data of polygonal vertices, including color or normal data
in world space coordinates. If color or normal data are not shared at the
vertex level, the column displays the word UnShared. These unshared
values can be viewed and edited from the AdvPolygons tab.

AdvPolygons

Lists vertex face component data, including color and normal values for the
vertex face.

Weighted Deformers Lists component data of CVs, vertices, or lattice points influenced by cluster

deformers (cluster weights).
SkinClusters

Lists component data of CVs, vertices, or lattice points bound to a skeleton’s
joints by smooth skinning (skin cluster weights).

JointClusters

Lists component data of CVs, vertices, or lattice points bound to a skeleton’s
joints by rigid skinning (joint cluster weights).
Note that if the components are organized into sets, the sets are also listed.
To modify component data:
1

In the Component Editor’s spreadsheet, click the component data box you
want to edit. Only the component whose box you selected is now selected in
the workspace.

2

Enter a new value or use the slider bar.
To modify several boxes at once:

1

In the workspace, select the components whose data you want to edit.

2

In the Component Editor’s spreadsheet, drag through the component data
boxes you want to edit.

3

Enter the value you want all the boxes to have.
To modify an entire row or column (IRIX only):

1

In the workspace, select the components whose data you want to edit.

2

In the Component Editor’s spreadsheet, click one of the boxes in the row or
column.

3

Click the row or column heading.
Now all the boxes for the row or column are selected.

4
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Enter a value for all the boxes in the row or column.
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To modify an entire row or column (NT only):
1

In the workspace, select the points whose weights you want to edit.

2

To change all the entries of a row or column, in the Component Editor’s
spreadsheet, select the row or column heading.

3

Shift select any of the boxes in that row or column.

4

Enter a new value to update the entire row or column.

Adjusting editor updating
By default, the Component Editor updates its display automatically to list
whatever components you’ve just selected in the workspace. This automatic
updating enables the rapid selection and editing of component data.
If you prefer, you can turn automatic updating off so that the Component
Editor lists components you selected in the workspace only when you tell it
to do so. In contrast to automatic updating, this approach is called manual
loading.
To use automatic updating:
In the Component Editor, select List > Auto Update, turning Auto Update
on. (This is the default.)

Note
The display does not automatically update if you undo, redo, or modify
components in the workspace. For these types of changes, you must
manually load components to refresh to Component Editor display.
To use manual loading:
1

In the Component Editor, select List > Auto Update, turning Auto Update
off.

2

In the workspace, select the components whose data you want to edit.

3

To list the components in the Component Editor, select List > Load Selected
Components. Alternatively, click the Load Components button located
below the spreadsheet.
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Using the Attribute Spread Sheet
Attributes (also known as channels) are qualities or characteristics that affect
the visual representation of objects (for example. position or color) or
behavior of objects (for example, the damping of a joint or magnitude of a
force). You can use the Attribute Spread Sheet to set various attributes for
more than one object in a pane or for a particular node of an object. You can
also use this tool to assign various attributes from the Attribute Editor to
multiple objects or nodes.
Use the Attribute Spread Sheet to see and edit attributes for multiple objects
simultaneously. It doesn't show whether attributes are connected or locked,
and it does not show multi-attributes at all.
To examine the attributes of a node in more detail, and with a more
explanatory interface, you can use the Attribute Editor. However, the
Attribute Editor can be slower than the Attribute Spread Sheet, because you
can only work on one object at a time. (The Channel Box works on all
selected objects.)

Displaying the Attribute Spread Sheet
Use the Attribute Spread Sheet to change the attributes for an object.
To display the Attribute Spreadsheet:
1

Select the node you want to change the attributes for.

2

Select Windows > General Editors > Attribute Spread Sheet. Maya displays
the node’s name in the Attribute Spread Sheet.

Notes
When the Attribute Spread Sheet first opens, the Keyable tab is selected.
This tab displays all the keyable attributes of the selected objects. Most
other tabs display useful subsets of these attributes. The All tab displays all
attributes, keyable or not.
Many attributes useful in editing an object are not stored in its main node,
but rather in the shape node associated with it. Some of the tabs in the
Attribute Spread Sheet (such as Shape Keyable, Tessellation, and so on)
show you attributes in the associated shape.
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Selected node

Name of the selected node

Tips
If you have any problems selecting a node, select Windows > Hypergraph.
For more information, see “Using the Hypergraph” on page 319.
To select all of an object’s nodes at once, drag a box around the object.
To display shorter attribute names:
When you display the Attribute Spread Sheet, Maya shows the full attribute
names. You can make the column smaller by showing the short names
instead.
To show the short attribute name, select Names > Short Attribute Names in
the Attribute Spread Sheet.
To show the long attribute name, select Names > Long Attribute Names.
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Entering values for attributes
With a single entry from your keyboard, you can change the value of:
•

a single attribute of one or more objects

•

two or more attributes of the same object

•

two or more attributes of multiple objects
You can set any of these combinations with one text entry.
For example, you can enter the value 5 in one text box to change the three
attributes for scaling along the X, Y, and Z axis for more than one object.
You can also change the values of several attributes by a relative amount.
For example, you can add 3 to the Scale X, Scale Y, and Scale Z attributes.
Entering an exact value for object attributes
You can give one or more attributes an exact value as follows:
To change the value of a single attribute:

1

Select the object(s). The Attribute Spreadsheet displays the attributes of the
object(s).

2

In the Attribute Spreadsheet, click the attribute’s text box.
For example, click the Scale X text box.

3

Type the new entry and press Enter or the tab key.
For example, type 5 and press Enter. For a Scale X entry, this sets the X axis
scaling of all selected objects to 5 grid units.
To change the value of two or more attributes:

1

Select the object(s). The Attribute Spreadsheet displays the attributes of the
object(s).

2

In the Attribute Spreadsheet, select the desired attribute text boxes.
For example, you can click the Translate X text box and drag through to the
Translate Y text box for an object, then drag down to select the Translate X
and Y boxes for other objects.
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The first box you click is where you enter the value. The other selected text
boxes turn black. This lets you know they’re selected in addition to the box
where you’ll type the new number.

Drag through adjacent boxes

Tip
You can select multiple text boxes:

3

•

To select several adjacent boxes, drag through them.

•

To add a non-adjacent box to a selection, Ctrl-click the
additional box.

•

To select a range of boxes, click the first box and Shiftclick the last box.

•

To select an entire row of boxes, click the node name.

•

To select an entire column of boxes, click the column
name.

Type the new entry and press Enter or the tab key.
For example, type 5 and press Enter. If Translate X and Translate Y are
selected when you enter 5, all selected Translate X and Translate Y attributes
become 5.
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Entering a relative value for attributes
You can change the values of several attributes by a relative amount. For
example, you can add 3 to the Scale X, Scale Y, and Scale Z attributes. To do
this, you must enter these arithmetic operators in the text boxes:

Arithmetic
operator

Operation

Example entry

+=

Adds the entry to the existing value in
each selected box

+= 3.5

-=

Subtracts the entry to the existing
value in each selected box

-= 3.333

*=

Multiplies the entry to the existing
value in each selected box

*= 7

/=

Divides the entry to the existing value
in each selected box

/= 3

For example, suppose you’ve selected an object named Ball. Its Scale X and
Scale Y attributes are set to 3 and 5 in the Attribute Spreadsheet.
If you select the Scale X and Scale Y text boxes, typing += 2 in the text box
adds 2 to each value. So Scale X would become 5 and Scale Y would
become 7.
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Managing the layout of information
There are three ways to manage information in the Attribute Spread Sheet:
•

Select Layouts > Show Selected Columns Only to display selected columns
of information. This reduces the amount of information on your display.

•

Use Layouts > Remember this Layout to save a selected layout and recall it
later.

•

Use Layouts > Delete Current Layout to delete a layout.
To show selected columns:

1

From the Attribute Spread Sheet, select the tab that has the attributes that
you want to display. Each attribute occupies a column.

2

Click on the title of one of the columns you want to show. Ctrl-click to select
additional columns, until you have selected all the attributes you are
interested in.

3

Select Layouts > Show Selected Columns Only. All the other columns are
hidden, leaving only the ones you have selected. This layout persists until
you select another tab, or close the Attribute Spread Sheet. To make the new
layout permanent, follow the next set of steps.
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To remember a layout:
1

Select Layouts > Remember This Layout. The following window appears.

Enter name of new layout here

2

Type the name of the new layout, then click Remember. Maya adds the
layout name to the existing tabs. You can now recall the layout by clicking
on the tab.
To delete a layout:
To delete a layout, select Layouts > Delete Current Layout. Maya removes
the tab from the window.

Note
You can remove Maya’s pre-defined tabs, but they will return the next time
you open the window.

Setting attribute keys in the Attribute Spread Sheet
Keys are markers that represents the value of an attribute of an object at a
particular time. When the value of an attribute is different at one key from
another, that attribute’s value will change over time as Maya calculates the
value of the attribute in the time between the keys, and that attribute is
animated. The act of placing a key is called “setting a key” for that attribute
at that time. For details, see Using Maya: Animation.
To set attribute keys in the Attribute Spread Sheet:
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1

Select the cells you want to set keys for.

2

Select Key > Key Selected.
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Specifying tool settings
Tool settings determine how a tool behaves. For example, if you are using
the EP Curve Tool, you can specify whether the knot spacing is uniform or
chord length.
To change a tool’s settings:
1

Do one of the following to open the Tool Settings window:
If the tool is represented by an icon on the Minibar, double-click on it with
the left mouse button.
or
If the tool is in a menu, select the check box (❐) located beside the tool.
or
Select the tool and then select Window > General Editors > Tool Settings.

2

Make the desired changes and click Close.
To return to a tool’s default settings:
In the Tool Settings window, click Reset Tool.

Duplicating a tool
Using shelves, you can have two tools with the same name but different tool
settings. For example, you can have two versions of the Particle Tool.

Tips
You cannot change the name of the tool using the Tool Settings window. If
you want to change the name of the tool, see “Changing icon labels” on
page 504.
To remove an icon from a shelf, drag it to the garbage can.
To duplicate a tool:
1

Select the shelf that will contain the new version of the tool.

2

Select the tool that you want to duplicate.
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3

Using the middle mouse button, drag the tool icon from the Minibar to the
shelf.

4

Select the new version of the tool on the shelf and open the Tool Settings
window (Window > General Editors > Tool Settings).

5

Change the tool settings.
To test whether Maya saved the settings for each tool, select the original tool
and check the settings in the Tool Settings window. Leave the Tool Settings
window open and select the new tool on the shelf and check the settings.

6

Click Close.

Note
When you drag a tool from the Minibar to the Shelf, a copy of the tool is
made. If you use Ctrl-Shift to place a menu item that selects a tool on the
shelf, Maya does not place a copy of a tool on the Shelf. Instead, only the
action that invokes the original tool is placed on the Shelf. For more
information on adding tools and actions to a shelf, see “Creating and
editing shelves” on page 493.

Specifying performance settings
You use the Performance Settings window to set when you want to refresh
the screen when manipulating objects and to control complex operations,
such as stitching and deformation. You can use the performance settings to
suspend these complex operations during mouse interaction or to
completely disable them. This improves performance by reducing the
amount of evaluation necessary during interaction and playback.
To specify performance settings:
Select Window > Settings/Preferences > Performance Settings. The
Performance Settings window opens.
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Selecting screen refresh options
To set when to refresh (or redraw the screen) when manipulating objects, in
the Dependency Graph Evaluation section, select one of the following:
Drag

Refreshes the display during the drag.

Demand

Refreshes the display only when you release the mouse button and click the
Update button that appears in the bottom right of the display window.

Release

Refreshes the display only when you release the mouse button.
Controlling complex operations on surfaces
To control complex operations on surfaces during mouse interaction, in the
Surfaces section, select one of the following beside the surface:
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On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.
Controlling complex operations on deformers
To control complex operations on deformers during mouse interaction, in
the Deformers section, select one of the following beside the surface:

On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.

Per Node

For Cluster Resolution and Lattice Resolution only, improves redraw
performance for individual cluster or lattice deformations by setting the Use
Partial Resolution attribute to partial and setting the Percent Resolution on a
per node basis. For details, see Using Maya: Character Setup.

Global

For Cluster Resolution and Lattice Resolution only, improves the redraw
performance of all cluster or lattice deformations. (You do not need to set the
Percent Resolution for each cluster or lattice.)
Set Global Cluster Resolution and Global Lattice Resolution to Full, High,
Medium, or Low. A Low setting corresponds to a low percentage, and
therefore more improved performance.
For more information on surfaces, see Using Maya: NURBS Modeling and
Using Maya: Polygonal Modeling. For more information on deformers, see
Using Maya: Character Setup.

Loading and unloading plug-ins
A plug-in is an add-on module that extends Maya’s capabilities. File
translators are plug-ins you use to import and export various file formats.
You can create or purchase specialty plug-ins to customize Maya for a
specific job.
Some features that can be added through plug-ins are:

EDITORS

•

file translators

•

tools

•

objects (nodes)
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•

MEL commands

•

device drivers
The Plug-in Manager identifies which plug-ins are loaded into Maya. If you
have a plug-in that you use frequently, you can make sure it is always there.
The Plug-in Manager automatically scans all the directories in the plug-in
path and lists available plug-in features.

Loading plug-ins
You can manually load plug-ins each time you run Maya, or you can have
them load automatically when you start Maya.
To load a plug-in:
Select Window > Settings/Preferences > Plug-in Manager. The Plug-In
Manager window opens.

Click here to load
the plug-in

Click here to enable
the auto load feature

Selecting loading options
Toggle the appropriate option beside the plug-in.
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loaded

Toggle on loaded to load the plug-in for the current Maya session.

auto load

Toggle on auto load to load the plug-in so that the next time you start Maya
the plug-in loads automatically.

Displaying plug-in information
To view information about a particular plug-in, you must first load it, then
click the i button beside the plug-in.

Click here to display
information on the plug-in

Maya displays the following information for a selected plug-in:
Name

The name of the plug-in. On IRIX, plug-ins have the extension .so. On NT,
they have the extension .mll.

Path

The location of the file. On IRIX, the default plug-in location is /usr/aw/
maya3.0/bin/plug-ins. On NT, the default plug-in location is
drive:\aw\maya3.0\bin\plug-ins.
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Vendor

The manufacturer of the plug-in.

Plug-in Version

The version number of the plug-in.

For API Version

The version of the Maya API (Application Programmer Interface) the plug-in
was compiled for.

Note
You cannot load a plug-in for any version of Maya that predates the
version it was compiled for.
Auto Load

Indicates whether the plug-in has been marked for auto load.

Is Loaded

Indicates whether the plug-in is loaded.

Plug-in Features

Displays a list of the features added by the plug-in (for example, commands,
dependency nodes, file translators).
To display additional plug-ins, click the triangle to open the Other
Registered Plug-ins section.

Unloading a plug-in
You can unload a plug-in when you finish with it. To unload a plug-in,
toggle off the loaded box next to it.
If you are developing a plug-in, unload it so the source code can be changed,
the plug-in recompiled, and then reloaded.
Removing references to the plug-in
Before you can unload a plug-in, you must first remove all references to it
from the Maya scene. Otherwise, Maya converts the plug-in nodes to
unknown nodes. For example, if you load a shader plug-in and then unload
that same shader plug-in without first removing the special shader node and
all of its references in the scene, Maya will display an error message the next
time you open that scene.
If you try to unload a plug-in while it is in use, a warning message will
display. You can then cancel the unload or force it.
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If you force the unload of a plug-in while it is in use, you cannot reload that
plug-in’s node. Maya converts the existing nodes to unknown nodes. When
you reload plug-ins, you cannot change the type of these existing unknown
nodes.

USING THE RELATIONSHIP EDITOR
Use the Relationship Editor to edit relationships in Maya, where a
relationship is a collection or grouping of objects or components. These
relationships include:
•

sets

•

deformer sets

•

character sets

•

partitions

•

display layers

•

render layers

•

shading groups

•

light linking (light centric and object centric)

Note
The Relationship Editor is separate from the Dynamic Relationships Editor,
which is used to control relationships of particle objects. See Using Maya:
Dynamics for more information.
For all these types of relationships, you can do the following in the
Relationship Editor:
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•

specify view options (see “Setting view options” on page 256)

•

select which relationships and objects display (“Displaying relationships and
objects” on page 257)

•

create and delete relationships (see “Creating relationships” on page 259)

•

select members of a relationship (see “Selecting relationships, relationship
members, and objects” on page 260)
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•

add and remove members of a relationship (see “Adding and removing
relationship members” on page 261)

•

filter which relationships and objects display in the Relationship Editor (see
“Selecting which relationships and objects show” on page 258)
To open the Relationship Editor:

•

From the main Maya window, select Window > Relationship Editors and
select the relationship you want to work with. (You can change this from
within the Relationship Editor.)
or

•

From a panel, select Panels > Panel > Relationship Editor. Note that this
opens the Relationship Editor in a panel rather than a separate window.
The Relationship Editor opens.

Select the type of
relationship you want
to work with

The left side of the editor displays relationships of the type you selected,
while the right side of the editor displays objects in the scene.

Setting view options
You can set view options for sets, partitions, characters, deformer sets, and
shading groups.
You can automatically expand the relationships in the display area so you
can see the members of each relationship without having to click the plus
sign beside them. In the Relationship Editor, select the relationship type,
then select Options > Auto Expand Frames to toggle it on.
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For shading groups, you can also automatically assign a random color to
new shading groups when you create them. In the Relationship Editor, select
Options > Assign Color to New Groups. For details, see Using Maya:
Rendering.

Displaying relationships and objects
Using the List menu, you can control which relationships are loaded in the
left panel of the Relationship Editor, and which objects are loaded in right
panel. By default, all relationships and objects display, but you may want to
limit the display so you can see what you’re working on more clearly.
You can also control what displays in the Relationship Editor using the
Show menu. For details, see “Selecting which relationships and objects
show” on page 258.
To display relationships:
On the left panel, select one of the following options from the List menu.
Auto Load All

Toggle this on to automatically display all relationships of the selected type
in the scene. This is the default.

Manual Load

Toggle this on to display relationships by choosing one of the following
options:
Load from Selection – Display only the relationships associated with the

objects selected in the scene.
Add from Selection – Add to the display the relationships associated with the

objects selected in the scene.
Remove from Selection – Remove from the display the relationships

associated with the objects selected in the scene.
To display objects:
On the right side panel, select one of the following options from the List
menu.
Auto Load All

Toggle this on to automatically display all objects in the scene.

Auto Load Selection Toggle this on to automatically display objects in the relationships associated

with the objects selected in the scene.
Manual Load
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Toggle this on to display objects by choosing one of the following options:
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Load List from Selection – Display only the selected objects.
Add Selection to List – Add to the display the objects selected in the scene.
Remove Selection from List – Remove from the display the objects selected in

the scene.

Selecting which relationships and objects show
You can display a subset of relationships and objects in the Relationship
Editor using the Show menu. What you can display depends on the
relationship you are editing.
For more information, see “Limiting the information shown in editors” on
page 311.
To select which relationships show:
•

In the left panel of the Relationship Editor, select Show > Objects, then select
the types of relationships you want to show. Only the items you select will
display in the left panel.
or

•

Type text in the Text Filter box to limit the display to items with that text.
For details, see “Limiting the display to items containing specific text” on
page 312.
To show all relationships:

•

In the left panel of the Relationship Editor, select Show > Objects, then toggle
off the items you now want to show.
or

•

To show all types of relationships, select Show > Show All.
To select which objects show:

•

In the right panel of the Relationship Editor, select Show > Objects, then
select the types of objects you want to show. Only the items you select will
display in the right panel.
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or
•

Type text in the Text Filter box to limit the display to items with that text.
For details, see “Limiting the display to items containing specific text” on
page 312.
To show all objects:

•

In the right panel of the Relationship Editor, select Show > Objects, then
toggle off the items you now want to show.
or

•

To show all types of objects, select Show > Show All.

Creating relationships
From the Relationship Editor, you can create the following relationships:
•

sets (see “Creating sets” on page 375

•

partitions (see “Creating, displaying, and removing partitions” on page 381)

•

characters (see Using Maya: Character Setup)

•

display layers (see “Using display layers” on page 139)

•

render layers (see “Using render layers” on page 147)

•

shading groups (see Using Maya: Rendering)

•

light sets and object sets (see Using Maya: Rendering)
You cannot create deformer sets.
In general, use the following procedure to create a new relationship.
To create a relationship in the Relationship Editor:

1

Select the objects or items in the workspace, Outliner, or elsewhere.
If you don’t select any objects or items, an empty set will be created. You can
add to it later. See “Adding and removing relationship members” on page
261.

EDITORS

2

Open the Relationship Editor (see “To open the Relationship Editor:” on
page 256).

3

Select the type of relationship you want to create, if it isn’t already selected.
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4

For sets, partitions, and characters:

•

On the left panel of the editor, select Edit > Create Relationship ❒, where
Relationship is the type of relationship you are creating (set, partition,
character). An Options window opens.

•

In the Name box, type a name for the set. For example, if you are creating a
set with polygonal objects, you might call the set polyObjects.

•

Click Apply.

5

For shading groups, light sets, or object sets, select Edit > Create Relationship,
where Relationship is the type of relationship you are creating (shading
group, shading group (force), partition, character, display layer).

6

The new set appears on the left side of the Relationship Editor.
If a relationship or other item in the scene already has the specified name,
the new set name will be appended with a number. For example, entering
top results in top1, because top is the name of a camera that exists in every
scene by default.
To rename a relationship in the Relationship Editor:
Double-click the name of the relationship and type the new name.
To delete a relationship in the Relationship Editor:
In the left panel, click on the relationship you want to delete and select
Edit > Delete Highlighted.

Selecting relationships, relationship members, and objects
You can use the Relationship Editor to quickly select relationships, members
of relationships, and objects in your scene.
When you select a relationship, it becomes active in the channel box, or the
Attribute Editor.
To select a relationship:
1

In the left panel of the Relationship Editor, click the relationship(s) you want
to select. Notice that member of the set are highlighted in the Objects panel.

2

Select Edit > Select Highlighted. The relationship(s) becomes active.
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To select set members:
1

In the left panel of the Relationship Editor, click the relationship(s) with the
members you want to select.

2

Select Edit > Select Set Members, The members of the highlighted set are
selected in the scene.
To select objects in your scene:

1

In the right panel of the Relationship Editor, click the object(s) you want to
select in your scene.

2

Select Edit > Select Highlighted. The highlighted objects are selected in your
scene.

Adding and removing relationship members
Use the Relationship Editor to quickly add and remove objects or items from
a relationship.
To add objects or items to a relationship:
1

In the left panel of the Relationship Editor, click the relationship you want to
add objects or items to.

2

In the right panel of the Relationship Editor, click on the objects or items you
want to add to the relationship.
or
In the scene, select the objects or items you want to add to the relationship
and select Edit > Add Selected Items or click the large plus sign beside the
relationship type at the top left of the Relationship Editor.
To remove objects or items from a relationship:

EDITORS

1

In the left panel of the Relationship Editor, expand the relationship you want
to remove objects or items from by clicking the plus sign (+) beside it, if it is
not already expanded.

2

Still in the left panel, click on the object or item you want to remove from the
expanded relationship and select Edit > Remove Highlighted from Set.
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or
1

In the left panel of the Relationship Editor, click the relationship you want to
remove objects or items from.

2

In the Object panel of the Relationship Editor, click on the highlighted
objects or items you want to remove from the relationship.
or
In the scene, select the objects or items you want to remove from the
relationship and select Edit > Remove Selected Items or click the large minus
sign beside the relationship type at the top left of the Relationship Editor.

USING THE ATTRIBUTE EDITOR
Use the Attribute Editor to view and set the attributes for any object or node.
For example, you can use the Attribute Editor to change the rotation order of
an object (that is, the rotation order under the scale/rotate/translate
attributes.) You can also use the Attribute Editor to toggle many items in the
Display menu on and off. The Attribute Editor provides access to all
attributes for an object or node.
You can also use the Channel Box and the Attribute Spreadsheet to view and
set attributes. The Channel Box provides access to keyable attributes only.
For information on the Channel Box, see “Using the Channel Box” on page
280. The Attribute Spreadsheet provides access to all attributes, and lets you
change attribute values for multiple objects at the same time. For
information on the Attribute Spreadsheet, see “Using the Attribute Spread
Sheet” on page 241.

Displaying the Attribute Editor
The Attribute Editor displays in a separate window or in the main Maya
window, depending on your preference settings (Window > Settings/
Preferences > Preferences, Interface category).
To open the Attribute Editor:
Do one of the following:
•

Select Windows > Attribute Editor.
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•

Press Ctrl-A in the view.

•

Right click on the object or node and select it from the marking menu.

•

Select Display > UI Elements > Attribute Editor.

•

In the Hypergraph, select the object or node, then select Edit > Attributes.

•

Double-click a node in the Hypershade, Visor, Multilister, or Outliner.

To change the default display of the Attribute Editor:

EDITORS

1

Select Window > Settings/Preferences > Preferences, Interface category.

2

Select one of the following options beside Open Attribute Editor:
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In Separate Window

Opens the Attribute Editor in a separate window.
In Main Maya Window

Opens the Attribute Editor in the Main Maya window where the Channel
box normally resides. You can switch between displaying the Attribute
Editor and Channel Box from the Display > UI Elements submenu. (You
cannot display both the Attribute Editor and the Channel Box in the main
Maya window at the same time.)
Common attributes and buttons
Each tab in the Attribute Editor represents an individual node and contains
all the attributes for that node. Click a tab to display and modify the
attributes for that node. For details about specific attributes, refer to the
appropriate Using Maya book.
The following attributes and buttons are common to most Attribute Editor
tabs.
•

the name of the node (for example, nurbsSphere1 or lambert1)

•

Input Connection button
Hold down the left mouse button on the Input Connection button to display
the first input connection node for the currently displayed node. Hold down
the left mouse button on the Input Connection button to display a list of all
input connection nodes. You can then choose a node from this list to display
in the Attribute Editor.

•

Output Connection button
Hold down the left mouse button on the Output Connection button to
display the first output connection node for the currently displayed node.
Hold down the right mouse button on the Output Connection button to
display a list of all output connection nodes. You can then choose a node
from this list to display in the Attribute Editor.

•

Focus button — Click this button to set the Attribute Editor focus to this
node

•

a sample image or icon that represents the node (where appropriate)

•

Select button — Click this button to select the node that is currently
displayed in the Attribute Editor.
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•

Load Attributes button — Click this button to manually load the attributes
of the selected object or node.
Menus
The Attribute Editor has the following menus:

List

Use this menu to load attributes into the Attribute Editor and to define
which items display in the Selected/Object menu. See “Loading object
attributes into the Attribute Editor” on page 266.

Selected/Object

The Selected menu lists objects currently selected in the scene while the
Object menu displays all the objects in the scene of a selected type. See
“Loading attributes from the Selection/Object menu” on page 267.

Copy

Use this menu to display the selected tab as a separate window. See
“Viewing attributes for different objects at the same time” on page 268.

Focus

This menu displays all nodes that have been selected in the scene while the
Attribute Editor is open. The most recently selected node is at the top of the
list. “Loading attributes from the Focus menu” on page 268.

Add

Use this menu to add extra attributes to an object or node. These appear
under the Extra Attributes section. You can also add attributes by selecting
Modify > Add Attribute. See “Adding a custom attribute” on page 269.
Right-click menu options
For some attributes, a pop-up menu appears when you right-click the
attribute name or text box. This pop-up menu has the following options:

output connection node

If you set a key for the attribute or connect a texture to it, the resulting
output connection node name displays as the first menu item. To load the
attributes for this node into the Attribute Editor, select it.
Create New Expression

Select this option to create a new expression for the attribute. For details, see
“Launching the Expression Editor” on page 275.
Set Key
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Select this option to set a key for the attribute. For details, see “Setting keys
for attributes in the Attribute Editor” on page 273. This options disappears
from the menu if you have already connected a texture to the attribute.
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Set Driven Key

Select this option to link the attribute values. For details, see “Linking
attributes” on page 274.

Break Connection

Select this option to break the connection between the attribute and a key or
texture. For details, see “Breaking connections” on page 274.

Create New Texture Select this option to connect a texture to the attribute. For details, see

“Mapping a texture to an attribute value” on page 275.
This option displays for color attributes only. Select it to open the Color
Chooser. For details, see “Using the Color Chooser” on page 276.

Color Chooser

Lock/Unlock Attribute

Select the Lock option to lock an attribute value so that it cannot be changed.
Use Unlock Attribute to unlock the value. For details, see “Locking attribute
values” on page 274.
Ignore/Don’t Ignore when Rendering

This option displays only for attributes that are connected to keys or
textures. Select the Ignore when Rendering option to ignore the connection
when rendering. If the attribute has a map button, the button changes to
indicate that the connection will be ignored.
Indicates that the attribute is connected to a key or texture
Indicates that the connection will be ignored when rendering

Select the Don’t Ignore when Rendering option to render with the set
connection. For details, see Using Maya: Rendering.

Loading object attributes into the Attribute Editor
Loading attributes into the Attribute Editor makes them available to view or
edit. There are three ways to load object attributes into the Attribute Editor:
•

automatically when you select the object

•

manually

•

by selecting the object from the Attribute Editor Selected/Object menu

•

by selecting the object from the Focus menu
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Loading attributes automatically
When you select an object, its attributes are automatically loaded into the
Attribute Editor where you can view and edit them. Each node of the
selected object automatically appears as a tab. This is the default method.
To automatically load attributes for selected objects:
In the Attribute Editor, select List > Auto Load Selected Attributes to toggle
it on.

Note
If you select more than one item, Maya automatically updates the most
recently selected one (that is, the most recent one in the pick list).

Loading attributes manually
If Auto Load Selected Attributes is toggled off, after selecting an object, you
must manually load the object’s attributes into the Attribute Editor to view
and edit them.
To manually load attributes for selected objects:
•

In the Attribute Editor, select List > Load Selected Attributes.
or

•

Click the Load Attributes button at the bottom of the Attribute Editor.

Loading attributes from the Selection/Object menu
By default, the menu that appears beside the List menu is the Selection
menu. It lists all selected objects in the scene so they are readily available for
loading into the Attribute Editor. To list selected objects in the Selection
menu, select List > Selected Items.
Instead of listing selected objects for easy availability in the Attribute Editor,
you can list objects of a specified type. If you choose to do this, the menu
that appears beside the List menu becomes the Object menu. To list all
objects in the scene of a specified type, select the object category from the
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List menu (Dynamics, Kinematics, Deformers, Lights, Shading), then select
the object. For example, to list all joints in the scene under the Object menu,
select List > Kinematics > Joints.
To load attributes for objects in the Selected/Object menu:
In the Attribute Editor, select Selected > objectName, where objectName is the
name of the object you want to load into the Attribute Editor.

Loading attributes from the Focus menu
The Focus menu displays all nodes that have been selected in the scene
while the Attribute Editor is open. You can think of it as a history of the
nodes you’ve viewed in the Attribute Editor. The most recently selected
node is at the top of the list.
Use it to redisplay the attributes for these nodes.
To redisplay node attributes:
In the Attribute Editor menu bar, select Focus, then select the node you want
to load. The attributes for the selected node appear in the Attribute Editor.

Viewing attributes for different objects at the same time
You can simultaneously view attributes for multiple objects by opening
multiple copies of the Attribute Editor.
To view attributes for different objects at the same time:
1

Select the first object and load the attributes into the Attribute Editor. (See
“Loading object attributes into the Attribute Editor” on page 266.)

2

In the Attribute Editor, select Copy > Tear Off Copy to create another
version of the Attribute Editor. It appears as a separate window with the
attributes for the selected object loaded.

3

Select the next object and load the attributes into the original Attribute
Editor. Note that the attributes for the first selected object remain loaded in
the copy of the Attribute Editor.

4

Repeat steps 2 and 3 for each other object you want to view attributes for
simultaneously.
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Adding a custom attribute
Custom attributes are attributes you optionally add and define from the Add
Attribute window. Although custom attributes are dynamically added to an
object, we refer to them as custom to distinguish them from the built-in
dynamic attributes.
Custom attributes have no direct effect on any characteristic of an object in
Maya. You can use them to control a combination of other attributes. You
might also use a custom attribute as a variable—a place to store a value
temporarily to be read by other attributes.
When you add a custom attribute to an object, it appears in the Extra
Attributes section of the Attribute Editor (and in the Channel Box, if you
make the attribute keyable).
For practical examples of when you would add extra attributes, see Using
Maya: Expressions.
For details on deleting a custom attribute, see “Deleting or renaming custom
attributes” on page 271.
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To create a new attribute definition:
1

In the Attribute Editor, select Add > Add Attributes and click the New tab.

2

Set the new attribute options as follows and click the Add button.
To view the new attribute controls, expand the Extra Attributes section in
the Attribute Editor.
Setting new attribute options

Attribute Name

Type the name of the attribute you are adding.

Make Attribute Keyable

Toggle this option on to make this attribute keyable. For information about
keyable attributes, see Using Maya: Animation.
Data Type

Select the data type for the attribute:
Vector – Creates a vector attribute consisting of three floating point values.
Float – Creates a floating point attribute.
Integer – Creates an integer attribute.
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Boolean – Creates an attribute consisting of an on/off toggle.

If you select Vector or Integer, you can also set Min/Max Values.
Attribute Type

Select a type:
Scalar – Creates a per object attribute that you can set to a single value that
applies to every particle in the object. A vector scalar is considered a single
value with three numbers. If you select Scalar, you can specify Minimum,
Maximum, and Default values for a Float or Integer attribute.
Array – Creates a per particle attribute. You can set this type of attribute to

different values for each particle. If you select Array, you can also create a
counterpart initial state attribute by turning on Add Initial State Attribute.
Add Initial State Attribute – Toggle on to create a corresponding initial state

attribute for the added attribute. Without this corresponding attribute, you
can’t save a particle object’s current attribute values for initial state usage.
You must write a creation expression if you decide to initialize the custom
attribute’s value upon rewinding the animation. If you know you’re going to
write a creation expression for a custom attribute, you can set Add Initial
State Attribute to off when you add the attribute. Otherwise, set Add Initial
State Attribute to on whenever you add a custom per particle attribute.
Min/Max Values

For scalar attributes, Minimum and Maximum set the lowest and highest
values you can enter for the attribute in the Attribute Editor or Channel Box.
Default sets the default value for the attribute.

Deleting or renaming custom attributes
You can delete custom (or dynamic) attributes from either the main menu
(Modify > Delete Attributes) or from the Attribute Editor (Attributes >
Delete Attributes). You cannot delete built-in dynamic attributes.
To change the attribute’s label, Rename Attributes from the Modify or
Attributes menu.
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Changing node behavior
You can improve Maya’s performance by changing node behavior settings.
To change node behavior, select the node and expand the Node Behavior
section of the Attribute Editor.

Caching

Toggle Caching on to temporarily store upstream node evaluations in the
cache. When Maya needs these evaluations (as input to the node), it uses the
information stored in the cache rather than re-evaluating the upstream node.
If no changes have been made to the node, it redraws more quickly. The
cache is destroyed when you edit an attribute. Note that caching uses more
memory, which could affect Maya’s performance.

Node State

Changing the node state can improve performance. There are six possible
node states:
Normal – Causes the node to behave normally, according to the defined

settings and effects. This is the default.
HasNoEffect – Disables any effects on the node so that fewer calculations are

necessary at the time of redraw. Note that the effect will not render until you
reset the Node State back to Normal. Maya evaluates the nodes in the node’s
history, but not the node itself.
For example, if you translate a cluster to deform a geometry, then set the
Node State of the cluster node to HasNoEffect, the geometry will appear
undeformed, as though the translation had not occurred. To view the effect,
change the Node State back to Normal.
Blocking – Temporarily hides the node and does not display the results of

any input (upstream evaluations) to the node. This can speed the redraw. It
is also useful when you have complex scenes and want to edit only one
aspect of a node. Blocked nodes do not render.
For example, if you have a complex revolved surface and want to edit the
curve, but don’t want to wait while the curve redraws, select Blocking and
edit the curve. To display the modified revolved surface, reset the Node
State to Normal.
Note that Blocking has no effect on deformers.
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Waiting-Normal – If the dependency graph refresh performance setting

(Window > General Editors > Performance Setting) is set to Demand or
Release, the node will take the Normal state when in the Hypergraph you
select Update or release the mouse button.
Waiting-HasNoEffect – If the dependency graph refresh performance setting
(Window > General Editors > Performance Setting) is set to Demand or
Release, the node will take the HasNoEffect state when in the Hypergraph
you select Update or release the mouse button.
Waiting-Blocking – If the dependency graph refresh performance setting

(Window > General Editors > Performance Setting) is set to Demand or
Release, the node will take the Blocking state when in the Hypergraph you
select Update or release the mouse button.

Setting keys for attributes in the Attribute Editor
You can set a key for an object attribute in the Attribute Editor. For details
about keys, see Using Maya: Animation.
To set a key for one attribute:
1

Select the object.

2

Click the timeline frame number where you want to set the key.
Click the timeline
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3

In the Attribute Editor, select the attribute value.

4

Type the value of the attribute and press Enter.

5

Right-click the attribute name or text box and select Set Key. This sets the
key for the object attribute value.

USING MAYA: ESSENTIALS
273

USING MAYA EDITORS | 9
Using the Attribute Editor

Tip
To set a key for all attributes, use the Channel Box. For details, see “Setting
keys for attributes from the Channel Box” on page 291.

Linking attributes
Maya has a special type of key called a driven key that links one attribute
value to another. When you create a driven key, you specify a driver
attribute value and a driven attribute value. The value of the driven attribute
is locked to a corresponding value of the driver attribute.
You can link attributes from the Attribute Editor by right-clicking the
attribute text box or label and selecting Set Driven Key. For details, see Using
Maya: Animation.

Breaking connections
In the Attribute Editor, the text box for an attribute that is connected to an
expression, key, or other attribute (for example texture attribute) is displayed
in a different color, depending on your color settings.
To break a connection:
1

Select the object.

2

In the Attribute Editor, right-click the attribute name or text box and select
Break Connections.

Locking attribute values
You can lock an attribute value to avoid accidentally changing it later.
To lock an attribute:
1

Select the object.

2

In the Attribute Editor, set the attribute value you want to lock.

3

Right-click the attribute name or text box and select Lock Attribute.
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This locks the value. The Attribute Editor displays locked attributes with a
gray background. (This color may not be visible while the text box is
selected.)
When you’ve locked an attribute, you cannot change its value in the
Attribute Editor, Channel Box, the workspace, or elsewhere.
You must unlock the attribute to change its value.
To unlock an attribute
1

Select the object.

2

In the Attribute Editor, right-click the attribute name or text box and select
Unlock Attribute.

Launching the Expression Editor
You can launch the Expression Editor for the attribute selected in the
Attribute Editor.
To start the Expression Editor:
In the Attribute Editor, right-click the attribute name or text box and select
Create New Expression. The Expression Editor opens.
For details on its use, see Using Maya: Expressions.

Mapping a texture to an attribute value
You can map textures to non-keyed attributes in the Attribute Editor.
To map a texture to an attribute value:
•

In the Attribute Editor, right-click the attribute name or text box and select
Create New Texture.
or

•

Click the map button beside the attribute

.

The button changes to indicate there is a connection.
view the attributes for the connected node.

Click this button to

The Create Render Node window opens. For details, see Using Maya:
Rendering.
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USING THE COLOR CHOOSER
The Color Chooser is a color selection tool that launches when you click a
color attribute in the Attribute Editor. (It also opens when assigning interface
colors in the Colors window; see “Changing color settings” on page 482 for
more information.)
When you select a new color in the Color Chooser, it becomes the current
color, shown in the top left tile of the Color Chooser and also in the color
block of the Colors window or Attribute Editor. You can then close the Color
Chooser.
The Color chooser has several color selection tools. Review the following
illustration and topics for an explanation.

Current color
Color selection tools:

Storage
tiles—to store,
right-click on a
tile or click the
arrow button

Eyedropper
Wheel (drag marker to
select color)

Sliders (RGB or HSV )

Blend box

Palette (including
Adobe palettes)
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Using the color wheel and storage tiles
The fastest way to select a color is to drag the selector in the color wheel.
Once you have the color selected, you can drag the brightness control on the
left.
Another quick way to select a color is to left click on one of the storage tiles
at the top. To store the current color on a tile, right click a tile or click the
arrow button.

Using the eyedropper
The eyedropper tool lets you grab a color from anywhere on the computer
screen, including other applications. The eyedropper operates differently on
Windows NT and IRIX:
•

On NT, click the eyedropper button, hold down the mouse button, and drag
the eyedropper cursor to any position on your screen. Release the mouse to
grab the color.

•

On IRIX, click and release the eye dropper button, then position the
eyedropper cursor anywhere on your screen. Click again to grab the color.
You can also type grabColor in the Command Line to grab the color under
the eyedropper cursor. On NT, this command only works within Mayarelated windows.

Using the sliders
For precise color selection, you can use the color sliders. You can switch
between RGB sliders (Red, Green, Blue) or HSV (Hue, Saturation, Value),
depending on the color model you want.
HSV

In this color model, Hue corresponds to the pure colors of the rainbow, such
as yellow, blue, and green. Saturation is the amount of white mixed with the
hue to set the intensity of the color. Value is the amount of black mixed with
the hue to make it darker. If the Value is 0 (zero), then the color is black,
regardless of the values for Hue and Saturation.

RGB

This color model describes how red, green, and blue light combines at
different intensities to produce different colors. Using RGB, you can choose
which value range you want:
0 to 1 – Each component color has a value from 0 to 1.
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0 to 255 – Each component color has a value from 0 (zero intensity) to 255

(full intensity). This model is useful because it relates directly to how
monitors emit light to create colors. However, it is often hard for people to
figure out what the RGB values are for a specific color.
A (alpha) slider

With the A (alpha) slider, you can control the opacity or transparency of the
color you choose. Many Maya options already have an alpha or
transparency control, but if it does not or you are calling the Color Chooser
from the command line, you can use this slider to control the alpha channel.

Using the Blend box
The Blend box creates a blend between colors so that you can select a new
color from the blended gradient. The following illustration explains how to
use it.

1. To set a blend color,
click a corner. It’s
replaced with the current
color in memory.

2. Click anywhere
in the blend box
to select a
blended color.

Using the Palette
In the Palette section, you can create and save custom color palettes. You can
also open Adobe color palettes (file extension .aco), if it is in one of the
following formats: RGB, HSV, CMYK, Lab, or Inverted Lab. (Other formats,
such as Pantone, are not supported.)
The following illustration highlights the palette components.
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Choose a palette
from the pull-down
Left click a cell to
select a color
...or...
right click a cell to
store a color

Click Blend to
create a color
gradient between a
group of cells you
selected

Open, Save, and
Close palettes

To create a custom palette
1

Select a color using any of the Color Chooser tools, such as the Wheel.

2

Right click on any tile to store the current color there.

3

To create a blended gradient, select several tiles by dragging the mouse, then
click Blend.
A color gradient is created between the first and last tiles in your selection.
For example, as shown below, you may want more color gradations than in
the default palette.
Blended tiles

4

When finished assigning colors, click Save and specify the filename.
You can save the file in any directory. It is saved in ascii format.
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USING THE CHANNEL BOX
Like the Attribute Editor, you use the Channel Box to modify an object’s
attribute values. The Channel Box is different from the Attribute Editor in
that:
•

It displays only the keyable attributes for the selected object. (You can make
an object keyable, and therefore display in the Channel box by selecting
Windows > Channel Control. For information on using Channel Control, see
Using Maya: Animation.)

•

You can change multiple attribute values of multiple objects (see “Entering
values for attributes” on page 285)

•

It takes up much less space in the window.

•

You can control construction history.
The information displayed in the Channel Box varies, depending on what
kind of object or component you have selected. If you haven’t selected an
object, the Channel Box region is blank.

Displaying the Channel Box
The Channel Box appears in the Maya window only if you choose to display
it. It appears to the right of the workspace.

Note
You can display either the Channel Box or the Attribute Editor in the main
Maya window, but not both.
To display the Channel Box:
1

Select the object (or component) that has the attributes you want to modify.

2

If the Channel Box is not already displayed, turn on Display >
UI Elements > Channel Box. The following example shows the attributes of a
selected sphere in the Channel Box.
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Channel Box
Selected object

Object attributes

Object attributes

Displaying object attributes
When you select a geometric object, the Channel Box displays these sections:

EDITORS

Section

Usage

objectName

Lists the keyable transform attributes that translate, scale,
and rotate the object’s absolute position in the world space.
Also shows the object’s visibility attribute.

SHAPES

Lists the names of nodes that define the geometry of the
object. Other nodes, such as related particle emitters may
be found here.

INPUTS

Lists the names of other nodes that affect this one.
Typically, these comprise the “construction history” of the
node.
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Section

Usage

OUTPUTS

Lists the names of the output nodes (nodes that receive
data) for this node.

If you’ve selected two or more objects, the Channel Box displays the
attributes for the last object selected only. To display the attributes in the
Channel Box of another selected object, select Object > objectName.
Note that edits you make in the Channel Box will affect all selected objects
of the same type as the one displayed.

Note
When you set an attribute value using an expression or a Key, the attribute
text box displays in a different color. (The actual color depends on which
color scheme you are using.)

Adding attributes to the Channel Box
The Channel Box includes keyable attributes only. To add an attribute to the
Channel Box, you must make it keyable.
To make an attribute keyable:
1

Select the objects that have the attribute(s) you want to make keyable.

2

Select Window > General Editors > Channel Control and click the Keyable
tab. The Channel Control window opens.

3

In the Non Keyable box, select the attributes you want to make keyable. Ctrlor Shift-click to select more than one attribute.

4

If you selected more than one object, toggle on Change all selected objects of
the same type to enable the editing of attributes common to the selected
objects.

5

Click Move. The selected attributes move to the Keyable box.

6

Click Close. The attributes appear in the Channel Box.
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Displaying component attributes
If you display attributes of an object component, the Channel Box displays
only one section for shape attributes that pertain to the component.
For example, suppose you’ve created a NURBS curve with the following
CVs:

If you turn on component selection mode (in the Main menu bar) and select
the CVs, the Channel Box displays this:

You can display the CV values in the Channel Box and enter new values. To
display the values, click CVs (click to show) in the Channel Box.
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Changing the display format
To make more workspace available while you display the Channel Box, you
can display abbreviations for the attribute names.

Complete names

Abbreviations

To display attribute name abbreviations:
In the Channel Box, select Channels > Channel Names > Short.
There are three choices for names: Long displays the full, correct channel
name, Short displays the abbreviation, and Nice displays the name in the
most readable form.
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Tip
The Channel Box is set to only show two decimal places of precision. You
can increase this precision up to fifteen places by entering the channelBox
command from the Command Line. For example, to increase the precision
to 4, use this command:
channelBox -edit -precision 4 mainChannelBox;

Entering values for attributes
With a single entry from your keyboard, you can change the value of:
•

a single attribute of one or more objects

•

two or more attributes of the same object

•

two or more attributes of multiple objects
Object 1

Object 2

Object 3

Object 4

Scale Y

Scale X
Scale Y
Scale Z

Scale X
Scale Y

Scale X
Scale Y

You can set any of these combinations with one text entry.
For example, you can enter the value 5 in one text box to change the three
attributes for scaling along the X, Y, and Z axis.
You can also change the values of several attributes by a relative amount.
For example, you can add 3 to the Scale X, Scale Y, and Scale Z attributes.

Tip
When you enter a value in the Channel Box, you can press the tab key or
one of the Enter (or Return) keys. If you press the Enter key on the numeric
keypad, the keyboard focus will stay in the Channel Box. If you press the
other Enter key, the keyboard focus will go back to the last selected panel.

Entering an exact value for object attributes
You can give one or more attributes an exact value as follows:
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To change the value of a single attribute of one or more objects:
1

Select the object or objects.
For example, select the object from the Outliner or in the workspace. If you
select two or more objects, the Channel Box displays only the attributes of
the object you selected last.

2

In the Channel Box, click the attribute’s text box.
For example, click the Scale X text box.

Click the text box

3

Type the new entry and press Enter.
For example, type 5 and press Enter. For a Scale X entry, this sets the X axis
scaling of all selected objects to 5 grid units.
To change the value of two or more attributes of the same object:

1

Select the object.

2

In the Channel Box, select the desired attribute text boxes.
For example, you can click the Translate X text box and drag through to the
Translate Z text box.
The first box you click is where you enter the value. The other selected text
boxes turn black. This lets you know they’re selected in addition to the box
where you’ll type the new number.
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Drag through adjacent boxes

Tip
You can select multiple text boxes:

3

•

To select several adjacent boxes, drag through them.

•

To add a non-adjacent box to a selection, Ctrl-click the
additional box.

•

To select a range of boxes, click the first box and Shiftclick the last box.

Type the new entry and press Enter.
For example, type 5 and press Enter. If X translate, Y translate, and Z
translate are selected when you enter 5, all three attributes become 5.
To change the value of two or more attributes of multiple objects:

1

Select the objects.

2

In the Channel Box, select the attribute’s text boxes.

3

Type the entry and press Enter.

Entering a relative value for attributes
You can change the values of several attributes by a relative amount. For
example, you can add 3 to the Scale X, Scale Y, and Scale Z attributes. To do
this, you must enter these arithmetic operators in the text boxes:
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Arithmetic
operator

Operation

Example entry

+=

Adds the entry to the existing value in
each selected box

+= 3.5

-=

Subtracts the entry to the existing
value in each selected box

-= 3.333

*=

Multiplies the entry to the existing
value in each selected box

*= 7

/=

Divides the entry to the existing value
in each selected box

/= 3

For example, suppose you’ve selected an object named Ball. Its Scale X and
Scale Y attributes are set to 3 and 5 in the Channel Box.
If you select the Scale X and Scale Y text boxes, typing += 2 in the text box
adds 2 to each value. So Scale X would become 5 and Scale Y would become
7.

Entering values using manipulators
By default, when you click an object’s translate, rotate, or scale attribute
name (such as Translate X), manipulators appear on the object in the
workspace.
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The manipulators are the same ones displayed with the Move, Rotate, and
Scale tools. You can drag the manipulators directly using the left mouse
button.
If you do not want to display these manipulators, select Channels > Settings,
then select either No Manips or Invisible Manips. If you select No Manips,
you can only perform these operations from the Channel Box by entering
values in the text boxes. If you select Invisible Manips, you perform these
operations using the mouse (see “Entering values with the mouse (channel
slider)” on page 289) or by entering values in the text boxes.
You can also switch between using manipulators, no manipulators, and the
mouse (channel slider) using the buttons at the bottom of the Channel Box.

Standard
Manips

Invisible
Manips

No
Manips

Entering values with the mouse (channel slider)
For most attributes in the Channel Box, you can click the attribute name or
text box then drag the middle mouse button in the workspace to change its
value. Dragging to the right decreases the value, dragging to the left
increases the value. You can also press the Ctrl key while dragging for fine
control.
To use this interactive channel slider, you must set the channel box to use
standard or invisible manipulators (Channels > Settings then select Standard
Manips or Invisible Manips). If you select Channels > Settings > No Manips,
you cannot enter attribute values with the mouse. You must enter the values
for these attributes in the text boxes.
When you select Channels > Settings > Invisible Manips, the cursor changes
to a left and right pointing arrow when you press the middle mouse button,
indicating that you are using the channel slider to change values.
You can set how quickly the channel slider responds when you drag. Select
Channels > Settings, then select Slow, Medium, or Fast or switch these
settings using the buttons at the bottom of the Channel Box.

Slow
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Medium

Fast
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You can also specify whether the attribute values change linearly as you
drag (values increase steadily as you drag), or hyperbolically (values
increase more sharply as you drag). Toggle off Channels > Settings >
Hyperbolic to change the values linearly, and on to change values
hyperbolically, or switch the settings using the buttons at the bottom of the
Channel Box.

Linear

Hyperbolic

Entering values for attributes with a pop-up menu
For some attributes, a pop-up menu appears when you click the mouse in its
text box. You can choose from the selections displayed by dragging the
mouse over the desired choice.
Example
Suppose you add the predefined Node State attribute to a NURBS sphere’s
keyable attributes. (You can do this with Windows > General
Editors > Channel Control.) Node State appears in the list of attributes below
the transform attributes.

If you click in the Node State text box, a pop-up menu appears with six
choices: Normal, HasNoEffect, Blocking, Waiting-Normal, WaitingHasNoEffect, Waiting-Blocking. Drag the mouse over the desired selection.
For information on these states, see “Changing node behavior” on page 272.
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Setting keys for attributes from the Channel Box
You can set a key for one or more object attributes in the Channel Box. For
details about keys, see Using Maya: Animation.
To set a key for one attribute:
1

Select the object.

2

Click the timeline frame number where you want to set the key.
Click the timeline

3

Click the attribute name to select it.
For example, click Translate X.

4

Type the value of the attribute and press Enter.
For example, enter 10 and press Enter.

5

In the Channel Box, choose Channels > Key Selected.
or
Right-click the attribute name or text box and select Key Selected.
This sets the key for the object attribute value you specified.
Setting a key for all attributes

1

Click the timeline frame number where you want to set the key.

2

Enter values for the desired attributes in the Channel Box. Press Enter after
entering the attributes.

3

In the Channel Box, select Channels > Key All.
or
Right-click the attribute name or text box and select Key All.
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This sets the key for all the object attribute values displayed in the
Channel Box.

Note
You can key the same attribute value for two or more objects. Select the
objects, click the frame, enter the value in the text box, then select
Channels > Key Selected.
You can also key multiple attribute values for multiple objects. Follow the
instructions in the previous paragraph, only select several attribute text
boxes using Ctrl- or Shift-click before typing the numerical entry.
To copy keyed attribute values:
1

Select the object.

2

In the Channel Box, select the desired attributes. (You can select either the
attribute name, or the attribute text boxes.)

3

Select Channels > Copy Selected.
or
Right-click the attribute name or text box and select Copy Selected.

4

Select the attributes you want to paste the keyframed values to.

5

Select Channels > Paste Selected.
or
Right-click the attribute name or text box and select Paste Selected.

Setting breakdown keys for attributes from the Channel Box
Breakdowns are a type of key that maintains a proportional relationship
with adjacent keys. You can set a breakdown key for an attribute from the
Channel Box. For information about breakdowns, see Using Maya: Animation.
To set a breakdown for selected attributes:
1

Select the object.

2

Click the timeline frame number where you want to set the breakdown.
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3

Select the attributes you want to set breakdowns for.

4

Enter the values of the attributes.

5

Select Channels > Breakdown Selected.
or
Right-click the attribute name or text box and select Breakdown Selected.
To set breakdowns for all attributes:

1

Select the object.

2

Click the timeline frame number where you want to set the breakdowns.

3

Enter the values of the attributes.

4

In the Channel Box, select Channels > Breakdown All.
or
Right-click the attribute name or text box and select Breakdown All.

Breaking connections from the Channel Box
In the Channel Box, the text box for an attribute that is connected to an
expression, key, or other attribute (for example texture attribute) is displayed
in a different color, depending on your color settings.
To break a connection:
1

Select the object.

2

In the Channel Box, select the connected attribute (click the attribute name or
text box).

3

Select Channels > Break Connections.
or
Right-click the attribute name or text box and select Break Connections.
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Locking attribute values from the Channel Box
You can lock an attribute value to avoid accidentally changing it later.
To lock an attribute:
1

Select the object.

2

In the Channel Box, click the attribute name.

3

If you need to set the attribute value before locking it, type a value and press
Enter.

4

In the Channel Box, select Channels > Lock Selected.
or
Right-click the attribute name or text box and select Lock Selected.
This locks the value. The Channel Box displays locked attributes with a gray
background. (This color may not be visible while the text box is selected.)
When you’ve locked an attribute, you cannot change its value in the Channel
Box, the workspace, or elsewhere.
You must unlock the attribute to change its value.

Tip
You can lock two or more attributes at the same time. Ctrl- or Shift-click
the attribute names to select them, then select Channel > Lock Selected (or
right-click the attribute names and select Lock Selected).
To unlock an attribute
1

Select the object.

2

In the Channel Box, click the attribute name.

3

In the Channel Box, select Channels > Unlock Selected.
or
Right-click the attribute name or text box and select Unlock Selected.
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Launching the Expression Editor from the Channel Box
You can launch the Expression Editor for the attribute selected in the
Channel Box.
To start the Expression Editor:
•

In the Channel Box, select Channels > Expressions.
or

•

Right-click the attribute name or text box and select Expressions.
The Expression Editor appears. See Using Maya: Expressions for details on its
use.

Linking attributes from the Channel Box
Maya has a special type of key called a driven key that links one attribute
value to another. When you create a driven key, you specify a driver
attribute value and a driven attribute value. The value of the driven attribute
is locked to a corresponding value of the driver attribute.
You can link attributes from the Channel Box by selecting the attribute and
then selecting Channels > Set Driven Key (or by right-clicking the attribute
name or text box and selecting Set Driven Key). For details, see Using Maya:
Animation.

Modifying an object’s history (inputs)
Use the INPUTS component of the Channel Box to modify an object’s
construction history. Since all objects in Maya can be created with “History
On,” you can change initial parameters after the fact.
In the following example, we change the object’s radius from 0.5 to 0.8, its
height from 1 to 2, and its X, Y, and Z subdivisions from 20, 1, and 8 to 18, 2,
and 5, respectively.
To modify an object’s history:
1

EDITORS

Select the object you want to modify.
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Click here to
display the boxes

2

Type the new information in the respective boxes and press Enter. Each time
you change part of the object’s history, Maya changes the object.
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3

To return to the original setting for Subdivision Z, select Edit > Undo or
press Ctrl-Z. The object returns to its original scale for Subdivision Z.

4

Repeat for the other boxes.

USING THE OUTLINER
You can use the Outliner to do these tasks:

EDITORS

•

Examine the structure and components of the scene. See “Navigating the
Outliner” on page 300.

•

Display shape nodes, connections, and attributes. See “Displaying shape
nodes” on page 302.

•

Make an object the child of a parent object. A child adopts attribute changes
made to the parent. See “Parenting objects” on page 306.
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•

Select and rename an object. See “Selecting and renaming objects” on page
309.

•

Reorder nodes. Reordering a node’s position in the Outliner affects Maya’s
evaluation order for the object. See “Reordering nodes” on page 309.

Tip
If your scene has many objects or it contains character skeletons, consider
using the Hypergraph instead of the Outliner. The Hypergraph displays
the scene hierarchy in a graphical format that’s more convenient for
complex scenes.
You can open the Outliner in its own window or in a workspace panel. If
you display it in a workspace panel, you see the Maya user interface and the
Outliner at the same time without having to reposition the windows.
To open the Outliner in its own window:
From the menu bar or Hotbox, select Window > Outliner. The Outliner
opens.
Menu bar

Scene
hierarchy

Scale and move the window as needed.
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To open the Outliner in a workspace panel:
From a workspace panel, select Panels > Panel > Outliner.
Outliner panel items
The Outliner’s menu bar selections control what types of objects and other
items are displayed in the scene hierarchy. A scene hierarchy is sometimes
referred to as a DAG (for Directed Acyclic Graph).
The Outliner lists invisible objects, such as the perspective, top, front, and
side cameras, in blue text. In a new, empty scene, the Outliner lists only
these objects and the default light and object sets. As you add objects to the
scene, they appear in the Outliner.

Understanding scene hierarchy terminology
A common technique in modeling, rendering, and animating is to work with
objects in a hierarchical relationship. To work with a hierarchy you must
understand the terminology for describing the relationship of objects.
We use the following figure to define common hierarchy terminology:

Parent

EDITORS

An object or other item that controls attributes of one or more children. A
parent can also be the child of another parent.
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In the figure, InnerSolarSystem is a parent of Sun. Sun is a parent of
Mercury, Venus, Earth, and Mars. Earth is a parent of Moon.
Child

An object whose attributes are controlled by its parent. A child can be the
parent of other children. A child is connected to its parent by an indented
right angle line.
Sun is a child of InnerSolarSystem. Mercury, Venus, Earth, and Mars are
children of Sun. Moon is a child of Earth.

Node

A parent, child, or independent object or item.
InnerSolarSystem, Sun, Moon, persp, top, and all other entries in the
example are nodes.

Hierarchy

The arrangement of all connected nodes that make up a scene or object.
The scene hierarchy is made of all nodes in the figure. The Earth hierarchy
consists of Earth and Moon.

Transform node

A node that contains an object’s transformation attributes—values for its
translation, rotation, and scale. It also holds information on any parent-child
relationships it has with other nodes. Transform nodes are also called DAG
objects.
InnerSolarSystem, Sun, Moon, and all other entries in the example are
transform nodes.

Shape node

A node that holds an object’s geometry attributes or attributes other than the
object’s transform node attributes. A shape node is always a child of a
transform node.
Shape nodes do not appear in the Outliner by default. To display shape
nodes, see “Displaying shape nodes” on page 302.

Navigating the Outliner
As you examine a scene with many objects, you must scroll or expand the
Outliner panel. You’ll also need to expand or collapse the display of nodes.
You expand a node to see the child node below it. You collapse a node to
simplify your view of the hierarchy.
To expand a node:
Click the plus sign ( ) to its left.
The plus sign ( ) changes to a minus sign ( ).
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As a quick way of expanding several collapsed hierarchies, you can select
them, expand one of them, and they all expand.
To collapse a node:
Click minus sign ( ) to its left.
The minus sign ( ) changes to a plus sign ( ). Note that Hierarchies become
highlighted if they are collapsed but contain an item that is selected.
To expand a node’s entire hierarchy:
Shift-click the plus sign ( ) to its left.
The plus sign ( ) changes to a minus sign ( ).
If your scene has many objects in a complex hierarchy, you might need to
expand many nodes to find a child. To find the node quickly, you can select
the object in the workspace and choose a menu entry to expand all nodes
necessary to list the object.
To display a child not currently listed in the Outliner:
1

Select the object in the workspace.

2

In the Outliner, select Display > Selected.

Tip
To select Outliner menus more conveniently from a pop-up menu, click the
right mouse button in the Outliner window.
To split the Outliner window:
You can split the Outliner window in order to see either end of a long list. To
split the window, click the separator at the bottom of the window and drag
it up. Restore full display by dragging the separator back to the bottom. As
visual cue, moving your cursor over the separator bar changes it to:
(IRIX) or
(Windows NT).

EDITORS

USING MAYA: ESSENTIALS
301

USING MAYA EDITORS | 9
Using the Outliner

Drag the separator
bar to split the outliner

Displaying shape nodes
By default, the Outliner displays only DAG objects in the scene. DAG objects
are transform nodes. You can also display shape nodes, the nodes that hold
an object’s geometry attributes or attributes other than the object’s transform
node attributes.
To display shape nodes:
In the Outliner, toggle on Display > Shapes.
Example
Suppose you select Create > NURBS Primitives > Sphere to create a sphere.
Maya creates a transform node and a shape node.
If you toggle on Display > Shapes and expand the nurbsSphere1 node, the
shape node appears underneath.

Maya gives the nodes the default names shown in the figure. The
nurbsSphere1 is the transform node; nurbsSphereShape1 is the shape node.
If you rename the transform node, for example, as Bubble, Maya renames
the shape node BubbleShape.
If you rename the shape node, Maya does not rename the transform node.
Maya doesn’t transmit a child’s attribute changes up to its parent.
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Note
The Display and Show menu settings are saved with a scene file. The menu
settings are not saved when you open a new or different scene.

Displaying attributes
You can display attributes of the nodes shown in the Outliner. To simplify
the Outliner’s appearance, you can also limit the display of attributes to the
following categories:
•

keyable attributes

•

translate, scale, and rotate attributes

•

attributes connected to an animation curve or expression

•

attributes connected to any controlling node
To display all attributes:

1

Select Display > Attributes (Channels) to toggle it on. (Make sure you are not
showing only selected items by selecting Show > Show All.)
A plus symbol ( ) appears to the left of each node.

2

Click ( ) to display the node’s attributes.
The ( ) changes to a minus symbol ( ) when the node’s attributes are
expanded. You can click the minus symbol to collapse the attributes.
Some attributes also appear with ( ) to the left. These are compound
attributes consisting of two or more attributes. Click ( ) for a compound
attribute to see its component attributes. For example, the compound
Translate attribute is made of Translate X, Translate Y, and Translate Z
attributes.
You can’t use the Outliner to change attributes’ values. You can set them in
the Channel Box, Attribute Editor, or Attribute Spreadsheet. Note also that
you use those tools to set the value of noncompound attributes only. You
can set compound attributes (to set the component attributes) only with
MEL commands.
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Tips
To open the Attribute Editor for a node, double-click the icon beside the
node name.
You can double-click a noncompound attribute to start the Expression
Editor with the attribute automatically selected.
To display only keyable attributes:
1

Select Display > Attributes (Channels) to toggle it on.

2

Select Show > Attributes > Keyable to toggle it on.
To display only translate, scale, and rotate attributes:

1

Select Display > Attributes (Channels) to toggle it on.

2

Select Show > Attributes and toggle on one of these:

Rotate

Displays only Rotate attributes.

Scale

Displays only Scale attributes.

Scale Rotate Translate

Displays only Scale, Rotate, and Translate attributes.
Displays only Translate attributes.

Translate

3

Click ( ) to expand the compound Translate, Rotate, or Scale attributes into
the component attributes.
For example, if you expand the compound Translate attribute, the Outliner
displays Translate X, Translate Y, and Translate Z attributes.
To display only attributes connected to a controlling node:

1

Select Display > Attributes (Channels) to toggle it on.

2

Click ( ) to display the node’s attributes.

3

Select Display > Connections to toggle it on.
This displays only the attributes whose value is connected to the following
types of controlling nodes:
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•

keys

•

set driven key

•

constraint

•

motion path

•

expression

•

any other direct connection
Example
Suppose you create a NURBS sphere named Ball and a NURBS cone named
Cone. You write an expression to assign the value of Ball’s translateY
attribute to Cone’s translateY attribute.
If you select Cone, toggle on Display > Attributes (Channels) and
Display > Connections, then expand Cone and the Translate attribute, the
Outliner displays the following:
Only connected attributes
are displayed in the list of
attributes

To display only attributes connected to anim curves or expressions:
Select Show > Attributes and toggle on one of these:
Driven by Anim Curve

Displays only attributes with an animation curve. This includes attributes
animated with keys, set driven keys, constraints, and motion paths.
Driven by Expression

Displays only attributes controlled by expressions.
To display all attributes again:
Select Show > Attributes > Clear Below.

EDITORS
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Displaying specific types of nodes
To simplify the Outliner’s appearance, you can limit node display to various
categories.
To display only specific types of nodes:
1

Toggle on Display > Shapes or Display > Dag Objects Only, as appropriate.

2

Select Show > Objects > and the type of node.
To display all nodes again:
Select Show > Objects > Clear Below.

Parenting objects
You can make an object the child of a parent object. The child adopts some
or all attribute changes made to the parent.
For example, suppose you animate a planet to orbit the center of the
workspace. If you make a moon the child of the planet, it follows the motion
of the planet.
Though the moon is the child of the planet, you can also give the moon
motion that’s independent of the planet. For example, you can make it orbit
the planet. If you later change the orbiting motion of the planet, the moon
continues to follow the planet’s motion, but stills retains its original orbiting
motion.
To control multiple objects with one node, you can also create an empty
group and make several objects its children. By grouping objects under one
node, you can move, shade, apply texture, and do many other actions to all
the objects by working with the group node.
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Example
BackTire

FrontTire

1. Create original objects.

Tires

2. Create empty node and name it Tires.

Tires

3. Group objects under Tires.

BackTire
FrontTire

4. Move, rotate, shade Tires.

To parent an object in the Outliner:
1

Make sure both objects are visible in the Outliner.
If you can’t see both nodes at the same time even after maximizing and
scrolling the Outliner, use Edit > Parent in Maya’s main menu bar. In the
Outliner, Ctrl-click the children first, then Ctrl-click the parent, then select
Edit > Parent.

2

In the Outliner, use the middle mouse button to drag the child node onto the
parent node.
Use the middle mouse
button to drag Moon

Moon is now a child of Planet

To parent several objects to a new group node:
1

EDITORS

From the main menu bar, choose Edit > Create Empty Group. A new group
node appears in the Outliner named null1. This node is an invisible, empty
object.
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2

Use the middle mouse button to drag an object node onto the null1 node.
The object becomes a child of the null1 node.

3

Repeat this step for other objects to be children of the group.

4

Rename the null1 node to something more meaningful.
For example, you might rename a group with four flower petals as flower.
The Outliner displays the objects parented to the group node.

If you modify the group node attributes, its corresponding member’s
attributes are also modified. For example, if you decrease the Y scale
attribute for a flower group node, the Y scale attributes of the four petals
decrease also.
To break the relationship between parent and child:
1

Select the child.

2

From the Maya main menu bar, select Edit > Unparent.

Prefixing hierarchy names
You can give the same prefix to all objects within a hierarchy. For example, if
you select a parent object and give it a prefix, all objects under that parent
will now have the same prefix name.
To assign prefix hierarchy names:
1

Select the parent.

2

From the Maya main menu bar, select Modify > Prefix Hierarchy Names.

3

Enter a prefix name in the Prefix Hierarchy window and click OK.
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Selecting and renaming objects
You can select and rename objects and other nodes in the Outliner. Selecting
an object in the Outliner is useful when the workspace is crowded with
objects.
You can give two nodes the same name, but only if each has a different
parent (as in the following example).

To select an object:
1

Scroll to find the node that represents the object or component.

2

Click the node to select it. The node is highlighted in the scene to indicate it
is selected.
To deselect an object:
Click an empty spot in the Maya workspace. (You can also click below the
last item in the Outliner.)
When you deselect a node, its highlighting turns off.
To rename an object:

1

Double-click the name of the object in the Outliner.

2

Enter the name in the text box.

Reordering nodes
You can reorder the position of nodes in the Outliner, for example, to make
the node’s Outliner position correspond to its spatial position in the
workspace.
Be aware that reordering an object’s position in the Outliner might may
affect its behavior or appearance in your scene. Reordering a node’s position
in the Outliner affects Maya’s evaluation order for the object. Maya evaluates
objects as listed from top to bottom in the Outliner.

EDITORS
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For example, Maya typically renders nodes in the order they appear in the
Outliner. Changing this order changes their rendering order. However, if a
node has transparency, Maya puts the node in a delayed render queue.
Maya renders objects in the queue after all opaque objects.
To reorder a node in the Outliner:
Use the middle mouse button to drag the node to another position.
As you drag, a horizontal line appears in the Outliner that indicates where
the dragged node will be positioned. Release the mouse button at the
desired position.
Example
Suppose you created a scene containing several of the solar system’s planets,
including earth. As you add each planet, the Outliner adds a node
representing the planet.
Maya puts each new node in the Outliner below existing nodes. The location
of the planet nodes in the Outliner might not represent the spatial
relationship of the planets in the workspace as in this example:

Here, earth sits further from mercury than mars. In the actual solar system,
and in your workspace, this is not true.
To make the Outliner reflect the positioning of the earth in the workspace,
use the middle mouse button to drag the earth above mars.
Maya positions earth below venus and above mars.
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LIMITING THE INFORMATION SHOWN IN EDITORS
You can limit which information shows in the Outliner, Hypergraph, Graph
Editor, Dope Sheet, and Relationship Editor. Each of these editors has a Text
Filter box and Show menu (except the Dope Sheet, which has only the Show
menu). With these controls, you can limit the display to the following:
•

items containing specified text (for example, type spot* to show items
beginning with spot)

•

object types (Geometry, NURBS Objects, Polygon Objects, Cameras, Joints,
IKHandles, Sets, Lights, Materials, Textures, Renderable Objects, Shading
Groups, Partitions)

•

attribute types (Hidden, Driven by Anim Curve, Driven by Expression,
Keyable, Rotate, Scale, Translate, Scale Rotate Translate)

Filter on/off icon

Text Filter box

For details, see the next topic, “Limiting the display” on page 312. Also,
using the Show menu, you can also do the following:

EDITORS

•

“Showing all items not currently displayed” on page 314

•

“Storing your restrictions” on page 314

•

“Controlling display of auxiliary nodes” on page 316
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Limiting the display
You can limit the amount of information shown in the Outliner,
Hypergraph, Graph Editor, and Relationship Editor by selecting the object
types and attribute types you want shown. You can show items containing
specified strings. You can also store your selections for later use. When you
limit the display in the editor, the icon beside the Text Filter box changes.
All objects and attributes show
Filtered display (only objects and attributes of selected types or containing
specified text show)

When you have a filter active, you can revert to showing all objects by
clicking the filtered display icon ( ).

Limiting the display to items containing specific text
Use the Text Filter box to limit the display to all objects and attributes with
names containing the text string you type. Type the string in the box and
click Enter. This box is case sensitive. For example, typing nurbs will yield
different results than typing NURBS.
Use the asterisk (*) wildcard to match any number of characters in the string.
For example, to show all items with names starting with nurbs, type nurbs* in
the text filter box and press Enter.
Use the question mark (?) wildcard to match a single character. For example,
to show items bodyFur and bodyfur (remember, the box is case sensitive), type
body?ur and press Enter.

Limiting the display to selected objects
You can limit the display to any combination of the following objects:
Geometry, NURBS Objects, Polygon Objects, Cameras, Joints, IKHandles,
Sets, Lights, Materials, Textures, Renderable Objects, Shading Groups, and
Partitions.
To limit the display to objects of a specified type:
Select Show > Objects, then select the items you want to display (toggle them
on). Only the items you select will display. If you do not want an object type
to show, toggle it off.
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To clear the list so that no restrictions are placed on what displays (in effect,
you are removing the object filter), select Show > Clear Below.

Limiting the display to selected attributes
You can limit the display to any combination of the following attributes:
Hidden, Driven by Anim Curve, Driven by Expression, Keyable, Scale,
Rotate, Translate, and Scale Rotate Translate.
In the Relationship Editor you can limit the display of attributes of a specific
type when character editing only.
In the Outliner, you can limit the display of attributes of a specific type only
if Display > Attributes (Channels) is toggled on.
You cannot limit the attribute display in the Hypergraph.
To limit the display of attributes of a specified type:
Select Show > Attributes, then select the items you want to display (toggle
them on). Only the items you select will show. If you do not want an
attribute type to show, toggle it off.
To clear the list so that all attributes display (in effect, you are removing the
attribute filter), select Show > Clear Below.

Limiting the display of object or attribute types based on
the selected items
Instead of limiting the display using the Objects and Attributes menus, you
can limit the display to all objects or attributes of the same type as the
selected (highlighted) objects or attributes by selecting Show > Show
Selected Type(s). You must first select objects or attributes (in the Outliner or
workspace) to make this command available.

Applying custom display restrictions
If you saved your display restrictions (see “Storing your restrictions” on
page 314), it appears on the Show > Objects menu or Show > Attributes
menu, (depending on the type of items selected). To apply it, simply select it
from the appropriate menu (toggle it on).

EDITORS
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Showing all items not currently displayed
You can quickly toggle the display to show all items that are not currently
displayed. To do this, select Show > Invert Shown to toggle it on.

Showing all items (removing restrictions)
To quickly remove all restrictions so that all objects and attributes show,
click the filtered display icon ( ) or select Show > Show All.

Storing your restrictions
You can store your display restrictions for later use. Restrictions that you
store in one editor are available for use in the other editors.
To store your restrictions:
1

In the Outliner or workspace, select the objects and attributes that are the
type you want to show.

2

Select Show > Show Selected Type(s). The editor shows all objects and
attributes that are the same type as the selected objects.

3

Select Show > Create Entry. The Create Entry window opens.
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If you selected only objects in step #1, only the Objects section appears on
the Create Entry window. Similarly, if you selected only attributes in step #1,
only the Attributes section appears.
4

In the Objects section (if there is one), toggle Entry name on and type a name
for the selection list in the adjacent box. This name will appear on the
Show > Objects menu.

5

In the Attributes section (if there is one), toggle Entry name on and type a
name for the selection list in the adjacent box. This name will appear on the
Show > Attributes menu.

6

Click Save.

Deleting stored restrictions
Deleting a stored restrition removes it from the Show > Objects or
Show > Attributes menu.
To delete a stored restriction:
1

Select Show > Delete Entry. The Delete Entry window opens.

2

To delete Object selection list, click the Objects tab, then click the entries you
want to delete.
To delete Attributes selection list, click the Attributes tab, then click the
entries you want to delete.

3

EDITORS

Click Delete.
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Controlling display of auxiliary nodes
By default, there are several auxiliary nodes, such as unitConversion, that do
not show in the Outliner and other editors. These nodes are hidden to
reduce clutter. If you need them to show or you want to hide additional
nodes, you can use the Show menu selections: Show Auxiliary Nodes and
Auxiliary Nodes.
Your Auxiliary Node settings are saved immediately in your preferences, so
they affect all editors. They are loaded whenever you start Maya.
To show a hidden auxiliary node:
•

To see all auxiliary nodes, choose Show > Show Auxiliary Nodes.
or

•

To selectively show an auxiliary node, choose Show > Auxiliary Nodes to
open the Auxiliary Nodes window. From the list of auxiliary nodes, select
the ones you want to show and click Remove From List To Show.

Auxiliary Nodes
window

To hide a node:
1

Choose Show > Auxiliary Nodes to open the Auxiliary Nodes window.

2

Click the Add To List tab.

3

Either turn on All Node Types or turn on Selected Node Types.
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The Selected Node Types option lets you select the node in the Outliner,
Hypergraph, or other panel.
4

EDITORS

Click Add To List To Hide.
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USING THE HYPERGRAPH
The Hypergraph shows a graphical relationship between components of a
scene. You can display two kinds of graphs in the Hypergraph: the scene
hierarchy or dependency graph.
The scene hierarchy shows the ordered arrangement of objects, lights,
cameras, and other items that make up a scene. It’s similar to the Outliner
but has more features and visual aids for working with the hierarchy of
scene components.
Here’s an example scene hierarchy:

A dependency graph shows the architectural connections between Maya
entities that input and output data. For example, it shows connections
between shading group elements that create an object’s material appearance.
This chapter describes the following topics:
•

“Opening the Hypergraph” on page 320
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•

“Understanding scene hierarchy terminology” on page 322

•

“Using the scene hierarchy” on page 324

•

“Understanding the dependency graph” on page 337

•

“Using a dependency graph” on page 338

•

“Editing objects” on page 352

•

“Altering the view of a graph” on page 356

OPENING THE HYPERGRAPH
You can open the Hypergraph in its own window or in a workspace panel.
Displaying it in a workspace panel has the advantage of letting you see the
Maya user interface and the Hypergraph without having to reposition the
windows.
To open the Hypergraph in its own window:
From the menu bar or Hotbox, select Window > Hypergraph. The
Hypergraph opens.
Menu bar
Tool bar

Scale and move the window as needed.
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To open the Hypergraph in a workspace panel:
From a workspace panel, select Panels > Panel > Hypergraph.
When you display the Hypergraph the first time, the scene hierarchy
displays. In subsequent displays of the Hypergraph, the scene hierarchy or
dependency graph appears, depending on which was displayed the
previous time you closed the window. Note that a scene hierarchy is also
referred to as a DAG (directed acyclic graph).
If you display the scene hierarchy for a new, empty scene, you’ll see no
graph.
If you display the scene hierarchy, invisible objects such as the perspective,
top, front, and side cameras do not appear in the graph by default. In
contrast, the Outliner shows the default cameras unless you choose not to
display them.

Note
Unless instructions in this chapter state otherwise, make all menu choices
from the Hypergraph menu bar.
Hypergraph menu bar
The Hypergraph menu bar has entries for working with the scene hierarchy
or dependency graph.
Hypergraph toolbar
The tool bar has icons for commonly used Hypergraph menu bar selections.
To see the selection that an icon represents, move the mouse pointer over the
icon. If popup help is toggled on (Help > Popup Help), the name of the
selection appears in a yellow popup. Otherwise, look in the help line at the
bottom of the Maya window.

EDITORS
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UNDERSTANDING SCENE HIERARCHY TERMINOLOGY
A common technique in modeling, rendering, and animation is to work with
objects in a hierarchical relationship. To work with a hierarchy you must
understand the terminology for describing the relationship of objects.
The following figure illustrates a scene hierachy.

Parent

An object or other item that controls attributes of one or more children. A
parent can also be the child of another parent.
In the figure, InnerSolarSystem is a parent of Sun. Sun is a parent of
Mercury, Venus, Earth, and Mars. Earth is a parent of Moon.

Child

An object having attributes controlled by its parent. A child can be the
parent of other children. A child in the graph is connected to its parent by an
indented right angle line.
Sun is a child of InnerSolarSystem. Mercury, Venus, Earth, and Mars are
children of Sun. Moon is a child of Earth.

Node

A parent, child, or independent item. This refers generally to any box in the
graph.
InnerSolarSystem, Sun, Moon, and all other boxes in the graph are nodes.

Subnode

Any node below another node in the hierarchy.
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The subnodes of InnerSolarSystem are Sun, Mercury, Venus, Earth, Moon,
and Mars. The subnodes of Sun are Mercury, Venus, Earth, Moon, and Mars.
The subnode of Earth is Moon. Moon and Mars have no subnode.
Branch

All nodes along a path from a parent to child. A branch from Sun to Moon
includes Sun, Earth, and Moon.

Hierarchy

The arrangement of all connected nodes that make up a scene or object.
The scene hierarchy is made of all nodes in the figure. The Earth hierarchy
consists of Earth and Moon.

Transform node

A node that contains an object’s transformation attributes—values for its
translate, rotation, scale, and so on. It also holds information on parent-child
relationships it has with other nodes.
InnerSolarSystem, Sun, Moon, and all other boxes shown in the example are
transform nodes.

Shape node

A shape node holds an object’s geometry attributes or attributes other than
the object’s transform node attributes. Shape nodes do not appear in the
scene hierarchy by default. To display shape nodes, see “Displaying special
nodes and connections” on page 326.
The scene hierarchy and the dependency graph display animated nodes as
slanted boxes. If you animate a node with an expression, it displays a regular
rectangle rather than a slanted box. All other animation techniques display a
slanted box. Specifically, a slanted box indicates that the node has a param
curve connected to it.

Not animated

EDITORS

Expression animation Other animation
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USING THE SCENE HIERARCHY
You can use the scene hierarchy to:
•

display special nodes and connections
You can display shape, invisible, and underworld nodes. You can also show
expression, constraint, and deformer connections that link nodes. See
“Displaying special nodes and connections” on page 326.

•

make an object the child of a parent object (known as parenting)
A child adopts attribute changes made to the parent. See “Parenting objects”
on page 329.

•

reorder the position of nodes (see “Rearranging scene hierarchy nodes” on
page 331)

•

create a free-form graph of the hierarchy that suits your visual preference
(see “Creating a free-form hierarchy” on page 333)

•

select, rename, and hide objects, and edit attributes of an object (see “Editing
objects” on page 352)

•

examine the structure of the scene
The Outliner lists the components of a scene as an indented list. The
Hypergraph shows the relationship of the objects of the scene graphically.
See “Altering the view of a graph” on page 356 for details on navigating the
view of the graph.

Expanding scene hierarchy nodes
As you examine a scene hierarchy, you can expand or collapse the display of
nodes. Collapsing nodes is helpful for lessening clutter in a hierarchy. You
expand a node to see nodes below it.
For a selected node, you can display:
•

subnodes one level below the node

•

all subnodes below a node
When you know where a node is in the workspace but you’re not sure of its
graph position, you can select the node in the workspace and expand all
nodes necessary to display and highlight it.
A selected node is yellow in the scene hierarchy.
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Note
A node name followed by “...” is abbreviated in the graph. See “Dollying
the view” on page 356 to learn how to view the full name. For other graph
viewing techniques, see “Altering the view of a graph” on page 356.
To expand a node:
1

Select the node.
If the node is not visible in the scene hierarchy, select it in the workspace or
Outliner.

2

Select:
Edit > Expand to expand a node to one level below.
Edit > Expand All to expand all subnodes below a node.
Edit > Show Selected to display and expand a node not visible in the graph.

A red arrow appears
below a node if it’s
collapsed.

Expanded node

To collapse a node:

EDITORS

1

Select the node.

2

Select Edit > Collapse.
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Tips
•

To expand or collapse a node, double-click it.

•

To quickly select Hypergraph menus, click the right
mouse button in an empty part of the Hypergraph
window.

•

To display context-sensitive Hypergraph menus, move
the mouse over a node and click the right mouse
button. These menus are also available from the main
Hypergraph menus, but they apply only to the
selected node.

•

For details on navigating the view of the graph, see
“Altering the view of a graph” on page 356.

Displaying special nodes and connections
You can display shape, invisible, and underworld nodes in the scene
hierarchy. You can also display expression, constraint, and deformer
connections that link different nodes.

Shape, invisible, and underworld nodes
By default, the scene hierarchy does not display shape nodes, invisible
nodes, or underworld nodes. It displays only transform nodes—nodes that
hold attributes and other information on an object’s transformation and
parent-child relationships.
A shape node holds an object’s geometry attributes or attributes other than the
object’s transform node attributes. A shape node is a child of a transform
node. A transform node has only one shape node.
An invisible node is any object you have hidden using Display > Hide from
Maya’s menu bar. The default cameras top, front, side, and persp are also
invisible nodes.
An underworld node is a pair of nodes below a shape node. When you create a
curve on a NURBS surface, Maya generates an underworld transform node
and shape node below the shape node of the surface. The CV positions of
underworld nodes have UV coordinates on the surface rather than
coordinates in world or local space.
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To display invisible nodes, object shape nodes, or underworld nodes:
Toggle on these options:
•

Options > Display > Shape Nodes

•

Options > Display > Invisible Nodes

•

Options > Display > Underworld Nodes
Invisible nodes display with the text grayed.
Underworld nodes appear only if you also display shape nodes in the graph.
A dotted line in the scene hierarchy indicates a connection to an underworld
node. Connections to instanced objects are also indicated by dotted lines.

Note
Hypergraph option settings are saved with a scene file. The options are not
saved for Maya globally.
Example
Suppose you select Create > NURBS Primitives > Sphere to create a sphere.
Maya creates a transform node and a shape node.
The sphere’s shape node holds the mathematical description of the sphere’s
shape. The sphere’s transform node holds the sphere’s position, scaling,
rotation, and so on. The shape node is the child of the transform node.
If you select Options > Display > Shape Nodes in the Hypergraph, the scene
hierarchy shows these nodes for the sphere:

Maya gives the nodes the default names shown in the preceding figure. The
transform node is nurbsSphere1, the shape node is nurbsSphereShape1. If
you rename the transform node, for example, to Bubble, Maya renames the
shape node to BubbleShape.

EDITORS
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If you rename the shape node, Maya does not rename the transform node.
Maya doesn’t transmit a child’s attribute changes up to its parent.
Example
Suppose you select Create > NURBS Primitives > Sphere to create a sphere.
Maya creates a transform node and a sphere node. Suppose you then select
Modify > Make Live, then use the Create > CV Curve Tool to draw a curve
on the surface of the sphere.
If you turn on the display of shape nodes and underworld nodes, the scene
hierarchy appears as follows:

Maya gives the nodes the default names shown. The transform node is
nurbsSphere1, the shape node is nurbsSphereShape1. The curve1 and
curveShape1 nodes are underworld nodes for the curve created on the
sphere’s surface.
When a curve-on-surface is hard to select in the workspace because of
crowding or complex geometry, you can select it easily in the scene
hierarchy with underworld nodes displayed.

Expression, constraint, and deformer connections
You can display color-coded lines in the scene hierarchy that illustrate nodes
connected by an expression, constraint, or deformer.
To display nodes connected by an expression, constraint, or deformer:
Toggle on any or all of these options:
•

Options > Display > Expression Connections

•

Options > Display > Constraint Connections

•

Options > Display > Deformer Connections
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To hide these connections, toggle off the appropriate options.
Example
Suppose you create a NURBS sphere named Ball and a NURBS cone named
Cone. You write an expression to assign the value of Ball’s translateY
attribute to Cone’s translateY attribute.
The expression links the two values. When you move Ball up or down in the
workspace (in a Y-axis direction), Cone moves up or down the same amount.
If you select Options > Display > Expression Connections, the scene
hierarchy displays this:

This line means attributes in the
two nodes are connected, for

Tip
You can change the color-coding of the connection lines and other
important entities by selecting Window > Settings/Preferences > Colors
from Maya’s main menu bar and expanding Hypergraph/Hypershade.

Parenting objects
You can make an object the child of a parent object. The child adopts some
or all attribute changes made to the parent.
For example, suppose you animate a planet to orbit the center of the
workspace. If you make a moon the child of the planet, it follows the motion
of the planet.
Though the moon is the child of the planet, you can also give the moon
motion that’s independent of the planet. For example, you can make it orbit
the planet. If you later change the orbiting motion of the planet, the moon
continues to follow the planet’s motion, but stills retains its original orbiting
motion.
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To control multiple objects with one node, you can also create an empty
group and make several objects its children. By grouping objects under one
node, you can move, shade, apply texture, and do many other actions to all
the objects by working with the group node.
Example
BackTire

FrontTire

1. Create original objects.

Tires

2. Create empty node and name it Tires.

Tires

3. Group objects under Tires.

BackTire
FrontTire

4. Move, rotate, shade Tires.

To parent an object:
In the scene hierarchy, use the middle mouse button to drag the child node
on the parent node.
Use the middle mouse button
to drag Moon onto Planet.

Moon is now a
child of Planet.

If the parent node is not visible in the window, drag the child toward in the
direction of the parent. The graph view scrolls as you drag into the
Hypergraph’s window border.
To parent several objects to a new node:
1

From the Maya main menu bar, select Edit > Create Empty Group. A new
node appears in the scene hierarchy named null1. This node is an invisible,
empty object.
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2

Use the middle mouse button to drag an object node onto the null1 node.
The object becomes a child of the null1 node.

3

Repeat this step for other objects to be children of the group.

4

Rename the null1 node to something more meaningful.
For example, you might rename a group containing four flower petals as
flower. See “Renaming an object” on page 354.
The scene hierarchy displays the objects parented to the group node:

If you modify the group node attributes, its corresponding member’s
attributes also are modified. For example, if you scale down a flower group
node, the four petals scale down also.
To break the relationship between parent and child:
With the middle mouse button, drag the child node to an empty spot in the
workspace.

Rearranging scene hierarchy nodes
You can rearrange the position of nodes in a scene hierarchy to suit your
preferences as follows:
•

Move a node’s relative position.

•

Create a free-form scene hierarchy.

•

Display the graph vertically or horizontally. See “Displaying a graph
vertically or horizontally” on page 364.
Note that Maya updates the scene hierarchy as you modify a scene.
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Changing a node’s relative position
You can move a node’s relative position vertically or horizontally in a scene
hierarchy. You might want to do this, for example, to make the node’s graph
position correspond to its spatial position in the workspace.
Be aware that rearranging an object’s position in the Hypergraph might alter
its behavior or appearance in your scene. Reordering a node’s position in the
graph affects Maya’s evaluation order for the object. The evaluation order
occurs from left to right and top to bottom for a scene hierarchy displayed in
automatic layout.
For example, Maya typically renders nodes in the order they appear in the
scene hierarchy. Changing this order changes their rendering order. If a
node has transparency, however, Maya puts the node in a delayed render
queue. Maya renders this queue after all opaque objects.
To see the evaluation order for a graph currently in free-form layout, select
Options > Layout > Automatic Layout. To return to the free-form layout,
select Options > Layout > Freeform Layout.
To move a node in the graph:
Use Ctrl-middle mouse button to drag the node on top of another node.
In a horizontal graph, the dragged node replaces the other node’s position.
The other node’s position gets pushed to the right.
In a vertical graph, the dragged node replaces the other node’s position. The
other node’s position gets pushed downward.
Example
Suppose you created a scene containing several of the solar system’s planets,
including earth. As you add each planet, the scene hierarchy puts a node
representing the planet in the graph.
Maya puts each new node in the graph to the right of existing nodes. The
location of the planet nodes in the graph might not represent the spatial
relationship of the planets in the workspace, as in this example:
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Here, Earth sits further from mercury than mars. In the actual solar system
and in your workspace, this is not true.
To make the graph reflect the positioning of the earth in the workspace, use
Ctrl-middle mouse button to drag the Earth on top of Mars.
Maya positions the node to the right of Venus and to the left of Mars.
Thereafter, you’ll know where to look for Earth in the scene hierarchy.

Creating a free-form hierarchy
Maya lets you select a free-form layout for the scene hierarchy to suit your
node position preferences. By doing so, you can make the graph’s
appearance resemble the appearance of characters or other complex objects
in your scene. This helps you find and select components from the hierarchy
more quickly.
For example, suppose you modeled a human hand. You can customize the
graph so the location of its nodes resembles the arrangement of the joints
that represent the fingers and palm:
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Important
Move as few nodes as necessary. When you drag a node to a new position
in the graph, you increase the scene’s file size and the Maya processing
time needed to work with the scene.
When you move a parent node, Maya automatically moves its children
with it. Automatically moved children do not increase the file size and
processing time.
To make a free-form graph:
1

Select Options > Layout > Freeform Layout.

2

Drag nodes to the desired positions in the graph.
If the spot where you want to put a node is not visible in the window, drag
the node past the edge of the window. The window scrolls in the direction
you drag.
To drag two or more nodes to another position, click the first node, Shiftclick the second node and any other nodes, then drag to the desired position.
To drag a parent but not its children, Ctrl-Shift-click the node and drag to
the desired position.
To return to the automatically generated layout:
Select Options > Layout > Automatic Layout.
You can return to your previous free-form graph arrangement by selecting
Options > Layout > Freeform Layout.
To reset the free-form graph:
If you create a free-form graph and you decide you no longer like its
appearance, you can reset the graph to the automatic layout.

1

Select Edit > Reset Freeform Layout.

2

Click Yes when asked to confirm your selection.
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Displaying a background image with a scene hierarchy
You can display a single image of your choice as the background for a scene
hierarchy. This is helpful if you want to create a free-form hierarchy that lets
you identify and select a character’s joints and nodes more easily.
For example, suppose you modeled a human character. Suppose further you
rendered an image of the character or used a snapshot utility to capture an
image of the character’s skeleton in the workspace.
You can display the image in the background of a free-form hierarchy, then
position nodes and joints to match the character skeleton. This helps you
identify scene hierarchy components more quickly.
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The character skeleton exists behind the scene hierarchy. With this
arrangement, you can quickly find nodes, for example, that represents the
character’s feet and ankles.
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To import the background image:
1

Switch to freeform layout, if you are not already in it (Options > Layout >
Freeform Layout).
Note that you can import an image for the free-form layout only. Having a
background image for the automatic layout has no practical purpose. The
node positions for the automatic layout are fixed.

2

Select View > Load Background Image. A file browser appears.

3

Select and load the image. The image appears in the scene hierarchy.

4

Dolly or track to bring the image into view.

5

Move nodes to positions on top of the image.
Whenever you display the scene hierarchy in the Hypergraph (in freeform
layout), the image appears behind the nodes.
To turn the display of the background image off or on:
Toggle Options > Display > Background Image (in free-form) on or off.
You can display the image in the background of a free-form hierarchy.

UNDERSTANDING THE DEPENDENCY GRAPH
The dependency graph displays connections between nodes in Maya that
input and output data. A dependency graph node can represent an object’s
geometry, for example, a NURBS sphere. A node can also represent a Maya
operation such as a deformer. Inputs and outputs are the connections
between nodes, including direction of influence.
A dependency graph has no parent-child relationships, only data flow. You
can display a dependency graph, for example, to see the data flow between
nodes that make up an object’s construction history or shading.
All nodes in a scene hierarchy also can be displayed in a dependency graph.
However, not all nodes in a dependency can be displayed in a scene graph.
For example, a NURBS sphere’s transform and shape nodes appear in a
scene graph and therefore can be displayed in a dependency graph. A
shading group node or deformer operation node that appears in a
dependency graph never appears in a scene hierarchy.
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A dependency graph node takes input data from one or more other nodes
and uses the input to create output data. When you create models, deform
objects, animate, process audio, and so on, dependency graph nodes work
with the data involved.
Although we refer to a dependency graph as a singular graph, be aware you
can display two or more independent graphs of connected nodes in the same
window. We refer to each independent graph also as a dependency graph.
Maya updates the dependency graph as you modify a scene.

USING A DEPENDENCY GRAPH
The dependency graph is a tool for programmers who extend Maya
capabilities. If you’re an advanced Maya user, you’ll also find it useful to:
•

examine render node connections (see “Displaying render node
connections” on page 339)

•

examine other node connections (see “Displaying upstream and downstream
connections” on page 340)

•

disconnect rendering nodes and other nodes (see “Disconnecting nodes in a
dependency graph” on page 344)

•

connect rendering nodes and other nodes (see “Connecting nodes in a
dependency graph” on page 346)
Avoid disconnecting and connecting nodes unless you have an
understanding of Maya’s architecture. You’ll spare yourself frustration
tracking down resulting problems.
See “Editing objects” on page 352 and “Altering the view of a graph” on
page 356 for additional details on working with a dependency graph.

Tip
As a new user of the Hypergraph, you might be unsure whether you’re
looking at the scene hierarchy or a dependency graph. If you see arrows
between nodes, you’re looking at a dependency graph. If Scene Hierarchy
under the Graph menu is grayed, you’re looking at the scene hierarchy.
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Displaying render node connections
You can show connections to shading groups, materials, textures, and lights.
See Using Maya: Rendering for details.
To display render node connections:
Select one of these options:
•

Rendering > Show Shading Groups

•

Rendering > Show Materials

•

Rendering > Show Textures

•

Rendering > Show Lights
Example
Suppose you create a NURBS sphere, then use the Hypershade to create and
assign a Phong shading group to it. Next you use the Hypershade to create a
2D checker texture and assign it to the Phong node.
The Hypershade displays the following contents:

The following dependency graph appears when you select
Rendering > Show Shading Groups in the Hypergraph.
Connection line
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The connection lines between nodes show connection direction. The
connection line originates at a node that outputs data, and the line points to
a node receiving the data as input.
The preceding figure shows that the flow of output goes from the phong1SG
shading group to the renderPartition.
Although you can see most of the same nodes in the Hypershade, the
dependency graph shows the nodes in a flow diagram. This makes it easy to
see the connections between the nodes that make up a shading group.
If you move your mouse pointer over a connection line, small white boxes
appear next to the input node and output node. The white box next to an
input node shows the node’s name and attribute that receives the input.

checker1.outColor

phong1.color

Mouse pointer

The white box next to an output node shows the node’s name and attribute
that provides the output. Each node name and attribute is separated by a
period, for example, checker1.outColor and phong1.color. In the preceding
figure, the outColor attribute of checker1 is output to the color attribute of
phong1.
In many cases, you must be familiar with Maya internal operation details to
understand the node and attribute names you see in the white boxes.

Displaying upstream and downstream connections
You can show upstream and downstream connections to a selected node. An
upstream connection is a node that provides input to the selected node. A
downstream connection is a node that receives input from the selected node.
To see connections to most objects, you must select the shape node of the
object rather than the transform node.
To select a node and display its connections:
1

Select the node.
To select a shape node from the scene hierarchy, make sure
Options > Display > Shape Nodes is toggled on.
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Tip
You can select an object’s shape node in the scene hierarchy without
showing shape nodes. Select the object’s transform node, put the mouse
pointer in the Maya or Hypergraph window, then press your keyboard’s
down arrow key.
Selecting a shape node with this technique is useful for scenes having
many nodes, where displaying all shape nodes in the scene hierarchy takes
up much panel space.
Press the up arrow key to return to the transform node.
2

Select one of the following:

•

Graph > Up and Downstream Connections

•

Graph > Upstream Connections

•

Graph > Downstream Connections
When you display upstream connections for a node, you see the chain of
nodes that provide input to each other all the way to the selected node.
When you display downstream connections for a node, you see the chain of
nodes that output to each other, all the way through to the end receiving
node.
Example
Suppose you create a wine glass surface by revolving a NURBS curve. The
following dependency graph appears when you select the revolved surface’s
shape node and select Graph > Up and Downstream Connections:
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Note that the graph is shown with a vertical orientation to make the
illustration fit on this page. By default, a dependency graph has a horizontal
orientation. See “Displaying a graph vertically or horizontally” on page 364.
The connection lines between nodes show connection direction. The
connection line originates at a node that outputs data, and the line points to
a node receiving the data as input. For information on the connection line
colors, see “Connection line colors” on page 343.
The example graph shows that a curve provides input to the revolve
operation node. The revolve operation generates a revolved shape—the wine
glass. The revolved shape is connected to initialShadingGroup, which sets
the default color of all geometric shapes created in Maya.
If you move your mouse pointer over a connection line, small white boxes
appear next to the input node and output node. The white box next to an
input node shows the node’s name and attribute that receives the input.
The white box next to an output node shows the node’s name and attribute
that provides the output. Each node name and attribute is separated by a
period.
In many cases, you must be familiar with Maya internal operation details to
understand the node and attribute names you see in the white boxes.
Note that the dependency graph and scene hierarchy display animated
nodes as slanted boxes. If you animate a node with an expression, it displays
a regular rectangle rather than a slanted box. All other animation techniques
display a slanted box. Specifically, a slanted box indicates Ball has a param
curve connected to it.
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Example
Suppose you keyframe the translateX attribute of a NURBS sphere named
Ball. If you select Ball’s transform node and display all upstream and
downstream connections, this graph appears:

The slanted box indicates Ball’s transform node has been animated. The
graph doesn’t indicate which type of animation technique controls the
attribute.

Connection line colors
The connection lines are color-coded to indicate the type of attribute that is
connecting the nodes. In this case, attribute types are single, double, triple,
data, and array. See the following table for an explanation.

Default Color

Attribute Type

Example Attributes

Blue

Single

transform.translateX,
makeNurbsSphere.radius

Cyan

Double

file.repeatUV,
cameraShape.cameraAperature

Green

Triple

transform.translate, lambert.color

Magenta

Data

nurbsSurface.create,
makeNurbsSphere.outputSurface

Red

Array

particleShape.position,
particleShape.velocity

These colors are the default. You can change them in the Colors window
(Window > Settings/Preferences > Colors).
Also note that a dotted line in the scene hierarchy indicates a connection to
an underworld node or an instanced object.
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Dragging nodes into a dependency graph
You can drag one or more nodes from the Outliner or Hypershade into the
dependency graph to display the dependency graph of the node or nodes.
This is ideal for keeping irrelevant nodes out of view when you’re creating
and assigning rendering nodes.
Any dependency graphs previously in the display remain there.
1

To clear out all graphs from the display, select Edit > Clear View.

2

Click Yes to confirm.
Note that you can also drag a node into the dependency graph from any part
of Maya that lets you drag icons.
To drag the node into the dependency graph:
Use the middle mouse button to drag the node or nodes into the
Hypergraph panel.

Disconnecting nodes in a dependency graph
You can use the dependency graph to disconnect nodes.
To disconnect nodes:
1

Click the connection line representing the connection in the dependency
graph. The connection line turns yellow to indicate it’s selected.

2

Press your keyboard’s Backspace key. The connection line disappears,
indicating you disconnected the connection.
To update the graph’s layout to display the disconnected nodes more
appropriately, select Graph > Layout.
Example
Suppose you create a NURBS sphere named Ball. You then use the
Hypershade to create a Phong E material with red color and assign the
resulting phongE1SG shading group node to Ball.
The Hypershade displays the following contents.
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The following dependency graph appears when you select
Rendering > Show Shading Groups, then select the phongE1SG node and
select Graph > Up and Downstream Connections.

The graph shows that an attribute of the BallShape node (that represents
Ball’s geometry) is input to the phongE1SG shading group node. Ball gets its
color from the phongE1SG node.
To stop the phongE1SG node from setting Ball’s color, do the following:
1

Click the connection line leading from BallShape to phongE1SG. The
connection line turns yellow to indicate it’s selected.

2

Press the Backspace key on your keyboard.
The connection line disappears, indicating you disconnected the nodes. The
phongE1SG no longer controls Ball’s color.
Ball keeps its previous shading group attribute values. In other words, it
stays red and doesn’t become the default gray. If you alter attributes of
phongE1SG, though, the changes are not passed to Ball.
You can reconnect BallShape to another shading group node to make it
control Ball’s shading. For example, you can use the middle mouse button to
drag BallShape from the Outliner onto initialShadingGroup.
Ball’s color becomes the default gray color set in the initialShadingGroup
node. Note that each geometric object you create is connected to the
initialShadingGroup node, by default, until you connect it to another
shading group.

EDITORS

USING MAYA: ESSENTIALS
345

USING THE HYPERGRAPH | 10
Using a dependency graph

Connecting nodes in a dependency graph
The dependency graph offers convenient ways to connect nodes while you
examine the graph. In the dependency graph, you can:
•

launch the Connection Editor

•

launch a window that displays input or output attributes you can connect to

•

connect a node’s default output attribute to a node’s default input attribute
To launch the Connection Editor:
Use Shift-middle mouse button to drag from an output node to an input
node.
The Connection Editor appears. The Outputs side of the Connection Editor
displays the dragged node and its attributes. The Inputs side displays the
attributes of the destination node. See Using Maya: Rendering for details on
the Connection Editor.
To create a default connection:
Use the middle mouse button to drag the output node onto the input node.
Maya connects the default output attribute from the output node to the
default input attribute of the input node. Usually, the default input and
output attributes are the attributes you would most likely want to connect.
If the attributes aren’t compatible, no connection occurs and the Connection
Editor appears instead.
Example
Suppose you create a NURBS sphere and cone named Ball and Cone. You
use the Hypershade to create a Phong E material with red color, and a Blinn
material with blue color. You assign the resulting phongE1SG shading group
node to Ball, and the blinn1SG shading group to the Cone.
The Hypershade displays the following contents:
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The following dependency graph appears when you select
Rendering > Show Shading Groups, select the phongE1SG and blinn1SG
shading groups and select Graph > Up and Downstream Connections.

The graph shows ConeShape connected to the blinn1SG shading group, and
BallShape connected to the phongE1SG shading group.
You can swap the colors of Ball and Cone by reversing their connections to
the shading groups.
To reverse connections:
1

Use the middle mouse button to drag ConeShape onto phongE1SG. This
reconnects the default output attribute of the ConeShape node to the default
input attribute of the phongE1SG node. Cone becomes red.

2

Use the middle mouse button to drag BallShape onto blinn1SG. This
reconnects the default output attribute of the ConeShape node to the default
input attribute of the phongE1SG node. Ball becomes blue.

Tip
Select Rendering > Create Render Node to create a new material, texture,
or light. You can then connect to the new node using the dependency
graph.
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Example
Suppose you create a NURBS sphere named Ball. You then use the
Hypershade to create a Phong E material with blue color and assign the
corresponding phongE1SG shading group node to Ball to color it blue.

You then create a black and white 2D checker texture, but you haven’t
assigned it to an object.
The Hypershade displays the following contents.

To replace Ball’s blue color with the checker texture, you must use the
middle mouse button to drag the texture node onto the shading group.
If you select Rendering > Show Shading Groups, you’ll see the shading
groups in the scene, but not the textures.
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If you select Rendering > Show Textures, you’ll see the textures created in
the scene, but not the shading groups.

To drag the checker1 texture onto the phongE1SG shading group, you need
to display them in the graph at the same time. Do the following steps:
1

While the checker1 node is displayed in the dependency graph, use the
middle mouse button to drag the phongE1SG shading group node from the
Hypershade into the Hypergraph window.

2

Select the checker1 and phongE1SG nodes and select Graph > Upstream and
Downstream Connections.
The dependency graph for the phongE1SG node appears as follows.

3

EDITORS

Use the middle mouse button to drag the checker1 node onto the
phongE1SG or PhongE1 node. Maya makes a connection from checker1 to
phongE1 and draws a connection line representing the connection:
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Ball shows a black and white checkerboard texture, rather than blue color.
Turn on Shading > Smooth Shade All and Shading > Hardware Texturing to
display shading and textures of objects in your workspace.

4

To redraw the graph with better organization of connection lines, select
Graph > Layout.

5

Dolly and track to bring the reorganized graph into view:

6

Move the mouse pointer over the connection line between checker1 and
phongE1.
White boxes appear next to the nodes. They show that the default output
outColor attribute of checker1 connects to the default input color attribute of
phongE1.
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Because of this connection, the black and white checker1 texture provides
the material color for the phongE1 node and therefore the phongE1SG
shading group. An object connected to the phongE1SG shading group
receives the black and white checker1 texture.
To launch the display of input or output attributes:
1

Drag a connection line to a node.
If you drag the side of the line closer to the original output node, you display
output attributes of the destination node. If you drag the side of the line
closer to the original input node, you display input attributes of the
destination node.
After you drag a connection line to a node, a pop-up menu displays listing
either of the appropriate attributes you can connect to, either input or
output. The part of the connection line you drag determines whether you
display the node’s input or output attributes.

2

Click the attribute you want to connect to.

Updating the layout of a dependency graph
When you add or connect nodes in a scene, the dependency graph might
place the nodes in a position that isn’t easy to read. If you don’t like the
positioning of the added node, you can update the graph’s layout to a
default reorganized layout.
To update the dependency graph’s layout:
1

Select Graph > Layout. A window opens and asks you to confirm your
choice.

2

Click Yes.
To return to the scene hierarchy from the dependency graph:
Select Graph > Scene Hierarchy.
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Clearing the contents of a dependency graph
You can clear the display of the dependency graph from the Hypergraph
window. This is helpful when you’re looking at connections for one or more
nodes, but want to look at unrelated nodes without the clutter of the existing
nodes.
To clear the contents of the dependency graph:
1

Select Edit > Clear View. A window requesting confirmation appears.

2

Click Yes.

Returning to the scene hierarchy
While examining a dependency graph, you can return to the view of the
scene hierarchy.
To return to the view of the scene hierarchy:
Select Graph > Scene Hierarchy.

EDITING OBJECTS
There are several ways to edit objects as you’re examining the scene
hierarchy or dependency graph. You can:
•

select objects

•

add and select an IK handle

•

rename objects

•

hide objects

•

edit a selected node’s attributes

•

add a render node

Selecting objects
The scene hierarchy and dependency graph offer a convenient way to select
objects or other items in a scene. This is useful when items in the workspace
are crowded and overlapping.

USING MAYA: ESSENTIALS
352

PART 2

USING THE HYPERGRAPH | 10
Editing objects

To select an object:
1

Track and dolly the view to find the node that represents the object or
component.
For example, if your scene has an object named Ball, bring the node
representing Ball into view in the scene hierarchy.

2

Click the node to select it. The node changes to yellow.

Click a node to
select the object
it represents.

To deselect an object:
Click an empty spot in the window. When you deselect a node, it becomes
gray again.

Adding and selecting an IK handle
In a scene having an IK character with a complex, crowded skeleton, you can
use the scene hierarchy to easily add an IK handle to a joint chain. This lets
you select the handle easily.
To add an IK handle:

EDITORS

1

In the Animation menu set, select Skeleton > IK Handle Tool.

2

In the scene hierarchy, select the top node of the joint chain.

3

Shift-select the bottom node of the joint chain. Maya creates an end effector
and IK handle for the joint chain.
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IK handle icon

To select an IK handle:
Click the IK handle icon to the right of the end effector node. The IK handle
node and icon turn yellow to indicate you selected it.
If you make the IK handle node the child of another node, its location might
be hard to find in the graph. The IK handle icon to the right of the end
effector at the bottom of the joint chain makes it easy to find.

Renaming an object
You can rename an object or other item in the scene hierarchy or
dependency graph. You can give two nodes the same name, but only if each
has a different parent.
RoadBike

FrontTire

MountainBike

BackTire

FrontTire

BackTire

This is allowed.

Bike

Tire

Tire

This is not allowed.
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To rename an object:
1

Right-click on the node representing the object and select Rename from the
pop-up menu. A small text box appears in the node:

2

Enter the new name.

Hiding an object in the workspace
You can use the scene hierarchy or dependency graph to make an object or
other item invisible in the workspace.
To hide an object:
Right-click on the node representing the object and select Hide from the popup menu. The object disappears from the workspace and the text on the
node becomes grayed in the scene hierarchy.
To display a hidden object:
1

Select Options > Display > Invisible Nodes. The text on a node representing
a hidden object is grayed to indicate it’s invisible in the workspace.

Invisible node

2

Right-click on the node representing the object and select Show from the
pop-up menu. The object reappears in the workspace.

Editing an object’s attributes
After you select a node in the scene hierarchy or dependency graph, you can
edit its attributes:
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To edit a node’s attributes:
1

Select the node in the graph.

2

Select Edit > Attributes. The attributes for the selected node load into the
Attribute Editor.

Creating a render node
You can launch the Create Render Node window to create a new material,
texture, and light. This is convenient when you’re examining the
dependency graph for a rendering node.
The Create Render Node window is the same window that appears when
you select Create > Create Render Node from the Hypershade.
To create a render node:
Select Rendering > Create Render Node. The Create Render Node window
opens. For details, see Using Maya: Rendering.

ALTERING THE VIEW OF A GRAPH
A scene hierarchy or dependency graph covers lots of screen space for
complex scenes. For example, you might create a detailed kinematic
character that results in thousands of nodes.
The following pages describe general navigation techniques for examining a
graph. You can use the techniques with a scene hierarchy or dependency
graph, unless otherwise noted.

Tracking the view
You can move the view of the graph up, down, or sideways.
To track the view:
In the graph view, use Alt-middle mouse button to drag in the desired
direction.

Dollying the view
You can enlarge or shrink the view of the graph.
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To dolly the view:
In the graph view, hold down the Alt key and drag the left and middle
mouse buttons left to shrink the view; drag to the right to enlarge the view.

Note
If you dolly away from a graph, the text in node boxes becomes
abbreviated. An ellipses (...) appears to the right of the abbreviation.
To read the text, move the mouse pointer over the box. The node’s name
appears in a pop-up box. The type of node appears in parenthesis next to
the node name.
For example, if you see Ball (transform) in a box, it means the box
represents the node named Ball, which is a transform node.

Dollying a region
You can dolly the view of a selected region by dragging a selection box.
To dolly a region:
Ctrl-Alt-drag a selection box from left to right around the region.

Drag from
left to right

The region in the selection box expands to the center of the Hypergraph
window.
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To dolly away from a selection:
Ctrl-Alt-drag a selection box from right to left around the region.

Fitting an entire graph in the window
You can fit an entire graph in the Hypergraph window. This is helpful if you
want to see the general organization of nodes.
To fit the entire scene graph in the window:
Select View > Frame All.
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In a large graph, the node names will be too small to read. You’ll need to
dolly and track this view to read the names.

Centering selected nodes in the window
You can center and expand the view of selected nodes in the Hypergraph
window. You might want to do this, for example, when you’re looking at
distant, unreadable view of the graph, and you want to read the name of the
currently selected object.
To center selected nodes in the window:
1

Click the node or nodes in the graph. You can also select a node in the Maya
workspace or from the Outliner.

2

Select View > Frame Selection.
Here’s an example display.

Selected node

Centering a hierarchy in the window
You can center a selected node’s hierarchy in the Hypergraph window. This
is useful when you want to focus on a group of related nodes above and
below the selected node. This option works only in the scene hierarchy, not
in the dependency graph.
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To center a hierarchy in the window:
1

Click the node in the graph. You can also select a node in the Maya
workspace or from the Outliner.

2

Select View > Frame Hierarchy.

Centering a hierarchy branch in the window
You can center the branch descending from a node in the Hypergraph
window. This is useful when you want to focus on the related nodes below a
selected node. This option works only in the scene hierarchy, not in the
dependency graph.
To center a branch in the window:
1

Click the node in the graph. You can also select a node in the Maya
workspace or from the Outliner.

2

Select View > Frame Branch.

Adjusting view transition speed
When you change the panel view of a graph, for example, by selecting
View > Previous View, Maya dollies from one view to another
instantaneously, by default. You can slow Maya’s transition speed between
views to make the view change action easier to see.
To adjust the transition speed between views:
1

Toggle on Options > Transitions > Animate Transitions.

2

Select Options > Transitions > and select one of these speeds:

•

5 Frames

•

10 Frames

•

15 Frames

•

20 Frames
20 Frames dollies slowest, 5 Frames dollies fastest.
To return to the default transition speed between views:
Toggle off Options > Transitions > Animate Transitions.
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Setting graph update options
Whenever you add or delete an object, rendering node, or other item in the
scene, the Hypergraph updates the scene hierarchy and dependency graph,
by default.
When you select an object in the scene hierarchy or dependency graph, the
object is also selected in the workspace, Outliner, and elsewhere in Maya.
Also, when you select an object in the workspace, Outliner, and elsewhere in
Maya, the object becomes selected in the scene hierarchy or dependency
graph.
These updates slow Maya operation when you work with a complex scene
or when you’re examining nodes or dragging nodes to new positions in a
free-form hierarchy. You can toggle off updating to improve operation
speed.
To turn off graph updates for created nodes:
Toggle off Options > Update > On Nodes Creation.
If you toggle this option on later, the graph displays all previously added
and deleted nodes.
To turn off Hypergraph selection updates:
Toggle off Options > Update > On Selection.

Undoing a view of a scene hierarchy
As you track, dolly, and make other changes to the view of a scene
hierarchy, you may want to return to a previous view. Maya keeps the
history of your view changes and lets you return to one or more previous
views.
After you display a previous view, you can move forward again to other
view.
To change to a previous view:
Select View > Previous View.
To see the view before this one, select View > Previous View again.
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To see the view ahead:
Select View > Next View.
This works only after you use View > Previous View. To see another view
ahead, select View > Next View again.

Using bookmarks for graph views
You can bookmark the view of a graph to return to it later. For instance,
suppose you dolly the view to see a group of nodes, then bookmark the
view. If you dolly to a different view of the scene, you can select the
bookmarked view to return to it.
Note that the layout of the nodes in a previously bookmarked view changes
when you modify a scene as follows:
•

add or delete objects.

•

reposition nodes in a free-form hierarchy

•

expand or collapse nodes

•

display invisible, shape, or underworld nodes
If a node was selected and entirely visible in the view at the time of
bookmarking, when you return to the bookmarked view, the node appears
in the same position regardless of how you altered the graph.
If no node was selected or if a selected node was only partly visible in the
view, returning to the bookmarked view shows the previously displayed
region in the graph.
Depending on how you altered the graph, the previously displayed nodes
might not appear in the bookmarked region anymore. You’ll likely need to
create a new bookmark.
As you add or delete nodes in a scene, Maya updates the layout of the scene
hierarchy and dependency graph. Don’t be alarmed if you notice a node
disappears from a previously bookmarked view of the dependency graph.
This is usually the result of Maya conforming with its default graph layout.

USING MAYA: ESSENTIALS
362

PART 2

USING THE HYPERGRAPH | 10
Altering the view of a graph

Tip
You can ensure that a bookmarked view displays a node even after you
reposition, add, or delete nodes in the scene. To do so, select the node and
make sure its entire outline is visible in the view before creating the
bookmark.
If you select two or more nodes, the bookmarked view displays the first
node selected.
To bookmark a view:
1

Track and dolly the view as desired.

2

Select Bookmarks > Create Bookmark. The bookmarked view gets a default
name, for example, hyperView1. The name appears at the bottom of the
Bookmarks menu.
To name a view before bookmarking it:

1

Track and dolly the view as desired.

2

Select Bookmarks > Create Bookmark ❒. A window opens and prompts for
the bookmark name.

3

Enter a bookmark name.
To return to a bookmarked view:
Select Bookmarks and the name of the bookmark at the bottom of the menu.
For example, select Bookmarks > MonsterHead.
To delete a bookmarked view:
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1

Select Bookmarks > Bookmark Editor. The Bookmarks window opens,
showing all bookmarks you added.

2

Click the name of the bookmark.

3

Select Edit > Delete Bookmark. The name of the bookmark is deleted.
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To rename a bookmarked view:
1

Select Bookmarks > Bookmark Editor. The Bookmarks window opens,
showing all bookmarks you added.

2

Click the name of the bookmark.

3

Select Edit > Rename Bookmark. A window opens and prompts for the
bookmark name.

4

Enter the new name.
You can also rename a bookmark by selecting Bookmarks > name ❒, where
name is the name of the bookmark. A prompt window opens and lets you
enter the new name.

Displaying a graph vertically or horizontally
The scene hierarchy and dependency graph have a horizontal layout by
default.

If you prefer to look at a graph upright, you can change to a vertical layout.
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To display the graph vertically:
Select Options > Orientation > Vertical.
To display the graph horizontally:
Select Options > Orientation > Horizontal.

Rebuilding the graphs
If your scene hierarchy or dependency graph doesn’t seem up to date, you
can rebuild the graphs. For example, if you add an object to a scene and it
doesn’t appear in the scene hierarchy, rebuild the graphs to make the scene
hierarchy aware of the object’s presence.
To rebuild the graph:
Select Graph > Rebuild.
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SETS AND PARTITIONS
A set is a collection of objects or components. For example, a set might
include geometric objects, NURBS CVs, polygonal vertices, lattice points,
polygonal facets, or other items. Any item you can select can be in a set.
In some instances, Maya creates sets for you as you work with objects. For
example, when you add a cluster to several CVs of a NURBS cone, Maya
makes a set of the CVs. You can edit and tune such sets to control the area
affected by deformation.
You can also create a custom set so you can work on its items with a single
action. For instance, you can create a set of NURBS objects, then hide or
display them as a single entity.

You can edit and tune sets to
control deformation of one or
more objects.

This chapter has the following topics:
•

“How you can use sets” on page 368

•

“Understanding sets” on page 369

•

“Creating, selecting, and removing sets” on page 375

•

“Editing set membership” on page 378

•

“Editing set membership” on page 378

USING MAYA: ESSENTIALS
367

SETS AND PARTITIONS | 11
How you can use sets

•

“Altering the display of sets” on page 379

•

“Understanding partitions” on page 379

•

“Creating, displaying, and removing partitions” on page 381

•

“Adding sets to partitions” on page 382

HOW YOU CAN USE SETS
Here are the ways you can use sets:
•

adjusting deformer, skin, and flexor deformation

•

adjusting the weight of cluster, cluster flexor, and skin points

•

simplifying selection of objects or components that you regularly select or
have difficulty selecting in the workspace.

•

assigning objects to shading groups for rendering

•

moving objects from one layer to another
If you apply a deformer or skin to a geometric object, Maya creates a set for
the geometry’s CVs, vertices, or points. You can add or remove set members
to alter the effect of the deformer or skin. See Using Maya: Character Setup for
details on deformers and skins.
For clusters and cluster flexors, you can apply different weights to the set
members to increase or decrease deformations at specified points.
For skin, you can apply different weights to the set members to increase or
decrease skin deformation around the joints.
You can create your own set of objects or components for easier selection
and transformation. For instance, suppose you need to repeatedly select the
same few CVs around the eye of a cyclops to animate the eye. Rather than
struggle to select the CVs with a selection box, you might create a set named
cyclops_eye for the CVs, then select the set by clicking the set name in a
convenient set editing tool named the Relationship Editor.
When you create a shading group with the Hypershade, Maya creates a set
that represents the shading group. You can work with such sets rather than
the Hypershade to conveniently assign shading groups to objects. See Using
Maya: Rendering for details on shading groups.
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When you create a layer, Maya creates a set that represents it. You can work
with sets rather than layer menu entries to quickly move members from one
layer to another.
When you add a field to vertices, CVs, or edit points, Maya creates a set
named after the field, for instance, uniformFieldShape1Set. The set members
are the vertices, CVs, or edit points to which you added the field. You can
add or remove the set members to alter the effect of the field. See Using
Maya: Dynamics for details on fields.

UNDERSTANDING SETS
It’s easiest to learn about sets by examining the display of the Relationship
Editor, the main tool for working with sets. You can launch the Relationship
Editor by selecting it from the main menu or with other common techniques
such as the Hotbox. For more information about the Relationship Editor, see
“Using the Relationship Editor” on page 255.
To open the Relationship Editor:
From the main Maya menu, choose Window > Relationship Editors > Sets.
The Relationship Editor opens.
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Scale and move the window as needed.
You can also display the Relationship Editor in a workspace panel by
choosing Panels > Panel > Relationship Editor. This lets you see the Maya
user interface and the Relationship Editor without having to reposition the
windows.

Note
Unless instructions in this chapter state otherwise, make all menu choices
from the Relationship Editor’s menu bar.

Sets you create
When you create a set, the Relationship Editor displays the set’s name and
contents. You can apply an operation to a set to affect all its members.
Example
Suppose you create three NURBS spheres. You can put the spheres in a set
as follows:
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1

Select the spheres in the workspace, Outliner, or elsewhere.

2

In the Sets panel of the Relationship Editor, select Edit > Create Set. The
Relationship Editor displays the newly created set.
By default, Maya gives the set the name set1 or something similar. To use
your own name rather than the default, choose Edit > Create Set ❒.

3

Click the plus sign (+) next to the set to expand its contents.

The set contains nurbsSphere1, nurbsSphere2, and nurbsSphere3. Items
indented below a set name are its members. You can select the set to do
operations on each of its members.
4

To select the objects in the set, click the set name and select Edit > Select Set
Members.
This selects the three spheres that are members of the set. With the sphere
members selected, you can do operations such as:

•

hide them from the workspace view

•

translate, rotate, and scale

•

start the Attribute Editor, so all three spheres are available for editing there
Subsequent topics provide more details on working with sets.

Sets created by Maya
A new empty scene has the following default sets:
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•

defaultLightSet

•

defaultObjectSet (not used)

•

defaultLayer
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•

Shading group sets (initialShadingGroup, initialParticleSE)
In addition to the default sets, Maya creates sets automatically when you
create shaders. It also creates sets automatically when you create deformers,
flexors, or when you bind skin (Deformer and skin point sets).

defaultLightSet
When you add a light to the scene, the light becomes a member of the
defaultLight set by default. Maya keeps all lights in these set, even when you
assign a light to another set.

defaultLayer
Each scene has a default display layer that consists of all objects that have
not been assigned to any other layer. When you remove an object from a
layer, it becomes a member of the default layer.

Shading group sets
A new, empty scene has two shading group sets by default:
initialShadingGroup and initialParticleSE. These sets control the default
shading of objects added to the scene.
When you add a geometric object to the scene, the object becomes a member
of the initialShadingGroup set by default. The shading group colors its
members a dull gray. (You can see the default gray color of such objects in
the workspace by choosing Shading > Smooth Shade All.)
If you create a sphere, for instance, Maya adds the sphere to the
initialShadingGroup set. (To see these sets, you must select Shading Groups
Editing from the drop-down list in the Relationship Editor.)

Member of the set
initialShadingGroup
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Maya keeps a newly added geometric object in the initialShadingGroup set
until you create and assign a different shader to the object. Maya then
relocates the object to a set it creates for the shading group you created. You
typically won’t do anything directly with the initialShadingGroup set. It’s
for Maya’s internal use as you make shading choices.
Example
Suppose you use the Hypershade to create a Phong material. When you
create the node, Maya creates a set named phong1SG. This set represents the
Phong shading group.
Suppose further you use the Hypershade to assign phong1SG to a geometric
object named nurbsSphere1. Maya moves the object from the
initialShadingGroup to the phong1SG set.

Member of
phong1SG

The object receives its surface shading from the options you set in the
Attribute Editor for the phong1SG node.
If you were to add a particle object to a scene, it would become part of the
initialParticleSE shading group set. This set has the same purpose as
initialShadingGroup, only it controls the default shading characteristics of
particles rather than geometry.
An object can be part of only one shading group set—whether
initialShadingGroup, the initialParticleSE, or one you create.
By looking at the members of the shading group sets, you can see which
objects are shaded by the shading groups you’ve added to your scene. To try
out various shaders on different objects, use the middle-mouse button to
drag objects from one shading group set to another.
For more details on working with shading groups, see Using Maya:
Rendering.
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Deformer and skin point sets
When you attach a deformer to an object, Maya creates a set from the
object’s points. When you bind skin to a skeleton, Maya creates two or more
sets for the skin points attached to the joints. (To see these sets, you must
select Deformer Set Editing from the drop-down list in the Relationship
Editor.) See Using Maya: Character Setup for details on deformers and skin
points.
Example
Suppose you create a NURBS cone, select several CVs, then choose
Deform > Create Cluster from the Animation menu to apply a cluster.

Apply cluster to
these points

Maya creates a set named cluster1Set or something similar by default.

Applying a cluster
creates a set

The set contains the points in the cone controlled by the cluster. In such sets,
you can alter deformations by adding and removing points or by editing
point weights of existing members.
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For example, you can add corresponding points from a newly added cone in
the scene. The added points deform with the existing points as you translate,
rotate, or scale the cluster handle.

CREATING, SELECTING, AND REMOVING SETS
The following topics describe how to create, select, and remove a set. Note
that binding skin or adding a deformer or flexor to an object automatically
creates one or more sets. You need not create a set for such objects. See “Sets
created by Maya” on page 371 for details.

Creating sets
You can create a set of geometric objects, CVs, vertices, polygonal faces, or
other items.
To create a set with a default name:
1

Select the objects or items in the workspace, Outliner, or elsewhere.
For example, use the Artisan Paint Selection Tool (Modify > Paint Selection
Tool) to select CVs.
If you don’t select any objects, an empty set will be created in the next step.
You can add to an empty set later.

2

From Maya’s main menu, choose Edit > Sets > Create Set.
or
From the Relationship Editor, select Set Editing from the drop-down list and
select Edit > Create Set in the Sets panel.
The set appears with a default name in the Relationship Editor.
To create a set and name it:

1
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Select the objects or items in the workspace, Outliner, or elsewhere.
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2

From Maya’s main menu, choose Edit > Sets > Create Set ❒.
or
From the Relationship Editor, select Set Editing from the drop-down list and
select Edit > Create Set ❒ from the Sets panel.
The Create Set Options menu opens.

3

Enter the name of the set in the Name text box.
For example, enter nurbsObjects.
Other options in the window let you add the set to a partition. See “Adding
sets to partitions” on page 382 for details.

4

Click Apply. The set appears with the chosen name in the Relationship
Editor.
If a set or other item in the scene already has the specified name, the new set
name will be appended with a number. For example, entering top results in
top1, because top is the name of a camera that exists in every scene by
default.

Selecting sets
You can select a set or the contents of a set. You must select a set to remove
or rename the set. You must select the contents of the set to apply an action
to each member of the set.
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To select a set:
1

In the left panel of the Relationship Editor, click the name of the set and
choose Select > Highlighted.
You can also select the set in the Outliner or Hypergraph’s dependency
graph view.
To display set members in the Outliner so you can select them, toggle on
Display > Set members.
To display sets in the Hypergraph’s dependency graph view, select the
object shape node associated with the set and choose Graph > Up and
Downstream Connections.
To select a set’s contents only:

1

In the left panel of the Relationship Editor, click the name of the set.

2

Select Edit > Select Set Members. This selects the contents of the set, but not
the set.

Removing sets
If you are no longer using a set, you can remove it without removing its
members.
To remove a set, but not its members:
1

In the Relationship Editor, select Set Editing from the drop-down list.

2

Click the name of the set in the left panel.

3

Select Edit > Delete Highlighted.

Creating sets for easy object selection
You can create a set of joints, geometry, CVs, materials, or other items for
quick selection in the main menu. You might want to do this, for instance, so
you can select different animation characters quickly without having to start
the Relationship Editor. This is also useful for selecting items not visible in
the workspace, for instance, invisible objects.
To create a quick set:
1
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Select the objects or items.
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2

From the main Maya menu bar, select Edit > Sets > Create Quick Select Set.
A window prompts for a set name.

3

Enter the set name for the items and click OK. This creates the set and puts
its name in the cascading menu to the right of Edit > Quick Select Set in the
main Maya window.
To select items in the quick set:
From the main Maya menu bar, select Edit > Quick Select Set and the name
of the set.
This selects the items in the set, not the set itself.

EDITING SET MEMBERSHIP
You can add or remove members of a set with the Relationship Editor, the
Paint Set Membership Tool, or the Edit Membership Tool.
The advantage of the Relationship Editor is that it:
•

includes a formatted list of set members and associated objects

•

displays U and V parameters of NURBS curve and surface CVs

•

lets you edit the weight of cluster, cluster flexor, and skin points
For information on using the Relationship Editor to add and remove set
members, see “Adding and removing relationship members” on page 261.
The advantage of the Paint Set Membership Tool is that you can modify
which of a deformable object’s points (for example, CVs or vertices) belong
to multiple deformer sets by painting the points you want added to,
transferred to, or removed from the set, directly on the object. Color
feedback makes sets easy to identify. See Using Maya: Character Setup for
details.
The advantage of the Edit Membership Tool is that you can add and remove
set members in the workspace without using another window or panel. This
is ideal for quickly altering membership of sets Maya creates for deformers
and skin. See Using Maya: Character Setup for details.
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ALTERING THE DISPLAY OF SETS
You can display all sets in your scene (including character sets, deformer
sets, shading groups, and layers) in the Relationship Editor. For information
on the options for narrowing or broadening which sets display, so you
spend less time scrolling and expanding sets, see the following:
•

“Displaying relationships and objects” on page 257

•

“Setting view options” on page 256

•

“Selecting which relationships and objects show” on page 258

UNDERSTANDING PARTITIONS
A partition is a collection of related sets. The sets in a partition can have no
overlapping members.
As you create shading groups, bind skin, and do a few other tasks, Maya
creates partitions. It does this to keep the sets separate where an operation
would be hindered by overlapping members. You can also create custom
partitions to keep your own sets separate.

Partitions you create
When you use the Create Set menu item to create a set, its members can, by
default, exist in any other set you’ve created. In some instances, you might
want to prevent two sets from having overlapping members. You can do this
by creating a partition and putting the sets in it.
Example
Suppose you’re animating a cartoon character’s nose as he smiles and
laughs. You added a cluster to several CVs for adjusting the nose as he
smiles and another cluster to different CVs for adjusting the nose as he
laughs.
Creating the two clusters creates a set for each group of CVs. Occasionally
you want to move CVs from one set to the other, to alter the deformations
that occur as you transform the clusters.
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When you move the CVs from one set to the other set, they remain in the
first set. You might not want the CVs in the first set because they add
undesirable deformations as you transform the cluster.
To avoid this problem, you can create a partition and put both sets in it. The
partition prevents one set from having members of another set. When you
move the CVs from the first set to the second set, they’re automatically
removed from the first set.
You can also add a partition to prevent clusters from having overlapping
members when you add the cluster with Deform > Create Cluster ❒. See
Using Maya: Character Setup for details.

The LaughCVs and SmileCVs
sets in the NoseParts partition
cannot have overlapping
members.

Partitions created by Maya
Maya creates partitions in cases where objects or items must be kept separate
for correct operation. A new scene has two partitions by default:
•

characterPartition

•

renderPartition

USING MAYA: ESSENTIALS
380

PART 2

SETS AND PARTITIONS | 11
Creating, displaying, and removing partitions

The characterPartition contains the character sets for each character you
create. With all the character sets in the same partition, you can be sure that
the attributes in one character set will not be in some other character set.
The renderPartition contains the shading group sets explained in “Shading
group sets” on page 372.
Because you can apply only one shading group per object or per polygonal
facet, the rendering partition ensures you can’t accidentally render a single
object or polygonal facet with two shading groups.
If you rigid bind skin to a skeleton, Maya also creates a partition. The
partition has the name joint1skinPartition or something similar. It contains
all the skin point sets in your scene. The partition prevents you from
assigning skin points to two different joints, which would result in
undesirable skin deformations when you manipulate a skeleton.
If create a deformer with the Exclusive option, Maya creates a partition
named deformPartition by default. The partition contains all deformer point
sets in your scene. It prevents you from assigning points to two different
sets, which might result in undesirable deformations when you manipulate
the deformers.
Because Maya creates partitions for you when it makes sense to do so, you’ll
rarely need to create your own partitions. Still, if you find a situation where
you need create one, you can do so as described in the next topic.

CREATING, DISPLAYING, AND REMOVING PARTITIONS
The following procedures describe how to create, display, and remove
partitions.
To create a partition with a default name:
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1

Make sure no objects or other items are selected.

2

Select any sets you want to put in the partition. See “Selecting sets” on page
376 for details.

3

To create a partition with a default name, select Edit > Sets > Create Partition
on the main Maya menu bar. (This completes the procedure.)
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or
In the Relationship Editor, select Partition Editing from the drop-down list
and select Edit > Create Partition in the Partitions panel.

Note
To name the partition when you create it, replace step #3 with:
Select Edit > Sets > Create Partition ❐ in the main Maya menu bar or in the
Relationship Editor, select Edit > Create Partition ❐.
Enter the name of the partition in the Name text box of the Partition
Options menu and click Apply.
To display partitions:
In the Relationship Editor, select Partition Editing from the drop-down list.
The partitions appear in the left panel.
To see the sets a partition contains, click the plus sign (+) beside the partition
name.
To remove a partition, but not its sets:
1

In the Relationship Editor, select Partition Editing from the drop-down list
and click the name of the partition in the left panel.

2

Select Edit > Delete Highlighted.
This removes the partition, but not the sets within the partition.
To remove a set from a partition:

1

In the Relationship Editor, select Partition Editing from the drop-down list.

2

In the Partitions panel, expand the partition to see the set.

3

Click the set you want to remove and select Edit > Remove Highlighted
from Partition.

ADDING SETS TO PARTITIONS
The following procedures describe how to add and move sets to partitions:
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To add a set to an existing partition when you create the set:
1

Select the objects or items to be put in the set.

2

From Maya’s main menu, choose Edit > Sets > Create Set ❒.
or
In the Relationship Editor, select Set Editing from the drop-down list and
select Edit > Create Set ❒ in the left panel.
The Create Set Options window opens.

3

Enter the name of the set in the Name text box.

4

To add the set to a partition toggle on Try to Add or Force to Add.
If the partition already has a set containing elements of the selected object,
when you select Try to Add, Maya doesn’t add the member and instead
displays a warning message to the Script Editor.
If you select Force to Add, Maya adds the member to the set after removing
the member from the set it’s already part of.

5

After you toggle on either option in the prior step, select the name of the
partition from the Partition menu.

6

Click the Apply button.
Maya puts the set in the selected partition.
To add a set to a partition:

1

In the Relationship Editor, select Partition Editing from the drop-down list.

2

In the Partitions panel, click the partition you want to add to.

3

In the Objects panel, click the set to be added into the partition.
or
Select the set in the Outliner and select Edit > Add Selected Items in the
Relationship Editor.

EDITORS
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USING ARTISAN PAINT
TOOLS
Artisan was previously an add-on module to Maya that provided tools for
detailing surfaces. These tools are now part of Maya. The tools use an
intuitive paint and sculpting-based interface to deliver high quality and
otherwise complex results in minimal time.
This chapter provides an overview of the Artisan tools. It includes the
following topics:

•

“What are the Artisan paint tools” on page 388

•

“Changing paint tool settings” on page 393

•

“Creating an Artisan tool shelf” on page 410

•

“Defining Artisan hotkeys” on page 410

•

“Using Artisan marking menus” on page 414

•

“Snapping an Artisan paint brush to path” on page 415

•

“Masking surfaces” on page 416

•

“Mapping attributes” on page 419

•

“Working with seams” on page 426
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WHAT ARE THE ARTISAN PAINT TOOLS
There are nine Artisan paint tools that all work like a paint brush. You can
use your graphics tablet and stylus for greater control when you paint using
these tools.
Sculpt Surfaces Tool (for NURBS surfaces)
Use the Sculpt Surfaces Tool (Modeling menu set, Edit Surfaces > Sculpt
Surfaces Tool) to push and pull CVs on a NURBS surface. The effect is like
sculpting clay—push and the surface depresses, pull and the surface raises.
For details, see Using Maya: NURBS Modeling.
Sculpt Polygons Tool
Use the Sculpt Polygons Tool (Modeling menu set, Edit Polygons > Sculpt
Polygons Tool) to push and pull vertices on a polygonal surface. The effect is
similar to sculpting clay. For details, see Using Maya: Polygonal Modeling.
Paint Selection Tool
Use the Paint Selection Tool (Edit > Paint Selection Tool) to select vertices on
a NURBS or polygonal surface by painting on the surface with the tool. This
control quickly provides results that previously required painstaking
manipulation of individual vertices. You can also use the Paint Selection
Tool to select faces and edges on polygons. For details, see “Using the Paint
Selection Tool to paint-select components” on page 160.
Paint Weights Tool
Use the Paint Weights Tool (Animation menu set, Deform > Paint Weights
Tool) to paint weights on vertex clusters. For details, see Using Maya:
Character Setup.
Script Paint Tool
Use the Script Paint Tool (Modify > Script Paint Tool) to paint a surface with
a texture or attribute defined in a Maya MEL script. For example, you can
paint soft body goal weights or particle emitters on your surfaces like you
would paint a color or texture in a painting program. Maya includes sample
MEL paint scripts to apply to your surfaces. For details, see “Painting with
MEL Scripts” on page 441.
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Attribute Paint Tool
Use the Attribute Paint Tool (Modify > Attribute Paint Tool) to paint any
registered attributes on any object. For details, see “Painting attribute
values” on page 454.
Paint Set Membership Tool
Use the Paint Set Membership Tool (Animation menu set, Deform > Paint
Set Membership Tool) to paint the set membership of vertices instead of
having to individually select them. For details, see Using Maya: Character
Setup.
Paint Skin Weights Tool
By smooth binding skin to an object, you can create reasonable skin-like
deformations. In effect, all the vertices belong to all the joint clusters. Use the
Paint Skin Weights Tool (Animation menu set, Skin > Edit Smooth
Skin > Paint Skin Weights Tool) to modify the weights of these clusters at the
joints. For details, see Using Maya: Character Setup.
Paint Vertex Color Tool (for polygons only)
Use the Paint Color Per Vertex Tool (Modeling menu set, Edit
Polygons > Colors > Paint Vertex Color Tool) to paint a specified color value
and alpha onto polygon vertices. For details, see Using Maya: Polygonal
Modeling.
Paint Textures
Use the Paint Textures tool (Rendering menu set, Lighting/Shading > Paint
Textures Tool) to paint the following texture attributes: color, transparency,
incandescence, bump, specular color, and reflectivity. This tool operates
similar to other Artisan paint tools; however, some tool settings are unique,
such as Blend Mode. For details, see Using Maya: Rendering.

Typically, you create your model in Maya, then use these tools to detail and
modify it. By changing the settings for Artisan tools, you can also do the
following:
•

ARTISAN PAINT TOOLS

sculpt and paint over seams (see “Working with seams” on page 426)
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•

mask selected vertices and selectively apply Artisan effects to the masked
surface (see “Masking surfaces” on page 416)

•

import and export attribute maps (see “Mapping attributes” on page 419)

How Artisan paint tools work
The Artisan paint tools work like paint brushes with attributes that you can
modify to customize their effect.
When you select an Artisan tool, the Maya pointer changes to a paint brush.
When you move the pointer over a surface, Artisan displays a brush outline.
The brush outline defines the area you “paint” with the tool. The appearance
of the brush outline changes depending on the tool selected and the tool
settings. The following examples illustrate some Artisan tool brush outlines.

Sculpt Surfaces Tool
Pull operation

Sculpt Surfaces Tool
Smooth operation

Paint Selection Tool
Select selection type

Script Paint and Paint Weights Tools
Replace operation

Script Paint and Paint Weights Tools
Add operation
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Clicking the brush on a surface creates a stamp. A stroke is made up of
many overlapping stamps.

Stamp

Stroke

Each brush has a stamp profile that you can modify. The stamp profile
includes:
•

brush radius

•

brush opacity (for the Script Paint Tool, Attribute Paint Tool, Sculpt Surfaces
Tool, Sculpt Polygons Tool, Paint Weights Tool, and Paint Skin Weights
Tool)

•

brush value (for the Script Paint, Attribute Paint Tool, Paint Weights Tool,
Paint Skin Weights Tool only)

•

brush shape

ARTISAN PAINT TOOLS
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Brush radius
By increasing or decreasing the radius of a brush stamp, you increase or
decrease its area of influence. If the brush stamp compensation mode is set
to None, the radius is expressed as a percentage of the surface. Otherwise,
the brush radius is measured in the working units set for Maya. For details
on selecting the stamp compensation mode, see “Selecting the stamp
compensation mode” on page 408. For details on setting units, see “Linear”
on page 472.
If you use a graphics tablet and stylus, you can set an upper and lower range
for the radius. No matter how much or how little pressure you apply to the
stylus, the brush radius will not be larger or smaller than the set limits.

Brush opacity
Brush opacity refers to the fraction of the maximum displacement or brush
value (depending on the selected tool) to apply to each brush stamp within a
stroke.
Fraction of maximum displacement
(Sculpt Surfaces Tool)

High opacity

Low opacity

Fraction of value
(Paint Weights Tool)

High opacity

Low opacity

Only the following tools have an opacity setting: Script Paint Tool, Attribute
Paint Tool, Sculpt Surfaces Tool, Sculpt Polygons Tool, Paint Weights Tool,
and Paint Skin Weights Tool.

Brush value
Brush value refers to something different for each Artisan tool.
Paint Weights Tool

Brush value refers to the cluster weights.

Paint Skin Weights Tool

Brush value refers to joint cluster weights.
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Depends on the script.

Script Paint Tool

For the emitterPaint script, brush value refers to the operation set for the
script (for example, speed).
For the geometryPaint script, brush value refers to the size of the geometric
objects
For the softBodyPaint script, brush value refers to the goal weight.
Attribute Paint Tool

Brush value refers to the value of the attribute you are painting.

Brush shape
You can choose from several brush shapes to provide flexibility as you paint.
The area affected by the stamp corresponds with the selected shape. Note
that the shape of the brush outline does not change to reflect your selection.

CHANGING PAINT TOOL SETTINGS
Artisan uses the Maya Tool Settings editor to set tool properties. The most
common ways to open the Tool Settings editor are:
•

Click the ❐ beside the tool on its menu (for example, Edit > Paint Selection
Tool ❐).

•

Double-click the selected tool on the Minibar.

ARTISAN PAINT TOOLS
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Each tab contains settings that you change to affect the way the tool works.
There are tool-specific settings and settings that are common to all tools.
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Tool-specific settings
For information on changing tool-specific settings, refer to the following
table.

Tool

Tab

See

Sculpt Surfaces Tool

Sculpt tab

Using Maya: NURBS
Modeling

Sculpt Polygons Tool

Sculpt tab

Using Maya: Polygonal
Modeling

Paint Selection Tool

Select tab

“Using the Paint
Selection Tool to paintselect components” on
page 160

Script Paint Tool

Script Paint and
Setup tabs

“Painting with MEL
Scripts” on page 441

Attribute Paint Tool

Attr. Paint tab

“Painting attribute
values” on page 454

Paint Weights Tool

Weight tab

Using Maya: Character
Setup

Paint Skin Weights

Weight tab

Using Maya: Character
Setup

Paint Set Membership

SetMembership
tab

Using Maya: Character
Setup

Paint Vertex Color

Vertices Paint
tab

Using Maya: Polygonal
Modeling

Paint Textures Tool

Paint tab

Using Maya: Rendering

Tool
Tool
Tool
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Common tool settings
For information on changing common tool settings, refer to the following
table.

Tab

Description of Settings

See

Stroke

Define how the brush moves
across the selected surface

“Changing brush
stroke settings” on
page 397

Seam

Define how you want surfaces
to join

“Working with seams”
on page 426

Mask

Define which vertices, if any,
you want masked when you
use an Artisan paint tool on a
surface

“Masking surfaces” on
page 416

Map

Import or export attribute
(texture) maps

“Mapping attributes”
on page 419

Display

Define how the brush and
screen displays

“Changing display
settings” on page 404

Misc

Define less frequently used
tool settings

“Changing
miscellaneous tool
settings” on page 406
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Tips
Leave the Tool Settings editor open as you work in Artisan. When you
switch tools, the settings change to reflect the selected tool.
If you do not want to leave the Tool Settings editor open, define hotkeys
or use the Artisan marking menus to change commonly used settings for
each of the tools. For details, see “Defining Artisan hotkeys” on page 410
and “Using Artisan marking menus” on page 414.
Tailor the settings for your tools and save them to a shelf for easy access.
For details, see “Creating an Artisan tool shelf” on page 410.

Resetting tools
If you do not want to keep the changes you made to the settings in the Tool
Settings editor, click the Reset Tool button. This returns the settings on all
the tabs for the selected tool to their default values.
Note that the default settings for tools on a shelf are the settings that were
saved with the shelf.

Changing brush stroke settings
Brush stroke settings define how the selected Artisan brush moves across the
surface. They are defined on the Stroke tab of the Tool Settings editor.
You can change the following brush stroke settings for all Artisan tools:
•

reflect paint

•

stylus pressure (if you are using a graphics tablet and pen)

•

stroke profile alignment

Tip
You can make more accurate brush strokes on a surface, or have an effect
on the same surface’s area again and again by snapping the cursor to the
curve or a curve on the surface. For details, see “Freezing and resetting
transformations” on page 169.
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Reflected painting
You can set Artisan tools so that your brush strokes are mirrored or reflected
in the axis of your choice as you paint. This is useful when you want to
create a symmetrical effect.

Note
If you are painting on polygonal surfaces in projective paint mode, you
cannot reflect paint. To reflect paint, you must be in UV texture paint mode
and the UVs on the polygon must be evenly distributed, symmetrical, and
not overlapping. For information on setting the paint mode, see “Projective
Paint” and “UV Texture Paint” on page 409.

To reflect your brush stroke:
1

Select the surface you are painting.

2

Select the Artisan tool you want to use and open the Tool Settings editor.

3

Click on the Stroke tab.

4

In the Reflect Paint section, modify the settings as follows:
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Reflection

To reflect paint, toggle Reflection on.
Selecting the axis for reflection

U Dir, V Dir

You can restrict the reflection along the U or V direction of a single surface.
The following examples show the Sculpt Surfaces brush stamp reflected
along the U and V directions (or isoparms).

V

Reflection along
U direction (or isoparm)

U

V
U

Reflection along
V direction (or isoparm)

ARTISAN PAINT TOOLS
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In the adjacent box, type the relative position of the axis along the surface.
By default, reflections along the U or V direction (or isoparm) occur at 0.5,
the midpoint of the surface.
To reset the axis to the midpoint, click the Reset button.
Multiple Surf

When you reflect on multiple surfaces, the reflected brush stamp moves to
the same U/V position on the other surfaces.
To reflect your stroke on multiple surfaces, follow the instructions on page
398, making sure you select all the surfaces in step 1. For NURBS surfaces,
the number of U patches and V patches, or sections and spans must be
identical on each surface. For polygonal surfaces, the number of subdivisions
must be the identical on each surface.
Reflection on another surface

V
U

V

U

Note
When you reflect paint on a surface, it may appear as though the reflection
is not symmetrical...

... but in fact, the brush is reflected on
the other side of the object.
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Invert Reference Vector

This option is available for the Sculpt Surfaces and Sculpt Polygons Tools
only. Toggle Invert Reference Vector on to invert the direction of the
reference vector of the reflected brush. For details on setting reference
vectors, refer to the sculpting information in Using Maya: NURBS Modeling
and Using Maya: Polygonal Modeling. The following example show the effect
of reflect painting using the Sculpt Surfaces Tool along the V direction, and
then with the reference vector inverted.

Reflection along V isoparm

Reflection along V isoparm with
reference vector inverted

Tip
You can create a hotkey to modify the reflection isoparm without opening
the Tool Settings editor. For details, see “Defining Artisan hotkeys” on
page 410.

Setting stylus pressure
With a real paint brush, pressing harder makes the brush wider and applies
the paint more thickly. You can achieve a similar effect with a stylus in
Artisan by specifying the effect of pressure on the Artisan tool.
To set stylus pressure:
1

Select the Artisan tool you want to define the stylus pressure for.

2

Open the Tool Settings editor and click on the Stroke tab.

3

In the Stylus Pressure section, select the pressure option you want to use.
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None

No effect on the stylus pressure.

Opacity

Increases the opacity of the brush stamp as you add pressure to the stylus.

Radius

Increases the radius of the brush stamp as you add pressure to the stylus.

Both

Increases both the opacity and radius of the brush stamp as you add
pressure to the stylus.

Note
If you set the stylus pressure to Opacity or Both, you will not be able to
paint with your mouse, although you will be able to click with it.

Setting the brush stamp profile alignment
The profile alignment of the brush determines the alignment of the brush
shapes that are not uniformly round:

To set the brush stamp profile alignment:

U Tangent

1

Select the Artisan tool you want to define the profile for.

2

Open the Tool Settings editor and click the Stroke tab.

3

In the Profile Alignment section, select the alignment you want for the brush
stamp. Note that you select the brush stamp on the first tab (Sculpt, Select,
Script Paint, Weight, Attr. Paint, Vertices Paint, SetMembership, Skin Paint).

Aligns the stamp shape along the U tangent (V direction).
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V
U

V Tangent

Aligns the stamp shape along the V tangent (U direction).

V
U

Up Vector

Aligns the stamp shape relative to the up vector. The stamp shape retains its
orientation when you change the view.

Path Direction

Aligns the stamp shape relative to the direction you move the brush.

ARTISAN PAINT TOOLS
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Changing display settings
You can specify the display settings for the objects you are painting and the
Artisan tool brush stamps. For the Paint Weights, Attribute Paint, Paint Set
Membership, Paint Skin Weights Tool, and Script Paint Tools, you can also
select to display color feedback.
To customize display settings:
1

Select an Artisan tool and open the Tool Settings editor.

2

Click the Display tab and modify the settings as follows:
Toggling surface settings

Draw Outline

Displays the brush stroke outline when you move the pointer on the selected
surface. If you do not toggle this option on, you only see the brush pointer
and you will not be able to draw brush feedback or outline trails.

Draw Brush Feedback

Displays additional information on the brush outline indicating the
operation the brush is set to perform.

No brush feedback

Draw Outline Trail

Displays a trail of brush outlines as you paint.
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Show Active Lines

Displays the isoparms on the selected surfaces.

Show Preview

Displays the effect of the selected tool operation as you move the brush over
the surface, without actually applying it.
Setting screen display options

Redraw All Views

Toggle this option on to redraw all open views (panel windows) for the
scene while you paint your stroke. If you do not toggle this option on, the
active view will redraw as you paint, but the other open views will not
update until the stroke is complete.

Refresh (sec)

Type the number of seconds between screen refreshes. The maximum
number is 2 seconds. The shorter the interval you select, the slower the
performance.
Setting value options
These options affect the display when you work with the Paint Weights,
Attribute Paint, Paint Set Membership, Paint Skin Weights, and Script Paint
Tools.
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Toggle this option on to display surface attributes, for example, cluster
weights, as grayscale values. This helps you see the area as you paint and
helps identify what the values are (smaller values are darker, larger values
are lighter). To display color feedback, you must turn on smooth shading in
Maya.

Color Feedback

Display Active Vertices

For the Paint Set Membership Tool only, toggle this option on to display the
active vertices of a selected set. If this option is toggled off, when you select a
set on the SetMembership tab, the vertices for that set will be active, but you
will not be able to see that they are.
Disable Lighting

For the Paint Weights, Attribute Paint, Paint Skin Weights, or Script Paint
Tools only, toggle this on to remove lighting from the scene. Disabling
lighting provides you with a truer representation of the grayscales, making it
easier to identify the values.

Use Set Color

For the Paint Weights and Paint Skin Weights Tools only, toggle this option
on to use the color associated with the cluster set. This is particularly useful
when you are working with skeletons.

Min Color @

For the Paint Weights, Attribute Paint, Paint Skin Weights, or Script Paint
Tools only, use the slider to set the value at which the minimum color
displays. This is useful if your paint values are very close to each other,
making the color feedback display too subtle to detect.

Max Color @

For the Paint Weights, Attribute Paint, Paint Skin Weights, or Script Paint
Tools only, use the slider to set the value at which the maximum color
displays. This is useful if your paint values are very close to each other,
making the color feedback display too subtle to detect.

Changing miscellaneous tool settings
There are some Artisan tool settings you will find useful, although you may
rarely change them. You can find these settings on the Misc tab in the Tool
Settings editor. These settings include:
•

Multiple surface detection
Artisan detects layered and intersecting surfaces and projects the effects of
the brush stroke to each surface relative to the camera view.

•

Stamp compensation
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Artisan uses a paint on surface technique to ensure a consistent brush shape
while tracking the curvature of the surface. You can specify which method
you want Artisan to use to draw the brush stamp on the surface.
•

Paint mode
When you paint, Artisan uses a map of the surface UV points to produce the
desired results. On NURBS surfaces, maps are created by unwrapping the
surface into a rectangle, and positioning the UV points appropriately. On
polygons, the maps are created by projecting the UV points onto a
rectangular area. Because the mapping is created differently for NURBS
surfaces and polygonal surfaces, two paint modes exist to ensure you get the
desired results when you paint: projective paint (for polygons only) and UV
texture paint (for NURBS or polygons). You only use the UV texture paint
mode on polygons if you want to reflect paint (the UVs on the polygon must
be evenly distributed, symmetrical, and not overlapping).

•

Stroke smoothing
These options affect how Artisan smooths your strokes as you sculpt.

•

MEL stroke callbacks
You can specify MEL commands to run before and after a stroke.
To change miscellaneous tool settings:

1

Select an Artisan tool and open the Tool Settings editor.

2

Click the Misc tab and modify the settings as follows:
Setting multiple surface detection
Set the maximum number of layered or intersecting surfaces affected by the
same brush stamp when you perform sculpting operations.

Infinite

ARTISAN PAINT TOOLS
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Finite

The brush stamp applies the effect only on the number of layered or
intersecting surfaces you specify.

Maya detects two surfaces and applies
brush settings to both
Use Common Edge Info

Toggle Use Common Edge Info on to treat surfaces with common edges as
one surface.
Selecting the stamp compensation mode

None

No stamp compensation. Without stamp compensation, the brush tends to
stretch into odd shapes on complicated surfaces.

Linear

This is an efficient (computationally) form of compensation adequate for
smoothly curved surfaces.

Grid

This is the most sophisticated form of compensation and also requires the
most computations. Increasing the grid size increases the density of the grid,
and thus the number of compensation calculations. Grid compensation
mode provides the most consistent brush shape, but also slows Artisan’s
performance. You may find it useful when painting areas with uneven
parameterization (for example, at the poles of a sphere).
Setting the paint mode
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Projective Paint

Select Project Paint if you are painting polygonal surfaces. You cannot reflect
paint in this paint mode. To reflect paint on polygons, see UV Texture Paint,
next.

UV Texture Paint

Select this paint mode if you are painting NURBS surfaces or if you are
painting polygonal surfaces and want to reflect paint. To use UV Texture
Paint mode on a polygon, the surface must have UVs that are evenly
distributed, symmetrical, and do not overlap. You can check the surface
using the Texture View (Edit Polygons > Textures > Texture View).
Setting stroke smoothing options
These options affect the sculpting operations you perform.

Texture Space

Reads the points from the tablet or mouse, transforms them to parameter
space, then smooths the resulting path. This is the fastest stroke smoothing
option.

Screen Space

Smooths the path before determining where the points are in parameter
space. Although this method provides more accurate smoothing and doubles
the rate of the tablet, the amount of surface operations are also doubled,
therefore slowing Artisan’s performance.

Divisions

Indicate the number of divisions used to smooth a stroke. By increasing the
number of divisions, you can draw straighter, smoother lines, but you also
slow the performance.
Setting MEL stroke callback

Before Stroke Cmd Type the MEL command and parameters you want to run when you begin a

stroke, before the stroke actually starts. For example, for the Sculpt Surfaces
Tool, you can specify a command that changes the display smoothness for
the selected object to fine:
displaySmoothness -full -du 2 -dv 2 -pw 16 -ps 4
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After Stroke Cmd

Type the MEL command and parameters you want to run immediately after
completing a stroke. For example, for the Paint Selection Tool, you can
specify a command that subdivides faces after you select them, as follows:

1

Select a polygon.

2

Select Edit > Paint Selection Tool ❐.

3

On the Select tab, toggle off Add to Current Selection.

4

Change the pick mask to Poly Faces.

5

Click the Misc tab.

6

In the After Stroke Cmd box, enter:
polySubdivideFacet -dv 1 -m 0 -ch 1

7

Paint the faces you want to subdivide. Each painted face subdivides
automatically into four faces when you release the mouse button.

CREATING AN ARTISAN TOOL SHELF
To make your Artisan tools more convenient to access, you can create an
Artisan shelf and put the Artisan tools on it. Another advantage is that tools
on the shelf are saved with your specific tool settings. For details on shelves,
see “Creating and editing shelves” on page 493.

DEFINING ARTISAN HOTKEYS
You can use hotkeys to change some Artisan tool settings without opening
the Tool Settings editor.
You can set three types of Artisan hotkeys:
•

hotkeys that display marking menus

•

hotkeys that toggle or select options or actions

•

interactive hotkeys that change option settings when you click-drag or use
the arrow keys (for example the brush stamp radius or displacement)
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Hotkeys that display marking menus
By default, the hotkey combination u + left mouse button displays the
operation marking menu for the selected Artisan tool. For details, see “Using
Artisan marking menus” on page 414.
If you are running out of available keys, or you have created too many
hotkeys to remember, you can consolidate your Artisan hotkeys into a single
marking menu. Create a hotkey for Set Modify Target, with Marking Menu
and another for Activate/Deactivate Modify Target, with Marking Menu.
When you press the hotkey for Set Modify Target, with Marking Menu, a
marking menu appears for the selected tool. For details, see “Using Artisan
marking menus” on page 414. Select the option you want to modify. Then
hold down the hotkey for Activate Modify Target, and click-drag to modify
the settings.
You can also define hotkeys for marking menus you define yourself. For
details on defining marking menus, see “Creating marking menus” on page
511.
Hotkeys that toggle or select options or actions
These hotkeys are straightforward—press the key to toggle an option on or
off or to select an option or action. You can set hotkeys for the following
options or actions:

ARTISAN PAINT TOOLS

Option or Action

Default Hotkey

Flood with the current value

Press Alt f

Toggle Reflection ON/OFF

Press Alt r

Toggle Active Lines ON/OFF

Press Alt a

Toggle Show Preview ON/OFF

none

Toggle Masking CVs ON/OFF

none

Toggle Common Edges Display Mode

none

Toggle Common Corners Display

none
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Option or Action

Default Hotkey

Stitch Surfaces

none

Update Erase Surface

none

Update Reference Surface

none

Toggle Color Feedback ON/OFF

Press Alt c

~Increase Brush Radius

none

Decrease Brush Radius

none

Increase Maximum Displacement

none

Decrease Maximum Displacement

none

Interactive hotkeys
You can define interactive hotkeys for Artisan operations using the activate/
deactivate pairs listed in the Hotkeys editor.
These interactive hotkeys work by pressing the hotkey and doing one of the
following:
•

click-dragging left or right, or up and down
The setting appears as part of the brush outline and changes as you drag. For
example, the following brush outline appears when you use an interactive
hotkey to modify the brush stamp radius.
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The following hotkeys work this way:

Activate/Deactivate

Default Hotkey

Modify Lower Brush Radius

none

Modify Upper Brush Radius

Press/Release b

Modify Max Displacement

Press/Release m

Modify Opacity

none

Modify Value

Press/Release n

Modify Reflection Isoparm

none

Modify Target

none

or
•

selecting an item from a marking menu
A marking menu appears when press the hotkey and left mouse button.
Select the menu item and release the left mouse button.
The following hotkeys work this way:
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Activate/Deactivate

Default Hotkey

Maya Artisan Operation, with Marking
Menu

Press u

Set Modify Target, with Marking Menu
(works in conjunction with Modify Target)

none

Modify Sculpt Reference Vector

Press 0
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or
•

clicking a cluster, set, or surface area using the arrow pointer
You can set interactive hotkeys for the following options or actions:

Activate/Deactivate

Default Hotkey

Pick Color Mode

Press/Release /

(Use with the Paint Set Membership, Paint
Weights, Attribute Paint, and Paint Color
Per Vertex Tools.)
Select Cluster Mode

Press/Release ’

(Use with the Paint Weights Tool.)

For information on defining hotkeys, see “Assigning hotkeys” on page 526.

USING ARTISAN MARKING MENUS
Artisan marking menus give you quick access to tools and actions normally
accessed from the Tool Settings editor. You can use three types of marking
menus in Artisan:
•

tool operation marking menus

•

target operation marking menus

•

user-defined marking menus
Tool operation marking menus
By default, the hotkey combination u + left mouse button displays the
operation and brush stroke marking menu for the selected Artisan tool.
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Target operation marking menus
When you hold down the hotkey for Set Modify Target, with Marking
Menu, and press the left mouse button, a marking menu appears for the
selected tool. For details on defining hotkeys, see “Defining Artisan hotkeys”
on page 410. Select the option you want to modify. You can now hold down
the hotkey for Activate Modify Target, and click-drag to modify the settings.
User-defined marking menus
You can define your own marking menus. For example, you could define a
marking menu with each of the Artisan tools on it. For details on defining
marking menus, see “Creating marking menus” on page 511.
To use a marking menu:
1

Select the tool.

2

Press and hold the hotkey for the marking menu.

3

Click-drag the left mouse button to select the marking menu option.

SNAPPING AN ARTISAN PAINT BRUSH TO PATH
You can make more accurate brush strokes on a surface, or have an effect on
the same surface’s area again and again by snapping the cursor to the curve
or a curve on the surface.
To snap the brush to an isoparm:
1

Select the surface you want to paint.

2

Select the Artisan paint tool.

3

Press and hold down the c key on your keyboard while you do the
following:

•

Move the center of the brush outline directly over the path you want the
brush to snap to.

•

Click-drag the brush in the direction you want to paint.
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To snap the brush to a curve:
1

Create the curve on the surface as follows:

•

Select the surface you want to paint with an Artisan paint tool.

•

Click the Make Live button on the Status Line to make the surface live.

•

Select the appropriate curve tool (for example, CV Curve Tool) and create
the curve on the surface.

•

Click the Make Live button on the Status Line again.

2

Select the surface.

3

Select the appropriate Artisan paint tool.

4

Press and hold down the c key on your keyboard while you do the
following:

•

Move the center of the brush outline directly over the path you want the
brush to snap to.

•

Click-drag the brush in the direction you want to paint.

MASKING SURFACES
Masking blocks off an area on a surface so it is not affected by the Artisan
operations you apply to it. In Artisan, you can use selected or unselected
vertices (NURBS or polygonal) on your surface as a mask.
In the following example, if you masked the X, the positions, weights, or
scripted attributes would not be affected when you painted over them with
the Sculpt Surfaces, Sculpt Polygons, Script Paint, Attribute Paint, Paint
Vertex Color, Paint Weights, or Paint Skin Weights Tools. The areas outside
the X would be affected.
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To mask a surface:
1

Select the vertices on the surface. For details, see “Using the Paint Selection
Tool to paint-select components” on page 160.

2

Select one of the Sculpt Surfaces, Sculpt Polygons, Script Paint, Attribute
Paint, Paint Vertex Color, Paint Weights, or Paint Skin Weights Tools, and
open the Tool Settings editor.

3

Click the Mask tab.

4

Select a masking mode:
Off – No masking takes place.
Selected Vertices – Selected vertices act as a mask. The selected vertices will

not change position, weight, or attribute when you apply Artisan brush
strokes to them.
Unselected Vertices – Unselected vertices act as a mask. The unselected

vertices will not change position, weight, or attribute when you apply
Artisan brush strokes to them.
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5

By default, Artisan displays masked vertices while your surface is in object
mode. To hide masked vertices, toggle Display Vertices off.

6

Paint the surface with the selected Artisan tool. Any brush strokes you make
over the mask will have no effect on the masked vertices.
In the following example, the masked surface was sculpted using the Sculpt
Surfaces Tool.
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MAPPING ATTRIBUTES
An attribute map is a two-dimensional image with values that correspond,
or map, to attributes of points on a three-dimensional surface. This mapping
is relative to the U/V parameterization of the surface.
You can import image files created in other programs and use their alpha
channel values or luminance values as attribute maps. The alpha channel is
the channel in an image that contains the opacity information. Not all images
have an alpha channel. Luminance refers to the intensity or brightness of the
image.
Attribute map values are represented by grayscales, with black representing
a value of 0 and white representing a value of 1.

Alpha channel

Luminance

You can also export the values on your Artisan surfaces into image files.
You can import and export attribute maps in file format supported by Maya.
For a list of these file formats, see “Supported file formats” on page 196.
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Importing attribute maps
The Artisan paint tool you select, and its settings, determine the result you
get when you import an attribute map to a surface. Artisan maps the
attribute values onto the surface vertices relative to the U/V surface
direction and applies the Artisan tool settings to the vertices using the
mapped values.
To import an attribute map:
1

Select the surface or surfaces you want to apply the map to.

2

Select the Artisan paint tool and open the Tool Settings editor.

3

Make any changes to the tool settings.
For the Script Paint Tool, note the following:

•

The Replace operation replaces surface values with imported values.

•

The Add operation adds the imported values to the surface values.

•

The Scale operation scales the surface values by factors equivalent to the
imported values.

•

The Smooth operation smooths.

4

Click the Map tab.

5

Select the Import Value:
Alpha – Use the alpha channel values of the map you are importing.
Luminance – Use the luminance values of the map you are importing.
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R, G, B – Use only the Red, Green, or Blue values of the map you are

importing.
RGB – For the Paint Vertex Color Tool only, use each of the RGB channel

values of the map you are importing.
RGBA – For the Paint Vertex Color Tool only, use the RGB and alpha channel

values of the map you are importing.
6

If you selected the Paint Selection Tool, enter a value for the Threshold. This
threshold defines the minimum value to be affected by the tool selection
type. For example, if you set the selection type to be Select and the Threshold
to be 0.5, Artisan selects vertices that are mapped with an imported value
equal to or greater than 0.5.

7

If you are importing a map that was created in Artisan from multiple
surfaces, toggle on Reassign Attribute Maps. For details, see “Importing
Artisan attribute maps to multiple surfaces” on page 422.

8

Click in the Map Name box, then click the Browse button to select the file.
The Import window opens.
(Alternatively, you can type the directory location and file name in the Map
Name box and press Enter to import an image, skipping the last two steps.)

9

On IRIX only, to preview the image before importing it, select it, then click
the See Image button. The grayscales represent the values, where white
represents a value of 1 and black represents a value of 0.

10 Select the image and click the Import button. Artisan applies the values to
the selected surface(s) using the selected tool settings.
In the following example, the Paint Selection Tool is set to select control
vertices and the Threshold is set to 0.5.
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Selected control vertices
Value 0.4
Value 1

U
V

Attribute map

Mapped surface

To reload the image:
Click the Reload button on the Map tab.

Importing attribute maps to stitched surfaces
When you import attribute maps to stitched surfaces or surfaces with
common edges, the attributes map to each surface separately, rather than
across the entire stitched surface.
If you import a map onto stitched surfaces or surfaces with common edges
using the Sculpt Surfaces Tool, the stitching may come undone. To fix this,
click the Stitch Now button on the Seam tab after importing the map.

Importing Artisan attribute maps to multiple surfaces
If the attribute map was created from multiple surfaces in Artisan (see page
425) and you want to import the map for these surfaces back to the same
surfaces, the file names of the attribute map must match the surface file
names. Also, you must toggle Reassign Attribute Maps on when you import.
For example, suppose you create the following two surfaces and export the
attribute map, calling it xando.
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nurbsPlaneShape1

nurbsSphereShape1

Artisan creates two files, xando_nurbsPlane1_nurbsPlaneShape1 and
xando_nurbsSphere1_nurbsSphereShape1. It saves the attribute maps separately
for each surface in these files.
To import these maps back to the same surfaces, follow steps 1 through 6
under “To import an attribute map:” on page 420. For step 7, import either
the base file (xando) or one of the files associated with the surface
(xando_nurbsPlane1_nurbsPlaneShape1 or
xando_nurbsSphere1_nurbsSphereShape1). Artisan automatically maps each file
to the appropriate surface.
In the following example, the attribute was imported with the Sculpt
Surfaces Tool selected and set to Push.

nurbsSphereShape1

nurbsPlaneShape1

If you do not toggle Reassign Attribute Maps on, the imported file maps to
each selected surface.
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Exporting attribute maps
You can export attribute maps created with the Paint Selection, Script Paint,
Attribute Paint, Paint Vertex Color, Paint Weights, and Paint Skin Weights
Tools. The values you paint with these tools become the either the luminance
values or alpha values in the attribute map (except for the Paint Vertex Color
Tool, from which you can export RGB and RGBA values).
To export an attribute map:
1

Create surface values using one of the Artisan tools (Paint Selection, Script
Paint, Attribute Paint, Paint Weights, Paint Vertex Color, Paint Skin
Weights).

2

Select the surface or surfaces with values you want to export, then open the
Tool Settings editor.

3

Click the Map tab.

4

Select the Export Value.
Alpha – Export the alpha channel values.
Luminance – Export the luminance values.
RGB – For the Paint Vertex Color Tool only, export each of the RGB channel

values.
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RGBA – For the Paint Vertex Color Tool only, export the RGB and alpha

channel values.
5

Set the Map Size in the X and Y direction. The default is 256 pixels.

6

Toggle Keep Aspect Ratio on to maintain the height to width ratio of the
attribute map when you export it.

7

Select the format you want to save the image in.

8

Click in the Map Name box, then click the Browse button to select the
directory location. The Export window opens.
(Alternatively, you can type the directory location and file name in the Map
Name box and press Enter, skipping the next steps.)

9

In the Export window, select the directory location, type the file name, then
click the Export button.
If you select more than one surface in step 2, Artisan concatenates the name
you type with each surface name and creates a file for each surface.
For example, suppose you select two surfaces called nurbsSphereShape1 and
nurbsSphereShape2, and type checker for the map name. Artisan saves the
attributes of nurbsSphereShape1 in the file
checker_nurbsSphere1_nurbsSphereShape1 and the attributes of
nurbsSphereShape2 in the file checker_nurbsSphere2_nurbsSphereShape2. If you
include the file name extension (for example, checker.rgb) Artisan appends
the extension to the concatenated names (for example,
checker_nurbsSphereShape1.rgb and checker_nurbsSphereShape2.rgb).
To import these attribute files, the surfaces you import them to must have
the same name as the surfaces with the original attributes.
For more information on importing attribute maps, see “Importing Artisan
attribute maps to multiple surfaces” on page 422.
To resave a surface:
Click the Resave button on the Map tab.
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WORKING WITH SEAMS
This section describes how to use Artisan tools on the seams of NURBS
surfaces that are stitched together. It includes the following topics:
•

“What is a seam?” on page 426

•

“Selecting common edges and corners” on page 426

•

“Stitching surfaces” on page 438

•

“Painting weights and attributes, or script painting over seams” on page 438

What is a seam?
In Maya, you can stitch two surfaces together so that they join along their
common edges to become one surface. The seam is defined by the common
edges and the corners of the common edges.

Seam (common edges)
edges

Common corners

If you want Artisan to treat two surfaces joined by a seam as one surface,
you need to select the common edges before using the Artisan tool on the
seam. This prevents the seam from unstitching.
You can also use Artisan to stitch your own seams.
You can paint with the following Artisan tools: Paint Selection Tool, Script
Paint Tool, Attribute Paint Tool, Sculpt Surfaces Tool, Paint Weights Tool,
Paint Skin Weights Tool. You can stitch seams with the Sculpt Surfaces Tool.

Selecting common edges and corners
Artisan tools will treat two surfaces as one at the seam as long as you
identify the common edges. There are two ways to do this:
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•

let Artisan automatically select common edges

•

select your own common edges using common edge manipulators
Selecting common edges before you use Artisan tools on a seamed surface
prevents the seam stitching from coming undone.
Common edges display as highlighted lines. Common corners display as
highlighted dots. You can change the highlighted color by changing the
Component color in the Colors editor (select Window >Settings/
Preferences > Colors, click the Active tab and expand Components).

Selecting common edges and corners automatically
By default, Artisan selects common edges and corners that are within 0.5 cm
of each other and edges that are at least 0.05 cm long (or whatever unit you
have Maya set to use). You can modify these settings.

Note
Maya detects common edges and corners very precisely. To ensure that the
common seam is detected, try increasing the Seam Tolerance (for example,
to 0.7).
To modify automatic common edge and corner selection:
1

Select the Artisan tool you intend to use on your stitched surface and open
the Tool Settings editor. (Paint Selection Tool, Script Paint Tool, Attribute
Paint Tool, Sculpt Surfaces Tool, Paint Weights Tool, Paint Skin Weights
Tool.)

2

Click the Seam tab and adjust the settings in the Seam Auto-creation section.
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Multi Surfaces
Seam Tolerance

Set how close the edges and corners must be before Artisan detects them as
common. If edges and corners do not appear to join, try increasing this
value.

Min. Length

Set the minimum length the edges must be before they are detected as
common edges.
Single Surface
Set how close the vertices must be along an edge, and how close the edges
on the same surface must be to each other before they are detected as
common. This is most commonly used to detect poles on surfaces like
spheres.

Seam & Pole Tol.

Selecting common edges using manipulators
If you want greater control over common edges, you can use manipulators
to select them. Using manipulators, you can make your common edge a
segment of the surface edge.
When you select common edges using manipulators, the common corners
are not automatically selected. This means the corners will not stitch
together when you stitch seams. For details on selected common corners, see
“Selecting common corners using manipulators” on page 434.
To select common edges using manipulators:
1

Select the surfaces you want to have common edges.

2

Select the Artisan tool you intend to use on your stitched surface and open
the Tool Settings editor.

3

Click the Seam tab.

4

In the Brush Mode section select Select Edges, then follow the prompts on
the Help Line, as follows.

5

Click-drag across a surface to the edge you want to make common. When
you select the edge successfully, it becomes highlighted.

6

Press Enter to confirm the selection. The reference manipulator appears
along the selected edge.
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Notice that the operation handle is ADD, because the selected edge does not
yet have a common edge.
7

If you want the common edge to be a segment of the surface edge, slide the
blue dots to increase or decrease the length of the common edge.

8

Click ADD and click-drag to select another common edge. When you select
the edge successfully, it becomes highlighted.

9

Press Enter. Another reference manipulator appears on the second selected
edge.
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10 Slide the blue dots to increase or decrease the length of the common edge.
Typically, you want common edges to be the same length, or close to the
same length. If you are stitching the common edges, huge discrepancies in
length will produce “puckered” seams, which you probably do not want.

11 To confirm the addition of the common edge, click the dot between the red
arrows.
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Notice that the operation handle is DEL, because the selected edge now has a
common edge. You can delete the common edge by clicking DEL.
12 Press Enter to confirm the common edge.
13 Change the Brush Mode to Paint Surfaces. You can now stitch the edges
together to create a seam.

Notes
You can exit this procedure at any time by pressing Enter.
To deselect common edges, select another tool.
Selecting multiple common edge segments – an example
The following example shows how you can select common edge segments
on two surface edges. It describes how to stitch two segments of the surface
edges together, leaving the middle segment unstitched. The end result looks
as follows:
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As you follow the example, notice that you use the arrows on the reference
manipulator to navigate between segments.
1

Create two NURBS planes and position them side-by-side, leaving a gap
between the surfaces.

2

Select the planes.

3

Select the Sculpt Surfaces Tool and open the Tool Settings editor.

4

Click the Seam tab.

5

In the Brush Mode section select Select Edges, then follow the prompts on
the Help Line, as follows.

6

Click-drag across a surface to the edge you want to make common. When
you select the edge successfully, it becomes highlighted.

7

Press Enter to confirm the selection. The reference manipulator appears
along the selected edge.

8

Decrease the length of the common edge by sliding the blue dots.
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9

Click ADD and click-drag to select another common edge. When you select
the edge successfully, it becomes highlighted.

10 Press Enter to confirm the selection.
11 Decrease the length of the common edge by sliding the blue dots.

Click to add another
segment

12 To select the common edge segment and add another segment, click the
right red arrow.
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13 Click ADD and click-drag to select another common edge segment. When
you select the edge successfully, it becomes highlighted.
14 Press Enter to confirm the selection.
15 Resize the common edge segments by sliding the blue dots to the right.

16 Press Enter to confirm the selection. You now have two common edge
segments selected along the two surface edges.
17 In the Stitching Mode section of the Seam tab, click Stitch Now.

Selecting common corners using manipulators
If you want greater control over common corners, you can use manipulators
to select them.
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To select common corners using manipulators:
1

Select the surfaces you want to have common corners.

2

Select the Artisan tool you intend to use on your stitched surface and open
the Tool Settings editor.

3

Click the Seam tab.

4

In the Brush Mode section select Select Corners, then follow the prompts on
the Help line, as follows.

5

Click-drag across a surface to a corner you want to make common. When
you select the corner successfully, the edges become highlighted and a
highlighted dot displays on the corner.

6

Press Enter to confirm the selection. Notice that the operation handle
displays ADD. This is the master handle that you use to add all common
corners.

7

Click ADD and click-drag to select another common corner. When you select
the corner successfully, it becomes highlighted.

8

Press Enter. Another reference manipulator appears on the second selected
edge.
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Notice that the operation handle on the new common corner displays DEL.
To delete this corner, click DEL.
9

Repeat steps 7 and 8 above until you have added all the common corners
you want.

Tip
After adding the first common corner, you do not need to click ADD to
add other common corners. Simply click-drag across the surface to the
corner, then press Enter.
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10 Press Enter to confirm the common corners.
11 Change the Brush Mode to Paint Surfaces. You can now stitch the corners
together to join them.

Notes
You can exit this procedure at any time by pressing Enter.
To deselect common corners, select another tool.

Displaying common edges
By default, Artisan displays all common edges. They display as highlighted
lines. If your model has more than one pair of common edges, you may want
to display them one pair at a time, or hide them. (You must display all
common edges when you set the brush mode to Select Edges or Select
Corners.)
To display common edges one pair at a time:
1

Select the surfaces with common edges.

2

Select the Artisan tool you intend use on your stitched surface and open the
Tool Settings editor.

3

Click the Seam tab.

4

Click the Common Edge tab and select One.

The From Surface and To Surface boxes display the names of the surfaces the
displayed common edges belong to. The Edge boxes display which edge of
the surface each common edge belongs to (left, right, top, bottom).
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5

To display the next common edge pair, click the Next button. To display the
previous common edge pair, click the Prev button.

Note
To hide all common edges, select Off on the Common Edge tab.
To display all common edges, select All.

Displaying common corners
By default, Artisan displays all common corners. They display as yellow
dots. You can turn off the display of common corners. (You must display all
common corners when you set the brush mode to Select Edges or Select
Corners.)
To turn off the display of common corners:
1

Select the surfaces with common corners.

2

Select the Artisan tool you intend use on your stitched surface and open the
Tool Settings editor.

3

Click the Seam tab.

4

Click the Common Corner tab and select Off.

Stitching surfaces
You can stitch surfaces together using the Sculpt Surfaces Tool. There are
two ways to do this:
•

Sculpt across the common edges and common corners. The edges and
corners stitch together automatically to create a seam.

•

Use the Stitch Now button in the Stitching Mode section of the Seam tab.
For details, see Using Maya: NURBS Modeling.

Painting weights and attributes, or script painting over seams
You can paint weights and skin weights over seams using the Paint Weights
Tool and Paint Skin Weights Tool respectively, script paint over them using
the Script Paint Tool, and paint attributes over them using the Attribute
Paint Tool. To ensure that the values you specify when painting across a
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seam remain the same at the seam, toggle Averaging Seam on in the
Common Edge Value Averaging section of the Seam tab. To ensure that the
values you specify when painting across a pole remain the same, toggle on
Averaging Pole CVs.
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SCRIPT AND ATTRIBUTE
PAINT TOOLS
This chapter describes the advanced Artisan tools: Script Paint Tool and
Attribute Paint Tool. It includes the following topics:

•

“Painting with MEL Scripts” on page 441

•

“Painting attribute values” on page 454
These tools involve setting up custom MEL scripts. For information on
setting up the MEL scripts for these tools, see Using Maya: MEL.

PAINTING WITH MEL SCRIPTS
This section describes how to paint with MEL scripts using the Script Paint
Tool. It includes the following topics:
•

“Overview of MEL script painting” on page 441

•

“Setting Script Paint Tool options” on page 442

•

“Script painting” on page 447

•

“Script painting on masked surfaces” on page 454

•

“Flooding surfaces” on page 454

Overview of MEL script painting
A MEL script is a file that contains MEL commands, MEL procedures, or
both. Typically, you use a MEL script to create custom effects. Using Artisan
paint tools, you can paint these effects on your surfaces the same way you
paint weights. There are four sample scripts for you to try:

USING MAYA: ESSENTIALS
441

SCRIPT AND ATTRIBUTE PAINT TOOLS | 13
Painting with MEL Scripts

•

geometryPaint – Use this script to select predefined objects in your scene and

then paint them on a selected surface. For example, if the object is a cone,
you can paint cones on the surface using the geometryPaint script. The Script
Paint Tool settings determine the size, position, angle, and density of the
cones.
•

spherePaint – Use this script to paint spheres on a selected NURBS surface.

This is a customized version of the geometryPaint script.
•

emitterPaint – Use the emitterPaint script to paint emitters on surfaces.

Emitters generate particles. The attributes of the emitter control the position,
direction, quantity, and initial velocity of the emitted particles when they are
born. After the particle is born, the attributes of the particle object that the
emitter is connected to control the particle’s appearance. For more details
about emitters, see Using Maya: Dynamics.
•

softBodyPaint – Use this script to set the goal weights on a soft body by

painting on the soft body surface. For details about soft bodies, see Using
Maya: Dynamics.
These scripts are stored on the /usr/aw/maya3.0/scripts/others directory
(IRIX), or drive:\aw\Maya3.0\scripts\others directory (NT).
You might find these examples helpful when you are writing your own MEL
scripts. Note that these scripts have not been thoroughly tested and therefore
are not supported. For details on creating your own scripts, see the Using
Maya: MEL online documentation.

Setting Script Paint Tool options
Before you script paint, set options for the Script Paint Tool. The settings
determine the effect you will achieve when you paint with the tool. You can
define the following tool settings:
•

brush stamp profile

•

script paint operation

•

value range

•

clamping options
You can save your tool settings by adding the tool to a shelf. For details, see
“Creating an Artisan tool shelf” on page 410.
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To define Script Paint Tool settings:
Select the Script Paint Tool and open the Tool Settings editor
(Modify > Script Paint Tool ❐).

Tip
You can define hotkey combinations to change most of the settings without
opening the Tool Settings editor. For details on setting hotkey
combinations, see “Defining Artisan hotkeys” on page 410.
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Setting the brush stamp profile
Radius (U)

If you are using a stylus, set the upper or maximum possible radius for the
brush. No matter how hard you press the stylus, the brush radius will not
exceed this radius. If you are not using a stylus, this setting defines the
radius for the brush.
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Radius (L)

If you are using a stylus, set the lowest or smallest possible radius for the
brush when you apply pressure to the stylus. If you are not using a stylus,
this setting is not used.

Opacity

Set the fraction of the Value to apply to each brush stamp within a stroke.
Vertex values build up when stamps overlap. Stamps overlap when you
paint over the same area.
Using the Opacity setting, you can produce more gradual changes to achieve
more subtle effects.
Note that when you set Opacity to 0, your brush stroke has no effect.

Value

Set the value to apply when you perform any of the script painting
operations. The value has a different meaning depending on the script. For
example:
For the geometryPaint script, Value refers to the size of the geometry. The
size of the original geometry has a value of 1.
For the emitterPaint script, Value refers to the percentage of the selected
script operation.
For the softBodyPaint script, value refers to the goal weight on the soft body.
The soft body should be set to have an initial goal weight value of 1.

Shape

Click on the shape of the brush. This determines the shape of the area
affected by the brush action.
For brush shapes that are not uniformly round, you can change the profile
alignment. For details, see “To set the brush stamp profile alignment:” on
page 402.
Selecting the operation
Notice that the brush stamp changes to reflect the operation.

Replace

Add

Scale

Smooth

To remove the letters and gradient marking from the brush stamp, open the
Tool Settings editor, click on the Display tab and toggle Draw Brush
Feedback off.
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Replace

For the geometryPaint script, replaces the vertex values you paint over with
the specified Value and Opacity.
For the emitterPaint script, replaces the characteristics of the painted emitter
by the Value and Opacity settings and replaces the painted emitters with
emitters that have these new characteristics. For example, if the selected
operation is Speed, the emitter speed is factored by the Value and Opacity
settings.
For the softBodyPaint script, replaces goal weights by a factor of the original
goal weight.

Add

For the softBodyPaint script, adds the specified Value and Opacity to the
current vertex values you paint over. If the Paint Offset is negative, the value
actually decreases.
For the emitterPaint script, adds to the defined characteristics of painted
emitters by the Value and Opacity factors.
For the softBodyPaint script, adds to the goal weight.

Scale

For the softBodyPaint script, scales the current vertex values you paint over
by the Value and Opacity factors.
For the emitterPaint script, scales the defined characteristics of painted
emitters by the Value and Opacity factors.
For the softBodyPaint script, scales the goal weight.

Smooth

For the softBodyPaint script, changes the vertex values to be the average
values of the surrounding vertices.
For the emitterPaint script, changes the values of the painted emitters to the
averages of the characteristics.
For the softBodyPaint script, changes the goal weights to the averages of the
adjacent goal weights.
Setting the value range

Paint Offset

Set the factor you want to offset the Value by. This setting is most useful
when you want to change the range of paint values from the default, 0-1. For
example, if you want to paint objects with values between 4 and 5 using the
geometryPaint script, set Paint Offset to 4.
The default Paint Offset is 0, which has no effect on script painting
operations.
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Set the factor you want Value multiplied by.

Paint Mult.

Tip
To help you differentiate paint values when you script paint (for example,
with the softBodyPaint script), set Min Color @ and Max Color @ to
correspond with the Paint Offset and Paint Mult values, respectively. For
details, see “Changing display settings” on page 404.
Setting clamping options
In the Clamping section, select whether you want to clamp the values within
a specified range, regardless of the Value set when you paint. You can set
clamping to Lower, Upper, Both, or None.
For example, if you clamp Lower and set Clamp Lower to 0.5, the values you
paint will never be less than 0.5, even if you set Value to 0.25. Similarly, if
you clamp Upper and set Clamp Upper to 0.75, the values you paint will
never be greater than 0.75, even if you set Value to 1.

Tip
To maximize the range of values that display when you script paint (for
example, with the softBodyPaint script), set Min Color @ and Max Color @
to correspond with the Clamp Lower and Clamp Upper values,
respectively. For details, see “Changing display settings” on page 404.

Script painting
You script paint by selecting a script and applying brush strokes to the
surface with the Script Paint Tool.
To script paint:
1

Make sure that the script you want to paint with is in the script directory:
~username/maya/3.0/scripts (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\scripts (NT)
drive:\Documents and Settings\username\maya\3.0\scripts (Windows 2000)

2
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Select the surface you want to script paint on.
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3

Select the Script Paint Tool (Modify > Script Paint Tool) and define tool
settings, if required. For details on defining tool settings, see “Setting Script
Paint Tool options” on page 442.

4

Click the Setup tab.

5

In the Tool Setup Cmd box, type the name of the MEL script (without the
.mel extension) and any required parameters, and then press Enter.
This box is case sensitive. For example, for the sample scripts type
geometryPaint, emitterPaint, softBodyPaint goalPP.
A script window may open, depending on the script.

6

Change any settings in the script window then click-drag the brush across
the surface.
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geometryPaint settings

Geometry

Type the names of the objects you want to paint, separating each with a
space. The objects must be in your scene. If you type more than one object
name, Maya paints them randomly.

Identifier

Type a name to identify the layer the painted objects belong to. By painting
on different layers, you can modify the objects on one layer without affecting
the objects on a different layer. For example, if you type Layer1 in this box,
then paint cones, then type Layer2 in the box and paint spheres, when you
go back to Layer1 and paint, the spheres in Layer2 will be unaffected.
If you cannot remember a layer name, or identifier, open the Outliner and
select an object belonging to the layer. The identifier name is part of the
object name.
Selecting an operation

Create/Modify

Creates new objects, and modifies the objects you paint over using the
settings in this window and on the Script Paint tab.

Modify

Modifies the objects you paint over using the settings in this window and on
the Script Paint tab.

Remove

Removes the objects you paint over.
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Setting grid options
Grid

Turn Grid on to use the grid you set in the U Grid Size and V Grid Size
boxes to place the geometries. If you do not turn Grid on, Maya uses the
vertex position to place geometries.
For each surface you paint, do not change the grid size. Changing the grid
size while you paint produces undesirable results.
Also, keep in mind that your grid settings are interpreted in part by the UV
mapping technique used on the surface. Make sure the UVs are correctly
projected on the surface.

Jitter Grid

Toggle Jitter Grid on to randomize the position of the painted objects on the
grid.

U Grid Size V Grid Size

Select the desired U and V Grid Size. Artisan paints the geometry on the grid
point of the U and V grid you specify here, regardless of the isoparm density
you set for the surface. The larger the grid size, the denser the geometries.
In the following example, the isoparm density of the surface is 40, but the U
and V Grid Size are both set to 10 in the Geometry Paint Settings window.

Selecting controls
These controls define how painted objects are transformed. Do not select
both scale and rotation controls at the same time.
X, Y and Z Scale

Reduces object values by the factor set in the Value box of the Script Paint
tab.

X, Y and Z Rot

Rotates objects based on the Value set in the Script Paint tab. A Value of 1
rotates objects 360 degrees.
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X, Y and Z Trans

Moves objects along the surface in the X, Y, and/or Z direction based on the
Value set in the Script Paint tab. A Value of 1 moves objects 1 grid position.
Selecting paint options

Proportional

Distributes changes proportionally across all painted attributes rather than
replacing them all with the new value.

Attach

Attaches the objects to their position so they move with the surface when
you modify the surface (for example, when you sculpt or translate it).

Duplicate

Creates copies rather than instances of the original objects.

Group

Groups the painted objects together on one identifier, or layer.

Isolate

Isolates scale, rotate, and translate transformations, so they remain
independent of each other. With Isolate toggled on, you can return objects to
a base position by selecting the control and flooding with a Value of 0 for
rotation and translation, or 1 for scale.

Align

Aligns objects along the surface normal.

Align toggled off

Align toggled on

Assigning a jitter value
Enter a jitter value to apply to the selected controls when Jitter Grid is
toggled on, where 0 results in no jitter, and 1 results in maximum jitter.
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emitterPaint settings

U Grid Size V Grid Size

Select the desired U and V Grid Size. Artisan paints the emitters on the grid
points of the U and V grid you specify, regardless of the isoparm density
you set for the surface. The larger the grid size, the denser the emitters.
Selecting grid options
Jitter

Randomizes the position of the painted emitters.

Dither

Concentrates emitters at the center of the brush stamp, with few emitters at
the edge. If you do not toggle this option on, the emitters concentrate
uniformly on the stamp.
Selecting an operation

Create

Creates emitters.

USING MAYA: ESSENTIALS
452

PART 3

SCRIPT AND ATTRIBUTE PAINT TOOLS | 13
Painting with MEL Scripts

Remove

Removes emitters.

Modify Emitter Attr. Changes the value of the selected attribute (Rate, Spread, Speed, Min Dist, or

Max Dist) to the value set under Creation Options.
Modify Particle Attr. Changes the value of the selected attribute (Lifespan, Opacity, Point Size,

Line Width, Tail Fade, Tail Size, Radius, Multi Count, Multi Radius) to the
value set under Stamp Profile on the Script Paint tab.
Modify Render Type Changes the particle render type to the selected type (Multi-Point, Multi-

Streak, Numeric, Points, Spheres, Sprites, Streak, or Blobby (s/w)).
Selecting a type
Omni-directional

Sets the type of emitter to be an omnidirectional point emitter. This emits
particles in all directions.

Directional

Sets the type of emitter to be a directional point emitter.
Setting creation options

Rate

Set the rate at which particles are emitted. The rate is particles per unit of
time.

Speed

Set the speed multiple of the emission. The velocity of the emitted particles
is multiplied by this amount.
You can enter a value of 0 or greater.

Spread

Set the spread angle for the emitted particles, along the specified emission
direction. Particles are randomly distributed within the spread angle and
around the base of a cone between 0 and 360 degrees. This option is valid for
directional emitters only.
You can enter a value between 0 and 1. A value of 1 means 180 degrees.

Min Dist

Set the minimum distance from the emitter at which emission starts. You can
enter a value of 0 or greater.
Particles get emitted at a random distance uniformly distributed between the
Min Distance and Max Distance.

Max Distance

Set the maximum distance from the emitter at which emission ends. You can
enter a value of 0 or greater.

Particles

Toggle on Per Emitter to create a separate particle shape for each emitter.
Toggle this option off to share one particle shape between all emitters. Per
Emitter must be toggled on to paint Particle Attr. or Render Type.
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Script painting on masked surfaces
You can create a mask on your surface that is unaffected by any script
painting you do. When you apply brush strokes over the mask, the vertices
on the masked area remain unchanged, regardless of the script paint
operation.
For details on masking surfaces, see “Masking surfaces” on page 416.

Flooding surfaces
Flooding a surface is like taking a huge brush and applying its settings to the
entire surface. The result depends entirely on the brush settings defined
when you perform the flood.

PAINTING ATTRIBUTE VALUES
The Attribute Paint Tool allows advanced users to create new paint tools.
You can use the Attribute Paint Tool to paint any paintable attribute value on
a surface. A paintable attribute is one that has been registered in Maya.
Cluster weights and soft body particle attributes (goal weights, opacity, RGB
and velocity) are already registered as paintable. For information on making
an attribute paintable, see Using Maya: MEL.
The Paint Vertex Color Tool and the Paint Skin Weights Tools are actually
customized Attribute Paint Tools.

Painting attributes
You paint attributes by selecting surfaces with paintable attributes that are
registered in Maya, selecting which paintable object(s) you want to paint,
and then applying brush strokes to the surface with the Attribute Paint Tool.
To paint attributes:
1

Make sure that the attributes you want to paint are registered.

2

Select the surface you want to paint attribute values on.
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3

Select the Attribute Paint Tool (Modify > Attribute Paint Tool) and define
tool settings, if required. (For details on defining tool settings, see “Setting
Script Paint Tool options” on page 442. The settings on the Attr. Paint tab are
the same as the settings on the Script Paint tab.)

4

Do one of the following:

•

Right-click on the surface and select Paint > objectType > paintableAttribute.
The Attribute Paint Tool automatically detects paintable attributes on the
surface and displays them.
In the following example, the Attribute Paint Tool detects that the surface is
a soft body with a cluster (both attribute types are paintable).

or
•
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In the Tool Settings window, click the Attr tab. The Attribute Paint Tool
automatically detects paintable attributes on the surface and displays them
in the Paintable Object Type box.
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•

Click the plus sign (+) or Expand button to expand the object type and see
what attributes are paintable.

•

Click the paintable attribute. All selected objects that are paintable appear
under the Selection section in the Paintable Object List.
The name of the paintable attribute appears in the Selected Paintable Attr.
Type box. This is the attribute you will be painting.
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5

In the Paintable Object List, select the objects you want to paint and click the
arrow button (>) to add them to the Selected list. Click the double arrow
button (>>) to add them all.

6

If you are painting a three channel attribute (RGB or XYZ), under Vector
Index, select the channel you want to paint.

7

Click-drag the brush across the surface.
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SETTING PREFERENCES
You can use preferences to customize Maya to the way you work. You can
change general color definitions, the way manipulators display, and the
appearance of the Shelf, menu bars, and panels.
This chapter describes how to set preferences in Maya It includes:

•

“Settings/Preferences menu” on page 462

•

“Where Maya stores preferences” on page 462

•

“Saving preferences using userSetup.mel” on page 464

•

“Preferences window” on page 465

•

“Changing color settings” on page 482

•

“Specifying tool settings” on page 485

•

“Specifying performance settings” on page 487

•

“Loading and unloading plug-ins” on page 489
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SETTINGS/PREFERENCES MENU
The Window > Settings/Preferences menu gives you access to the various
Maya preferences windows, including:
Preferences

See “Preferences window” on page 465 in this chapter.

Tool Settings

Opens the settings for the current tool. See “Specifying tool settings” on page
485 in this chapter. Also see information on the specific tool.

Performance Settings

See “Specifying performance settings” on page 487 in this chapter.
Hotkeys

Displays the Hotkey Editor to let you create and edit your own hotkey
combinations. See “Assigning hotkeys” on page 526.

Colors

Displays the Colors window to let you specify the color of various
components of Maya, including the Hypergraph and the Multilister. See
“Changing color settings” on page 482 in this chapter.

Marking Menus

Displays the Marking Menu Editor to let you edit the marking menus. See
“Creating and editing marking menus” on page 509.

Shelves

Displays the Shelves window to let you create and edit shelves. See
“Creating and editing shelves” on page 493.

Panels

Displays the Panels window to let you create and edit your own panels. See
“Working with Panels and Layouts” on page 533.

Plug-in Manager

Opens the Plug-in Manager to let you load and unload plug-in software and
Maya modules. See “Loading and unloading plug-ins” on page 489.

WHERE MAYA STORES PREFERENCES
Many of the settings that define the Maya user interface are stored in .mel
files in the the following directory:
~username/maya/3.0/prefs (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\prefs (NT)
drive:\Documents and Settings\username\maya\3.0\prefs (Windows 2000)
Shelves are stored in the shelves subdirectory and icons are stored in the
icons subdirectory.
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When you customize Maya, your new settings are stored in user preference
files, so that each time you open Maya, your settings are used instead of the
Maya default settings. If you delete a preference file, Maya uses the default
settings.
Color and hotkey files
The following .mel files store settings you have customized using the Colors
window and Hotkey Editor.
•

userColors.mel – Contains preferences defined on the Active and Inactive
tabs of the Colors window.

•

userRGBColors.mel – Contains preferences defined on the General tab of the
Colors window.

•

paletteColors.mel – Defines the colors (RGB) making up the index palette in
the Active and Inactive tabs of the Colors window.

•

userHotkeys.mel – Contains any hotkeys you have assigned in the Hotkeys
window.

•

userNamedCommands.mel – Contains all the commands that have hotkeys
assigned to them.
Default hotbox marking menus
The following files define the default Hotbox marking menus.

•

menu_ChangePanelLayout.mel – North

•

menu_ChangePanelType.mel – South

•

menu_ChangeSelectionMask.mel – West

•

menu_CommonModelingPanes.mel – Center

•

menu_ControlPaneVisibility.mel – East
User preferences
The following files define user preferences.

PREFERENCES

•

userPrefs.mel – Contains preferences defined in the General Preferences
window (Window > Settings/Preferences > Preferences).

•

windowPrefs.mel – Defines the default size and position of Maya windows.
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SAVING PREFERENCES USING USERSETUP.MEL
While you save most Maya user preferences through the user interface, you
can also store preferences not stored through the user interface by creating
the file userSetup.mel in the following directory:
~username/maya/3.0/scripts (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\scripts (NT)
drive:\Documents and Settings\username\maya\3.0\scripts (Windows 2000)
Whenever you launch Maya, the MEL commands in this file run. For
example, you could put the following command in the userSetup.mel file:
alias djs jointDisplayScale;

This creates an alias named djs, that lets you set the joint size without using
the Display > Joint Size menu or typing jointDisplayScale. You can enter the
djs alias with a joint size in the Command Line or Script Editor:
djs 1.5;

In this example, the joint size is set to 1.5.

Important
The scene is cleared of all objects after the commands in the userSetup.mel
file are run. Therefore, any scene elements created using the userSetup.mel
file will have been removed when Maya comes up.
For details about writing MEL scripts, see Using Maya: MEL.

USING MAYA: ESSENTIALS
464

PART 4

SETTING PREFERENCES | 14
Preferences window

PREFERENCES WINDOW
You can set a variety of preferences in the Preferences window (Window >
Settings/Preferences > Preferences). Select a category on the left and set the
related preferences on the right.

Saving and reverting changes
Your changes to the preferences are saved automatically when you quit
Maya or when you click the Save button in the Preferences window. If you
need to revert to previous settings, you can use the options under the Edit
menu: Revert to Saved and Restore Factory Settings.
Revert to Saved returns all preferences to the settings when you last saved.
Restore Factory Settings returns all preferences to the default settings.

Tip
For your preference changes to take effect, make sure you click Save.

PREFERENCES

USING MAYA: ESSENTIALS
465

SETTING PREFERENCES | 14
Preferences window

Interface
Menu Set

This determines which menu set displays in the main Maya menu bar on
start-up. The default is Animation.

Show Menubar

Hides or displays the menu bar.

Show Title Bar

Hides or displays the title bar. The title bar includes window control buttons
for expanding and collapsing the application.

Windows

Turn on Remember Size and Position so that Maya restores the size and
position of all windows when closed and re-opened. If toggled off, Maya
windows always display in the center of the screen upon opening.

Command Line

Toggle on Hold Focus if you want the cursor to stay in the Command Line
after you press Enter. Otherwise, the cursor returns to the current window.

Open Attribute Editor

Use this option to specify how the Attribute Editor displays when you open
it (such as pressing Ctrl+A). To open the Attribute Editor in a separate
window, select In Separate Window. To open the Attribute Editor in the
main Maya window, select In Main Maya Window. Note that the Attribute
Editor always displays in the main Maya window when you choose
Display > UI Elements > Attribute Editor.
Expression Editor

Select an Expression Editor for editing text.

UI Elements
Visible UI Elements

Hides or displays UI elements. You can also control this display from the
Display > UI Elements menu.
Toggle on any components you want displayed in the Maya main window.

Note
You cannot display both the Channel Box and the Attribute Editor in the
main Maya window at the same time. If you toggle Attribute Editor off,
when you open the Attribute Editor, it will display according to the option
selected on the Windows tab. See “Open Attribute Editor” on page 466.
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Misc
Window Selection

Select whether Maya uses the existing help browser window (Use an
Existing Help Browser Window) or creates a new one (Create a New Help
Browser Window for Maya Help) when you select a Help menu item.

Window Visibility

Select whether an html browser appears when you select Help > Library,
Global Index, Search, Maya Basics, or MEL. The default is on.

New Scene Config

Select the view configuration to use the next time you open a new scene.

New File

Select whether the current panel configuration (Use Existing) or a specified
panel configuration (Use Specified) is used when creating a new file.

Open File

Select whether the saved panel configuration (Use Saved) or a specified
panel configuration (Ignore Saved) is used when opening a file.

Save File

Select whether to save the panel configuration automatically when you save
the scene file (Always Save), or never (Never Save).

Display
Fast Interaction

Toggle Fast Interaction on to improve performance by displaying fewer
geometric entities (such as polygons). Off is the default setting.

Axes

Displays one or both of the XYZ coordinates (view and origin axes). If you
disable both choices, no XYZ coordinates appear.
View Axis – Displays the XYZ coordinates in the bottom left corner of the
view. This is the default.
Origin Axis – Displays the XYZ coordinates at coordinates 0, 0, 0.

Grid Plane

Displays or hides the grid plane. The grid is a 2D plane that represents 3D
dimensions in the view. It is useful when you want to animate motion
relative to a solid surface. Select Hide to hide the grid.
This setting overrides the Display > Grid setting described in “Using a grid”
on page 120.

Active Object Pivots Specify whether to display pivot points.
Affected Highlighting

Turns highlighting display on or off. An object associated with or affected by
a selected object is highlighted in a different color.
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Note
You can edit this highlight color by selecting Window > Settings/
Preferences > Colors, clicking the Active tab, expanding General, and
modifying Active Affected.
Wireframe on Shaded

Select how you want to display the wireframe on shaded objects.
Full – Displays normal resolution wireframes on shaded objects. This is the

default.
Reduced – Displays fewer wires on shaded objects.
None – Displays no wires on shaded objects. Performance is enhanced if you

select None.
Region of Effect

This option lets you turn on or off the region of effect display. Region of
effect is the part of an object that will potentially change as a result of
moving selected CVs. Note that curves show the region of effect as well as
surfaces.

Region of
Effect on

Region of
Effect off

Shade Templates

If on, templated objects appear shaded in shaded view. If off, the templated
objects appear as wireframes while all other objects appear shaded.
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Kinematics
Joint Size

Changes the display size of skeleton joint sizes. The range is from 0.01 to 5.0.

IK Handle Size

Changes the display size of IK handles. The range is from 0.01 to 5.0.

Manipulators
Global Scale

Specifies the size of the manipulators. The range is from 0.10 to 10.00. The
default is 10.00.

Handle Size

Specifies the size of the handle. The range is from 4 to 100.

Line Size

Specifies the line thickness size of the rotate manipulator’s rings.

PREFERENCES

USING MAYA: ESSENTIALS
469

SETTING PREFERENCES | 14
Preferences window

Line Pick Size

Determines the line thickness used when picking the rotate manipulator
rings. The pick size should be the same as line size, so you can identify
which handle will be picked by the size of the ring.

Previous State Size

Controls the size of the points drawn for a previous feedback. For example,
for the Move Tool, an axis is drawn to indicate the previous position, with
square points at the end of the axes. This controls the size of the squares.
Rotate and scale manipulators also have previous state feedback. This type
of feedback is shown only when you drag; it disappears as soon as you
release the mouse.

NURBS
New Curves, New Surfaces

Select whether you want Edit Points, Hulls, and/or CVs on new curves or
new surfaces:

Note
These options work only on new curves or surfaces, not existing items.
Surface Divisions

Controls the smoothness of an object in a view. It also affects the rendering
of newly created surfaces. Enter a value or use the slider. The range is from 0
to 64. The higher the value, the smoother the surface.
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Curve Divisions

Controls the smoothness of a curve in a view. Enter a value or use the slider.
The range is from 1 to 128. The higher the value, the smoother the curve.

Shaded Divisions

Controls how smooth your smooth-shaded object looks. The greater the
number, the smoother the smooth-shaded object. Enter a value or use the
slider. The range is from 1 to 64.

Polygons
Vertices

Specify how you want vertices to display:
Display – Toggles the display of vertices on or off.
Normals – Displays vertex normals on or off.
Backculling – Makes vertices invisible in areas where the normal is pointing
away from the camera.

Edges

Specify how you want edges to display:
Standard – Displays all edges the same (hard or soft).
Soft/Hard – Displays soft edges as dotted lines and hard edges as solid lines.
Only Hard – Displays hard edges only (makes soft invisible).

Highlight

Specify how you want highlight polygons:
Border Edges – Displays thicker outside edges to make them more visible for
certain operations.
Texture Border – Displays a thick border to highlight the area a texture
affects per polygon or per vertex.

Border Width

Specify the width of the polygon border. The range is from 1 to 10.

Faces

Specify how you want faces to display:
Centers – Displays a small square to indicate the face center.
Normals – Shows the normals at the center of each polygon.
Triangles – Displays all polygons as triangles for display.

Show Item Numbers Specify where you want item numbers displayed: at each vertex (Vertices),

at each edge (Edges), or on each face (Faces).
Normals Size
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Color

Toggle Colored Shading on to use the Apply Color operation (Edit
Polygons > Colors > Apply Color). For details, see “Coloring polygons”, in
Using Maya: Polygonal Modeling.

Color Material

These menu options override any existing material channels and replace
them with the vertex colors you assign. For all options other than None,
lighting affects the object’s shading.
None – None of the material properties of the shader(s) assigned to the object

are used. In this case lighting is also disabled.
Ambient – The ambient material channel of the assigned shader(s) is

overridden by the vertex color.
Ambient+Diffuse – The ambient and diffuse material channels of the assigned

shader(s) are overridden by the vertex color.
Diffuse – The diffuse material channel of the assigned shader(s) is overridden

by the vertex color.
Specular – The specular material channel of the assigned shader(s) is

overridden by the vertex color.
Emission – The emission material channel of the assigned shader(s) is

overridden by the vertex color.
Backface Culling

Specify the display for backface culling:
Off – No backface culling occurs. This is the default.
On – Surfaces become invisible in areas where the normal is pointing away

from the camera.
Keep Wire – Displays wireframe outlines, but any areas where the normal is

pointing away from the camera are hidden.
Keep Hard Edges – Sets backface culling for soft edges only. See Using Maya:

Polygonal Modeling for more information on polygonal modeling.

Settings
Up Axis

Sets the up axis to Y or Z. The default is Y. See “Orienting the XYZ system”
on page 31.

Linear

Sets the unit of measure for operations that use linear values, for example,
moving and scaling. The default unit for measuring linear values is
centimeters.
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Angular

Sets the unit of measure for operations that use an angular value, for
example, rotation. The default unit for measuring angular values is degrees.

Time

Sets Maya’s internal representation of what one “second” is. For example, in
a dynamics simulation, which relies on real world timings, the resulting
simulation will produce keys which represent one second as 24 frames
(Maya’s default value).
It also allows you to compensate for intermediate output devices (for
example, Abekas, etc.) which may have different frame rates to your final
output (for example, Film). When changed, your animation keys will move
in time to match that range. This is only while your time units are on that
alternate setting. Returning the time units to your creation setting will return
your keys to their original location.
The default for measuring time is Film 24fps (24 frames per second).

Note
Be sure you set your preferred time unit for a particular session, before
creating any animation. This will ensure correct timing of your keyframes,
for the final output and final fps setting.
Tolerance
The Tolerance value determines the degree of accuracy that is maintained
between the original and fit (or interpolated) curves. This setting applies
globally to Maya. You can change it on a case-by-case basis. Set the
following tolerance options:
Positional

Set the degree of accuracy between the actual positions of the original and
interpolated curves.

Tangential

Set the degree of accuracy required to determine if two NURBS objects are to
be made tangent across a shared edge or point.

Dynamics
Auto Create Rigid Body

Toggle this option on to automatically create active rigid bodies when you
connect an object to a field (apply a field’s influence to geometry).
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Run Up To Current Time

If you click a frame in the Time Slider, the correct state of all dynamic objects
in the scene is displayed only if Maya performs run-up to calculate each
frame prior to that frame. Toggle this option on if you want to click frames
in the Time Slider. Note that run-up also occurs for hidden objects.
Leave run-up toggled off if you want to prevent Maya from calculating
dynamics when you click in the Time Slider. This is useful in a scene that has
both nondynamic objects and complex dynamic objects, where you want the
state of nondynamic objects to appear promptly after you click the Time
Slider. If you are keying dynamic objects, it’s also useful leave run-up
toggled off to avoid waiting for run-up calculations that are irrelevant to
your keying activities.
Run Up From

Select one of the following options:
Previous Time – If you click a frame higher than the current frame, run-up

starts from the prior current time and ends at the frame you click. Select this
option if you won’t be changing any attributes of a dynamic object in the
scene. This setting lessens the time you’ll spend waiting for run-up. If you
click a frame lower than the current frame, run-up starts from the beginning
of the animation.
Start Time – Run-up starts from the start frame regardless of where you click

in the Time Slider. Select this option if you plan to change any attributes of a
dynamic object in the scene. This ensures that you see the correct object
states when you click in the Time Slider after modifying an object’s
dynamics.
Save Startup Cache for Particles

When this option is turned on (the default), Maya automatically saves the
start-up cache for all your particles every time you save the file. Unlike
particle disk caches, you don't have to create the start-up cache explicitly
every time. See Using Maya: Dynamics for more information.

Files/Projects
Default Projects Directory,
Always Start in This Project

Use these settings to set up a default projects directory when you create new
projects and on startup.
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On File Save

Specify the compression mode you want to use when saving an ASCII file:
Compressed — Saves files in compressed mode. File compression reduces
the sizes of large files so they do not occupy as much space on your hard
drive.
Uncompressed — Saves files in uncompressed mode.
As Is — Keeps files in their original compression mode rather than

compressing or uncompressing them. As Is is the default.
File Import Merge

Specify how you want the Display Layer merged when you import a file.
None – All layers read in are put in a new layer, renumbered, and renamed,

if necessary to preserve uniqueness.
By Number – Rather than creating a new layer, all layers read in that have the

same index number as an existing layer are merged with that layer.
By Name – Rather than creating a new layer, all layers read in that have the

same name as an existing layer are merged with that layer.

Keys
Auto Key

Toggle Auto Key on to automatically set keys on any keyable attributes of an
animated object (including lights, shaders, textures, cameras, and so on).

Weighted Tangents Toggle Weighted Tangents on to give animation curve tangents weight. The

default is toggled off, which means the tangents are non-weighted.
Default In Tangent, Default Out Tangent

Set the default In and Out Tangents to:
Spline – Creates an animation curve that is smooth between the key before

and the key after the selected key.
Linear – Creates an animation curve as a straight line joining two keys.
Clamped – Creates an animation curve which has the characteristics of linear

and spline curves.
Flat – Sets the in and out tangents of the key to be horizontal (with a slope of

0 degrees).
Stepped – Creates an animation curve whose out tangent is a flat curve.
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Modeling
Output Geometry As These settings determine the type of geometry created from modeling

actions such as Revolve, Loft, Extrude, Fillet Blend, and so forth. Setting it
here affects all applicable modeling actions. Otherwise, select Mixed to use
the individual settings of each modeling action.
Interaction Mode

Specify whether you want certain NURBS modeling commands to behave
like actions or tools. An action performs a discreet function on selected
objects. A tool lets you manipulate objects until you complete the operation.
You may want to change actions to tools as you become proficient at Maya’s
NURBS modeling, or it you are accustomed to Power Animator tools.
To globally change the applicable modeling tools, choose Everything is a
Tool or Everything is an Action. To individually set each command, choose
Mixed.

Selection
Modifiers
Modifiers control Maya selection operations. They work with masks to
control what is displayed when you select items. You can toggle on one or
more of the following:
Single Marquee Select

Selects the first object in a hierarchy.
Click Drag Select

Lets you perform one-step click-dragging with the transformation tools. You
can move one object using the Move tool, then click on a second object and
the Move tool displays. This means you do not have to select the object and
the Move tool again—you can keep using the Move tool on any subsequent
selected object.

Affects Active

If you change from object to component selection mode, the selected object is
not affected. This option lets you select objects and components at the same
time. This is toggled on by default.

Allow Highlight Select

Highlights components when you switch from object to component selection
mode. This is toggled on by default.
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Ignore Selection Priority

Treats all objects with the same priority. The selection order does not matter.
This is toggled on by default.
Popup Menu Selection

When objects overlap in the view, lets you display a pop list of the objects so
you can select them. Left-click on the overlap area to display the menu.

Expand Popup List

If you toggled on Expand Popup List, displays all the pop list of objects and
everything underneath it in the hierarchy.

Click Box Size

This option controls the size of the selection area around the mouse pointer,
or click box. If you are having problems with selecting objects or components,
try adjusting this option. For example, a higher click box size might make it
easier to select curves. Increasing the click box size is also useful if you have
a high resolution screen display.
Polygon Selection

Select Faces with
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Center — Select polygonal faces at their center. In other words, you must

click the box at the center of the face to select the entire face.
Whole Face — Select the entire face. You can click anywhere on the face,

even any face edge, to select it.
Priority
You can specify a selection priority for objects and components. By default,
NURBS curves have a higher selection priority than surfaces. This means
that Maya will select the NURBS curve before the surface when you select
geometry that contains both NURBS curves and surfaces.
1 Scroll to select the item
you want to prioritize.
2 Select Custom.
3 Enter the
priority number.

Snapping
With these options, you can control the size region around the mouse
pointer that is used for the snap operation.
Use Snap Tolerance When on, the snap region is restricted to a square area around the cursor,

defined by the Snap Tolerance option. When off, the snap region is
unlimited; you can snap to anything viewable.
Snap Tolerance

Controls the size of the snapping area around the cursor when Use Snap
Tolerance is on. For example, if you have two curves close together and you
try snapping to one of the curves, the object may snap to the wrong curve.
To avoid this, try using a small Snap Tolerance value.

Sound
Waveform Display

The Waveform Display option allows you to control how much of the
sound’s waveform is displayed.
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Top – Displays only the top half of the sound.

Bottom – Displays only the bottom half of the sound.

All – Displays the full waveform.

Repeat on Hold

Repeats a sound at the current time. You must hold the mouse button down
in the Time Slider. For more information on using sound with Maya, see
Using Maya: Animation.

Repeat Size

Controls how much sound (in the current time unit) is repeated when you
toggle on Repeat on Hold.

Timeline
Playback Start/End Specifies the range of time to use as your time playback range.
Animation Start/End Displays the entire range of times available.
Height
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Adjusts the height of the time slider. This helps with sound synching (as a
soundtrack can be displayed in the time slider.) Select 1x for the default size,
2x to double the size of the slider, and 4x to increase the size four times.
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Key Ticks

Keyframe ticks show the location of keys along the time slider. Select None
to turn the key tick display off, Active to display only active keys, or
Channel Box to display only those keys in the Channel Box.

Options

Toggle the following options on or off:
Timecode – Changes the default display of time to video standard timecode.

Enables the Timecode Offset box so you can supply timecodes to match the
timing from videotape.
Snapping – Toggles key snapping on or off. When on, the time indicator

shows integer values only.
Timecode Offset

The Timecode Offset lets you specify how time 0 on the Time Slider appears
when displaying in Timecode mode. For example, if the Timecode Offset is
set to three hours (a value of 03:00:00:00), the Timecode Display would read
03:00:00:00 at time 0,

Update View

Specifies whether Maya plays back an animation in All modeling views or
only in the active view. The default is Active.

Looping

Specifies how you want Maya to play back an animation. Select Once to play
an animation once, then stop. Select Oscillate to play an animation forwards
and backwards continuously. Select Continuous to play an animation
continuously. This is the default setting.

Playback Speed

Specifies the frame rate for playback.
Free – Displays all the frames of your animation. Each frame is updated

completely before proceeding to the next one. Specify the exact rate in the
Playback by box. This rate reflects your system’s ability to draw your
animation on screen and is not necessarily a real-time playback mode. This is
the default setting.
Normal (24 fps) – Plays your animation in real-time. Some frames may be

dropped (not displayed) to execute this in real-time. This depends on your
system’s capabilities, the complexity of your scenes, and the display mode
for the playback.
Half (12 fps) – Plays back at exactly half the speed of real time.
Twice (48 fps) – Plays back at twice real-time speed.
Other – Enables the Other box so you can enter an exact ratio of playback

rate to real-time.
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Playback by

If you select Free for the Playback Speed, specify the exact rate in this box.
This rate reflects your system’s ability to draw you animation on screen and
is not necessarily a real-time playback mode. The default setting is 1.0.

Undo
Undo

Select On if you want to be able to undo operations. This is the default. See
“Selecting objects” on page 51.

Queue

Select Infinite to perform an unlimited number of undo operations. This
option uses a lot of memory. Select Finite to limit the number of times you
can perform undo operations (specified in the Queue Size box). The default
is Finite.

Queue Size

If Finite is the selected Queue setting, specify how many times you can
perform an undo operation here. The higher the number, the more memory
is needed. The default is 10.

Modules
Maya includes a number of different software modules. Each time you start
Maya, the software loads all the available licensed modules.

Disabling packages to free up RAM
Loading several modules can use a lot of RAM and thus increase the start-up
time. To avoid this, you can disable one or more of the modules. You can
still load a disabled module by selecting it from the main menu bar.

Disabling modules based on tasks
You can also disable various modules based on the specific tasks you are
performing. For example, if you are only rendering, you can improve system
response time by disabling Dynamics.

Note
If you enable or disable a module, you must exit Maya and restart the
software for the changes to take effect.
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OpenMaya
Loading

Controls how plug-ins are loaded. In Lazy Binding mode, references to
functions that cannot be resolved at load time will not be considered an
error. In Bind Now mode, unresolved references do issue an error.

Old Plugin Warning Determines whether or not Maya issues a warning when you load a plug-in

that was compiled against an older, and possibly incompatible, Maya
release.

CHANGING COLOR SETTINGS
You may want to make certain components stand out from a scene or object.

Tips
Use lighter colors for active components and darker colors for inactive
components.
If you have made changes to the color settings for a tool and want to
restore the original settings, select Edit > Reset to Factory in the Colors
window.

Changing default colors
You can change the default colors used by Maya in the Colors window
To open the Colors window:
Select Window > Settings/Preferences > Colors. The Colors window opens.
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The Colors window has three tabs. Each tab allows you to change the default
colors for a different set of components.
General tab

Use the General tab to change the default colors for components in these
areas: 3D Views, User Defined, Animation, Animation Editors, Multilister,
Hypergraph / Hypershade, and Outliner.

Active tab

Use the Active tab to change the default colors for components in these
areas: General, Objects, Components, Deformers, Manipulators, and
Animation.

Inactive tab

Use the Inactive tab to set the colors for objects that are not selected. The
Inactive tab lets you change the default colors in the following areas or tools:
General, Modeling, Objects, Components, Deformers, and Animation.
To change a default color:
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1

Open the Color window (Window > Settings/Preferences > Colors) and click
the appropriate tab (General, Active, or Inactive).

2

Expand the component type for the item you want to change.

3

Click on a component’s color to open the Color Chooser.
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Click here to
display the
Color Chooser

or
In the Active or Inactive tab, click on a component to select it. Maya matches
the existing color to one that most closely resembles it on the Index Palette.
Double-click the corresponding color on the Index Palette to open the Color
Chooser.

...then double-click here
Click here...
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4

Select the color in the Color Chooser. See “Using the Color Chooser” on page
276.

Note
You can change the color value in the Colors window by dragging the
slider beside the component color.

SPECIFYING TOOL SETTINGS
Tool settings determine how a tool behaves. For example, if you are using
the EP Curve Tool, you can specify whether the knot spacing is uniform or
chord length.
To change a tool’s settings:
1

Do one of the following to open the Tool Settings window:
If the tool is represented by an icon on the Minibar, double-click on it with
the left mouse button.
or
If the tool is in a menu, select the check box (❐) located beside the tool.
or
Select the tool and then select Window > Settings/Preferences > Tool
Settings.

2

Make the desired changes and click Close.
To return to a tool’s default settings:
In the Tool Settings window, click Reset Tool.

Duplicating a tool
Using shelves, you can have two tools with the same name but different tool
settings. For example, you can have two versions of the Particle Tool.
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Tips
You cannot change the name of the tool using the Tool Settings window. If
you want to change the name of the tool, see “Changing icon labels” on
page 504.
To remove an icon from a shelf, drag it to the garbage can.
To duplicate a tool:
1

Select the shelf that will contain the new version of the tool.

2

Select the tool that you want to duplicate.

3

Using the middle mouse button, drag the tool icon from the Minibar to the
shelf.

4

Select the new version of the tool on the shelf and open the Tool Settings
window (Window > Settings/Preferences > Tool Settings).

5

Change the tool settings.
To test whether Maya saved the settings for each tool, select the original tool
and check the settings in the Tool Settings window. Leave the Tool Settings
window open and select the new tool on the shelf and check the settings.

6

Click Close.

Note
When you drag a tool from the Minibar to the Shelf, a copy of the tool is
made. If you use Ctrl-Shift to place a menu item that selects a tool on the
shelf, Maya does not place a copy of a tool on the Shelf. Instead, only the
action that invokes the original tool is placed on the Shelf. For more
information on adding tools and actions to a shelf, see “Creating and
editing shelves” on page 493.
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SPECIFYING PERFORMANCE SETTINGS
You use the Performance Settings window to set when you want to refresh
the screen when manipulating objects and to control complex operations,
such as stitching and deformation. You can use the performance settings to
suspend these complex operations during mouse interaction or to
completely disable them. This improves performance by reducing the
amount of evaluation necessary during interaction and playback.
To specify performance settings:
Select Window > Settings/Preferences > Performance Settings. The
Performance Settings window opens.
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Selecting screen refresh options
To set when to refresh (or redraw the screen) when manipulating objects, in
the Dependency Graph Evaluation section, select one of the following:
Drag

Refreshes the display during the drag.

Demand

Refreshes the display only when you release the mouse button and click the
Refresh button that appears in the bottom right of the display window.

Release

Refreshes the display only when you release the mouse button.
Controlling complex operations on surfaces
To control complex operations on surfaces during mouse interaction, in the
Surfaces section, select one of the following beside the surface:

On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.
Controlling complex operations on deformers
To control complex operations on deformers during mouse interaction, in
the Deformers section, select one of the following beside the surface:

On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.

Per Node

For Cluster Resolution and Lattice Resolution only, improves redraw
performance for individual cluster or lattice deformations by setting the Use
Partial Resolution attribute to partial and setting the Percent Resolution on a
per node basis. For details, see Using Maya: Character Setup.

Global

For Cluster Resolution and Lattice Resolution only, improves the redraw
performance of all cluster or lattice deformations. (You do not need to set the
Percent Resolution for each cluster or lattice.)
Set Global Cluster Resolution and Global Lattice Resolution to Full, High,
Medium, or Low. A Low setting corresponds to a low percentage, and
therefore more improved performance.

USING MAYA: ESSENTIALS
488

PART 4

SETTING PREFERENCES | 14
Loading and unloading plug-ins

For more information on surfaces, see Using Maya: NURBS Modeling and
Using Maya: Polygonal Modeling. For more information on deformers, see
Using Maya: Character Setup.

LOADING AND UNLOADING PLUG-INS
A plug-in is an add-on module that extends Maya’s capabilities. File
translators are plug-ins you use to import and export various file formats.
You can create or purchase specialty plug-ins to customize Maya for a
specific job.
Some features that can be added through plug-ins are:
•

file translators

•

tools

•

objects (nodes)

•

MEL commands

•

device drivers
The Plug-in Manager identifies which plug-ins are loaded into Maya. If you
have a plug-in that you use frequently, you can make sure it is always there.
The Plug-in Manager automatically scans all the directories in the plug-in
path and lists available plug-in features.

Loading plug-ins
You can manually load plug-ins each time you run Maya, or you can have
them load automatically when you start Maya.
To load a plug-in:
Select Window > Settings/Preferences > Plug-in Manager. The Plug-In
Manager window opens.
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Click here to load
the plug-in

Click here to enable
the auto load feature

Selecting loading options
Toggle the appropriate option beside the plug-in.
loaded

Toggle on loaded to load the plug-in for the current Maya session.

auto load

Toggle on auto load to load the plug-in so that the next time you start Maya
the plug-in loads automatically.

Displaying plug-in information
To view information about a particular plug-in, you must first load it, then
click the i button beside the plug-in.
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Click here to display
information on the plug-in

Maya displays the following information for a selected plug-in:
Name

The name of the plug-in. On IRIX, plug-ins have the extension .so. On NT,
they have the extension .mll.

Path

The location of the file. On IRIX, the default plug-in location is /usr/aw/
maya3.0/bin/plug-ins. On NT, the default plug-in location is
drive:\aw\maya3.0\bin\plug-ins.

Vendor

The manufacturer of the plug-in.

Plug-in Version

The version number of the plug-in.

For API Version

The version of the Maya API (Application Programmer Interface) the plug-in
was compiled for.
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Note
You cannot load a plug-in for any version of Maya that predates the
version it was compiled for.
Auto Load

Indicates whether the plug-in has been marked for auto load.

Is Loaded

Indicates whether the plug-in is loaded.

Plug-in Features

Displays a list of the features added by the plug-in (for example, commands,
dependency nodes, file translators).
To display additional plug-ins, click the triangle to open the Other
Registered Plug-ins section.

Unloading a plug-in
You can unload a plug-in when you finish with it. To unload a plug-in,
toggle off the loaded box next to it.
If you are developing a plug-in, unload it so the source code can be changed,
the plug-in recompiled, and then reloaded.
Removing references to the plug-in
Before you can unload a plug-in, you must first remove all references to it
from the Maya scene. Otherwise, Maya converts the plug-in nodes to
unknown nodes. For example, if you load a shader plug-in and then unload
that same shader plug-in without first removing the special shader node and
all of its references in the scene, Maya will display an error message the next
time you open that scene.
If you try to unload a plug-in while it is in use, a warning message will
display. You can then cancel the unload or force it.
If you force the unload of a plug-in while it is in use, you cannot reload that
plug-in’s node. Maya converts the existing nodes to unknown nodes. When
you reload plug-ins, you cannot change the type of these existing unknown
nodes.
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CUSTOMIZING SHELVES,
MARKING MENUS, AND
HOTKEYS
This chapter provides detailed information about Maya’s shelves, marking
menus, and hotkeys. This information is for advanced users.
Shelves are user-customizable areas to hold the actions and tools you use
most often. Marking menus are an innovative way of selecting various menu
items with the right mouse button. Hotkeys are keyboard shortcuts for
commands.
This chapter describes the following topics:

•

“Creating and editing shelves” on page 493

•

“Creating and editing marking menus” on page 509

•

“Assigning hotkeys” on page 526

CREATING AND EDITING SHELVES
You use shelves to put all the tools or action icons you use in one place. You
can drag tools, options, and actions onto a shelf from the Minibar, a menu, or
the Script Editor.
From the Maya main window, you can perform the following tasks:
•

add shelf items (see “Adding shelf items” on page 498)

•

remove shelf items (see “Removing shelf items” on page 499)

•

move and copy shelf items (see “Moving and copying shelf items” on page
500)
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You can use the Shelves window to:
•

create and delete shelves (see “Creating and deleting shelves” on page 495
and “Reordering the shelves” on page 501)

•

change shelf icons (see “Changing shelf icons” on page 502)

•

change icon labels (see “Changing icon labels” on page 504)

•

add overlay labels (see “Setting Shelf label options” on page 506)

•

change MEL commands associated with an icon (see “Changing MEL
command(s) associated with an icon” on page 507)
To open the Shelves window:
Select Window > Settings/Preferences > Shelves.

Shelves

Click the Shelves tab to display existing shelves. From here you can create
and delete shelves and change their order. For details, see “Creating and
deleting shelves” on page 495 and “Reordering the shelves” on page 501.

Shelf Contents

Click the Shelf Contents tab to display the contents of a specific shelf. From
here you can move and delete shelf items, change an item’s label and change
its icon. For details, see “Changing shelf icons” on page 502, “Changing icon
labels” on page 504, “Setting Shelf label options” on page 506, “Changing
shelf icons” on page 502.
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Edit Commands

Click the Edit Commands tab to view and edit the MEL code associated with
a tool or action. For details, see “Changing MEL command(s) associated with
an icon” on page 507.

Label

Specify a brief description of the tool. This description appears with the icon
in the icon or text modes. For details, see “Changing icon labels” on page
504. (Where it appears is determined by Options menu settings. For details,
see “Setting Shelf label options” on page 506).

Overlay Label

Type a label for the icon. This text appears on top of the icon to distinguish it
from other items that use the same icon. For details, see “Setting Shelf label
options” on page 506.

Save All Shelves

Click Save All Shelves to save all changes immediately and write the
information to the user shelves directory. The file name for a shelf file has
the prefix shelf_.

Close

Click Close to accept your changes but not write them to the disk
immediately. If your UI preference is to save shelf changes only when
explicitly requested, the changes will stay in effect only for the current
session. Otherwise your changes will be saved the next time you save a file
or quit the application. For information on changing this preference, see
“Setting Shelf label options” on page 506.

Creating and deleting shelves
In addition to using the default shelves, you can create custom shelves. Use
custom shelves to group common or frequently used tools, menu
commands, or MEL commands for easy access.
To create a shelf:
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1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab. Maya displays the names of all existing shelves.

2

Click New Shelf. Maya displays a default name for the new shelf in the
Name box and adds a new shelf tab in the main Maya window.
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Default name
for new shelf

Default name
for new shelf

3

Double-click in the Name box or press the Tab key to select the text in the
Name box.

4

Type the new shelf name (for example, Kinematics), then press Enter. Maya
adds the name of the new shelf to the Shelves window and the Maya
window.
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Name of the
new shelf

5

Click Save All Shelves or Close.
To delete a shelf:

1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab. Maya displays all existing shelves.

2

Select the shelf you want to delete, then click the Delete Shelf button. (You
do not have to delete any of the associated icons before deleting the shelf.)
You are prompted to confirm the deletion.

3
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Click OK. Maya removes the shelf from the list of existing shelves and from
the Maya window.
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Note
You cannot undo a delete command. However, Maya retains the shelf
information in the file shelf_NAME.mel.deleted in the user shelves
directory:
~username/maya/3.0/prefs/shelves (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\prefs\shelves (NT)
drive:\Documents and Settings\username\maya\3.0\shelves (2000)
So if you want to restore a deleted shelf, rename the file to
shelf_NAME.mel, then restart Maya.

Adding shelf items
You can add menu commands, MEL commands, and tools to shelves from
the Minibar, a menu, or the Script Editor.
You can also save multiple versions of the same tool to the shelf with
different settings. For example, add a Sculpt Surfaces Tool with the Push
option selected and another Sculpt Surfaces Tool with the Pull operation
selected.
To add a tool from the Minibar:
Using the middle mouse button, drag the tool to the shelf.

This creates an editable tool on the shelf. If you select this tool from the shelf
and change any settings in the Tool Settings window, the settings for the
shelf item also change. These new settings become the default for the shelf
tool.
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To add a menu item to a shelf:
Press Ctrl-Shift-Alt (IRIX), Ctrl-Shift (NT), then select the item from the
appropriate menu. Maya places the item on the shelf. This adds the base tool
to the shelf. Any changes you make to the tool settings will be reflected in
the shelf tool also.
To add a MEL command to a shelf from the Script Editor:
1

In the Script Editor (Windows > General Editors > Script Editor), highlight
the MEL command text that you want to add to a shelf.

2

Using the middle mouse button, drag the selected text to the shelf and
release. This places a MEL icon on the shelf. When you click the icon, Maya
runs the command(s).
For example:

1

Open the Script Editor window (Windows > General Editors > Script Editor).

2

In the Modeling menu set, select Create > NURBS Primitives > Sphere. A
sphere appears at the origin.

3

Select the Move tool and drag a manipulator arrow to move the sphere.
The MEL command move -r 5.315 0 0; (with your own coordinates), appears
in the upper pane of the Script Editor.

4

Highlight the MEL command text in the upper pane of the Script Editor.

5

Using the middle mouse button, drag the selected text to the shelf and
release. This places a MEL icon on the shelf. When clicked, the icon executes
the move -r 5.315 0 0; command again.

Removing shelf items
There are two ways you can delete a shelf item. You can use the middle
mouse button to drag items to the garbage can directly on the shelf or you
can use the Shelves window.
To remove a shelf item directly from a shelf.
Use the middle mouse button to drag the icon to the garbage can.
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Maya removes the tool or action icon from the shelf tab.
To remove a shelf item using the Shelves window:
1

Open the Shelves window (Window > Settings/Preferences > Shelves).

2

Click the Shelves tab, then select the shelf containing the tool or action you
want to delete. The selected shelf becomes active in the main Maya window.

3

Click the Shelf Contents tab.

4

Select the description of the icon you want to delete, then click Delete Item.
Maya removes the icon from the shelf.

5

Click Save All Shelves or Close.

Moving and copying shelf items
You can move shelf items to change the order they appear and you can
move shelf items between shelf tabs.
You can also copy shelf items. For example, you can add the same tool to a
shelf more than once, but with different settings. The original tool must have
been added to the shelf from the Minibar (see “To add a tool from the
Minibar:” on page 498).
To change the order of shelf items:
•

On the shelf, use the middle mouse button to drag the icon to the desired
position.
or

1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelf Contents tab.

2

Select the item you want to move and click the Move Up or Move Down
button until the item appears where you want it to appear.

3

Click Save All Shelves or Close.
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To move an item between shelf tabs.
1

Use the middle mouse button to drag the icon onto the other shelf tab. The
icon is removed from the current shelf.

2

Click the shelf tab on which you dropped the icon. The icon is visible on the
new shelf.
To copy an existing item on the shelf.
Press the Ctrl key and use the middle mouse button to drag the icon to its
new position. A copy of the icon appears on the shelf.

Renaming shelves
You can change the name of a shelf at any time to something more
meaningful (for example from ShelfLayout1 to Dynamics).
To rename a shelf:
1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab.

2

Select the shelf you want to rename. Maya displays the name of the selected
shelf in the Name box.

3

In the Name box, double-click on the name of the shelf.

4

Change the name, then press Enter. Maya displays the new name in the list
of existing shelves and in the Maya window.
You cannot use spaces or special characters (for example, !,@,#,$,%) in shelf
names.

5

Click Save All Shelves or Close.

Reordering the shelves
You can reorder the shelves that you use frequently. This is especially
helpful if you have more shelves than Maya can display at once.
To reorder the shelves:
1
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Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab. Maya displays all available shelves in the order they
appear in the Maya window.
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2

Select the shelf you want to move, then click the Move Up or Move Down
button until the selected shelf appears where you want it to appear.

3

Click Save All Shelves or Close.

Changing shelf icons
On IRIX, Maya uses xpm (IRIX) images for the shelf button icons. Maya NT
uses bitmap (bmp) images and xpm images. You can assign a new image to
a shelf button to more accurately reflect the button’s function. If you want to
use an icon design other than a Maya default images, you must create your
own image file. You cannot modify Maya’s default shelf button icons.
To create a new icon image
Use any available 2D image program to create new image files. The image
file size must be 32 x 32 pixels to fit within the shelf button. Typically, you
place the image in your user icons directory:
~username/maya/3.0/prefs/icons (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\prefs\icons (NT)
drive:\Documents and Settings\username\maya\3.0\prefs\icons (2000)
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If you use a different directory, you should specify it in the
XBMLANGPATH environment variable. See Chapter 8, “Setting
Environment Variables.”
To change an icon’s image:
1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab.

2

Select the shelf containing the tool you want to change.

3

Click the Shelf Contents tab.

Description of icon

Tool’s icon

4

Select the description of the shelf item you want to change, then click the
Change Image button. A file browser window opens with the images
directory selected.
On IRIX, the browser is called the Pixmap Selector. The browser defaults to
/usr/aw/maya3.0/icons, the location of Maya’s default icons.
On NT, the default icons are stored in drive:\AW\Maya3.0\extras\icons.

5
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Select a Maya default image or navigate to a new user-created image (it must
have the file extension .xpm or .bmp).
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Note
Maya stores the image as a reference file. If you move it, you must specify
the new location by using the Shelves editor or by setting the
XBMLANGPATH variable.
6

On IRIX, click Apply to see your change in the main Maya window without
closing the Pixmap Selector. Click Done to apply your change and close the
Pixmap Selector.
On NT, click Open.

7

Click Save All Shelves or Close.

Note
On IRIX, you can modify existing images and create new ones from the
Pixmap Selector.
To modify an existing image (but not a Maya default shelf button icon),
select it and click the Modify button to launch the xpaint application. Make
your changes and save them.
To create a new image, click the New button, type a name for the new file,
then click OK to create a blank image in the icons directory. Select the new
image and modify it.

Changing icon labels
You can change the label of a tool or action icon if you:
•

Want to make it more indicative of the function it performs.

•

Have changed the options and want to change the name to reflect changes.
For example, if you modify a copy of the sphere action so that it now creates
a hemisphere, you can change both the label and icon to reflect this change.
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Note
Before you start, select Window > UI Preferences and click the Shelf tab.
Click Icon/Text Below. This displays descriptive text below the icon.
To change an icon’s label:
1

Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab

2

Select the shelf that contains the icon you want to rename. The selected shelf
becomes active in the main Maya window.

3

Click the Shelf Contents tab, then click the name of the icon you want to
relabel.

4

Enter the new name of the icon in the Label box, then press Enter.
Maya changes the tool name in the Shelves window and on the shelf in the
main Maya window.

New name of
the Sphere
action
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Note
To change the overlay label of the tool, see “Setting Shelf label options” on
page 506.
5

Click Save All Shelves.
When you move the cursor over the renamed icon, Maya displays the new
name on the Help Line and in the popup help.

Setting Shelf label options
Use the Options menu in the Shelves window to specify the appearance of
the Shelf labels options.
Icon Only

Displays only the icon.

Icon/Text Below

Displays descriptive text below the icon.

Icon/Text Beside

Displays descriptive text beside the icon.
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Adding overlay labels
Maya uses families of icons to represent related tools and actions.
You can create an overlay label to distinguish individual icons. For example,
if you have several MEL command icons on your shelf, they all look the
same because they all use the same default icon. You can use overlay labels
to distinguish between these MEL buttons as shown in this illustration.

Overlay label on a
MEL command icon

You use the Shelves window to assign an overlay label to a tool or action.
To assign an overlay label to an icon:
1

Select Option > Settings/Preferences > Shelves and click the Shelves tab.

2

Select the shelf containing the tool you want to rename. The selected shelf
becomes active in the main Maya window.

3

Click the Shelf Contents tab, then select a tool or action.

4

Enter the label in the Overlay Label box, then press Enter. Maya adds an
overlay label in the shelf.

5

Click Save All Shelves.

Changing MEL command(s) associated with an icon
All actions on the shelf consist of a single or series of MEL commands. You
can change these commands to change the behavior of the action.
In the following example, we modify the MEL code for a move command to
change the action’s behavior.
To modify an action’s MEL code:
1
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Open the Shelves window (Window > Settings/Preferences > Shelves) and
click the Shelves tab.
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2

Select the shelf containing the item you want to edit. The selected shelf
becomes active in the main Maya window.

3

Click the Shelf Contents tab and select the item you want to edit.

4

Click the Edit Commands tab. The commands for the shelf item appear in
the text area.
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5

Make any necessary changes to the commands.

6

Press Enter on the keyboard. When you click the icon for this action, the new
commands will run.

7

Click Save All Shelves or Close.

CREATING AND EDITING MARKING MENUS
Marking menus let you quickly access various tools and actions. You can
customize a marking menu’s format and content.
A marking menu has a radial portion and an overflow portion.
The radial portion consists of one to eight menu items arranged in a circle.
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Each menu item represents a command you have added to that marking
menu. You can use the Marking Menus window to add, change, or delete a
menu item or command. For more information on using the Marking Menus
window, see “Modifying existing marking menus” on page 516.
The overflow portion (or linear portion) has one or more menu items. The
overflow items are arranged in a column below the radial items.
Marking menus can be hierarchal. In other words, any menu item can have a
submenu.

Note
Each menu and submenu can contain a maximum of 38 menu items.
You can use the Marking Menus window to:
•

create marking menus (see “Creating marking menus” on page 511)

•

attach a marking menu to a hotkey (see “Assigning marking menus to
hotkeys” on page 515)

•

modify existing marking menus (see “Modifying existing marking menus”
on page 516)

•

add submenus to marking menu items (see “Adding submenus to menu
items” on page 520)

•

add MEL scripts to marking menus (see “Associating a MEL script with a
menu item” on page 522)

•

delete marking menus (see “Deleting marking menus” on page 523)
To display the Marking Menus window:
Select Window > Settings/Preferences > Marking Menus.
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Marking menu defaults

Zone

Associated mouse buttons

Creating marking menus
You can modify the default marking menus or use the Marking Menus
window to create new marking menus.
You can add the following items to marking menus:
•

text from the Script Editor

•

tool icons and action icons from a shelf

•

the Select, Translate, Rotate, Scale, and Show Manipulator icons in the
Minibar
You can associate your marking menu with a zone or mouse button in the
Hotbox, or a specific hotkey to the marking menu.
The Hotbox can support a different menu for each mouse button in each of
the Hotbox’s five zones. You can create three menus per zone, for a total of
15 marking menus (3 menus x 5 zones) with eight commands per marking
menu. This gives you approximately 120 total commands (3 menus x 5 zones
x 8 commands).
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To create a marking menu:
1

Select Window > Settings/Preferences > Marking Menus. The Marking
Menus window opens.

2

Click Create Marking Menu. The Create Marking Menu window opens.

Place tool or action
icons here

Enter name of the
marking menu

3

Use the middle mouse button to drag tools or actions to the Create Marking
Menu window.
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For example, to add the Add Points tool, select (from the Modeling menu
set) Edit Curves > Add Points Tool. The tool displays in the minibar. Using
the middle mouse button, drag the Add Points tool from the minibar to the
Create Marking Menu window.

Note
You can also add MEL commands to the Marking Menus window. For
details, see “Associating a MEL script with a menu item” on page 522.
4

Repeat step 3 for any additional tools.

Tips
To delete an icon, place the pointer on the icon, press the right mouse
button, and select Delete Menu Item.
To create a submenu, see “Adding submenus to menu items” on page 520.
This is useful if you want to increase the number of menu items you can
access from a marking menu.
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5

Enter the name of the new menu in the Menu Name box.

Enter name of the
new menu here

Click here to
test the marking
menu format

6

To move a tool’s position, use the middle mouse button to drag the icon to a
new position within the Create Marking Menu window.

Tip
If a tool has an option box, you can make changes to the options.

Click here to change
the tool’s options

7

When you are satisfied with the position of every tool in the marking menu,
click Save and close the Create Marking Menu window.

8

Set the following options and click Apply Settings, then Close.
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Use Marking Menu in

Specify whether the marking menu is linked to the Hotbox or a hotkey. For
information on linking a marking menu to a hotkey, see “Assigning marking
menus to hotkeys” on page 515.
Hotbox region

If you selected Hotbox for Use Marking Menu in, select the Hotbox zone the
marking menu occupies: North, South, East, West, or Center.

Mouse button(s)

Select the left, middle, or right mouse button used to display the marking
menu. You can select one, two, or three mouse buttons.

Assigning marking menus to hotkeys
In addition to adding or customizing marking menus in the Hotbox, you can
assign a marking menu to a specific hotkey. Each time you press the hotkey
and the left mouse button, the associated marking menu appears. For
example, the q key is associated with the Select marking menu.

Note
A marking menu/hotkey combination will not work in a tear-off window.
You display marking menus by pressing the left mouse button and the
appropriate hotkey. The following hotkeys bring up marking menus.
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Hotkey

Action on Marking Menu

a

Select All History, Disable All Future, Select All Future, and
Enable All Future

d

High, Medium, and Low Quality Display

e

Rotate X, Y, and Z
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Hotkey

Action on Marking Menu

h

Modeling, Animation, Dynamics, Rendering

q

Select Mask (see previous illustration)

r

Scale X, Y, Z and Scale XYZ

w

Translate X, Y, Z and Translate XYZ

For more information on setting hotkeys, see “Assigning hotkeys” on page
526.

Modifying existing marking menus
Use the Edit Marking Menu button in the Marking Menus window to
modify existing marking menus. You can add, edit, or delete individual
menu items in a marking menu.
You can also add submenus to add more tools and actions to a marking
menu. For details, see “Adding submenus to menu items” on page 520.
Each icon in the Edit Marking Menu window corresponds to a menu item in
a marking menu.
For information on adding menu items to an existing marking menu, see
“Creating marking menus” on page 511.
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To delete a menu item:
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1

Open the Marking Menus window (Window > Settings/
Preferences > Marking Menus).

2

Select an existing marking menu.

3

Click Edit Marking Menu. The Edit Marking Menu appears with each icon
corresponding to a menu item.

4

Right-click on the menu icon you want to delete and select Delete Menu Item
from the pop-up menu.
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5

Select Save or Close.
To edit a menu item:

1

Open the Edit Marking Menu window.

2

Right click on the menu icon you want to edit and select Edit Menu Item
from the pop-up menu.

The Edit window appears according to the position of the icon (for example,
Edit North, Edit North East, Edit East, Edit South East, Edit South, etc.).
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3

Set the following options, Click Save and Close or Close, then close the Edit
Marking Menu window.

Label

Enter the name of the marking menu item.

Icon Filename

Enter the name of the icon file. For more information, see Using Maya: MEL.

Command(s)

Enter the MEL script used as the command for the menu item. You can drag
the MEL script from the Script Editor’s bottom panel with the middle mouse
button.

Check Box

Displays a check box beside the marking menu item.

Radio Button

Displays a toggle box beside the marking menu item.

Neither

Displays nothing beside the marking menu item.

Option Box

Toggle Option Box on to display the option box ❐ beside the menu item so
you can change a tool’s options from the marking menu. For more
information, see “Specifying tool settings” on page 248.
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Note
If the tool or action does not have an options window, you must use MEL
code to create the box. Once the box is created, you must write MEL code
to invoke the option window. For more information on MEL commands,
see Using Maya: MEL.
Option Box Command(s)

Enter the MEL script to use as the command for the menu item’s option box.

Adding submenus to menu items
Like the main pull-down menus, menu items in a marking menu can have
submenus. These submenus let you add extra tools and actions to a marking
menu.

Note
If you create submenus under an overflow menu item, the submenus
cannot contain any radial items.
In the following example, there are four menu items associated with one
submenu.
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Adding a submenu:
In the following example, a submenu is associated with an icon.
1

Open the Marking Menus window (Window > Settings/
Preferences > Marking Menus).

2

Select the marking menu that has the menu item you want to add a
submenu to.

3

Click Edit Marking Menu.

4

Position the cursor on the icon you want to add a submenu to.

5

Press the right mouse button and select Popup Submenu from the pop-up
menu. The icon changes shape indicating that a submenu is associated with
it and the Submenu Editor dialog opens.
Menu item icon
changes to this
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6

Using the middle mouse button, drag tools or actions to the Submenu
Editor.

7

Close the Submenu Editor window.

8

To test the submenu, click in the Click Here to Test box.
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9

Click Save or Close.

Associating a MEL script with a menu item
If you have written a script to perform a particular task, you can associate it
with a menu item in a marking menu. In the following example a MEL script
is added to an existing marking menu.
To associate a script with an menu item:
1

Open the Marking Menus window (Window > Settings/
Preferences > Marking Menus).

2

Select the marking menu that has the menu item you want to add a
submenu to and click Edit Marking Menu.
or
Click Create Marking Menu to create a new marking menu. For more
information, see “Creating marking menus” on page 511.

3

Open the Script Editor (Window > General Editors > Script Editor).

4

With the left mouse button, highlight the MEL script you want to associate
with a marking menu.

5

Press and hold the middle mouse button over the highlighted text. An icon
appears.
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6

Using the middle mouse button, drag the icon to the marking menu’s menu
item in the Edit or Create Marking Menu window.

Icon representing the
MEL script

7

Place the cursor over the new MEL icon and use the right mouse button to
select Edit Menu Item.

8

Assign a label for the menu item.
For more information, see “Modifying existing marking menus” on page
516.

Deleting marking menus
You can use the Marking Menus window to delete marking menus. When
you delete a marking menu you can create a backup file which allows you to
restore the menu.
To delete a marking menu:
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1

Open the Marking Menus window (Window > Settings/
Preferences > Marking Menus).

2

Select the marking menu, then click Delete Marking Menu. The following
dialog appears.
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3

If you want to delete the marking menu but keep a backup copy of it, select
Create Backup.
Maya stores the backup file in the user prefs directory with a file extension
of .bak. For information on how to recover the marking menu, see “To
restore a marking menu backup:” on page 524.
or
If you want to delete the marking menu without creating a backup file, click
Do Not Backup.

Note
You cannot recover a marking menu after you select Do Not Backup.
Maya removes the marking menu from the Marking Menus window.
4

Click Close.
To restore a marking menu backup:

Note
You must exit Maya before restoring a deleted marking menu.
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1

Rename the marking menu backup file menu_MenuName.mel.bak to
menu_MenuName.mel.

2

Restart your system.

3

Select Window > Settings/Preferences > Marking Menus. The following
message appears.

4

Click Load Menus. The recovered marking menu appears in the Marking
Menu window.

Note
Because Maya does not recover the mouse button assignment, you will
have to re-assign a mouse button to the recovered marking menu.
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ASSIGNING HOTKEYS
If you use a selection frequently, you may want to assign it to a hotkey. For
example, if you select File > Import frequently, you can assign a hotkey to it.
This decreases your reliance on the main menu.
You assign hotkeys in the Hotkey Editor (Window > Settings/Preferences >
Hotkeys) window. It lists most menu items in the main menus, as well as
commonly-used operations, such as Display Wireframe (hotkey 4). Also, you
can assign hotkeys to your own MEL scripts or to commands that
accompany plug-in software.

Select a
command
here...

...assign the
hotkey here

You can add
a custom
command
here so you
can assign it
a hotkey
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Hotkeys on menu labels
When you assign a hotkey to a menu item, the change appears on the main
menu label. (This feature does not apply to menu labels in the hotbox.)

Hotkeys shown
beside menu
selections

How hotkeys are saved
Maya saves your custom hotkey preferences so that they do not interfere
with the default Maya hotkey settings. Your preferences will not be
overwritten when you upgrade to the next Maya version.
The file names containing hotkey preferences are userHotkeys.mel and
userNamedCommands.mel under user prefs directory:
~username/maya/3.0/prefs (IRIX)
drive:\WINNT\Profiles\username\maya\3.0\prefs (NT)
drive:\Documents and Settings\username\maya\3.0\prefs (Windows 2000)

Assigning hotkeys to standard commands
Use the top half of the Hotkey Editor to assign hotkeys to a menu selection
or standard command. To help you choose hotkeys, you can also view a list
of mapped and unmapped keys.
To assign a hotkey:
1

Choose Window > Settings/Preferences > Hotkeys.

2

Select the category and command.
There are categories for all of the main menus and for several other
commands. Menu commands for plug-ins, including Live and Fur, are under
the User category. If you have trouble finding a command, click Search (see
“Example—creating a hotkey for a view menu option:” on page 530).

3
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In the Assign New Hotkey area, specify the key combination and other
settings. You can see a list of which keys are unmapped by clicking List All.
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Key

Enter the key you want to assign to the selected command.
Enter a letter from A to Z (upper and lower case are
different keys) or a number from 0 to 9. You cannot use
more than one letter or number.
Or, choose a special key from the pull-down list. For
example, if you want the right arrow key to act as the
trigger, assign it here.

Modifier

Select either Alt or Ctrl for the hotkey modifier.

Direction

Use Press or Release to associate a command with the
press or a release of a key. For example, you can create a
hotkey to instruct Maya to snap to a curve when you press
a key, then turn off the snapping when you release it.
If you added a key to an operation ending with (Press) or
(Release), add the same key to the corresponding (Release)
or (Press) operation.

4

Repeatable

Turn on so that this hotkey is repeatable using the Edit >
Repeat command. Turn off to prevent repeating the
hotkey using Edit > Repeat.

Query

Click Query to determine whether the specified key
settings have already been assigned to a command.

Find

Clicking Find highlights the category and command for
the key you enter in the Key field.

Click Assign.
The new hotkey should appear in the Current Hotkeys list.

Viewing hotkey lists
Click List All to view a list of mapped and unmapped keys. This opens a
window that allows you to sort the keys in various ways.
To print the hotkeys list to a file, click Save to File button and specify a
destination directory.
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No Modifiers

Lists only single hotkeys, without Ctrl or Alt.

Ctrl

Lists only hotkeys with a Ctrl + key combination.

Alt

Lists only hotkeys with an Alt + key combination.

List All

Lists all hotkeys.

Ignore Release

Turn on to ignore the hotkeys that activate when you release the key, versus
when you press the key. Turn off to see all hotkeys, including the ones
activated when you release the key.

Searching for commands
Click the Search button at the bottom of the Hotkey Editor to perform a
search through all existing commands. For example, you may want to
perform a search if you know part of a command name, but not the category.
Or, if you are adding a new command, you can first search for commands
that are related.

PREFERENCES

USING MAYA: ESSENTIALS
529

CUSTOMIZING SHELVES, MARKING MENUS, AND HOTKEYS | 15
Assigning hotkeys

In the Search for Command window, you type a case-sensitive string. The
program searches for that string in the command names and command
syntax. You can use * to represent any character or characters. You can also
use brackets to enclose both capital and lower-case letters, such as: [aA].

Changing or deleting a hotkey
If you want to alter or delete an existing hotkey, select it from the Current
Hotkeys list and click Remove. You can then assign a different hotkey as
needed. You cannot restore a hotkey after you have deleted it; you must
reassign it.

Adding commands for hotkey assignment
If there is a MEL command or script you want to enact with a hotkey, you
can add that command and then assign it a hotkey. This capability is also
useful for assigning hotkeys to the selections on the panel menu bar: View,
Shading, Lighting, Show, and Panels (see “Example—creating a hotkey for a
view menu option:” on page 530).
To add a new command for hotkey assignment:
1

Click New.

2

Complete the Name and Description.
These fields are for future reference. They only appear in the Hotkey Editor.

3

Select a category from the Category pop-up menu.

4

Enter the MEL command into the Command box.

5

Click Accept.
The command should appear under the chosen category. You can now
assign a hotkey to this command.
Example—creating a hotkey for a view menu option:

1

In the Hotkey Editor, click New.

2

Complete the Name, Description, and Category.
For the Command, you will cut and paste from the Script Editor.

3

Open the Script Editor (Window > General Editors > Script Editor).
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4

In the Script Editor, select Edit > Echo All Commands.
This instructs Maya to display all MEL commands used to execute any menu
options.

5

In the view menu bar, select the menu item you want to create a hotkey for
(for example, Shading > Smooth Shade Selected Items).

6

Select the echoed MEL command from the Script Editor window.

Select text
from here...

... to here
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7

Copy and paste the command into the Command box in the Hotkeys
window. On IRIX, use the middle mouse. On Windows NT, use Ctrl+C
(copy) and Ctrl+V (paste).

8

Click Accept in the Hotkeys window.
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The command should appear under the chosen category. You can now
assign a hotkey to this command.
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WORKING WITH PANELS
AND LAYOUTS
You can use panels and layouts to customize your workspace.
Panels consist of interface elements, such as graphs, camera views, editors,
and Outliners, that you can view within the main window. Layouts are
groups of panels.
This chapter describes how you work with panels and layouts:

•

“Using the Panel Editor” on page 533

•

“Viewing panels” on page 535

•

“Defining layouts” on page 539

USING THE PANEL EDITOR
You use the Panel Editor to assign panels and layouts to your workspace.
The Panel Editor also lists the existing layouts and panels.
To display the Panel Editor:
•

On the Maya menu bar, select Window > Settings/Preferences > Panels.
or

•

On the view menu bar, select Panels > Panel Editor.
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You can select the following Panel Editor tabs:
Panels

Displays existing panels you can rename or delete. See “Modifying existing
panels” on page 535.

New Panel

Displays the types of panels that you can create. See “Creating and deleting
panels” on page 537.

Layouts

Displays existing panel layouts. See “Creating layouts” on page 540.

Edit Layouts

Displays the current panel layout. See “Defining layouts” on page 539.

History

Displays the history of the panels you used. See “Maintaining layout
history” on page 544.
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VIEWING PANELS
A panel is a collection of interface display elements. You can view panels
within the main window or tear them off so they exist in a separate window.
Panels can consist of a single element, such as a camera view in a Modeling
panel, or multiple elements, such as the Multilister with its many buttons
and tabs. Panels have their own menu bars for their specific options.

Modifying existing panels
You rename or delete existing panels using the Panel Editor.
To rename a panel:
1

Select Panels > Panel Editor.

2

Select the panel you want to rename.

Note
You cannot rename the Top, Side, Front, or Persp view panels.
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Type the new name of
the view here

3

Type the new name in the Label box, then press Enter. Maya changes the
name of the panel in the list of existing panels.

4

To make sure that the renamed panel appears in the list of available panels,
select Panels > Panel.
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New name of the view

Creating and deleting panels
Sometimes an object or scene is too big to fit in a window. When this
happens, you may want to create a second panel.
For example, if you created a skeleton and wanted to use the Outliner to
look at two different parts of the object at the same time, you could create a
second Outliner. Since the Outliner cannot display all of the nodes of the
skeleton, you could use the second Outliner to view different parts of the
object.
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To create a new panel:
1

Select Panels > Panel Editor and click the New Panel tab.

2

If you have more than one view open, select the view where you want the
new panel to appear.

3

Select a panel (such as the Outliner), then click Make New Panel. Maya
creates a new panel and lists it before the selected view. The name of the
new panel appears in the Panels tab.

Note
Not all panels can be duplicated. For example, only one Hypergraph panel
is allowed. If you try to display multiple Hypergraph panels, Maya
displays an alert message.
4

To view a second Outliner, select Windows > Outliner. Both Outliner
windows now appear in the view.
You can now make changes to the Outliners so they display different
information about the scene.
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To delete a panel:
Once you have deleted a panel, you cannot restore it.
1

Select Panels > Panel Editor.

2

On the Panels tab, select the panel you want to delete, then select Delete. A
confirmation dialog appears.

3

To confirm the deletion, click OK. Maya removes the panel from the display.

DEFINING LAYOUTS
You often work with the same combinations of panels, depending on the
task you are working on. When you render, you might want to work with
the Multilister, RenderView and a perspective view. When you edit models,
you might use the Outliner and a perspective view. Panel layouts provide
these kinds of configurations.
A number of predefined layouts are provided in Maya, but you can also
create your own.

Selecting panel layouts
There are three ways to select panel layouts:
•

from the main Maya window

•

from a view panel

•

from the Panel Editor
To select a panel layout from the main Maya window:
On the main Maya menu bar, select Window > Saved Layouts, then select
the layout you want to use.
To select a panel layout from a view panel:
On the view menu bar, select Panels > Saved Layouts, then select the layout
you want to use.
To select a panel layout from the Panel Editor.

1
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Select Panels > Panel Editor and click the Layouts tab.
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2

Select one of the layouts.
Selecting any item from the list applies that panel layout to the main
window. Try a few of them. Some panels take a moment to load the first
time you use them.

3

To return to the original panel layout, select Current Layout from the list.
To add a layout to a shelf:

1

Select a shelf by clicking the shelf tab.

2

Select Panels > Panel Editor and click the Layouts tab.

3

Select the layout, then click Add to Shelf.

Layout added to the Shelf

To add a name to the layout shelf button (it displays as a MEL icon), see
“Setting Shelf label options” on page 506.

Creating layouts
By default, any new panel layouts you create are saved with your preference
file. This allows you to use them with any of your scene files. You can also
create and save panel layouts that are only available with a specific scene.
To create a layout:
1

Select Panels > Panel Editor and click the Layouts tab.

2

Select a layout such as the Single Perspective View then click the New
Layout button.

3

Tab to the Name box and rename the layout.

4

Click the Edit Layouts tab.
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Maya displays two additional sub-tabs:
Configurations – Use this tab to change the configuration and proportions of

the views in your window.
Contents – Use this tab to change which panels appear in which views.
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5

From the Configuration pull-down menu, select the panel configuration
required (in this example, 3 Pane Right Split).

6

Resize the panes by dragging the borders in the thumbnail view of the
layout. The main window changes to reflect your changes.
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Click-drag here to change
the width of the display.

Click-drag here to change
the height of the display

7

Click the Contents tab.

Click here to display
available panel types

8

Select whether you want layout to be scene independent or associated with
the scene.
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Scene Independent – Scene independent layouts are available for all scenes.

Their contents are defined by panel types.
If you have multiple panels of the same type in a scene, it is not certain
which panels show up when you select your layout. This is not a problem in
most cases; however, if you are working in a particular scene a great deal,
we recommend developing layouts that you can save specifically with that
scene.
Associated with scene – These layouts are only usable with the current scene.

You can specify a particular panel if you have more than one of the same
type.

Note
If you want to look through cameras other than the built-in persp, top,
front, or side cameras, create another model panel for use in your panel
layout. The Top View, Front View, Side View, and Persp View layouts use
their respective built-in cameras as defaults.
9

From the Select Panel by Type menus, select layouts for your panes.
For example, select the Outliner, Render Window, and Hypershade panels
for panes 1, 2, and 3, respectively.

10 Click the Layouts tab.
11 Select another layout. The main window changes to show the selected
layout.
12 Select the layout you just created.
Your new panel layout displays in the main window. Your layout also
appears in the Panels > Saved Layouts menu and the Windows > Saved
Layouts menu.
To save the current layout:
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1

Select Window > Save Current Layout. The Save Panel Arrangement
window opens.

2

Enter a name for the new layout and click OK. The layout appears in the
Panels > Saved Layouts menu and the Windows > Saved Layouts menu.
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Deleting layouts
At some point, you may no longer need layouts you created.
To delete a layout:
1

Select Window > Settings/Preferences > Panels.

2

Click the Layouts tab, select the layout you want to delete, then click Delete.
A confirmation dialog appears.

3

Click OK to remove the layout.
To remove a layout icon from the shelf:
Use the middle mouse button to drag the icon to the garbage can.

Note
When you delete a layout, you only delete the named panel configuration,
not the constituent panels.

Maintaining layout history
Maya keeps a record of panel layout changes. This lets you step forward or
back through each view. This is helpful if you are moving between two
layouts and cannot remember their names.
To display panel history:
Select Panel > Panel Editor and click the History tab.
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History Depth

Specify the number of configurations you want stored in the history.

Wrap History

Toggle this on to return you to the first view or the most recent view
configuration when you reach the end of recorded history.

Clear History

Click this button to delete the record of all the panels you have used.

Previous Layout

Click this button to browse back through the panel layouts.

Next Layout

Click this button to browse forward through the panel layouts.
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A
absolute
path 214
values 95, 97
actions
defined 17
redoing 68
undoing 68
active lines, showing 405
Add Attributes option, Attribute
Editor 269
Add Instance option 66
Add to Current Selection brush
option 164
Advanced Visualizer file
format 197
Affects Active modifier
option 476
After Stroke Cmd 409
aiff file format 197
aliasWire format 197
aligning
brush profile 402
objects, snapping 155
vertices 154
All Components Off option 159
Allow Highlight Select modifier
option 476
alpha channel 419, 420
Angle of view 35
Angular units option 472
anim file
exporting 210
importing 188
animated nodes 323, 342
animating
rotation channels 89
transitions (of view) 360

animation
continuous play option 480
controls 479
curves
exporting 210
importing 188
using to create
falloff 104
key options 475
menus 5
nodes 49
oscillating 480
playback options 480
preferences button 7
Animation Start/End
option 479
animImportExport plug-in 188,
210
aperture 35
API, version for plug-ins 253,
490
applications, importing files
from 184
Apply Current to All option 125
Arc Length Tool 114
arc lengths
locators 115, 116
measuring 114
Array Cloning. See Duplicate
Options window 59
Artisan
attribute maps 422
paint tools 387, 388
ASCII file 199
format 196, 197, 198
Assign Selection option 141, 148

Attribute Editor 235, 262
arc length locator 116
axis display 78
breaking connections 274
compared to Attribute Spread
Sheet 241
custom attributes,
adding 269
displaying 262
distance locators 110
linking attributes 274
loading attributes into 266
locators 106
locking attribute values 274
mapping textures to
attributes 275
node behavior 272
opening multiple copies 268
parameter locators 113
pivot points 74, 76
right-click menu options 265
rotation order 87
setting keys 273
attribute maps 420
Attribute Paint Tool 454
Attribute Spread Sheet 235, 241
layout 246
names, shortening 242
option 236, 241
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INDEX

INDEX

attributes
adding to Channel Box 282
Attribute Editor 266
Attribute Spread Sheet 241
breakdown keys, setting 292
changing multiple
values 243, 286
Channel Box 281
components, displaying in
Channel Box 283
compound 303
connections, breaking 274,
293
custom 269
default input and output 350
defined 241
deleting custom 271
displaying 303
editing 69, 241, 355
editing multiple 236, 241
exporting maps 424
handles 73
ignoring when
rendering 266
importing maps (paint
tools) 420
keying 247, 273, 291
linking 274, 295
locking values 274, 294
mapping textures to 275, 419
painting 454
relative values, entering 245,
287
showing for just one
view 119
unlocking 275, 294
values 203, 243, 285
audio file format 197
Auto Key
animation option 475
button 7
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auto load plug-in option 252,
490
Autodesk file format 197
Autom Create Rigid Body
dynamics option 473
automatic graph layout 334
automatically created sets 367
auxiliary nodes 316
Averaging option 438
avi file format 198
axes
changing from command
line 79
constraint, snapping 154
description 78
displaying 78
global 78
grid 121
local 78
orientation 88
outline 121
reflected painting 398
restricting object movement
to 80
rotation order 88
snap 155
Axes option 78
Azimuth Elevation Tool 37

B
backculling 135
Backculling display option 471
Backface Culling option 124,
137, 472
backfaces
culling, display 472
displaying and hiding 131

background image
importing to scene
hierarchy 335
Backspace key 56
backup copies of marking
menus 523, 524
Based on distance option 101,
102, 104
Before Stroke Cmd 409
binary file format 196
bitmap images for shelf
icons 502
Blend box 278
Bookmark Editor 47
bookmarks 47
adding to shelf 49
automatic view change 362
creating 47, 363
deleting 48, 363
predefined 47
renaming 49, 364
returning to 363
selecting custom 48
Boomarks option 48
Border Edges option 136, 471
Border Width option 136, 471
borders
changing 136
displaying 136
edges 471
Bounding Box option 123
branches 323
centering in view 360
breakdown keys, setting 292
breaking parent-child
relationship 308, 331

INDEX

brush
feedback 404
opacity 392
outline trail 404
outline, drawing 404
outlines 390
radius 392
shape 393
stamp profile 402
stroke settings 397
value 392

C
caching 272
CAD system file format 197
Camera Settings option, View
menu 38
Camera Tools option, View
menu 36, 37
Camera/Light Manipulator
option 137, 138

cameras 40
aperture 35
center of interest 37, 137
changing settings 38
clipping planes 137
creating 36
cycling index 138
default display of 299, 321
displaying 36
dollying 36
field chart 39
fill 40
film gate 38
frustrum 38
gate 38
hiding 126
horizontal 40
journal 38
looking through 37
manipulators 94, 126, 137
moving 36
orthographic 41
oversan 40
overview 34
perspective 38
resolution gate 39
revolving 36, 37
rolling 36
safe action 39
safe title 39
tools 36
tracking 36
tumbling (NT) 124
yaw pitch 37
zooming 36
categories
of projects 214
Center of Interest option 137,
138
Center polygon selection
option 477
Center zone marking menu 27

centering nodes in view 359
Channel Box 235, 280
adding attributes to 282
attribute components 283
attribute values,
entering 285
attributes 281
breakdown keys, setting 292
breaking connections 293
custom attributes,
deleting 271
displaying 280
Expression Editor,
launching 295
format, changing 284
history 295
history node, selecting 92
keys, setting 291
linking attributes 295
locking attribute values 294
manipulators 288
name abbreviations 284
pop-up menus in 290
precision 285
values, entering with
mouse 289
Channel Control
option 237, 280
channel slider 289
channelBox command 285
channels
data file format 198
defined 241
deleting 57
material, overriding 472
Channels delete option 57
Channels option 203
characterPartition 380
Check Box option 519
check boxes in marking
menus 519
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INDEX

children 300, 306, 322, 329
breaking relationship 308
displaying 301
Clamped animation option 475
clamping options, Script Paint
Tool 447
cleaning up referenced files 196
clearing graph display 352
Click Box Size 477
Click Drag Select modifier
option 476
Click Here to Test box 521
Clipping Planes option 137
Clone. See Duplicate option 58
clusters 368
sets 374
collapsing
nodes 300, 324
sets 371
Color Chooser window 276
Color Feedback option 406
Color in Shaded display
option 136
Color Index Mode option
(IRIX) 124
Color Material option 472
Color Shading option 472
color wheel 277
colors
changing 482
default, changing 482
feedback (paint tools) 406
layer 144
min and max (paint
tools) 406
render layer 150
selection 276
swapping object 347
value 277
Colors customize UI option 482
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Colors window 482
combined transformations 97
rotating 99
scaling 98
command line
absolute values 97
axis origin, changing 79
focus, default 466
moving, rotating, or scaling
from 97
relative values 97
Command Shell option 237
Command(s) option 519
commands
adding to shelf from Script
Editor 499
adding to shelves 498
common edges, detecting 408
complex
models, displaying 123
scenes, display
performance 124
Component Editor 237
modifying data 239
option 236
querying data 238
updating data 240
Component selection mode
pivot points, pinning 77
components
deleting by type 56
editing 237
limiting selection 157, 159
paint-selecting 160
querying data 238
selecting using selection
mask 159
selection mode 476
compound attributes 303
Compressed option 475

compression mode 475
Cone Angle option 138
configuring workspace 539
connecting
default output to input 346
nodes 346
Connection Editor
launching from dependency
graph 346
option 237
connection lines
in dependency graph 340
in scene hierarchy 328
connections
breaking 274, 293
creating default 346
direction of 340
displaying 328
constraining rotations 85
constraint
axis, snapping along 154
constraints 203
connections, displaying 328
Constraints option 203
construction curve 93
construction history 203
deleting 171
effect on speed 170
manipulators 91
turning off 170
tweaking 170
continuous play option 480
controlling node, attributes
connected to 304
coordinates
local 33
system 31, 33
world 33

INDEX

copying
files 184, 190
objects 58
shelf items 500
corners
displaying common 438
selecting common 426
selecting common using
manipulators 434
Create Display Layer
window 141, 148
Create Empty Group option 66
Create Layer option 141, 148
Create Marking Menu
option 512
Create Multiple Objects
option 183
Create Partition option 381
Create Quick Select Set 377
Create Reference option 184,
191, 192
Create Render Node window
launching 356
Create Set option 375
Create Set Options window 383
creating
new materials, textures, or
lights 356
new projects 215
projects 213
scene file 181
culling, backface 472
current
layer 139
project, editing 218
Curve Div per Span option 134
Curve Divisions option 470
curve on surface
creating 172
snapping to 154

curves
arc lengths, measuring 114
constraining on surface 83
construction 93
divisions per span 134
input 93
interpolated, setting
tolerance 473
isoparm, snapping to 154
modification falloff 104
new, display options 470
on surface, moving 83
on surface, snapping to 152,
154
parameter range 93
parameter values,
displaying 111
smoothness, controlling 470
snapping to 152
custom attributes, deleting 271
Custom Polygon Display
Options window 135
CVs
displaying and hiding 133
displaying on new curves or
surfaces 470
modifying
proportionally 100
moving 81
paint-selecting 160
selecting 160, 164
selection type 164
transforming
proportionally 99
unselecting 160, 164
CVs, hiding 125
Cycling Index option 138, 139

D

Data Transfer File Locations 214
Decay Regions option 138
default
input and output
attributes 350
layer 139
nodes, importing 184
Default File Extensions
option 203, 209
Default Home option 40
Default In/Out Tangent
animation options 475
Default Object manipulator 94
Default Object Manipulator
option 94
defaultLayer 371
defaultLightSet 371
defaultObjectSet 371
Deferred References 182
deformers
adjusting operation of 368
complex operations,
controlling 251, 488
connections, displaying 328
geometry, hiding 126
hiding 126, 128
sets 368, 374
skin 368
deformPartition 381
Degree option 102
Delete All Objects by Type
option 57
Delete by Type option 56
Delete Current Layout
option 246
Delete key 56
Delete Marking Menu
option 523
Delete Shelf option 497

DAG nodes, instancing 62
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INDEX

deleting
by type 56
channels 57
hotkeys 530
icons 513
marking menu items 517
marking menus 523
objects 55
objects by type 57
options, setting 57
plug-ins 254, 492
referenced files 194
shelves 497
Dense Wireframe Acceleration
option (NT) 124
dependency graph 319
displaying lights 339
displaying textures 339
how to use 338
materials 339
rebuilding 350
shading groups 339
types of nodes 337
understanding the 337
device drivers, plug-ins 251, 489
directories, mapping
missing 218
Disable Lighting option 406
Disable Nodes command 49
disabling
Hotbox 25
modules 481
display
quality 133
Display Active Vertices
option 406
Display Control Options
window 133
Display Layer Options
window 141, 148
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display layers 139
assigning objects to 141, 148
attributes 146
color, changing 144
creating 141, 148
default 372
import options 475
index number 475
merge options 147, 475
object appearance 146
options 141, 148
removing objects from 142,
149
renaming 141, 148
selecting all objects in 55
Display Level attribute 176
Display Local Axis option 78
Display menu 119
display performance 124
improving 123, 131
Display Polygon Count 122
Display Render Tesselation
Geometry option 135
Display Rotate Pivot option 74
Display Scale Pivot option 74
displaying
edges 136
entire graph in view 358
grid 120
hard edges only 136
hidden objects 355
horizontal graph 364
NURBS components 132
objects 119, 122
objects as semitransparent 123
up and downstream
connections 340
vertical graph 364
vertices 135

distance
locators 107, 109, 110
measuring 107
point, snapping 108
start and end points,
specifying 110
Distance Cutoff option 101, 102
Distance Tool 107
Divisions option 409
divisions per span, curve 134
divisions stroke smoothing 409
Dolly Tool 36
dollying
cameras 36
graph view 356
selected region 357
Don’t Ignore when Rendering
option 266
downstream connections 340
dragging
node from Outliner or
Multilister 344
to reconnect nodes 349
Draw Brush Feedback
option 404
Draw Outline option 404
Draw Outline Trail option 404
Drawing Exchange File file
format 197
Driven by Anim Curve show
option 305
Driven by Expression show
option 305
driven keys 274, 295
Duplicate Input Connections
option 59
Duplicate option 58
Duplicate Options window 59
Duplicate Upstream Graph
option 59

INDEX

duplicating
objects 58
options 59
tools 248, 485
DXF
exporting 207
file format 197
file format, exporting file
in 207
dynamics
menus 5

E
East zone marking menu 26
echoing last action 68
edges
common info, using 408
common, selecting 426
common, selecting using
manipulators 428
displaying 136
displaying common 437
hard 136
hard, displaying 471
numbering 136, 471
paint-selecting 160, 162
selecting 162
selecting CVs along 161
soft 136, 471
Edges display option 471
Edit Bookmarks option 47
Edit Commands tab 494
Edit Marking Menu button 516
Edit Membership option 142,
149
Edit Membership Tool 378
Edit menu 51
Edit Menu Item option 518
edit mode 74, 75, 77, 81, 86, 90

edit points
displaying and hiding 133
displaying on new curves or
surfaces 470
editing objects 352
editors 235
Attribute 235
Attribute Spread Sheet 241
Channel Box 280
Color Chooser 276
Component 237
Connection 237
Expression 275, 295
general 235
limiting information
displayed in 311
Outliner 297
Performance Settings 249,
487
Plug-in Manager 251, 489
Relationship 235
Tool Settings 393
ellipses (...) in graph 357
emitterPaint script 441
empty groups 66
nodes 307, 330
Enable Nodes command 49
environment variables
setting 221
EPS file import 188
evaluation order, position in
Outliner 309
Execute Script Nodes option 182
Expand Popup List modifier
option 477
expanding
nodes 300, 324
set contents 371
Explore file format 197
ExploreGeo file format 197

Export All option 202, 207
Export Selected As Reference
option 192
Export Selection option 193,
202, 207
exporting
animation curves 210
attribute maps (paint
tools) 424
DXF 207
files 207
IGES 207
move files 204
obj file format 205
plug-ins 205
referenced files 193
rendering information 203
RenderMan 207
scene contents 202
wire 207
Expression Editor 236
default, selecting 466
opening from Attribute
Editor 275
opening from Channel
Box 295
expressions 203
connections, displaying 328
delete options 57
Expressions option 203
Extension Padding option 209
Extent option 121
eyedropper tool 277
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INDEX

F
faces
centers, displaying 471
display options 471
displaying 136
normals, displaying 471
numbering 136, 471
paint-selecting 160, 161
subdividing automatically
after selection 410
falloff
curve modification 104
linear modification 101
power modification 102
Proportional Modification
tool 101
script modification 103
Fast Interaction option 467
feedback
brush 404
color (paint tools) 406
Field Chart option 39
file formats
avi 198
movie 198
File Type option 182, 200, 203
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files
absolute paths 214
exporting in IGES or
DXF 207
for shelf button icons 504
formats 184, 197, 198
importing 184, 190
management 179
naming 199
Particulars 193
reference options 191
referenced 191, 193, 194,
195
relative paths 214
saving 198
searching for 215
size, reducing 201
transferring 199
translators, plug-ins 251,
489
Fill option 40
Film Gate option 38
filters 311
moving to shelf 168
Fine option 134
Finite option 408
Flat animation option 475
Flat Shade options 123
flooding, Script Painting
Tool 454
Fly Tool 37
focal length 34
focus, command line 466
Force to Add option 383
Frame Rate 122
frame rate, playback 480
Free playback option 480
free-form hierarchy 335, 337
creating 333

Freeze Transformations
option 169
Freeze. See Templates
option 139
freezing transformations 169
frustrum 38
renderable 39

G
garbage can 499
gate 38
General
Preferences option 73
General Editors 235
Attribute Spreadsheet 241
option 236
Performance Settings 249,
487
Plug-in Manager 251, 489
selecting 236
tools settings 248, 485
geo file format 197
geometry
file format 197
hiding 125, 126
Geometry Motion Blur
option 209
geometryPaint script 441
Gimbal manipulator 87
Gimbal rotate mode 87
Gimbal rotation manipulator 89
global axis 78
changing from command
line 79
global rotate mode 87
Global Scale manipulator
option 469
grabColor command 277

INDEX

Graph Editor, limiting
information displayed
in 311
graphics card, Dense Wireframe
Acceleration option 124
graphs
clearing display 352
dollying view 356
navigation techniques 356
rebuilding 365
tracking 356
turning off updates 361
viewing 356
grid
corners, snapping to 152
default 121
displaying 120
extent 121
hiding 120
options 121
size 121
snapping to 152
specifying appearance 121
stamp compensation 408
style 121
subdivisions 121
Grid option 120, 121, 408
Grid Options window 121
ground plane 32
Group option 185
Group option. Hierarchies (3D
Studio Max). See Group
option 63
Group Options window 63
Group Pivot option 63
Group Under option 63

groups
editing 255
empty 66
imported objects 185
nodes 306, 329
objects 63
options 63

H
Half (12 fps) playback
option 480
Handle Size manipulator
option 469
handles
active 80
active or current 73
attributes 73
color 73
keyframing active 73
manipulator 73
scale manipulator 89
selecting common corners
with 434
selecting common edges
with 428
size, specifying 469
sizing 73
hard edges
backface culling option 472
displaying 471
displaying as solid lines 136
Hardware Texturing option 125
Height animation option 479
help 29
browser options 467
popup 29
hidden objects 355
Hide Cloth option 126
Hide Deformers option 126, 128

Hide Geometry option 125, 126
Hide Kinematics option 125,
127
Hide menu 125
Hide Selection option 125
Hide Unselected CVs 125
Hide Unselected Objects 125
hiding
camera manipulators 126
light manipulators 126
markers 126
objects 125
texture placements 126
Hierarchies (3D Studio Max). See
Ungroup option 64
hierarchy 235
centering node in view 359
creating 66
limiting selection to 166
names, prefixing 308
removing objects from 67
terminology 299
Hierarchy List. See Outliner 235
Highlight option 136
highlighting
colors, changing 482
polygons 471
history
accessing 91
construction 203
modifying 295
node, selecting 92
History option 203
Hold Focus command line
option 466
horizontal layout of graph 342,
364
Horizontal option 40
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INDEX

Hotbox 512
appearance, changing 23
disabling 25
displaying 21
hiding menubars 24
making transparent 24
marking menus 511
menus, changing 23
region option 512
Style option 24
style, changing 24
turning off 25
using 20
using marking menu in 25
zones 21, 25, 26
hotkeys
assigning 526
customizing 493
deleting 530
marking menus 27, 512, 515
paint tools 410
snapping 153
transformations 72
Hotkeys option 25
Hotkeys window 25, 526
categories 530
HSV color model 277
html browser 467
Hull Simplification options 135
hulls
displaying and hiding 133
displaying on new curves or
surfaces 470
Hypergraph 319
layout, updating 351
limiting information
displayed in 311
menu bar 321
opening 320
tool bar 321
using to select a view 38
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I
Icon Filename option 519
icons
bitmap images 502
changing on shelves 502
deleting from marking
menu 513
images on shelves 502
xpm images 502
IGES
exporting 207
exporting file in 207
file format 197
Ignore
Selection Priority modifier
option 477
when Rendering option 266
IK Handle Size kinematics
option 469
IK handles
adding 353
display size, setting 469
hiding 127
selecting 353
Illustrator file import 188
image
displaying as
background 335
file format 198
icon 502
Import option 184, 185
Import Reference option 192

importing 420
animation curves 188
attribute maps 422
files 184
by copying 190
by reference 192
merging layers 147
move files 186
plug-in 205
improving speed,
Hypergraph 361
In Main Maya Window
option 264
In Separate Window option 264
In Tangents, default 475
Include These Inputs option 203
Including Texture Info
option 203
Infinite option 407
information, plug-ins 253, 490
Initial Default option 158
Initial Graphics Exchange
Specification format 197
initialParticleSE 371
initialShadingGroup 371, 372
input
curve 93
nodes 340
INPUTS 281
instance 60
DAG nodes 62
deleting from hierarchy 67
limitations 61
interactive
display 124
hotkeys (paint tools) 412
Interactive Shading option 124
interface
panels 535
turning parts off or on 26

INDEX

interpolated curves
tolerance, setting 473
intersecting surfaces 407
intialParticleSE 372
Invert Reference Vector
option 401
invisible
nodes 326
objects 355
Invisible Manips option 288
isoparms
curve, snapping to 154
displaying 405

J
Joint Size
kinematics option 469
joint1skinPartition 381
joints
display size, setting 469
hiding 127
Journal option 38

K
Keep Hard Edges option 472
Keep Only a Reference
option 203
Keep Original option 93
Keep Wire option 472
Key Selected option 247
Key Ticks option 480
Keyable tab, Attribute
Spreadsheet 241

keys
attribute, setting 273, 291
creating 247
options 475
snapping option 480
kinematics
hiding 125, 127

L
Label option 519
Label tab 494
labels
icon 504
overlay 507
lattices
hiding 128
points, displaying and
hiding 132
shape, displaying and
hiding 132
Layer Attributes option 146
Layer Bar, displaying 140
Layer Editor, displaying 145
layered surfaces 407
layers 139, 146
assigning objects to 141, 148
attributes 146
color, changing 144
creating 141, 148
import options 475
index number 475
merge options 147, 475
moving sets to 369
removing objects from 142,
149
renaming 141, 148
selecting all objects in 55

layouts 539
adding to shelf 540
associated with scene 540
Attribute Spread Sheet 246
changes to 544
configuring 540
creating 540
deleting 544
history, maintaining 544
Scene Independent 540
selecting 539
updating graph 351
Layouts option 45
Layouts option, Panels menu 45
leaf, selecting only 166
lens 34
level of detail 173
adding a level 175
changing threshold
distances 174
creating 173
Display Level attribute 176
orthographic cameras 177
previewing several
objects 176
re-ordering levels 175
Threshold attribute 174
lighting 42
disabling (paint tools) 406
Lighting menu 42
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INDEX

lights
barn doors 138
center of interest 138
cone angle 138
cycling index 139
decay regions 138
dependency graph 339
hiding 126
manipulators 94, 137, 138
manipulators, hiding and
showing 126
penumbra 138
pivot 138
limiting selection
by object type 157
by task 167
object and component 157
to hierarchy items 166
to template objects 166
Line Pick Size manipulator
option 469
Line Size manipulator
option 469
linear
modification falloff 101
stamp compensation 408
Linear animation option 475
Linear units option 472
lines
dotted 136
solid 136
thickness, manipulators 469
live, making objects 171
Load Deferred References,
option 182
Load Menus option 524
Loaded
plug-in option 252, 490
loading
plug-ins 205
referenced files 195
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local
axis 78
coordinates 33
rotate mode 87
rotation axes, displaying and
hiding 132
space, distance locator 110
space, Move tool 82
Local Space option, pivot
points 76
location
of projects 214
locators
arc length 114
creating 105
distance 107, 110
distance, moving 109
moving 105
parameter values 111
parameter, moving 112
repositioning from Attribute
Editor 106
transforming 106
Lock current selection icon 170
locking
attribute values 274, 294
pivot points 77
transform tool or
manipulator 170
LOD 173
lod 173
Long Attribute Names option,
Attribute Spreadsheed 242
Look through Barn Doors
option 138
Look Through Selected option,
Panels menu 37
Looping animation option 480
luminance 419, 420

M
ma file format 196
Make Live option 171
Make New Layers Current 141
managing files 179
manipulators 72
active 80
camera 94
displaying 137
hiding 126
Channel Box 288
color 73
combined Move/Rotate/
Scale 97
default object 94
displaying 137
Gimbal 87, 89
handles 73
displaying and
hiding 132
light 94
displaying 137
hiding 126
locking 170
Move curve on surface 83
Move tool 83
pivot point 74
rotate 86
Rotate tool 85
scale tool 89
selecting
common corners
with 434
common edges
with 428
Show Manipulator tool 91
sizing handles 73
snapping 154
thickness 469
mapping attributes 419

INDEX

Mapping missing
directories 218
marker
animation path 84
hiding 126
marking menus
backup files for 523
creating 511
customizing 493, 509
default 26
deleting 523
deleting icons from 513
Hotbox 25, 463
hotkeys 27, 515
MEL scripts on 522
modifying 516
paint tools 414
restoring backups of 524
right mouse button 28
submenus, adding 520
using 25
zones 512
Marking Menus window 510
marking views 47
masked surfaces, script
painting 454
material channels,
overriding 472
materials dependency
graph 339
Maya
ASCII file format 196
Binary file format 196
Embedded Language file
format 197
projects 213
scene information 214
version and release date 30
MayaToAlias 207
MayaToIgesDxf plug-in 206,
207

Measure menu 107
measure tools 107
measuring arc lengths 114
Medium option 134
MEL 103
file format 197
plug-ins 251, 489
Script Paint Tool 441
script painting 447
MEL commands 237
adding to marking
menu 519, 522
adding to shelf 499
customizing on shelf 507
scene orientation 33
MEL scripts
adding to marking
menu 519, 522
adding to shelf 499
customizing on shelf 507
painting 441
propMod script 103, 105
stroke callback 409
membership editing 235
memory, improving use of 212
menu bars
hiding 24
Hypergraph 321
Outliner 299
menu options
adding to shelves 498
option boxes 17
Menu Set preference 466
menu sets 5
Hotbox 20
menu_ChangePanelLayout.mel
463
menu_ChangePanelType.mel 46
3

menu_ChangeSelectionMask.me
l 463
menu_CommonModelingPanes.
mel 463
menu_ControlPaneVisibility.mel
463
menus
context sensitive 326
Hotbox 23
option boxes 17
quick access 20
selecting 5
merging display layers 147, 475
microCAD systems file
format 197
min and max color (paint
tools) 406
Min Color @ option 406
Min. Length option 428
Minibar 18, 72, 79, 87, 89
adding tool to shelf 498
mirrored painting 398
mirroring brush strokes 398
modeling
aids 151
menus 5
models, complex 123
Modifier Stack. See construction
history 203
Modifiers (3D Studio Max). See
deformers 126
modules
disabling 481
options 481
selecting 5
motion path markers 84
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INDEX

mouse
entering values in Channel
Box 289
marking menu buttons 28,
512
suspending complex
operations during
interaction 249, 487
Mouse button(s) option 512
move command 97
move files 198
exporting 204
importing 186
Move manipulator 83
Move tool 72, 79, 82, 170
coordinate system 82
motion path markers 84
restricting movement 80
tips 81
Move Up and Down shelf
buttons 501
Move/Rotate/Scale tool 97
movement, restricting to one
axis 80
moving
numeric values 95, 97
selection limitations to
shelf 168
Multiple Surf option 400
multiple surface detection 406,
407

N
namespaces 185
native
ASCII file format 196
binary file format 196
Never Save option 201
New Curves option 470
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New File panel option 467
New Layer button 141, 148
New Scene Config panels
option 467
New Surfaces option 470
next view 362
No Gate option 38
No Manips option 288
node state 272

nodes 300, 322
animated 323, 342
attribute names in
dependency graph 340, 342
behavior, changing 272
child 300, 306, 322, 329
collapsing 300, 324
connecting 346
containing param
curves 323, 342
controlling 304
DAG 62
default 184
displaying underworld 326
dragging from Outliiner or
Multilister 344
dragging to reconnect 349
empty group 307, 330
enabling and disabling 49
expanding 300, 324
framing in Hypergraph
view 359
group 306, 329
history, selecting 92
input 340
invisible 325, 326
moving relative position 332
output 340
parent 299, 306, 322, 329
plug-ins 251, 489
renaming 309, 354
reordering in outliner 309
selecting 309, 352
shape 300, 302, 323, 326
slanted boxes 323, 342
subnodes 322, 324
transform 300, 323
types 306
nonlinears, hiding 128
Normal (24 fps) playback
option 480

INDEX

normals
displaying and hiding 133
size 136
size on polygons 471
vertex 135
Normals Size option 136
North zone, marking menu 26
numbering
edges 471
faces 471
vertices 471
numeric input field 15
moving, rotating, or scaling
from 95
numeric values
absolute and relative 95
NURBS
components, displaying and
hiding 132
curves, hiding 126
display options 470
display quality 133
smoothness 133
surfaces, hiding 126
NURBS Components option 132
NURBS Smoothness option 133
NURBS Smoothness Options
window 134

O
obj file format 197
exporting to 199, 200, 205
Object Components option 131
objectName 281

objects
assigning to layers 141, 148
attributes 69, 355
components, displaying and
hiding 131
deleting 55
displaying 119, 122
duplicating 58
editing 51, 352
editing attributes of 355
file format 197
grouping 63, 185
hiding 125, 355
invisible 355
layer apearance 146
limiting selection 157
live 171
moving 79, 97
parenting 66, 306
plug-ins 251, 489
removing from hierarchy 67
removing from layers 142,
149
rotating 85
scaling 89
selecting 51, 352
selection
mode 476
priorities 168
shape, changing 81
showing for just one
view 119
smoothness, controlling 470
snapping to grid, curve,
point, or view plane 152
space coordinate system,
Move tool 82
templates 139, 166
transforming 72
ungrouping 64
unparenting 67
untemplating 139

objExport plug-in 206
On File Save compression
option 475
Only Hard option 136
opacity
brush 392
Script Paint Tool 445
stylus pressure 402
Opacity option 445
Open File panel option 467
Open Scene option 181
opening
Expression Editor 275, 295
scene file 180
scene files 181
operations, complex,
supsending 249, 487
Optimize Scene Size option 212
Optimize Scene Size Options
window 212
optimizing scene size 212
Option Box Command(s)
option 520
option boxes 17
options 101
Orbit Camera. See Tumble
Tool 36
order
rotation 87
rotation channels 89
orientation, changing 33
origin
setting transformations
to 169
Origin Axis 122
Origin option 78
Orthographic option, Panels
menu 41
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INDEX

orthographic view 34
creating 41
Oscillate animation option 480
Out Tangents, default 475
Outliner 235, 297
attributes, displaying in 303
children, displaying 301
limiting information
displayed in 311
menu bar 299
navigating 300
nodes
displaying in 306
renaming 309
reordering 309
selecting 309
opening 298
panel 298
output nodes 340
OUTPUTS 281
overlapping set members,
preventing 379
Overlay Label tab 494
overlay labels 507
Overscan camera attribute 39
Overscan option 40

P
packages
disabling 481
options 481
paint mode 406, 408
Paint Mult option 447
paint offset
Script Paint Tool 446
Paint Offset option 446
paint preview, showing 405
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Paint Selection Tool 160
options 162
radius, brush 163
selection type 164
settings 162
shape, brush 164
Paint Set Membership Tool,
editing sets 378
paint tools 387
Artisan, customizing 393
brush
outlines 390
stroke settings 397
display, customizing 404
multiple surface
detection 406
paint mode 406
profile alignment 402
reflected painting 398
resetting 397
settings, common 396
stamp compensation 406
stylus pressure 401
value options 405
paint-selecting components 160
palette in Color Chooser 278
paletteColors.mel 463
Panel Editor 533
Panel option 44
Panel tab 201
panels 535
arrangements, saving 539
arranging 540
configuration options 467
creating 537
deleting 539
layouts, selecting 539
renaming 535
viewing 535
Panels menu 43, 44
panes, resizing 540

param curves 323, 342
parameter
locators, editing 113
range, changing 93
values, displaying 111
Parameter Tool 111
Parent option 66
Parent Options window 66
Parent to World option 67
parents 299, 306, 322, 329
breaking relationship 308,
331
creating 307, 330
object hierachies 307
object hierarchies 66
removing object from 67
Partial curve range option 93
partitions 379
adding sets to 383
created by Maya 380
created by you 379
creating 381
default 380
defined 379
displaying 382
removing 382
sets, removing from 382
path
absolute 214
animation marker,
moving 84
direction, aligning brush
stamp profile 403
plug-ins 253, 490
Path Direction option 403
Penumbra option 138
performance improvements 212
Performance Settings 249, 487
window 249, 487

INDEX

performance, improving 124,
131, 249, 272, 467, 487
perspective 35, 40
creating view 40
view 40
Perspective option 37, 38, 40
perspective view 34
pick mask 157
pinning pivot points 77
Pivot camera option 137
Pivot light option 138
pivot points 76, 81
defined 74
displaying 74, 132
displaying and hiding 132
manipulator 74
moving 75, 86
pinning 77
scale, moving 90
temporary 77
translate tool 81
unpinning or unlocking 78
World Space 76
Pixel Samples option 209
placements, texture 126
planes
hiding 126
view 152
playback
buttons 7
frame rate, setting 480
range, setting 479
Playback Speed option 480
Playback Start/End options 479

plug-ins
API version 253, 490
auto loading 252, 490
features 253, 490
importing 205
information about 253, 490
loading 252, 489
manager 251, 489
MayaToIges 206
MayatoIges 207
objExport 206
path 253, 490
references, removing 254,
492
unloading 254, 492
version 253, 490
point snap hotkey 153
Point to Point option 155
points
cluster 374
measuring distance
between 107
snapping 152, 155
snapping to 152
Points option 123
Pole Tolerance option 428
Polygon Components
option 135
polygon count 122

polygons
border width 471
components, displaying 135
display options 471
displaying as triangles 471
faces, displaying 471
normal size, specifying 471
numbering faces, edges, or
vertices 471
paint mode 408
painting on using
Artisan 407
surfaces, hiding 126
texture border, thickening
display 471
Pop HotBox hotkey 25
popup help 29
popup menu
Channel Box 290
Popup Menu Selection modifier
option 477
Popup Submenu option 521
Positional tolerance option 473
power modification falloff 102
PowerAnimator file formant 197
Predefined Bookmarks
option 47
pre-defined tabs, Attribute
Spreadsheet 247
preferences
files 462, 463
saving using
userSetup.mel 464
setting 461
stored location 462
user interface 201
Prefix with option 203
Preserve Position option 63, 66,
67
pressure, stylus 401
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INDEX

PreView file format 198
Previous State Size manipulator
option 469
Previous View option 40
previous view, returning to 361
priority
for object selection 168
priority preference 478
profile
alignment 402
projective paint 407
Projective Paint option 408
projects
categories and locations 214
creating new 215
definition of 213
directories 213
editing 218
setting 217
propmod 99
propMod script 103, 105
Proportional Modification
tool 99, 101
proportional scaling 89
proportional transformations 99
falloff 101

Q
quality
display 133
shading 122
querying component data 238
Queue option 481
Queue Size option 68, 481
Quick Select Set option 55, 377
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R
Radio Button option 519
radio buttons in marking
menus 519
radius
brush (paint tools) 392
Paint Selection Tool 163
Script Paint Tool 444
stylus pressure 402
Radius option 444
RAM, freeing 481
Range Slider 7
options 479
range, parameter 93
rebuilding graph 350, 365
Recent Commands
option 22
Recent Files 181
Redo option 68
redoing actions 68
Redraw All Views option 405
redraw options 250, 488
reference
layers 139
vector, inverting 401
Reference Editor 192, 194
Reference option 191
referenced files 191
cleaning up 196
exporting 193, 201
importing 193, 201
loading/unloading 195
removing 194
replacing 195
selecting objects from 194
references
deferred 182
plug-in 254, 492

reflected painting 398
non-symmetrical 400
polygons 409
Reflection option 399
Refresh option 405
refresh options 250, 488
Region of Affect 468
region, dollying 357
Relationship Editor 235, 255
creating relationships 259
editing sets 378
limiting display 258
limiting information
displayed in 311
objects, displaying 257
opening 256, 369
relationships, displaying 257
sets 375
view options, setting 256
Relationship Editors option 369
relationships 260
adding members 261
creating 259
displaying 257
editing 255
removing members 261
selecting members 260
relative paths of files 214
relative values
command line 97
entering 96, 245, 287
release date 30
Remember this Layout
option 246
Remove Instance option 67
Remove Reference option 192
removing referenced files 194
Rename Layer window 141, 148

INDEX

renaming
layers 141, 148
nodes 309, 354
Render File Locations 214
rendering
exporting information 203
menus 5
resolution 38
RenderMan
exporting 207
format 197
renderPartition 380
reordering
nodes in Outliner 309
shelves 501
Repeat on Hold sound
option 478
Repeat Size sound option 478
repeating actions 68
replacing referenced files 195
resetting transformations 169
Resolution Gate option 39
resolution, wireframe 468
Resolve Name Clashes by
option 186
restoring backup marking
menus 524
reversing actions 68
revolve history node 92
revolving cameras 36
RGB color model 277
RGB, RGBA options 420
RIB file format 197
ribExport plug-in 207
right mouse button, marking
menus 28
Roll Tool 36
rolling cameras 36
root, selecting only 166

rotate
axis 88
channels, animating 89
combined
transformations 99
command 97
modes 87
numeric values 95, 97
objects 85
order 87, 88
pivot point, moving 86
pivot points, displaying 132
Rotate tool 72, 85, 170
manipulators 86
Rough option 134
Run Up From dynamics
option 473
Run Up To Current Time
dynamics option 473

S
Safe Action option 39
Safe Title option 39
Save All Shelves button 494
Save All Shelves option 501
Save File option 201
Save File panel option 467
saving
Attribute Spread Sheet
layouts 246
files 198
scene information 214

scale
combined transformation 98
command 97
numeric values 95, 97
objects 89
pivot point 90
pivot points 132
proportionally 89
Scale tool 72, 89
manipulator 89
Show Manipulator tool 170
Scene Configurations 201
scene file
creating 181
opening 180
Scene File Locations 214
scene hierarchy 324
automatic layout 334
creating free-form 333
defined 319
displaying background
image 335
displaying special nodes and
connections 326
parenting 329
rearranging nodes 331
terminology 299, 322
Scene Independent layouts 540
scenes
display performance 124
exporting 202
hierarchy 235
importing 184
lighting 42
opening 181
optimizing size 212
panel configuration options,
setting 467
referencing 190
saved information 214
too big to fit window 537
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INDEX

Schematic window. See
Hypergraph 319
screen
refresh options 250, 488
refreshing (paint tools) 405
space stroke smoothing 409
Screen Space option 409
Script Editor option 237
Script Editor, adding command
to shelf 499
Script Nodes 182
Script Paint Tool 441, 447
add operation 446
flooding 454
opacity 445
options 442
paint offset 446
radius 444
replace operation 446
scale operation 446
shape 445
smooth operation 446
value 445
script painting 447
masked surfaces 454
seams 438
scripts 237
customizing on shelf 507
modification falloff 103
on marking menus 519, 522
propMod 103, 105
sculpt objects, hiding 128
Seam & Pole Tol. option 428
Seam Tolerance option 428
seams (paint tools) 426
attribute painting 438
defined 426
script painting 438
tolerance 428
weight painting 438
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searching for files 215
Select All by Type option 53
Select All History option 92
Select All option 52
Select brush option 164
Select Corners option 435
Select Edges option 428
Select Hierarchy and
Combinations icon 166
Select Reference Contents
option 192
Select tool 72
selecting 260
components 159, 160
CVs 160, 161, 164
IK handles 353
multiple text boxes 244, 287
nodes in Outliner 309
objects 51, 53, 352, 368
template objects 166
vertices 160, 164
selection
handles, displaying 132
limiiting by object type 157
limiting by component 159
limiting by task 167
masks 27, 157
priority 168, 478
type 164
Selection Mask options
window 81
set color, using (paint tools) 406
Set Driven Key option 274, 295
Set Named Selection. See Quick
Select Set option 55
Set Project option 217

INDEX

sets
addiing to partitions 383
adding members 378
automatically created 367
cluster 368
collapsing 371
created
by Maya 371
by you 370
creating 375
creating for easy object
selection 377
default naming of 371
defaultLayer 371
defaultLightSet 371
defaultObjectSet 371
defined 367
deformer 368, 374
displaying in Relationship
Editor 379
editing 255
expanding a set’s
contents 371
explained 369
indentation 371
initialShadingGroup 372
intialParticleSE 372
member weights 368
membership, editing 378
overlapping members,
preventing 379
quick select 377
removing 377
from partition 382
members 378
selecting 376
all objects in 55
contents only 371
quickly 377
shading group 371, 372
simplifying selection
with 368

skin point 368, 374
user-created 367, 368
uses 368
setting
key attributes 273
performance 249, 487
project 217
Shade options 123
Shaded Divisions option 470
shaded objects
smoothness, controlling 470
wireframe on 468
Shaded Surface Div per Span
option 135
shading
applying to all objects 125
interactive 124
quality 122
shading groups
changing selected 348
display example 339
displaying in dependency
graph 339
sets 371, 372
sets Maya creates 372
Shading menu 122
shape
brush 393
Paint SelectionTool 164
Script Paint Tool 445
shape nodes 300, 323
displaying 326
displaying in Outliner 302
Shape option 445
SHAPES section 281
Shelf Contents tab 494

shelves
bookmarks, adding 49
commands, adding to 499
copying items 500
creating 493, 495
customizing 493
deleting 497
duplicating tools 248, 485
editing 493
icons, changing 502
items, adding to 498
layouts adding to 540
MEL commands,
customizing 507
moving filters to 168
moving items between 500
removing items from 499
renaming 501
reordering 501
reordering items on 500
using 6
Shelves tab 494
Shelves window, opening 494
Short Attribute Names option,
Attribute Spreadsheet 242
Show Active Lines option 405
Show All Panes option 45
Show Auxiliary Nodes 316
Show Item Numbers option 136
Show Manipulator tool 72, 91
default manipulator 94
history node 92
lights and cameras 94
Show menu 119, 311
Show Only Viewing Panes
option 45
Show Preview option 405
Show Selected Columns Only
option 246
Show Text box 311
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INDEX

shutters on spotlight 138
simplification, hull 135
Single File Output option 209
Single Marquee Select modifier
option 476
size
handles 469
IK handle 469
joints 469
manipulators 469
scene, optimizing 212
skin points
sets 368, 374
slanted boxes 323, 342
Smart Transform option 59
Smooth Shade options 122
smooth skin influences
hiding 128
smoothing stroke options 409
smoothness
NURBS 133
setting 470
Snap
to Curves option 152
to Grids option 152
to Points option 152
to View Planes option 152
Snap Align Objects option 155
snap axis 155
Snap to curves icon
for distance measure 108
Snap Tolerance 478
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snapping 151
aligning objects 155
along a constraint axis 154
animation option 480
distance measure point 108
hotkeys 153
icons 151
to a curve on surface 154
to a curve or curve on
surface 152
to a point 152
to a view plane 152
to an isoparm curve 154
to grid corners 152
soft edges
backface culling 472
displaying 471
displaying as dotted
lines 136
softBodyPaint script 441
sound 183
animation options 478
File Offset option 183
repeating on hold 478
sound synching 479
South zone
marking menu 26
space bar 20
Specify Selected Lights
option 43
speed of Hypergraph,
mproving 361
spherePaint script 441
Spline animation option 475
spread sheet, attribute 235
Spreadsheet window. See
Attribute Spread Sheet 241

stamp 391
compensation 406
compensation mode 408
profile 163, 444
profile alignment 402
Standard Manips option 288
Static Channels, delete
options 57
Stepped animaton option 475
stitching
importing attribute
maps 422
surfaces 438
stroke 391
callback 409
outline trail 404
outlines 404
reflecting 398
settings, paint tools 397
smoothing 406
smoothing options 409
Style option 121
stylus pressure 401
subCurve 93
subdivisions
faces, automatically after
selection 410
grid 121
option 121
Submenu Editor 521
submenus, adding to marking
menus 520
subnodes 322, 324
Sudivision surfaces, hiding 126
Surface Div per Span
options 134
Surface Divisions option 470
surface history 91

INDEX

surfaces
arc lengths, measuring 114
complex operations,
controlling 250, 488
detection 407
flooding 454
intersecting 407
making live 171
moving curves on 83
new, display options 470
parameter values,
displaying 111
smoothness, controlling 470
stitching 438
suspending complex
operations 249, 487
symmetrical painting 398

T
tabs
pre-defined, Attribute
Spreadsheet 247
Tangential tolerance option 473
tangents, weighted 475
Tape. See Measure menu 107
task, limiting selection to 167
Tear Off Copy option, Panels
menu 45
Tear Off option, Panels menu 45
template objects
creating 139
limiting selection to 166
returning to standard
display 139
untemplating 139
templates
layer 139
Templates option 139

text boxes
selecting multiple 244, 287
texture border
thickening display 471
Texture Border option 136, 471
Texture Coordinates option
UV topology 136
texture paint 407, 409
Texture Placements option 126
Texture Space option 409
textures
displaying in dependency
graph 339
graph display example 349
mapping to attributes 275
Threshold attribute 174
TIFF file format 198
time ranges, setting 479
Time Slider 7
time slider
height, adjusting 479
key ticks option 480
options 479
time to video standard timecode,
default 480
Time units option 472
Timecode animation option 480
Timecode Offset option 480
timecodes
matching timing from
videotape 480
Toggle brush option 165
toggling CV selection 165
toggling vertice selection 165
tolerances
pole 428
seam 428
tool bar, Hypergraph 321
tool settings 248, 485

Tool Settings option 248, 485
Tool Settings window 82, 393
tools 72
adding to shelf 498
adding to shelves 498
Artisan 388
camera 36
defined 18
dragging to shelf 493
duplicating 248, 485
duplicating on shelf 500
Minibar 72
paint 388
plug-ins 251, 489
setting options 248, 485
tooltips 29
Track Tool 36
tracking
cameras 36
graph view 356
transferring objects to
layers 141, 148
transformations
combining 97
freezing and resetting 169
Move/Rotate/Scale tool 97
nodes 300, 323
pivot points 74
rotate attributes 88
tools, locking 170
using Numeric Input field 96
transforming objects
from command line 97
Move tool 79
moving tips 81
restricting movement 80
rotation 85
transition speed, changing 360
translate pivot point 81
triad option 83
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INDEX

triangles, displaying polygons
as 471
Truck Camera. See Track Tool 36
Try to Add option 383
Tumble Tool 36
tweaking construction
history 170
Twice (48 fps) playback
option 480
Two Points to To Points
option 155
Two Sided Lighting option 43
type
deleting object components
by 56
deleting objects by 57
selecting by 53
Type Is option 186

U
U Dir or V Dir option 399
U Tangent option 402
U tangent, aligning brush stamp
profile 402
UI Preferences
window 201
Uncompressed option 475
underworld nodes,
displaying 326
undo
actions 68
setting number of 481
Undo option 68, 481
Ungroup option 64
ungrouping
objects 64
Units options 472
units preferences 472
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unloading
plug-ins 254, 492
referenced files 195
unlocking
attributes 275, 294
pivot points 78
tools 170
Unmap Key button 25
unparenting objects 67
unpinning pivot points 78
Unselect brush option 164
unselected objects, hiding 125
unselecting
CVs 160, 164
vertices 160, 164
untemplate 139
Up Axis coordinate system
option 472
up axis, changing 33
Up Vector option 403
up vector, aligning brush stamp
profile 403
update options,
Hypergraph 361
Update View animation
option 480
upstream and downstream
connections 340
Use All Lights option 42
Use Common Edge Info
option 408
Use Current Layer option 142
Use Default Lighting option 42
Use Marking Menu in
option 512
Use Namespaces option 185,
203
Use Previously Specified Lights
option 42

Use Selected Lights option 42
Use Set Color option 406
Use Verbose Names option 183,
200
Use Verbose Names options 203
User defined anim curve
option 104
User defined script option 103
user interface
file, turning off creation 201
preferences files 463
userColors.mel 463
user-created sets 367, 368
userHotkeys.mel 463
userNamedCommands.mel 463
userPrefs.mel 463
userRGBColors.mel 463
userSetup.mel 464
UV Texture Paint option 408
Update 83
UVs, numbering 136

V
V Tangent option 403
V tangent, aligning brush stamp
profile 403
Value option 445
values
absolute 97
brush 392
numeric, entering 95
range 446
relative 97
Script Paint Tool 445
version
and release date 30
vertex normals, displaying 135,
471

INDEX

vertical layout of graph 342, 364
Vertical option 40
vertices 164
aligning 154
display options 471
displaying 135
numbering 136, 471
paint-selecting 160
selecting 160, 164
unselecting 160, 164
Vertices option 471
view
centering branch 360
centering node
hierarchy 359
centering nodes 359
changing transistion
speed 360
dollying graph 356
history 361
next 362
returning to prior 361
tracking graph 356
View Arrangement option,
Window menu 45
View Axis 122
view menu bars, hiding 24
view planes, snapping to 152
views
arranging 43
changing in current panel 26
displaying 45
laying out 45
marking 47
saving in layouts 540
selecting with
Hypergraph 38
switching between 27

W
walk throughs 37
WAVE file format 197
Waveform Display sound
option 478
waveform, displaying 478
Wavefront, exporting to 205
weight painting seams 438
Weighted Tangents key
option 475
weights, set member 368
West zone marking menu 27
white boxes in dependency
graph 340, 342
Whole Face polygon selection
option 477
Window Options option,
Hotbox 24
Window Selection help browser
option 467
Window Visibility help browser
option 467
windowPrefs.mel 463
windows
changing layout 26
wire
exporting 207
file format 197
wireframe
backface culling 137, 472
displaying 123
displaying on shaded
objects 468
option 122
resolution 468
shade option 123
Wireframe on Shaded
option 468
working units options 472

World Coordinate System
option 33
world space 33
Move tool 82
World Space option 76
wrap influences, hiding 128

X
xpm images for shelf icons 502
X-ray shade option 123
XYZ coordinate system 31

Y
Yaw Pitch Tool 37
yellow nodes 353
Y-up orientation 31

Z
zones
Hotbox 21
marking menu 512
marking menu defaults 26
Zoom Tool 36
zooming cameras 36
Z-up orientation 32

USING MAYA: ESSENTIALS
571

INDEX

USING MAYA: ESSENTIALS
572

