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Installing the Sample Files into a Folder 
 
 
Installing the sample files 
 
• Use the Windows Explorer to create a folder called Flash 5 Advanced Samples, just below 

the My Documents folder. 
• Copy the sample files from the ECDL_Training\work\Flash-5-advanced folder to the My 

Documents\Flash 5 Advanced Samples folder. 
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Frame Actions 
 
 
To Create Frame Labels 
 
• NOTE: If you have completed our Flash 5 Intermediate course, you can use the files you 

have created in the previous exercises.  If you do not want to alter your original file, we have 
already done all the work for you, just use the sample file mexico17.fla located in the Flash 
5 Advanced Samples Folder. 

 
Start with the Original File: 
• Use the Windows Explorer to create a folder called Flash 5 Advanced Work Folder, just 

below the My Documents folder. 
• Locate and open your version of mexico17.fla file. 
 
 
OR Start with the Sample File: 
• Use the Windows Explorer to create a folder called Flash 5 Advanced Work Folder, just 

below the My Documents folder. 
• Open the mexico17.fla from the Flash 5 Advanced Samples Folder. 
 
• In this exercise we will begin the process of turning the Scene 1 from the day scenery into the 

night scenery. 
• Insert a new Layer and name it "Labels". 
• Select frame 1, open the Frame Panel and name the label "Day". 
• Insert a keyframe at frame 10, labeling it "Night": 

 

 
 

• Your timeline should now look like this: 
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• Select the "Sky" shape on the stage and change the colors to a dark blue night color, using 

the Fill Panel: 
 

 
 

• Then, select the “Ground” shape and change the colors to a darker brown. 
• Just above the “Sun” layer, insert a new layer and name it "Moon". 
• In the “Moon” layer, insert a keyframe at frame 10. 
• Still in the frame 10, draw a full "Moon" circle shape; convert it to a graphic symbol and 

position it over the "Sun" symbol. 
• Convert “Moon” to a button symbol named "Moon Button": 

 

 
 

• Double click the "Moon Button" to edit symbol. In the Over button state, change the color of 
the "Moon" to a paler yellow. 

• Add a sound to the Down button state. 
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• Back on Scene 1, in the “Sun” layer, insert a blank keyframe at frame 10 (we don’t want the 

“Sun” to be displayed in the “Night” scene). 
• Insert a Frame at frame 30 on all layers, except the "Sun" layer. 
• Use File > Save As to save the movie in your Flash 5 Advanced Work Folder. 
• Save File as mexico18.fla 
• Open the mexico18.fla from the Flash 5 Advanced Samples folder to see an example. 
 
 
To Create Frame Actions 
 
• Now you will create various stars, twinkling in the night sky. 
 
• Still in the mexico18.fla file, just above the “Moon” layer, insert a new layer and name it “Star 

1”. 
• Draw a small “star” shape, convert it to a graphic symbol and name it “Star 1”: 

 

  
 

• Insert five more layers, naming them “Star 2” through to “Star 6”. 
• Draw a “Star” shape in each layer, and convert each “Star” to a graphic symbol naming them 

“Star 2” through to “Star 6”. 
• Position each “Star” instance on the stage across the "Night” sky. 
• Insert a keyframe at frame 30 on all layers, except the "Sun" layer. 
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• On each “Star” layer, insert keyframes at staggered intervals along the timeline and create 

motion tween in between them: 
 

 
 

• At each keyframe, using the Transform Panel, change the Scale of the “Star” instances so 
that the stars "twinkle": 
 

 
 

• At the top of the layer list, insert a new layer named "Actions". 
• Open the Actions Panel (Window > Actions). 
• Insert a keyframe at frame 1 of the “Actions” layer. 
• In the Toolbox List, double click on Basic Actions book, and then double-click Stop action.  

The action script syntax will appear in the right hand window: 
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• Now insert a keyframe at frame 10 of the “Actions” Layer. 
• In the Toolbox List, double-click on Play action: 

 

 
 

• Still on the same layer, insert a keyframe at frame 30 and double-click Go To action. 
• Enter "10" in the Frame box.  Make sure that Go to and Play is checked (this will loop the 

"Night" scene from frame 10 to frame 30 continuously): 
 

 
 

• Save File as mexico19.fla 
• Open the mexico19.fla from the Flash 5 Advanced Samples folder to see an example. 
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Button Actions 
 
 
To Assign Actions to a Button Symbol 
 
• Now we will assign actions to the "Sun" and "Moon" buttons. 
 
• Still in the mexico19.fla file, select the "Sun" button on the stage and open the Actions 

Panel. 
• In the Toolbox List, open the Basic Actions book and double-click the On Mouse Event 

action.  Note that the default on (release) script is inserted. 
• Now, double click on Go To action. 
• In the Parameters Area, select Frame Label and choose "Night" label. 
• Ensure the Go to and Play box is checked: 

 

 
 

• In frame 10 of the "Moon" layer, select the "Moon" button on the stage. 
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• Assign the Go To actions with "Day" frame label.  Uncheck the Go to and Play box: 

 

 
 

• Test the Movie.  The movie will stay still until you click on the "Sun" button, then it will display 
the "Night" scene with the "Star" animation.  "Night" scene will loop continually until the 
"Moon" button is clicked and the scene returns to "Day". 

• Save File as mexico20.fla 
• Open the mexico20.fla from the Flash 5 Advanced Samples folder to see an example. 
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Movie Clip Actions 
 
 
To Assign Actions to a Movie Clip Symbol 
 
• Now we will create the "Star" animation in a different way by adding it to a Movie Clip, and 

therefore reducing the overall file size. 
 
• Open the mexico18.fla again. 
• Insert a Frame at frame 20 in all layers, except the "Sun" layer. 
• Open as Library the mexico20.fla file.  Drag the “Star 1” graphic symbol from the 

mexico20.fla Library into the mexico18.fla Library.  Now you have a “Star 1” symbol in 
your current Library.  

• Rename the symbol to "Star". 
• Create a New Movie Clip Symbol named “Star Movie”. 
• Double click the “Star Movie” in the Library to edit symbol.  Name the default layer "Stars". 
• At frame one, drag the “Star” graphic symbol onto the stage. 
• Insert a keyframe in frames 10, 20, 30, 40, 50 and 60. 
• Insert a new layer named “Labels” and insert keyframes to match the "Stars" layer. 
• At frame 1, using the Frame Panel, name the Label "Star1".  Continue naming each of the 

following keyframes “Star 2” to “Star 6”: 
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• In the “Stars” layer, in each keyframe (1-10-20-30-40-50), using the Transform Panel, 

change the scale (constrained) of the “Star” instances.  Also, using the Effects Panel, 
change the Alpha or Brightness values to make the "Star" twinkle: 
 

 
 
Example:  
Star1  scale=100%   alpha=50% 
Star2  scale=20%    alpha=100% 
Star3 scale=75%    alpha=60% 
Star4  scale=40%    bright=80% 
Star5  scale=100%   alpha=60% 
Star6  scale=30%    bright=60% 

 
• Insert Motion Tweens in between keyframes. 
• Return to the main timeline. 
• Insert a new layer and name it "Stars": 

 

  
 

• With this as the active layer, drag six (6) “Star Movie” movie symbols onto the stage and 
place them across the "Night" sky. 

• Select each "Star" instance in turn, and using the Instance Panel, name each one “Star1” to 
“Star6”. 

• Select “Star1” instance and open the Actions Panel.  Open the Actions book and double-
click the OnClipEvent action (Note that the default onClipEvent (load) action will be 
automatically inserted). 

• Double-click the with action.  Notice that the parameters will be highlighted in red. 
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• Click on the Insert a Target Path icon at the lower right corner of the Panel (Blue "cross-

hair" icon).  If the cross-hair icon is grayed out, make sure that your cursor is inside the 
Objects field: 
 

 
 

• This will bring up the Insert Target Path window.  In order to see all the instances in your 
movie, make sure that you select Dots and Absolute. 

• Now you should see the list of "Star" instances. 
• Double-click the "Star" in the list (e.g. Star1): 

 

 
 

• This will automatically add the full path of that instance to the with action. 
• With the action still highlighted, double-click Go To action in the Basic Actions book.  This will 

add the gotoAndPlay script. 
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• Under Type, select Frame Label, and under Frame, enter “Star1”: 

 

 
 

• Repeat the above for all remaining "Star" instances on the stage, each time changing the 
Frame Label name.  Example: “Star2” instance will gotoAndPlay (“Star2”) frame label, etc. 

• In the main timeline, insert a new layer and name it "Actions": 
 

  
 

• In frame 1, add stop (); action. 
• In frame 10, add play (); action. 
• In frame 20, add gotoAndPlay (10); action. 
• On the stage, select the "Sun" button. 
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• In the Actions Panel, add On Mouse Event (release) and gotoAndPlay ("Night") actions: 

 

  
 

• On the stage, select the "Moon" button. 
• In the Actions Panel, add the On Mouse Event (release) and gotoAndPlay ("Day") actions. 
• Test the Movie.  Same as in the previous exercise, the movie will stay still until you click on 

the "Sun" button, then it will display the "Night" scene with the "Star" animation.  "Night" 
scene will loop continually until the "Moon" button is clicked and the scene returns to "Day".  
Only this time we didn’t need to create separate “Star” animations, but instead we have used 
(and re-used) one movie clip for all the stars. 

• Save File As mexico21.fla 
• Open the mexico21.fla from the Flash 5 Advanced Samples folder to see an example. 
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To Create a Draggable Movie Clip 
 
• In this exercise, we will create a draggable movie clip using the "Mayan" button, to enable the 

user to drag and drop the "Mayan" Button anywhere on the stage. 
 
• Still in the mexico21.fla file, click on the "Mayan" button on the stage and convert it to a 

Movie Clip Symbol.  Name it "Mayan Button Movie": 
 

 
 

• Double-click the "Mayan Button Movie" instance on the stage to Edit Symbol. 
• Now select the “Mayan Button” instance (inside the “Mayan Button Movie” timeline) and open 

the Actions Panel. 
• Double-click the On Mouse Event in the Basic Actions book.  Check Press and uncheck 

Release event: 
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• Double-click startDrag in the Actions book, and enter the Constrain parameters. (Note: Use 

the Info Panel to find out the L = Left, R = Right, T = Top and B = Bottom constrain values): 
 

 
 

• Check Lock mouse to center. 
• Add another On Mouse Event in Basic Actions, leaving the default Release as checked. 
• Double-click stopDrag in Actions. 
• Test the movie.  The "Mayan" object can now be dragged and dropped anywhere within the 

stage. 
• Save File As mexico22.fla.  
• Open the mexico22.fla from the Flash 5 Advanced Samples folder to see an example. 
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Programming With ActionScript 
 
 
To Set Movie Clip Properties 
 
• Now we will create a new Flash movie where we can put into practice some powerful Actions, 

like changing the object transparency. 
 
• Create a new movie and name it “quiz1.fla”. 
• This movie should have the same properties as our Mexico movies: 12 fps, W = 550 pix, H = 

400 pix, and white background color. 
• Create new movie clip symbol named “Background Movie”. 
• In the Edit Symbol mode, set fill color to dark green: 

 

 
 

• Draw a large green rectangle to be used as the background image for our movie (W = 550, H 
= 400). 

• Place the instance of this symbol onto the Stage and center it.  Note: This clip should totally 
cover the white background of the Stage. 

• Name this instance “Background”: 
 

 
 

• Rename the default layer to “Background”. 
• Insert a new layer and name it “Buttons”. 
• Create new button symbol and name it “Background Button”. 
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• In the Edit Symbol mode, draw a small black square (W = 13.5, H = 13.5): 

 

 
 

• Select “Buttons” layer and place five instances of this symbol to the Stage.  Position them in 
the bottom left corner: 
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• Change the Alpha Effect of button instances as follows: 

Button 1 = Alpha 100% 
Button 2 = Alpha 80% 
Button 3 = Alpha 60% 
Button 4 = Alpha 40% 
Button 5 = Alpha 20%: 
 

 
 

• You will now have five buttons with different levels of transparency: 
 

 
 

• Select first button and open the Actions Panel.  From the Basic Actions, double-click the On 
Mouse Event action.  Check the Release and Roll Over events: 
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• From the Actions, double-click the setProperty action.  You will notice that the warning will 

show on the script line: 
 

 
 

• Under Property, select _alpha (Alpha): 
 

 
 

• Enter the Target field and click the Insert a target path icon: 
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• In the Insert Target Path window, select the Background instance.  Note: The _root will be 

automatically added to the full path, presenting the root of the current movie: 
 

 
 

• Under Value, enter 100.  This will make the Background clip 100% Alpha, meaning non-
transparent: 
 

 
 

• Now repeat the same process for the rest of the buttons, changing only the Value to 80, 60, 
40, and 20 respectfully.  Note: You can copy and paste the script, then change the Value. 

• Test the movie.  When you roll the mouse over the buttons, the background transparency will 
change: 
 

 
 

• Save File As quiz1.fla.  
• Open the quiz1.fla from the Flash 5 Advanced Samples folder to see an example. 
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To Create the Input Text 
 
• In this exercise, you will start working with variables.  We will create the form with input fields 

to gather the information from the user. 
 
• Still in the quiz1.fla file, insert the new layer just above the “Background” layer and name it 

“Images”. 
• We have prepared the artwork for you in order to speed up the exercises.  From the File 

menu, select Open as Library and open Artwork.fla file from the Flash 5 Advanced 
Samples folder. 

• Drag the “man1” graphic symbol from the Artwork Library onto a Stage, and position it on the 
top left side: 
 

 
 

• Now insert a new layer above the “Images” layer, and name it “Text”. 
• In the “Text” layer, using the large, bold, white font, type the title “Quiz about Mexico”, and 

position it on the top right side of the Stage. 
• Then type some information, using smaller white font: “First, we would like to know more 

about you.  When you finish typing the information, click on the hand icon to continue...” like 
this: 
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• Using the Text Options Panel, insert an Input Text box.  For the Variable name enter 

“First”.  For the Embed fonts select upper and lower case characters.  This will be a field 
where users will enter their first name.  Type the “First name” label beside the Input Text field: 
 

 
 

• Using the same procedure, create another Input Text box, and enter “Last” for the Variable 
name. 

• Now create another Input Text box and enter “Age” for the Variable name.  This time for the 
Embed fonts select only numbers: 
 

 
 

• Save File As quiz2.fla.  
• Open the quiz2.fla from the Flash 5 Advanced Samples folder to see an example. 
 
 
To Create the Dynamic Text 
 
• Now you will display the text that the user has inputted earlier. 
 
• Still in the quiz2.fla file, at the top of the layer list, insert a new layer and name it 

“Navigation”. 
• Open as Library the Artwork.fla file. 
• From the Artwork Library, drag the “Hand Button” symbol onto the Stage.  Position the 

button at the bottom right corner of the Stage. 
• Now insert a new layer and name it “Labels”. 
• In the “Labels” layer, at frame 1, insert a Frame Label “Start”. 
• Insert another layer and name it “Actions”. 
• In the “Actions” layer, at frame 1, insert a stop (); action. 
• At frame 10, insert Keyframes for each layer. 
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• In the “Labels” layer, at frame 10, insert a Frame Label “2nd”. 
• In the “Buttons” layer, at frame 1, select the “Hand Button” instance and add the 

gotoAndStop ("2nd"); action.  Make sure that the Go to and Play option is un-checked: 
 

 
 

• In the “Images” layer, at frame 10, delete the “man1” instance from the stage and replace it 
with the “man3” graphic symbol from the Artwork Library. 

• In the “Text” layer, at frame 10, change title text to “Quiz Results”. 
• Still in the “Text” layer, at frame 10, delete the information text, all input text boxes and labels. 
• Using the Text Options Panel, insert a Dynamic Text box.  For the Variable name enter 

“NameCalc”.  For the Embed fonts select upper and lower case characters and numbers.  
Make sure that you have checked Word wrap option.  This will be a field where the user’s 
name and age will be displayed: 
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• In the “Actions” layer, at frame 10, insert the set variable action.  Under Variable enter the 

Dynamic Text variable name from the previous step, “NameCalc”.  Under Value, enter the 
following: "Your name is "+First+" "+Last+", and you are "+Age+" years old."  Make sure 
that the Expression option is checked: 
 

 
 

• Test the movie.  Enter your data in the form and click on the hand button.  This will take you 
to the results page with your data displayed on the stage. 

• Save File As quiz3.fla.  
• Open the quiz3.fla from the Flash 5 Advanced Samples folder to see an example. 
 
 
To Write Scripts Using the Dot Notation 
 
• In this exercise you will change your script code to be more efficient and shorter. 
 
• Still in the quiz3.fla file, in the “Buttons” layer, select the first button and open the Actions 

Panel. 
• The button action looks like this: 

 

 
 

• Now, enter the Expert Mode in the Actions Panel: 
 

 
 

• Select the setProperty… script line and rewrite the script using the Dot Notation style: 
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• Repeat the same process for all buttons changing only the alpha values to 80, 60, 40, and 20 

respectfully. 
• Still in the “Buttons” layer, select the frame 10, and Clear Keyframe: 

 

 
 

• Repeat the same step for the “Background” layer.  All other layers will stay the same, with 
Keyframes at frame 10.  Note: Removing the un-necessary Keyframes from your movie, will 
save the file size. 

• Test the movie.  The movie will work same as before, but now the code is much shorter.  
Using the Dot Notation will reduce the lines of code, therefore reducing the computer 
processing and speeding up the movie playback. 

• Save File As quiz4.fla.  
• Open the quiz4.fla from the Flash 5 Advanced Samples folder to see an example. 
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Smart Clips 
 
 
To Add Radio Button Smart Clips 
 
• In this exercise, you will create a multiple choices quiz using the Radio Button smart clips. 
 
• Still in the quiz4.fla file, in the “Labels” layer, insert a keyframe at frame 5. 
• Label that frame “1st”. 
• In the “Images” layer, insert a keyframe at frame 5. 
• Still in the “Images” layer, at frame 5, delete the “man1” instance from the stage and replace 

it with the “man2” graphic symbol from the Artwork Library. 
• In the “Text” layer, insert a keyframe at frame 5, and delete all existing text from this frame. 
• Open the Smart Clips Common Library (Window > Common Libraries > Smart Clips). 
• Select “RadioButton” smart clip from the Smart Clips Library, and drag it to the current movie 

Library: 
 

 
 

• Close the Smart Clips Library. 
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• Now we need to change the “RadioButton” movie clip properties to fit our movie.  From the 

current movie Library double-click the “RadioButton” to Edit Symbol: 
 

 
 

• In the Edit Symbol mode, double-click the “Radio Button“ again to edit: 
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• Inside the “RadioButton assets“ edit mode, select each asset and change its text properties 

to white color, bold type, size 14: 
 

 
 

• Go back to the Scene 1, still in the “Text” layer, at frame 5, drag the “RadioButton“ symbol 
from the current movie Library to the Stage. 

• Name this symbol instance “City1”. 
• With the “City1” instance still selected, open the Clip Parameters Panel and enter the 

following values: 
_name = City1 
checked = false 
label = Mexico City 
style = Win 
 

 
 

• Copy and paste this instance.  Then rename the pasted instance to “City2”. 
• Change the “City2” Clip Parameters to: 

_name = City2 
checked = false 
label = Cancun 
style = Win 

• Select and align these two instances, and convert them to a movie clip symbol named “City 
Radio Movie”. 
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• Name this new instance “CityRadio”.  Note: This is now a parent instance to the “City1” and 

“City2” instances.  We can call these two instances - child instances.  In the Dot Notation 
they would be presented like CityRadio.City1 and CityRadio.City2. 

• Using the white, bold text, type the quiz question “What is the capital city of Mexico?”  
Position it just above the radio buttons: 
 

 
 

• Now repeat the same process for another question “What is the currency used in Mexico?” 
with the following changes: 
 
1st radio button instance name = “Currency1” 
Clip Parameters: name = Currency1, checked = false, label = Peso, style = Win 
2nd radio button instance name = “Currency2” 
Clip Parameters: name = Currency2, checked = false, label = Dollar, style = Win 
Convert these to a movie clip named “Currency Radio Movie” 
Name this instance “CurrencyRadio” 
 

• Repeat the same process for the third question “What language is spoken in Mexico?” with 
the following changes: 
 
1st radio button instance name = “Language1” 
Clip Parameters: name = Language1, checked = false, label = English, style = Win 
2nd radio button instance name = “Language2” 
Clip Parameters: name = Language2, checked = false, label = Spanish, style = Win 
Convert these to a movie clip named “Language Radio Movie” 
Name this instance “LanguageRadio” 

• Repeat the same process for the fourth question “What is the population of Mexico?” with 
the following changes: 
 
1st radio button instance name = “Population1” 
Clip Parameters: name = Population1, checked = false, label = 100,000,000, style = Win 
2nd radio button instance name = “Population2” 
Clip Parameters: name = Population2, checked = false, label = 50,000,000, style = Win 
Convert these to a movie clip named “Population Radio Movie” 
Name this instance “PopulationRadio” 
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• Your final quiz questions should look like this: 

 

 
 

• Save File As quiz5.fla.  
• Open the quiz5.fla from the Flash 5 Advanced Samples folder to see an example. 
 
 
To Program Radio Buttons 
 
• In this exercise, you will calculate and display the quiz results. 
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• Still in the quiz5.fla file, in the “Actions” layer, at frame 1, add the evaluate script and in the 

Expression field enter Score = 0.  This will create and set the variable Score to 0.  This 
variable is used to keep the count of the correct answers to the previously created questions: 
 

 
 

• In the “Navigation” layer, insert a keyframe at frame 5. 
• Still in the “Navigation” layer, go back at frame 1, select “Hand Button” instance and change 

the action script to go to and stop at new frame label “1st”.  This will take the user from the 
introduction screen (labeled “Start”), to the quiz questions screen (labeled “1st"): 
 

 
 

• Now go back at frame 5 and select “Hand Button” instance.  Here we go to the quiz results 
screen (labeled “2nd").  However, before you can go to quiz results page, you will need to 
check if the user has answered the questions correctly, and for every correct answer, you will 
add one point to the “Score” variable.  The correct answers to the questions are as follows: 
 
Capital City = Mexico City (parent instance CityRadio, child instance City1) 
Currency = Peso (parent instance CurrencyRadio, child instance Currency1) 
Language = Spanish (parent instance LanguageRadio, child instance Language2) 
Population= 100,000,000 (parent instance PopulationRadio, child instance Population1) 
 

• The current button action script looks like this: 
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• Highlight the first line of the script on (release) { and add the if action.  This will give you the 

warning that condition is not set yet.  Click on the Insert a target path icon to select the first 
target for the conditional statement: 
 

 
 

• In the Insert Target Path window, select the instance City1: 
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• Now, in the Condition field, type the additional getstate() action.  Make sure that you type 

the dot symbol between the target and the function.  This action will return True if the target 
was selected, meaning if that radio button choice was checked by the user: 
 

 
 

• Now, add the evaluate action and in the Expression field enter Score = Score+1.  This will 
add one point to the score if the user has answered this question correctly: 
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• Using the Expert Mode, edit the rest of the script to look like this: 

 

 
 

• In the “Text” layer, go to frame 10 and create another Dynamic Text box.  Name the 
Variable “ScoreCalc”.  This field will be used to display the quiz results.  Make sure that the 
Word wrap option is checked.  Position this text box under the “NameCalc” box: 
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• Next step is to populate the “ScoreCalc” variable with the quiz results.  First we have to check 

what is the total “Score”, meaning how many questions the user has answered correctly.  
Then, based on the “Score” value, we will display the appropriate message.  The maximum 
score for 4 questions is 4; the minimum score is 0.  In the “Actions” layer, at frame 10, edit 
the script to look like this: 
 

 
 

• Test the movie.  Enter your name and age in the introduction screen; click the hand button to 
go to the next page.  Select your answers in the quiz questions screen and click the hand 
button to see the results.  Your name, age and score information will be displayed. 

• Save File As quiz6.fla.  
• Open the quiz6.fla from the Flash 5 Advanced Samples folder to see an example. 
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Modular Movies 
 
 
To Insert Another Scene 
 

• In this exercise, you will insert another Scene in the movie.  This scene will be used in the 
later exercises. 

 
• Open the mexico22.fla file. 
• Insert a new Scene to your movie (Insert > Scene). 
• Open the Scene Panel (Window > Panels > Scene). 
• Rename “Scene 1” to "Main". 
• Rename the new “Scene 2” to "Links": 

 

 
 

• Using the Scene Button, return to the "Main" scene. 
• Select the "Cactus" button instance, and add the gotoAndStop action.  Under Scene select 

"Links", under Type, select Frame Number, and under Frame, enter "1".  Deselect the "Go 
to and Play" box: 
 

 
 

• Test the movie.  When you click on the “Cactus” button, you should be taken to the “Links” 
scene. 

• Save File As mexico23.fla.  
• Open the mexico23.fla from the Flash 5 Advanced Samples folder to see an example. 
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To Load Another Movie 
 

• In this exercise, you will load another movie on the top of your existing movie.  This is the 
best way to split large projects by dividing them into various small, easy to download movies. 

 
• Open the quiz6.fla file. 
• In the “Navigation” layer, at frame 10, select the “Hand Button” and open the Actions Panel. 
• Change the current action by adding the loadMovie action.  Under the URL field, type 

mexico24.swf.  Under Location field, select Level and type 0 for the level number.  This will 
load the mexico24.swf movie and overwrite the current one: 
 

 
 

• Save File As quiz7.fla.  
• Publish the movie, but do not test the movie yet.  You will need to create mexico24.swf first, 

before you can test the above functionality.  For now, we just needed to create quiz7.swf file 
to be used for our next step. 

• Open the quiz7.fla from the Flash 5 Advanced Samples folder to see an example. 
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• Now open the mexico23.fla file. 
• In the “Text” layer, select the “Text Button” (MEXICO) and add the loadMovie action.  This 

time, under URL field, enter quiz7.swf.  Under Location field, select Level again and type 0 
for the level number: 
 

 
 

• Save File As mexico24.fla.  
• Now publish and test the movie.  When you click on the “Mexico” button, the Quiz movie will 

be loaded.  Complete the quiz, and on the Quiz Results page click on the “Hand” button.  
This will take you back to the Mexico movie. 

• Open the mexico24.fla from the Flash 5 Advanced Samples folder to see an example. 
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Web Interaction 
 
 
To Add Hyperlinks and Email  
 
• In this exercise we will add hyperlinks to other websites and send an email from within the 

movie. 
 
• Still in the mexico24.fla file, go to the scene “Links”. 
• In the scene “Links”, rename the default layer to "Background". 
• Draw a rectangular background shape and fill it with dark green color (R=0 G=51 B=51). 
• Using the Info Panel, adjust the background size to match the movie (550 x 400), and center 

it on the Stage: 
 

 
 

• Insert a new layer named "Image". 
• With frame 1 of the "Image" layer selected, import "Chillies.bmp" file from the Samples 

Folder. 
• Position it at middle-right area of the stage. 
• Insert a new layer named "Header Text". 
• Using the Impact font (size 45, white color), type the words "MEXICO online". 
• Select the word "MEXICO" and using the Character Panel, add Bold, Kern to 4. 
• With the word "online" selected, change the font size to 30, Kern to 18. This will be the page 

header. 
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• Next you will create separate layers for each text button to be used for hyperlinks.  The 

hyperlink text will be as follows: 
 
Travelers Guide to Mexico  (Layer name: Guide Text) 
Discovering Mexico   (Layer Name: Discover Text) 
Maya Adventure   (Layer Name: Mayan Text) 
The Mayan Civilization  (Layer Name: Civilization Text) 
Mexico Online   (Layer Name: Online Text)  
 

 
 

• On each appropriate layer, type the above text in capitals using Font = Impact, Size = 16, 
Kern = 3, Color = White (R=255 G=255 B=255).  

• Right-align the text so it is a couple of spaces to the left-side edge of the "Chillies" image. 
 

 
 

• Convert each line of text to a button symbol, naming them “Guide Text Button”, “Discover 
Text Button”, “Mayan Text Button”, “Civilization Text Button”, and “Online Text Button”. 

• Double click each button to edit.  Add keyframes to each state. 
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• In the Over state, select the text, and using the Mixer Panel, change the color to R=0 G=153 

B=153: 
 

 
 

• In the Down state, change the text color to R=0 G=204 B=204. 
• In the Hit state, draw a filled rectangle around the text, then remove the text: 

 

 
 
• Insert a new layer and name it "Mailto Text". 
• Using the Text tool, type "Click to request information".   
• Using the Character Panel, adjust the font size to 12, color to white, and Kern to 2.  
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• Type in the URL field “mailto:name@domain.com”.  Note: You can type your own email 

address instead of sample address name@domain.com: 
 

 
 

• Now add another layer and name it "Back Button". 
• Open as Library the Artwork.fla file from the Sample Folder. 
• From the Artwork Library, drag the “Hand Button” symbol onto the Stage.  Position the 

button at the bottom left corner of the Stage.  
• Add the gotoAndStop action to the “Hand Button”.  Under Scene, select "Main".  Under 

Type, select Frame Label, and under Frame select "Day" frame label.  Deselect the Go to 
and Play checkbox: 
 

 
 

• Insert a new layer, named "Actions".  Position this layer at the top of layer list. 
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• Still in “Actions” layer, add the Stop action to the frame 1: 

 

 
 

• Test the movie.  When you click on the “Cactus” button, you should be taken to the “Links” 
scene.  Click on the “Hand” button to go back to the main screen. 

• To test the links, File > Publish > Preview, and test the published movie inside the Internet 
browser. 

• Save File As mexico25.fla.  
• Open the mexico25.fla from the Flash 5 Advanced Samples folder to see an example. 
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Optimizing Movies 
 
 
To Create a Preloader 
 
• The Preloader is the scene that displays on screen while the main file is loading in the 

background.  We will create a simple preloader using a Movie Clip. 
 
• Still in the mexico25.fla file, create a new Movie Clip symbol and name it “Preloader Movie”. 
• In the Edit Symbol mode, rename the default layer to "Background". 
• Draw a rectangle to match the movie dimensions (550 x 400) and center it on the Stage. 
• Using the Linear Gradient Fill Panel, and colors from orange (#FF6400) to dark tan 

(#980000), fill the rectangle with color. 
• Insert a Frame at frame 40. 
• Insert a new layer named "Loading text". 
• Using the Arial Black font, size 20, pale orange color, type the word "Loading…" and convert 

it to a graphic symbol.  Name it "Loading Text".  Position the text to the top left side of the 
Stage: 
 

 
 

• Add keyframes on 5 frame intervals, and add the Motion Tween in between them: 
 

 
 

• At each keyframe, change the Tint Effect of the “Loading Text” instance.  This way the text 
will be changing its color throughout the animation: 
 
Frame 1 R=255 G=0 B=0 
Frame 5 R=255 G=51 B=0 
Frame 10 R=255 G=102 B=0 
Frame 15 R=255 G=153 B=0 
Frame 20 R=255 G=204 B=0 



N
O
T
 F
O
R
 T
R
A
IN
IN
G

50  Optimizing Movies - EXERCISES 
 2001 Cheltenham Computer Training  Flash 5 Advanced 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Computer Training 1995-2001 - www.cctglobal.com 

 
• Reverse the order in the rest of the frames, finishing with Frame 40 R=255 G=0 B=0: 

 

 
 

• Insert a new layer named "Postcard text". 
• Using the bold orange text, type "a postcard from" at the lower left area of the stage.  This 

does not need to be converted to a symbol, as it will not require any effects. 
• Insert a new layer named "Mexico text". 
• Type the word "MEXICO" and convert it to a graphic symbol named "Mexico Text". 
• Break apart the MEXICO text, so that you now have shapes instead of font objects. 
• Position the “Mexico text” instance to the top right area above the Stage (x=159.8, y=-218.2).  

Add keyframes at 10 frame intervals and insert the Motion Tween in between them: 
 

 
 

• Continue adding effects to each keyframe as follows: 
 
Frame 10:  x=14.9 y=-75.2 Alpha=40% 
Frame 20:  x=169.8 y=11.9 Alpha=60% 
Frame 30:  x=89.8 y=98.8 Alpha=80% 
Frame 40:  x=159.8 y=159.8 Alpha=100%  
 

 
 

• Insert a new layer named “Labels”. 
• Label the frame 1 as "Postcard". 
• Go back to the “Main” Scene. 
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• Insert a new layer, just under the “Labels” layer, and name it “Preloader”. 
• Insert two frames in front of frame 1 for each layer. 
• In the “Preloader” layer, place the “Preloader Movie” symbol in the frame 1. 
• In this layer only, delete all other frames except frame 1 and 2: 

 

 
 

• In the frame 2, drag the symbols used in the “Links” Scene and position them outside the 
Stage, on the Work Area.  This way they wont show when published, but they will still load at 
the beginning of the movie: 
 

 
 

• Test the Movie. 
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• While movie is being tested in the Flash Player, select View > Bandwidth Profiler. This will 

display the details of how the movie will play.  
• In the graph, note the frame number of the last vertical bar (i.e. frame 10). The following 

frame number (i.e. frame 11) will be used for the Preloader Action: 
 

 
 

• In the “Actions” layer, select frame 1 and add the if action from the Actions book. 
• In the Condition field add _framesloaded action, from the Properties book, and enter “>= 

11”.  Then add gotoAndStop (“Day”); action.  This means that the movie will check if the 11 
frames were loaded, and then go to and stop at frame label “Day”: 
 

 
 

• Test the movie.  Make sure to select View > Show Streaming, otherwise you may not see 
the Preloader, because the movie is playing from the hard-drive, all the frames are quickly 
loaded. 

• Save File As mexico26.fla  
• Open the mexico26.fla from the Flash 5 Advanced Samples folder to see an example. 
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To Test the Movie 
 

• Optimizing the movie will reduce the file size of your movie and improve download 
performance.  It requires experimentation to evaluate file size versus quality.  Optimizing can 
be done in two different ways: 

• As the movie is created, the individual components are optimized. 
• After the movie is created, the whole movie is optimized before Publishing. 
 

• Test your movie and while it is playing, select Control > View Bandwidth Profiler. 
• Note the movie size, frame rate, number of frames and the download time: 

 

 
 

• From the main menu, select Debug.  You will see the modem speed has been set to 56K 
(default). 

• Select the modem speeds for 14.4K and 28.8K and note the changes to the "Preload" 
download time in the Bandwidth Profiler.  

• Also note the small changes in the vertical bars on the graph. 
• Select Debug > Customize. Add 250k (DSL) settings to the list. 
• In the Menu text, change User Setting 4 to “250k (DSL)”, and the Bit rate to "32000": 

 

 



N
O
T
 F
O
R
 T
R
A
IN
IN
G

54  Optimizing Movies - EXERCISES 
 2001 Cheltenham Computer Training  Flash 5 Advanced 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Computer Training 1995-2001 - www.cctglobal.com 

 
• Select Debug again.  Note the “250k DSL” setting has been added to the connection list: 

 

 
 

• Select “250k DSL” and note the changes in the Bandwidth Profiler graph.  The vertical bars 
are reduced to a minimum.   

• The majority of web audience is using 56K modems; therefore you often need to optimize 
your movie to accommodate that download speed.  To see the simulation of the movie's 
download time, select View > Show Streaming. 

• Test the movie again, using different modem settings. 
• Select View > Frame by Frame Graph. Note the "spikes" are in frames 1, 3, 10 and 21 (i.e. 

above the red horizontal line). 
• Frame  3: Day 
• Frame 10: Night 
• Frame 21: Links 

 

 
 

• Cancel "Test Movie" and return to the "Main" scene. 
• Save File As mexico27.fla. 
• Test the movie again and check the file size of mexico27.swf file.  It should be approximately 

96KB. 
• Open the mexico27.fla from the Flash 5 Advanced Samples folder to see an example. 
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To Optimize the Movie 
 

• Now we will optimize the movie by optimizing individual components. 
 
• Still in the mexico27.fla file, open the Library. 
• Select "Chillies.bmp" and open Options > Properties. 
• Change the Compression to Lossless (PNG/GIF), then Test Movie again to see the change 

in SWF file size.  You will notice that the file size has increased significantly from 96KB to 
201KB: 
 

 
 

• Set the image Compression back to Photo (JPEG). 
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• In the Library, select the longest sound file “drum-conga-long-2.wav” from the Sound 

Folder: 
 

. 
 

• Experiment by changing the Sound Export Settings, testing the movie each time and noting 
the change in file size.  In this example, changing from MP3 to Raw compression has 
increased the SWF file size from 96KB to 211KB. 

• Set the sound compression back to MP3. 
• Now we will optimize the vector graphics in the movie.  Ensure that all layers are unlocked. 
• Using the Onion Skin tool, select Edit Multiple Frames. 
• Click the Modify Onion Markers menu and select Onion All. 
• Select All (Crtl+A).  This will select all the layers in the timeline. 
• In the main menu, choose Modify > Optimize. 
• Move the Smoothing slider to Maximum, check both option boxes, then OK: 
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• Note the response message in the reduction to the number of curves: 

 

 
 

• Test the movie.  You will notice that the SWF file didn’t change.  That is because your movie 
doesn’t have complex vector images.  If you had vector images with large number of curves, 
this optimization will reduce the file size. 

 
• Now we will optimize the movie by optimizing the whole move for the Publishing. 
 
• Select File > Publish Settings. 
• Select Flash tab and slide the JPEG Quality slider to the left, to decrease the quality of 

raster images: 
 

 
 

• This will optimize raster graphics. 
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• Test the movie again.  You will notice that the SWF file size has decreased from 96KB to 

83KB.  But if you look at the raster image in the “Links” Scene, you will notice that its quality 
has decreased significantly: 
 

 Before  After 
 

• Set the JPG quality back to 80.  This is the default setting. 
• Sound files can also be optimized using this process.  Just set the Audio Stream and Audio 

Event and check the Override sound settings option.  This will compress all sound files in 
the same way: 
 

 
 

• Test the movie.  You will notice that the SWF file size has decreased from 96KB to 93KB. 
• Go back and uncheck the Override sound settings.  This is the default setting. 
• Check the Generate size report option and click OK. 
• Test the movie.  You will notice that the report text (TXT) file is now generated in the same 

folder where your FLA and SWF files are.  Open this text file to view all size information of 
your movie.  

• Open the mexico27 Report.txt from the Flash 5 Advanced Samples folder to see an 
example. 
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Standalone Movies  
 
 
To Create the Projector 
 
• Some actions work only in standalone Projector files.  In this exercise we will add few of 

those actions. 
 
• Open the mexico27.fla file. 
• Select the "Pyramid Big Button" instance and add the On Mouse Event (release) action. 
• Add the FSCommand action.  Select fullscreen [true/false] from Commands for 

standalone player ("true" is the Arguments default).  This will make the movie increase to 
the full screen of the monitor: 
 

 
 

• Select "Pyramid Small Button" instance and add the fullscreen [true/false] from 
Commands for standalone player.  Change the Arguments to "false".  This will make the 
movie go back to its default screen size on the monitor. 
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• Back on the stage, select the "Gecko Button" instance and add the quit from Commands 

for standalone player.  This will close the standalone file: 
 

 
 

• Save File As mexico28.fla  
• Open the mexico28.fla from the Flash 5 Advanced Samples folder to see an example. 
• Before the above actions can be tested, there is one more step.  Choose File > Publish 

Settings. 
• Check Windows Projector (.exe) and click Publish button: 

 

 
 

• An .exe file is generated in your folder as mexico28.exe. 
• Run the mexico28.exe by simply double-clicking on it. 
• Test the button actions.  Click on the “Big Pyramid” will expand the movie to full screen.  Click 

on the “Small Pyramid” will resize the movie to its original size.  Click on the “Gecko” to close 
the projector. 
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To Prepare Final Movies 
 
• During the course of our exercises, we were naming the files accordingly, so that you can see 

the example results of each exercise.  However, now we will prepare the final versions for our 
movies. 

 
• First open the quiz7.fla file. 
• In the “Navigation” layer, at frame 10, select the “Hand Button” and edit the action to load 

the “mexico.swf” movie: 
 

 
 

• Set the Publish Settings for Flash file format only. 
• Save File As quiz.fla  
• Open the quiz.fla from the Flash 5 Advanced Samples folder to see an example. 
• Publish the movie to generate the quiz.swf file. 

 
• Now open the mexico28.fla file. 
• In the “Text” layer, select the Mexico “Text Button” instance and edit the action to load the 

“quiz.swf” movie: 
 

 
 

• Set the Publish Settings for HTML, Flash and Windows Projector file forms. 
• Save File As mexico.fla  
• Open the mexico.fla from the Flash 5 Advanced Samples folder to see an example. 
• Publish the movie to generate mexico.html, mexico.swf and mexico.exe files. 
• Run the mexico.exe file.  Test all functionalities. 
• Open the mexico.html file in the browser.  Test all functionalities.  Everything should work, 

except the Projector commands added to the “Big Pyramid”, “Small Pyramid” and “Gecko” 
buttons.  These commands will work on the standalone EXE file only. 

• Open the mexico.exe and the mexico.html files from the Flash 5 Advanced Samples folder 
to see an example. 

 
 


