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You can group separate FrameMaker 

documents into one book. This grouping 

lets you generate a single table of contents 

or index for the documents, and it greatly 

simplifies printing, numbering, cross-ref-

erencing, and formatting.



LESSON 11234
Books

This lesson uses four sample files: three chapter files and a preface file. You’ll collect these 

files into a book and then generate a table of contents from all the files in the book. If you 

want to see completed versions of the sample files, open the Finished folder in the 

Lesson11 folder.

In this lesson, you’ll learn how to do the following:

• Create a book file from one of the documents in the book

• Add documents to a book and paginate them

• Add a table of contents to a book

• Format a table of contents

Creating a book file
You’ll create a book file—a file that lets you group and work with several documents 

together—for a small three-chapter guide to prepress and commercial printing. Working 

from a book file as opposed to dealing with individual files lets you easily paginate across 

files, update all cross-references, and generate special documents such as an index or table 

of contents for the book.

1 Open Chapter1.fm in the Lesson11 folder. (You won’t be making copies of the sample 

files in this lesson. If you want to start over, you can get fresh copies of the files from the 

CD-ROM.)

2 Choose File > New > Book.

3 Click Yes when FrameMaker displays an alert message asking if you want to add 

Chapter1.fm to the new book.

A book window appears showing the book’s contents, so far only Chapter1.fm (the file 

from which the book was created).
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When you’re working in a book window, the menu bar contains only commands appro-

priate for books. (For example, the File menus for a book and for a document contain 

somewhat different commands.)

Note: On UNIX systems, the book menu bar appears as part of the book window. In Windows 

and on the Macintosh, the menu bar remains at the top of the application window.

4 Compare the File menu for the book window with the File menu for the document 

window by doing one of the following:

• (Windows and Macintosh) Click in the book window and display the File menu. Then 

click in Chapter1.fm and display the File menu.

• (UNIX) Display the File menu in the book window. Then display the File menu in the 

document window for Chapter1.fm.

For the rest of this lesson, you’ll work with the book rather than with individual files in 

the book.

5 Close Chapter1.fm, but leave open the book window you just created.

The book was assigned a default name (UntitledBook1.book), but you’ll save the book 

using a more appropriate filename.

6 Choose File > Save Book As, enter the filename Press.book, and click Save.
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Adding documents to the book
Your book will eventually contain a table of contents, a preface, and three chapters. You’ll 

add another chapter now.

1 Choose Add > Files.

2 Navigate to the folder containing the chapter files, if necessary, select Chapter2.fm and 

click Add. 

 To add a file to a book, you can also click  at the bottom of the book window.

Now, you’ll add the third chapter and the preface.

3 Choose Add > Files and do one of the following:

• (Windows and Macintosh) Select Chapter3.fm and Preface.fm, then click Add.

• (UNIX) Select Chapter3.fm and click Add, select Preface.fm and click Add, then click 

Done.
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The book window now shows that the book contains a preface and three chapters. 

Notice that the preface appears at the bottom of the list in the book window instead of at 

the beginning where it should be. You can fix that easily.

4 Select Preface.fm in the book window and drag it above Chapter1.fm. (You can 

rearrange one or more files in a book window by selecting them and dragging them where 

you want them to appear in the book.)

The files are now in the correct order.

5 Choose File > Save Book to save the book file.
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Opening files from the book window
Before adding a table of contents to the book, you’ll take a quick look at the individual 

chapters in the book.

1 Double-click Chapter1.fm in the book window.

Double-clicking a filename is a quick way to open an individual file. However, you can 

open many files at once by using a shortcut.

2 Close Chapter1.fm.

3 In the book file, hold down Shift and choose File > Open All Files in Book. All the 

documents in the book are opened. 

Note: In Windows and on UNIX systems, the documents are minimized, so you’ll need to 

open the minimized windows to see their contents.

Notice that each chapter is numbered Chapter 1 and begins on page 1. When you update 

the book later in the lesson, the chapter and page numbers will be renumbered correctly.

Initially, all three chapter numbers are 1.

4 Hold down Shift and choose File > Close All Files in Book to close the preface and all 

three chapters. Leave the book window open.

Getting Output: Key steps in the production cycle

1

Chapter 1: Getting Output
Proo ng, pre ight, and  le hand-off are three key 

steps in the  nal production cycle. This chapter dis-
cusses how these tasks in uence the success of your 
output.

Key steps in the production cycle
Proofing lets you check your work and ensure that the 

final printed piece will meet your requirements. It is 
appropriate to proof your publication at several stages 
in your project and the proo ng process should be inte-
grated into your work ow.

Preflight, a term that prepress professionals adapted 
from aeronautics, refers to the process of stepping 
through a systematic list of quality-control checks on 
your publication before the  nal output stage. A pilot 
performs a pre ight check to verify that a plane is air-
worthy and meets legal  ight requirements; performing 
a digital preflight check lets you verify that a publication 
prints and meets your prepress service provider’s 
requirements.

Handing off your  le is a step in the publishing pro-
cess where communication with your prepress service 
provider is critical. Recording the requirements, set-
tings, and  les in a written report for your service pro-
vider helps you organize  les and serves as a reminder 
of all special treatment areas in your publication. The 
location and organization of all your  les, including 

1

Chapter 1: Planning for 
Commercial Printing

Every commercial printing job requires that you con-
sider a complex set of variables ranging from what your 
budget and schedule allow to how the paper stock and 
printing press affect your  nal output. The earlier you 
think about these variables, the more control you’ll have 
over the quality, cost, and schedule of your project.

Planning and evaluation
Preparing a publication for commercial printing takes 

careful thought: both imagesetters and commercial 
printing presses have inherent limitations, and it’s pos-
sible to create publications that are dif cult to print on 
either an imagesetter or a printing press. By thinking of 
your design and production cycles as steps in a larger 
process, you can make choices that will let you work 
more efficiently and help you achieve the best printed 
results.

Before going to a commercial printer with your 
project, you need to evaluate your skills, your schedule, 
and your equipment to determine what tasks you will do 
and what services you will contract.

In addition to choosing a commercial printer, you may 

1

Chapter 1: Color and 
Commercial Printing

When you create a multi-color publication, you want 
the colors in the final printed piece to match your expec-
tations as closely as possible. To accomplish this, you 
need three things: a clear understanding of color and 
how it’s displayed and printed on different devices, 
knowledge of the commercial printing process, and 
close communication with your commercial printer.

This chapter presents fundamental color and printing 
concepts, defines printing terminology, and introduces 
new technologies. We also recommend browsing in your 
local library, bookstore, or graphic arts supply store for 
books on graphic arts and commercial printing. The 
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Adding a table of contents
The book is now complete except for the table of contents. The table of contents will be a 

generated file—a file whose entries are generated from the other files in the book.

Adding a table of contents is a twofold process. First, you add a description of the table of 

contents to the book file. Then you generate (create) the table of contents from the other 

files in the book.

1 In the book window, select Preface.fm because you want the book’s table of contents to 

appear before the preface.

2 Choose Add > Table of Contents.

In the dialog box that appears, you’ll choose chapter titles and one level of headings to be 

included in the table of contents.

Initially, the tags of all the paragraph formats in the files of the book appear in the Don’t 

Include scroll list on the right. When you set up a table of contents, you decide which tags 

to include in it. FrameMaker will look in the files of the book for any text that’s formatted 

with these tags. When it finds a paragraph formatted with one of the tags, FrameMaker 

copies the text into the table of contents.

You’ll include the paragraph tagged ChapterTitle in the table of contents by moving it 

from the right scroll list (the Don’t Include scroll list) to the left scroll list (the Include 

Paragraphs Tagged scroll list).

3 Select ChapterTitle in the right scroll list (you may need to scroll down) and move it to 

the left scroll list by clicking the left arrow ( ).

Moving ChapterTitle to the Include scroll list means that the text of any paragraph tagged 

ChapterTitle will be included in the book’s table of contents. Each chapter contains a 

single paragraph tagged ChapterTitle.
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4 Now double-click Heading1 in the Don’t Include scroll list to move it to the Include 

Paragraphs Tagged scroll list. (Double-clicking an item in a scroll list moves it to the 

opposite list.)

The text of any paragraph tagged Heading1 will also be included in the table of contents. 

Each chapter contains several paragraphs tagged Heading1.

5 Scroll in the Don’t Include list (if necessary) until you see PrefaceTitle.

6 Double-click PrefaceTitle to move it to the Include Paragraphs Tagged scroll list.

The text of any paragraph tagged PrefaceTitle will also be included in the table of contents.

7 Turn off Create Hypertext Links.

8 Click Add.

Generating the table of contents
In the Update Book dialog box that appears, the filename of the table of contents, 

PressTOC.fm, appears in the Generate list on the left. The filename is based on the book’s 

name (TOC indicates that the file is a table of contents.)

The PressTOC.fm file doesn’t actually exist until FrameMaker generates it (meaning that 

FrameMaker gathers the paragraphs tagged with the formats you want included 

(ChapterTitle, Heading1, and PrefaceTitle) and puts them into a new file called 

PressTOC.fm). 
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1 Click Update to generate the table of contents for your book.

At the same time, FrameMaker updates the chapter numbering, page numbering, and 

cross-references in the book.

Messages appear in the status bar at the bottom of the book window as FrameMaker 

examines each file in the book. After a few moments, the table of contents appears. 

Initially, the table of contents uses the page layout of the first document in the book 

(the preface).

Note: In Windows and on UNIX systems, the table of contents is minimized, so you’ll need to 

open the minimized window to see its contents.

i

Introduction iii
Color and Commercial Printing 5
The properties of color 5
Printing terminology 9
Computer graphics 13
Common printing problems 14
Bitmap image and output resolution 15
Screen ruling 16
Emerging printing technologies 18
Offset lithography 21
Imposition and binding 24
Other printing processes 25
Planning for Commercial Printing 29
Planning and evaluation 29
The publishing process 30
Defining project requirements 32
Defining quality requirements 33
Specific publication requirements 34
Choosing prepress tasks 36
Selecting vendors 37
Getting Output 41
Key steps in the production cycle 41
Desktop proofing options 42
Separation-based proofs 44
Creating a report for your service provider 47
Preparing files for imaging 49
Handing off files to a prepress service provider 51
Checking film separations 53
Checking contract color proofs 54
Checking press proofs 55
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2 Click in the first paragraph of the table of contents (the single-line paragraph whose 

text is Introduction) and notice the tag that appears in the status bar: PrefaceTitleTOC.

3 Press the Down Arrow key several times to move the insertion point down the page, 

noticing that the other paragraphs also have tags that end in TOC (ChapterTitleTOC and 

Heading1TOC).

FrameMaker created and assigned these TOC paragraph formats when the table of 

contents was generated. Because these three formats are initially identical, the entries in 

the table of contents all look the same. Later, you’ll redefine the formats and apply them 

to the entries in the table of contents.

 If you had placed a document in the book folder that was already named PressTOC.fm 

and that already contained definitions for the TOC formats, FrameMaker would have used 

that document for the table of contents instead of creating a new one. In this way, you can use 

a template to speed up formatting a generated file.

4 Minimize the table of contents again (Windows and UNIX) or move it out of the way 

and click in the book file (Macintosh).

Setting up chapter numbering
After adding the table of contents to your book, you’ll need to be sure that the chapters 

are numbered correctly.

1 Double-click Chapter2.fm in the book window to open the document. Notice that the 

chapter is still numbered Chapter 1. (FrameMaker does not continue paragraph 

numbering across all the files of the book unless you tell it to by using the Format > 

Document > Numbering command.)

2 Return to the book window and select both Chapter2.fm and Chapter3.fm.

3 Choose Format > Document > Numbering.
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4 Choose Chapter from the pop-up menu, select Continue Numbering from Previous 

FIle in Book, and click Set.

5 Choose Edit > Update Book, then click Update.

6 Display both Chapter2.fm and Chapter3.fm to confirm that FrameMaker has correctly 

renumbered them.

All three chapters are now numbered correctly.

Getting Output: Key steps in the production cycle

41

Chapter 3: Getting Output
Proofing, pre ight, and  le hand-off are three key 

steps in the  nal production cycle. This chapter dis-
cusses how these tasks in uence the success of your 
output.

Key steps in the production cycle
Proofing lets you check your work and ensure that the 

 nal printed piece will meet your requirements. It is 
appropriate to proof your publication at several stages 
in your project and the proo ng process should be inte-
grated into your work ow.

Preflight, a term that prepress professionals adapted 
from aeronautics, refers to the process of stepping 
through a systematic list of quality-control checks on 
your publication before the  nal output stage. A pilot 
performs a pre ight check to verify that a plane is air-
worthy and meets legal  ight requirements; performing 
a digital preflight check lets you verify that a publication 
prints and meets your prepress service provider’s 
requirements.

Handing off your  le is a step in the publishing pro-
cess where communication with your prepress service 
provider is critical. Recording the requirements, set-
tings, and  les in a written report for your service pro-
vider helps you organize  les and serves as a reminder 
of all special treatment areas in your publication. The 
location and organization of all your  les, including 

29

Chapter 2: Planning for 
Commercial Printing

Every commercial printing job requires that you con-
sider a complex set of variables ranging from what your 
budget and schedule allow to how the paper stock and 
printing press affect your  nal output. The earlier you 
think about these variables, the more control you’ll have 
over the quality, cost, and schedule of your project.

Planning and evaluation
Preparing a publication for commercial printing takes 

careful thought: both imagesetters and commercial 
printing presses have inherent limitations, and it’s pos-
sible to create publications that are dif cult to print on 
either an imagesetter or a printing press. By thinking of 
your design and production cycles as steps in a larger 
process, you can make choices that will let you work 
more efficiently and help you achieve the best printed 
results.

Before going to a commercial printer with your 
project, you need to evaluate your skills, your schedule, 
and your equipment to determine what tasks you will do 
and what services you will contract.

In addition to choosing a commercial printer, you may 

5

Chapter 1: Color and 
Commercial Printing

When you create a multi-color publication, you want 
the colors in the final printed piece to match your expec-
tations as closely as possible. To accomplish this, you 
need three things: a clear understanding of color and 
how it’s displayed and printed on different devices, 
knowledge of the commercial printing process, and 
close communication with your commercial printer.

This chapter presents fundamental color and printing 
concepts, defines printing terminology, and introduces 
new technologies. We also recommend browsing in your 
local library, bookstore, or graphic arts supply store for 
books on graphic arts and commercial printing. The 



LESSON 11244
Books

Fixing the pagination
The table of contents shows you how FrameMaker has paginated the book. Notice that the 

chapter titles for Chapter 2 (Planning for Commercial Printing) and Chapter 3 (Getting 

Output) incorrectly begin on page 1. FrameMaker does not number the pages consecu-

tively in a book unless you tell it to.

1 Make sure the book file is open and visible.

Next you’ll choose a command that will let you adjust how the second and third chapters 

paginate. You could choose the Document > Numbering command from the Format 

menu. Instead you’ll use a context menu, which is a convenient shortcut when working in 

a book window. (A context menu contains commonly used commands applicable to the 

item under the pointer.)

2 Select Chapter2.fm and Chapter3.fm in the book window, then do one of the following:

• (Windows and UNIX) Right-click in the book window.

• (Macintosh) Hold down Control and click in the book window.

Context menu for a book

3 Choose Numbering from the pop-up menu.

4 Choose Page from the pop-up menu in the Numbering Properties dialog box. 

5 Click Continue Numbering from Previous Page in Book.
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6 Click Set.

Any time you make a change to a file in a book—either to its contents or to its setup—you 

should update the book to see the change reflected in the book’s generated files.

7 Choose Edit > Update Book, then click Update.

8 Reopen the table of contents to see the new numbering. Notice that the book’s pages 

are now numbered sequentially.

You’ll make one more change to the book’s contents.

9 Click in Chapter3.fm, and change the title of this chapter from Getting Output to Good-

Looking Output.

10 Save and close Chapter3.fm.

11 From the book file, generate the table of contents again by choosing Edit > Update 

Book, then clicking Update.

 To update a book, you can also click ( ) at the bottom of the book window.

Good-Looking Output: Key steps in the production cycle

41

Chapter 3: Good-Looking 
Output

Proofing, preflight, and file hand-off are three key 
steps in the final production cycle. This chapter dis-
cusses how these tasks influence the success of your 
output.

Key steps in the production cycle
Proofing lets you check your work and ensure that the 

final printed piece will meet your requirements. It is 
appropriate to proof your publication at several stages 
in your project and the proofing process should be inte-
grated into your workflow.

Preflight, a term that prepress professionals adapted 
from aeronautics, refers to the process of stepping 
through a systematic list of quality-control checks on 
your publication before the final output stage. A pilot 
performs a preflight check to verify that a plane is air-
worthy and meets legal flight requirements; performing 
a digital preflight check lets you verify that a publication 
prints and meets your prepress service provider’s 
requirements.

Handing off your file is a step in the publishing pro-
cess where communication with your prepress service 
provider is critical. Recording the requirements, set-
tings, and files in a written report for your service pro-
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12 Inspect the updated table of contents and note that the entry for this chapter now 

correctly reads Good-Looking Output.

13 Save the table of contents and keep it open.

14 Save the book and keep it open.

Changing the layout
The preface and chapters in the book use a side-head area at the left side of each page. 

To make the table of contents more consistent with the rest of the book, you’ll use the

same layout.

1 Click anywhere in the table of contents, and then choose Format > Customize Layout > 

Customize Text Frame.

i

Introduction iii
Color and Commercial Printing 5
The properties of color 5
Printing terminology 9
Computer graphics 13
Common printing problems 14
Bitmap image and output resolution 15
Screen ruling 16
Emerging printing technologies 18
Offset lithography 21
Imposition and binding 24
Other printing processes 25
Planning for Commercial Printing 29
Planning and evaluation 29
The publishing process 30
Defining project requirements 32
Defining quality requirements 33
Specific publication requirements 34
Choosing prepress tasks 36
Selecting vendors 37
Good-Looking Output 41
Key steps in the production cycle 41
Desktop proofing options 42
Separation-based proofs 44
Creating a report for your service provider 47
Preparing files for imaging 49
Handing off files to a prepress service provider 51
Checking film separations 53
Checking contract color proofs 54
Checking press proofs 55
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2 Select Room for Side Heads, and make sure the Width is 92, the Gap is 14, and the Side 

is set to Left. 

3 Click Set. The entries move into the body-text area at the right side of the text frame. 

i

Introduction iii
Color and Commercial Printing 1
The properties of color 1
Printing terminology 5
Computer graphics 9
Common printing problems 10
Bitmap image and output resolution 11
Screen ruling 12
Emerging printing technologies 14
Offset lithography 17
Imposition and binding 20
Other printing processes 21
Planning for Commercial Printing 25
Planning and evaluation 25
The publishing process 26
Defining project requirements 28
Defining quality requirements 29
Specific publication requirements 30
Choosing prepress tasks 32
Selecting vendors 33
Good-Looking Output 37
Key steps in the production cycle 37
Desktop proofing options 38
Separation-based proofs 40
Creating a report for your service provider 43
Preparing files for imaging 45
Handing off files to a prepress service provider 47
Checking film separations 49
Checking contract color proofs 50
Checking press proofs 51
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Adding a title
Before you format the entries in the table of contents, you’ll add a title.

1 Click outside the frame to deselect it and then click at the beginning of the first 

paragraph of the table of contents (Introduction).

2 Press Return and then press the Up Arrow key to place the insertion point in the new 

empty paragraph above Introduction.

3 Type Table of Contents.

4 Choose Format > Paragraphs > Designer.

5 Choose New Format from the Commands pop-up menu.

6 Enter ContentsTitle in the Tag text box.

Table of Contents
Introduction iii

i

Color and Commercial Printing 1
The properties of color 1
Printing terminology 5
Computer graphics 9
Common printing problems 10
Bitmap image and output resolution 11
Screen ruling 12
Emerging printing technologies 14
Offset lithography 17
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7 Make sure that both options, Store in Catalog and Apply to Selection, are selected.

8 Click Create.

The tag of the title you just typed is changed to ContentsTitle (as shown in the status bar), 

and the format is stored in the Paragraph Catalog.

When you generate the table of contents again, FrameMaker will update only the 

paragraphs whose tags end in TOC. The title will remain because the tag you typed 

(ContentsTitle) doesn’t end in TOC and because the paragraph appears at the start of the 

text flow.

9 In the Paragraph Designer, choose Default Font from the Properties pop-up menu. 

(In Windows, you can just click the Default Font tab at the top of the designer.)

10 Change the Size to 30, the Weight to Bold, and the Color to HeadingColor.
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11 Click Update All to apply the changes to the title and to update the format in 

the catalog.

12 Choose Basic from the Properties pop-up menu.

13 Change the Space Below Pgf to 72 and click Update All.

The title will look better if it spans both the side-head area and the body-text area, so you’ll 

make that change next.

14 Choose Pagination from the Properties pop-up menu.

15 Click Across All Columns and Side Heads, then click Update All.

Now you’re ready to format the entries in the table of contents.

Table of Contents
Introduction iii

i

Color and Commercial Printing 1
The properties of color 1
Printing terminology 5
Computer graphics 9
Common printing problems 10
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Formatting the entries
Formatting a table of contents is a twofold process:

• In this section, you’ll format the entries as you would any paragraphs. 

• In the next section, you’ll make changes that affect the contents of the entries, instead 

of their formats.

Formatting a generated file takes some time, but you need to do it only once for the book 

because FrameMaker reuses your formatting each time you generate the file. You can also 

use the formatted table of contents from one book as a template for others, so the 

investment you make in formatting a table of contents pays off quickly.

Changing paragraph formats

First, you’ll change the paragraph formats of the entries.

1 Click in the first entry (the preface title, Introduction).

2 In the Paragraph Designer, display the Default Font properties.

3 Change the Weight to Bold and click Update All. 

4 Click in the second entry (the title of Chapter 1, Color and Commercial Printing).

5 In the Paragraph Designer, change the Weight to Bold, and click Update All. All three 

chapter titles change.

6 Display the Basic properties in the Paragraph Designer.

i
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7 Change the Space Above Pgf to 14 and click Update All.

8 Now click in the first entry for Chapter 1, The properties of color.

9 Display the Default Font properties in the Paragraph Designer.

10 Change the Family to Helvetica and the Size to 10, and click Update All.

11 Display the Basic properties again, change the Line Spacing to 14, and click 

Update All. 
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Adding tab leader dots

A table of contents often places page numbers at the right side of the page with dots 

between the text and the page numbers.

To do this for all Heading1 entries, you need to make a few more changes to the format of 

the entries.

1 Choose View > Rulers to display the document rulers.

2 If the formatting bar isn’t visible, choose View > Formatting Bar (Windows), or click 

the formatting bar toggle at the left side of the top ruler (Macintosh and UNIX).

The formatting bar contains several formatting pop-up menus and tab wells that you can 

use to set some paragraph properties. You’ll use the tab wells. 

A. Left-aligned tab well B. Centered tab well C. Right-aligned tab well
D. Decimal-aligned tab well

3 Click anywhere in the first entry for Chapter 1, The properties of color. Then drag a 

right-aligned tab stop from the tab well to just under the right indent on the ruler. 

You won’t see any result from having added the tab stop yet, because the Heading1 

paragraphs don’t contain tab characters. (Tab characters will be inserted automatically in 

the table of contents when it’s generated.) 

4 Double-click the tab stop (the little arrow) under the ruler. 

B C DA
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5 Select the first dotted leader in the Leader area of the Edit Tab Stop dialog box.

6 Click Edit.

7 In the Paragraph Designer, click Update All. The entries in the table of contents don’t 

change, because they don’t contain a tab character yet. You’ll fix that in the next section.

8 Close the Paragraph Designer.

9 Close the formatting bar.

10 Choose View > Rulers to hide the rulers.

Changing the contents of entries
The table of contents now has the general appearance you want, but the entries still may 

not be quite right for the intended design. For example, suppose you’d like the preface and 

chapter titles to appear without page numbers. Also, all the Heading1 entries now need to 

contain tab characters to correspond to the tab stop you defined in the Heading1TOC 

format in the previous section. 

Changes such as these affect the contents of entries rather than their formats. For this 

reason, you won’t be using the Paragraph Designer to make the changes. Instead, 

FrameMaker provides a special place to edit the contents of TOC entries: a reference page.

1 Choose View > Reference Pages.

The reference page that first appears contains graphics that are used to highlight notes to 

the reader in the chapter. You’ll work on a different page.
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2 Click the Next Page button in the status bar to display the next reference page, named 

TOC. The name of the reference page appears in the status bar.

The page contains a special text flow that controls the contents of the entries in the table 

of contents. The first paragraph—which is just one line long and whose text is 

<$paratext> <$pagenum>—is tagged PrefaceTitleTOC. 

This paragraph contains two building blocks, <$paratext> and <$pagenum>. Building 

blocks are special pieces of text that control the content of an entry. In this case, 

<$paratext> and <$pagenum> indicate that the text of the preface title and its page 

number should appear in the table of contents. The space between the two building blocks 

tells FrameMaker to insert a space between the text and the page number.

3 Place the insertion point at the end of the first paragraph (tagged PrefaceTitleTOC) and 

press Backspace to delete the <$pagenum> building block and the space before it. This 

instructs FrameMaker to place only the text of the preface title in the table of contents.

4 Press the Down Arrow key until the insertion point is in the last paragraph (tagged 

ChapterTitleTOC). The paragraph tag appears in the status bar.

5 Place the insertion point at the end of the paragraph and press Backspace to delete the 

<$pagenum> building block and the space before it. This instructs FrameMaker to place 

only the text of each chapter title in the table of contents.

6 Press the Up Arrow key to place the insertion point in the second paragraph (tagged 

Heading1TOC).

7 Select the space between the two building blocks and press Tab to replace the space with 

a tab character.

<$paratext> <$pagenum>
<$paratext> <$pagenum>

<$paratext> <$pagenum>
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The special text flow on the TOC reference page now looks like this.

8 Choose View > Body Pages.

Your recent changes are not reflected in the table of contents until you generate the table 

of contents again.

9 Save the table of contents and keep it open.

10 Return to the book window and choose Edit > Update Book.

11 Click Update.

12 Open the updated table of contents and notice that page numbers no longer appear 

next to the preface or chapter titles, and that all the Heading1 page numbers are now 

right-aligned with leader dots.

13 Save and close the table of contents and the book file.

<$paratext>
<$paratext> .............................................. <$pagenum>

<$paratext>
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Moving on
You’ve completed this lesson. For in-depth information about books, tables of contents, 

and other generated lists such as lists of figures and lists of tables, see Chapter 13, “Tables 

of Contents and Indexes,” and Chapter 14, “Books,” in the Adobe FrameMaker User 

Guide.

Review questions
For answers to these questions, see page 378.

1 What are some of the advantages of using a book file?

2 Where do you find the commands you need for working with a book file?

3 How do you access a context menu for a book window?

4 How can you open the individual files in a book file or open all files in a book?

5 When you set up a table of contents for a book, why do you have to move some tags to 

the Include Paragraphs Tagged scroll list?

6 How do you control the pagination of a file in a book?

7 When you add a title to a table of contents, why doesn’t FrameMaker overwrite it when 

it updates the file?

8 What are the two basic steps you need to perform to format entries in a table of 

contents?
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