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BY DAVID GALLAGHER

Continuing Character Setup in
Softimage|3D
To be transformed into a convincing
animated character, a model must be prepared for all the kinds of motion you
intend to create. This preparation—
basically everything between modeling
and animating—is called character setup.
In the first part of this series on character setup in Softimage, we looked at constructing a character’s skeleton (see “Character Setup in Softimage,” May 1999, p.
49). A web-based supplement discussed
attaching the character to the skeleton
using Softimage’s enveloping process (visit
“Web Only Content” at www.3d-design.com).
If you’ve followed along this far, your character should be able to bend and move with
its skeleton. In this installment, we’ll make
a set of animation controls so the character
will be easy to manipulate.
As I mentioned in part one, lack of foresight during the setup phase will mean a
limited performance during animation. Character setup should allow for a complete
range of movements, poses, and emotions.

dren follow along. But what if you wanted

Your ability to pose and animate a charac-

the hands or feet to stay put or the head

ter quickly will be aided greatly through the

to sit still while the shoulders rotate?

use of constraints.

That’s where constraints come in.

A constraint is simply a way to attach or

Softimage|3D certainly isn’t the only

relate one object to another object. Con-

program that allows for setups using

straints free you from the traditional limita-

constraints and expressions (a mathe-

tions of the hierarchy. Think of a simple

matical relationship between two

skeleton, designed in a linear fashion from

objects similar to a constraint), but it

the torso out to the limbs. When you move

has been the standard in character

or rotate a parent in the hierarchy, all the chil-

setup for years. Despite its slow devel-

Now that your Softimage|3D
character has developed
some backbone, the setup
process continues with a
look at controls, constraints,
and expressions.
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opment and the long wait for Sumatra (the
next generation of Softimage|3D), it
remains one of the strongest 3D programs
available for creating animated characters.
Softimage|3D allows you to take a freeform
approach to character setups; it’s an open
workflow that doesn’t feel like an add-on or
a plug-in. Softimage|3D’s toolset lets you
build a working virtual machine for manipulating your character.
To demonstrate the power of con-

FIGURE 1. You can use Effect→Alignment to get the null into position, then use

straints, we’ll continue using Stuart, the

Constraint→Position to attach the leg end effector to the null (now colored blue and

star of part one, who was designed origi-

scaled bigger for easy selection).

nally for an in-house project at my company,
Cineframe Animation.
Without using constraints, you could certainly pose and keyframe the end effectors
themselves. However, there’s a good reason

onette strings. As a result, this system is
sometimes referred to as the “marionette”
approach.
In Softimage|3D, a constraint object

to use constraints instead. A keyframed

isn’t a special kind of object. It’s simply any

end effector can’t have a parent relation-

object to which another object (or objects)

ship—its position can relate only to global

has been constrained. Normally, you’d

coordinates. If you were to need to move a

choose something generic, like a null or a

character globally after animating it, any

spline—a simple object that won’t render

end effectors you had keyframed would

and that’s easy to see and select.

drag behind, pointing toward the last
keyframed position. You can avoid this prob-

Leg Constraints Let’s start with the legs.

lem by constraining end effectors to other

We’ll use a null as a constraint object for

control objects, which, unlike end effectors,

each leg. To create the first null, choose

can have parent relationships.

Get→Primitive→Null. We need to place this

FIGURE 2. One way to control the plane

null in the same position as the left leg

of a 2D chain is an Up Vector constraint.

archy of control objects separate from the

end effector. With the null selected, choose

Here, the first joint of the leg points

skeleton that have their parent-child rela-

Effect→Alignment. In the dialog, select the

along its Y axis to the null. Moving the

tionships. For example, some of these rela-

X, Y, and Z Direction check boxes. Click OK,

null from side to side twists the leg

tionships might rotate the hips while the

then select one of the leg end effectors.

chain, making the knee point in or out.

torso stays still, while others might rotate

The null jumps to the position of the end

the hips and the torso together. The skele-

effector. To complete the process, select

instance, the positioning of the knees and

ton follows the constraint objects, which in

the end effector and choose Constraint→

arms in relation to the body.) Position a

turn drive deformations and movements in

Position, then select the null. Once the

null behind the body near the legs. It’s best

the body. This type of character setup is

constraint is active, you can no longer

if you position it exactly on the current

three-tiered: consisting of body geometry,

move the end effector—its position is

plane of the legs to maintain the default

skeleton, and constraints.

determined entirely by the position of the

pose. To do so, open an ortho window with

null (Figure 1). Depending on how large

the upper leg joint selected. Choose Y

skeleton and body appear as one hierarchy

your character is in the workspace, you

directly above the window to align the view

and the constraints are connected with yel-

may want to scale the null up to make it

with the Y axis of the selected object. Posi-

low lines to the individual constraint objects.

easier to see (even in shaded mode with

tion the null exactly behind the middle line

The three-tiered system looks like a tradi-

Show Icons active).

in the joint of the upper leg (Figure 2).

Using constraints, you can create a hier-

In Softimage|3D’s Schematic view, the

tional marionette in the schematic window;

To control the plane of the 2D chain

Select the joint again, choose

the character animation controls (also called

created in part one, you can apply an Up

Constraint→Up Vector, then select the null.

constraint objects) look like wood crossbars,

Vector constraint object. (This object con-

The leg chain should point directly away

and the constraint lines resemble mari-

trols the orientation of the chain, for

from the null without moving from its cur-
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rent orientation. Now, add the null into the
constraint hierarchy. Repeat the process
for the other leg, and finally parent both
constraint nulls to a parent null.
Saving a translation keyframe
(SaveKey→Object→Explicit Translation→All)
on each of the leg nulls lets you experiment
freely with the positions of the legs without
losing the original positions of the nulls.
Once the constraints are active, you can no
longer reliably use Skeleton→Reset Actor to
return the character to its default position;
constrained parts will always snap back to
their constrained positions after a refresh.
If you place the constraints just right for the
default position and save keyframes, you
can always return to the original pose when
you need to.
The constraint for the hips chain (with
its root near the belly) should be the main

FIGURE 3. The points of a spline cube can hover conveniently over the hips area, while
its center (the red and green arrows in the upper left window) remains in position at
the root of the hips chain.

parent of the rest of the body. Instead of
using a null this time, it might be easier to

Repeat this process with Constraint→Ori-

joints in the schematic window. Instead, I

use a spline (in this case a primitive

entation, and parent your new hips control

find it simpler to keep applying constraint

square, which is a linear spline drawn in a

to the parent of the two leg controls. To

objects even to parts like this that don’t

square shape). Spline objects, like nulls,

keep the default pose (as I mentioned ear-

need constraint objects but can benefit

won’t show up in renders and they aren’t

lier), save an Explicit Translation and Rota-

from the easier selection and visualization.

solid-shaded in OpenGL mode. They appear

tion keyframe on the square. This control

This approach has the added benefit of

to hover over your character’s geometry, so

now rotates and translates the whole body,

maintaining all the animation information in

they’re easier to select. And, unlike nulls,

except the legs.

one hierarchy and one animation file.

size is convenient, while the center remains

Independent Hip Rotation To control hip

cube as a constraint object. (Again, any

at the default scale of 1.

rotation independently of the upper body,

object can be used as a control.) Similar to

spline points can be scaled to whatever

Choose Get→Primitive→Square. Rotate

For areas like this, I tend to use a spline

you can simply rotate the hip joint, which is

a spline square, a spline cube is made

90˚ in X, then choose Effect→Freeze→

just beneath the root that was constrained

from a single linear spline, drawn in the

Transformations. To position the square at

earlier. Because the two leg chains are par-

shape of the cube. In shaded view, the

the hips, choose Constraint→Position

ented to this joint (or the end effector), the

cube doesn’t appear solid-shaded; only the

(instead of Effect→Alignment) and select

upper legs will always move with the hips.

lines show, hovering over the character’s

the root of the hips chain. We also want

But selecting joints in shaded mode is prob-

geometry. To make a spline cube, create a

this control to rotate the hips, so choose

lematic. Unfortunately, Softimage|3D does-

default primitive cube, then use Magnet→

Constraint→Orientation and then select

n’t have an X-ray mode that allows you to

On Point (located in the window’s Layout

the hips’ root. The square moves and

see joints within the shaded geometry, so

Options menu) to draw a linear curve over

rotates into position. Next, you need to

grabbing the hip joint can be tricky if you

each point and segment of the real cube.

undo the constraints while keeping them in

aren’t in wireframe mode. You could use

When you’re finished, discard the default

place. Choose Constraint→Relax and hit

the selectability feature to freeze the char-

cube and your spline cube is ready.

the middle mouse button to relax both con-

acter’s geometry and make it unselectable.

straints. Now repeat the process the other

To select the geometry you want to freeze,

straint→Position to move the spline cube

way, constraining the hips’ root to the

choose Select→Selectability→Toggle Selec-

into position over the hip joint. In this situa-

square’s position and orientation. Select

tion. Still, without a wireframe window visi-

tion, you’ll never need the constraint to

the root of the hips chain, choose Con-

ble, it’s hard to be sure what you’ve

translate the joint, only to rotate it, so after

straint→Position, and select the square.

selected. Of course, you could select the

relaxing the translation constraints, use

Use Constraint→Orientation and Con-
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Constraint→Orientation on the hips joint to

and the end effector will no longer be con-

the spline cube. Note that constraints can

strained to the null in those frames.

be used to aid in forward kinematics as

A more reliable and interactive way to

well as inverse kinematics (IK). In this situa-

allow for both inverse and forward kinemat-

tion, one constraint is used for driving rota-

ics is to apply an expression to the arm

tions only (forward kinematics), while others

end effector telling it to attach to a null only

affect translation (as with the legs) and still

if a certain condition is met. For instance,

others affect both rotation and translation

you can get a third null to act as a switch:

(as with the hips’ root).

When it translates to or above a value of 1

FIGURE 4. An expression can be used to

Parent the spline cube to the spline

in Y, the IK constraints will become active.

control whether an end effector will be

square hip control, then save a translation

Otherwise, you can use direct forward kine-

constrained to a null at any given time.

and rotation keyframe. You can also tag the

matics on the joints.

This expression tells the end effector to

points of the spline cube and translate

To make this setup, get a null to act as

follow its null, arm_lf, only when the null
ikswitch is greater than or equal to 1.

them to the best position for visualization

the switch (called a slider), and name it

purposes. This is fine, since you’re not

ikswitch (in Info→Selection). Name the arm

changing the object’s center. The spline

control arm_lf. Select the end effector and

ikswitch to 0, and the arm will no longer be

cube will function the same way as before,

choose Motion→Expressions→Edit. Type

constrained to the null. For constraint

but it will appear to hover over the entire

“etrnx” in the Affected Element portion

switching during animation, simply animate

area affected by it rather than over the root

after the object name or select etrnx from

the Y position of the ikswitch null.

only (Figure 3).

Fcurves. Etrnx is the function curve that
describes the explicit translation in X.

Inverse and Forward Kinematics A use-

For the part of the box labeled Expres-

If you attach an Up Vector constraint to
the arm chain (as you did previously with
the legs), you’ll need to add expressions

ful arm setup will allow you to switch

sion, put your cursor in the field, then click

between inverse and forward kinematics. If

on Condition in the Functions box. Click

a character is leaning on a desk, for exam-

Insert, which inserts the condition “tem-

to the joints for the forward kinematic

ple, you’ll want the arm to stay positionally

plate” into the Expression area. Select the

motions, the way you did with the hips rota-

independent from the body. As you make

<cond> part and type over it with the condi-

tion control. Joint rotation controls are eas-

changes in the spine and hips, the hand

tion part of the equation. Since you want

ier to select, and they maintain all the body

can stay locked to the desk through IK. But

the expression to apply only when the slider

animation under one null. However, they’re

when the position of the hand isn’t the top

null is at or above a value of 1 in Y, type in

more difficult to set up because you have

priority, many animators prefer the look and

ikswitch.etrny>=1, which means “if ikswitch

to turn some constraints off and turn oth-

control of forward kinematics. It’s easier to

is equal to or greater than 1 in Y transla-

ers on at the same time.

overlap the rotations of the arm joints—

tion...” Now replace the <true_expr> part

normally, you’d want the lower arm to rotate

with arm_lf.etrnx. This means “then make

parent any constraint objects to the appro-

into place slightly after the upper arm. This

my value the same as arm_lf.” For the

priate parent in the constraint hierarchy (in

procedure is difficult to simulate using IK.

<false_expr>, type in this.etrnx, which

this case, either the main null or the main

The simplest way to allow for both

deactivating that constraint as well.
Alternatively, you might apply constraints

Whichever method you use, be sure to

means “otherwise, let my value remain

hips constraint). And don’t forget to save

inverse and forward kinematics is to use the

unchanged (do nothing).” Hit Validate to val-

an explicit translation and/or rotation

dopesheet to deactivate a portion of the

idate the script and make sure you have no

keyframe.

time line for the relevant constraint. To do

syntax errors (Figure 4).

this, apply a constraint null to an arm the

Select the Expression part and click

Spine and Chest A common approach to

way you did earlier for the legs. Select the

Copy. Click on Next, then paste it into the

constructing a spine is to make a three-joint

arm end effector and open the dopesheet.

expression part. Change the Xs to Ys,

chain from the hips to the base of the

Click once to the left of the green bar. You

including the one in the affected element.

neck. Since every node in a spine must be

should see “CnsPos” in the green bar, which

Hit Validate, then repeat the process for Z.

able to twist in X as well as rotate in Y and

indicates that a position constraint has

This will give you three expressions, one for

Z, a 3D chain should be used. (Note: Draw-

been applied to the end effector. Drag a box

each axis.

ing 3D chains in the Right window is differ-

selection over part of the time line. Click

Try out the expressions by translating

ent than with 2D chains—the Z axis always

DEACT just above in the dopesheet window.

ikswitch up to 1, then moving arm_lf

points along the global Z axis. You may

That portion of the time line will turn gray,

around. The arm end effector follows. Move

want to draw a 2D chain and switch it to a
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3D chain using Skeleton→Toggle 2D/3D for
more consistent rotation values.) When animating, pose the spine and chest by beginning at the bottom of the chain and rotate
each joint successively to the top.
An easier approach might be to control
the motion from the top down using what
could be called an artificial chain. That is,
instead of building a multi-joint chain,
you’ll link together several single-joint
chains. In the Right window, draw three
single-joint chains up the spine, aligning
the bottom joint’s end effector with the
next joint’s chain root. Constrain each end
effector to the next chain’s root, up the
line from bottom to top. Position several
nulls between each chain, and constrain
each chain root to a null.
For the top chain, constrain the root
both positionally (Constraint→Position) and

FIGURE 5. In this top-down approach to spine control, each node up the spine can be

orientationally (Constraint→Orientation).

translated for positioning while the gradual twisting down the spine is controlled

Now you can control the top of the spine

through expressions based on the rotation of the top (chest) joint. (Note: This screen

via one null and each link using the other

shot is a composite. Softimage|3D doesn’t have a display mode that allows a skeleton

nulls. The top chain or joint can be posi-

to show through shaded surfaces.)

tioned and rotated quickly and the other
links translated quickly to form a pose.

top null (from the Scn Elements box). After

strain a series of joints to clusters along a

Using this method, the joints detach when

the name and period, type “roty” and then

spline and animate the spline. You can

the nulls are pulled out of reach, creating a

“/2” or 3 or 4, depending on how many

deform the spline to another spline with

stretching effect useful for spines. Note

joints you’ve made to represent the spine.

fewer points for even finer control. This

that your body’s spine can stretch a bit as

This procedure tells the joint to rotate half

approach allows you to control many joints

well. But the biggest advantage here is the

as much in X as the chest null rotates in Y.

via very few points. You can drive rotations

ability to do top-down posing.

Hit OK and repeat this process with each

of a series of joints by rotating a single null

spine joint (you can use Expressions→−

through expressions.

While each node can translate and the
top node can translate and rotate in any

Copy), decreasing the value of the rotation

direction, all twisting in X down the chain is

by increasing the division number. Last, you

Remain Flexible Once you’ve set up con-

controlled by the top node. Since the joints

need to zero the rotation values of the

straints, it’s easier to manipulate all of your

are not a single IK chain but a series of dis-

chest null to make it work properly—make

controls using the Preferred Transformation

tinct chains linked artificially, you can drive

the value 0,0,0 with an effective value of

feature. For instance, select the chest con-

their rotations through expressions. Other-

0,90,0. To do this, parent the chest null to

trol and choose Info→Transformation

wise, the expressions would conflict with

a new null with a rotation of 0,90,0 (or par-

Setup. Click on the Rotate button and

the chain’s built-in IK.

ent to the hips square which is oriented

choose Y (check off X and Z). Whenever you

this way) and set the chest null to 0,0,0.

select the chest control, the transformation

null oriented like the chain root, you need

When the controlling null rotates, it will do

mode will switch automatically to the preset

to link the X rotation (twist) of each lower

so in local space, yielding more predictable

choice. This feature is especially helpful for

joint to the Y rotation of this chest null

rotation values. Its rotation will now twist

rotations, because you don’t need to

(roots are oriented differently than joints).

the spine in decreasing amounts from the

remember which axis you’re most likely to

Select the first joint below the top one and

top down (Figure 5).

use whenever you go to rotate the object.

Because the top joint is controlled by a

choose Expressions→Edit. Type “rotx”

Many other methods can be employed

You can still use the other axes, of course,

where the cursor is, in Affected Element. In

to set up spines and spine-like structures

but this method can speed up the anima-

Expression, type or select the name of the

such as tails and long necks. You can con-

tion workflow quite a bit.
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It’s important to remember that a char-

counter, chin resting in hand, while moving

We’ve looked at only a few options and

acter setup can be changed as the need

its torso slightly and gesturing with the

essentials for character setups. With an

arises. Constraints can be deactivated and

other hand? With the current setup, which

engineer’s attention and an eye open to the

temporary constraints can be added. The

is designed to accommodate hand posi-

numerous possibilities, you’ll find character

whole thing can be thrown out for a particu-

tions only, this could be a very difficult shot.

setup a fascinating study and an amazing

lar shot and replaced by a setup that better

But if you design a setup to accommodate

help during character animation.

fits the needs of the movement. What if

the specific motion you need, your anima-

your character has to lean its elbow on a

tion will go much more smoothly.

•

