0.Silicon Graphics® O2®
R5000® Class CPU Upgrade
Installation Instructions

This flier describes upgrading your O2 R5000 system with a newer CPU. The instructions
for installing the processor module upgrade are different depending on which version of
the operating system you are using. After checking your shipment, begin on one of these
pages:
•

“Installing the Upgrade on IRIX 6.3 Systems” on page 2

•

“Installing the Upgrade on IRIX 6.5 Systems” on page 9

Follow the installation instructions provided in this flier in the order in which they are
given. First install the operating system software if needed, then install the software
patches, and finally, the hardware.
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Checking Your Shipment
The following items are included in this shipment:
•

IRIX 6.3 for O2 Including R10000 CD

•

IRIX 6.3 Recommended/Required Patches 6/99 CD

•

IRIX 6.5.x1 Overlay CDs

•

Wrist strap

•

Reversible screwdriver

•

R5000 class CPU processor module

•

Upgrade label

Installing the Upgrade on IRIX 6.3 Systems
Follow the upgrade instructions in this section if your system is running IRIX 6.3.
To upgrade your CPU, verify that you are running correct version of IRIX 6.3 and if not,
upgrade to the required version. Then install the IRIX 6.3 Recommended/Required
Patches 6/99 CD and install the processor module upgrade.
Procedures for locating and installing relevant documentation begin on page 7.
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Overlay software is labeled “IRIX 6.5.x, “x” referring to the current numbered version of the software,
for example 6.5.3. Base software is referred to as IRIX 6.5.
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Verifying and Installing the Operating System
Install the software before installing the hardware.
For the O2 R5000 class CPU upgrade, you need the version of the IRIX operating system
software called “IRIX 6.3 for O2 Including R10000.” Follow the steps below to make sure
your system is running the correct version before installing the patches and beginning
the hardware upgrade.
1.

Check your workstation’s IRIX version. In a shell window, enter:
uname -R

•

If you see 6.3 O2 R10000, you have the correct IRIX version. Go to “Installing
the IRIX 6.3 Recommended/Required Patches 6/99 CD” on page 4.

•

If you see 6.3 O2, you must upgrade your workstation to the correct operating
system before installing the patches and the hardware. The IRIX 6.3 for O2
Including R10000 CD is included in this shipment. Read the Caution below, and
then go to step 2. Otherwise go to “Installing the IRIX 6.3
Recommended/Required Patches 6/99 CD” on page 4.

Caution: Do not install the patch CD that contains the recommended patches now.
You do this later, after the IRIX and Applications CDs are installed and you have
rebooted the workstation. If you install the patches without rebooting, the flash
PROM environment variables may become corrupt.
2. Install IRIX 6.3 for O2 Including R10000
Read any letters or instructions that came with the CD. The CD booklet explains
how to read the release notes.
3. When IRIX 6.3 for O2 Including R10000 has been installed, you must reboot the
system before installing the patches CD. From the toolchest, choose Restart System.
Log in as usual when you see the Login screen.
You are ready to install the patches.
Note: Now that the system is running the correct version of IRIX, if you ever need to boot

from a CD (the miniroot), you must use the “IRIX 6.3 Recommended/Required Patches
CD”, not an operating system CD. The new hardware (CPU) is not compatible with the
original IRIX 6.3 operating system CD.
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Installing the IRIX 6.3 Recommended/Required Patches 6/99 CD
Caution: If you just installed “IRIX 6.3 for O2 Including R10000” and have not rebooted
your system, do so before installing the “6.3 Recommended/Required Patches 6/99”
CD.
1.

Insert the “6.3 Recommended/Required Patches 6/99” CD in the CD-ROM drive
and double-click the CD-ROM drive icon on the desktop. If you have a root
password set, you are prompted to enter it.

2. Read the Installation Startup message that displays and click Dismiss.
3. Choose /CDROM/dist/ in the Software Manager window, and click Open.
4. Read the Installation Startup script and follow the instructions.
5. In the Software Manager window, follow the instructions to install the patches.
Click Start to begin installation. When you are asked in the Open Additional
Distribution window if you want to install additional software, click Done.
6. Follow the installation instructions that are displayed in Software Manager. When
the installation is complete, from the File menu choose Exit.
7. From the Toolchest, choose System > Restart System.

Installing the Processor Module
To install the processor module upgrade in your workstation, refer to the installation
instructions in the O2 Workstation Owner’s Guide (printed) that came with your O2
workstation, or the online O2 Hardware Reference Guide. In the printed guide, find the
section “Replacing the R5000 CPU Module” and follow the instructions. Instructions for
locating the online O2 Workstation Hardware Reference Guide are in “Locating Online
Processor Module Upgrade Instructions” on page 7. Instructions for installing the guide
from the CD are on page 7.
You may be removing a processor module that has one of two form factors, L-shaped or
rectangular shaped. The processor module you receive with this upgrade is L-shaped.
Figures 1 through 3 provide additional information to the instructions found in the O2
Workstation Owner’s Guide and the O2 Hardware Reference Guide.
Note: Attach the O2 upgrade label near the system label on the bottom of the

workstation.
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Figure 1

Removing the Rectangular-Shaped Processor Module

Figure 2

Removing the L-Shaped Processor Module
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Figure 3

Installing the L-Shaped Processor Module Upgrade

Troubleshooting
If your workstation does not boot after installing the processor module, read the
processor module installation instructions carefully to make sure the new processor
module is correctly seated. Be sure you installed the software before installing the
hardware.
Check that the system is running the correct version of IRIX. See “Verifying and Installing
the Operating System” on page 3.
If necessary, remove the new hardware, reinstall the old hardware, install the operating
system software, remove the old hardware, and install the new hardware.

6

Silicon Graphics® O2® R5000® Class CPU Upgrade Installation Instructions

Locating Online Processor Module Upgrade Instructions
If you installed “IRIX 6.3 for O2 Including R10000,” the O2 Workstation Hardware Reference
Guide was installed by default on your system disk. See “Viewing the Book From the IRIS
InSight Library” below. If the book was removed from the system disk, see “Installing the
O2 Workstation Hardware Reference Guide From a CD” on page 7.
Viewing the Guide From the IRIS InSight Library

To locate the online book:
1.

From the Toolchest on your desktop, choose Help > Online Books > SGI End User >
O2 Workstation Hardware Reference Guide.

2. Choose Ordering, Removing, and Installing Replacement Parts.
3. Search for “Replacing the R5000 CPU Module”.
You can view the book online, or print the information you need. To print, from the Books
menu in IRIS InSight, choose Print.
Installing the O2 Workstation Hardware Reference Guide From a CD

If the online manual has been removed from your system disk, you can reinstall it from
the O2 IRIX operating system CD that came with your upgrade. Follow these steps:
1.

Place the “IRIX 6.3 for O2 Including R10000” CD in the CD-ROM drive and
double-click the CD-ROM icon on your desktop. The Software Manager window
appears. Click the Dismiss button.

2. Click Customize Installation.
3. When the Open Additional Distribution dialog box appears, click Done.
4. From the Selected menu, choose Unmark All.
5. From the Selected menu, choose Find.
6. When the dialog box appears, enter Hardware Reference Guide, and click Search.
Software Manager highlights the O2 Hardware Reference Guide in its Software
Inventory Window.
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7. Click in the Install check box to select the book for installation, and click Start to
begin the installation. When the installation is complete, you see a message
“Installation and removals were successful. You may continue with installation or
quit now.” Click OK.
8. Exit Software Manager by choosing Exit from the File menu.
9. To locate the online books, from the Toolchest choose Help > Online Books > SGI
End User > O2 Workstation Hardware Reference Guide.
10. If the book does not appear on the End User Bookshelf, you may have to update the
InSight database. In a shell window (to become super user) at the prompt, enter:
su

(Also enter the root password if you are prompted for it.)
11. To update the InSight database, enter:
/usr/lib/infosearch/bin/booksAdmin -full -hwdi \
/usr/share/Insight/library/SGI_bookshelves

See “Viewing the Guide From the IRIS InSight Library” on page 7 for instructions on
viewing the book online.

Viewing the O2 Workstation Hardware Reference Guide on the
Internet
If you have access to the Internet, you can view the O2 Workstation Hardware Reference
Guide in the Technical Publications Library on the Silicon Graphics home page at
http://techpubs.sgi.com/library/.
Search by the title and for “Replacing the R5000 CPU Module.”
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Installing the Upgrade on IRIX 6.5 Systems
Follow the upgrade instructions in this section if your system is running IRIX 6.5.
To upgrade to the R5000 Class CPU, install the IRIX 6.5.x Overlay software and install the
processor module.

Verifying and Installing the Software
Install the software before installing the hardware.
For the R5000 class processor module upgrade, you need the IRIX 6.5.x Overlay software
that came with this shipment. You must have IRIX 6.5 base software installed.
Note: IRIX 6.5 base operating system software does not ship with the processor module

upgrade. Contact your local sales representative to order the base operating system.
Install the base operating system software, then the 6.5.x Overlay CDs before installing
the processor module.
To check your workstation’s IRIX version, from the Toolchest > Desktop, open a UNIX
shell.
At the prompt, enter
uname -aR

Use the Installation Instructions booklet that comes with your IRIX 6.5.x Overlay CDs for
installing the operating system software.
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Installing the Processor Module
Install the software before installing the hardware.
For instructions on installing the processor module upgrade, see the section in the O2
Workstation Owner’s Guide, Chapter 5, called “Replacing the R5000 CPU Module”. This
information is also found in the online O2 Workstation Hardware Reference Guide.
Instructions for locating the online O2 Workstation Hardware Reference Guide are in
“Locating Online Processor Module Upgrade Instructions” on page 11. Instructions for
installing the guide from the CD are on page 10.
Note: Attach the O2 upgrade label near the system label on the bottom of the

workstation.

Troubleshooting
If your workstation does not boot after installing the processor module, read the
instructions carefully to make sure the new processor module is correctly seated. Be sure
you installed the software before installing the hardware.
Check that the system is running IRIX 6.5. To check your workstation’s IRIX version,
from the Toolchest > Desktop, open a Unix shell.
At the prompt, enter
uname -aR

If necessary, remove the new hardware, reinstall the old hardware, install the software,
remove the old hardware, and install the new hardware.
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Locating Online Processor Module Upgrade Instructions
To locate the online O2 Workstation Hardware Reference Guide, go to the Toolchest > Help
> InfoSearch. Type the title of the guide and it appears in your browser window.
To install the online O2 Workstation Hardware Reference Guide, see the Installation
Instructions booklet that came with your base operating system CDs.

Viewing the O2 Workstation Hardware Reference Guide on the
Internet
If you have access to the Internet, you can view the O2 Workstation Hardware Reference
Guide in the Technical Publications Library on the Silicon Graphics home page at
http://techpubs.sgi.com/library/.
Search by the title and for “Replacing the R5000 CPU Module.”
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