0. Silicon Graphics® O2® Workstation Memory
Installation Instructions

This flier provides hardware and software instructions for installing dual inline memory
modules (DIMMs) in a Silicon Graphics O2 workstation. Depending on which version of
IRIX you are using and the total size of the memory after the new memory installation,
you may or may not have to install software patches.
•

If you have an O2 workstation running IRIX 6.5, skip to “About DIMMs” on page 4
to begin the installation process. You do not have to install any software.

•

If you have an O2 workstation running IRIX 6.3, you must check the particular
version of the operating system and install patches for memory configurations
larger than 256 MB. For example, if you will have a total of 256 MB of memory after
installing the new DIMMs, you do not need the patches. If you will have more than
256 MB of memory after you have installed the new DIMMs, you need to install the
patches. Begin the installation process with “Checking the Operating System
Version” on page 2.

The following topics are covered in this flier:
•

“Checking the Operating System Version” on page 2

•

“Installing the Patches for IRIX 6.3 With More Than 256 MB of Memory” on page 3

•

“About DIMMs” on page 4

•

“Installing the DIMMs” on page 5

•

“Verifying the Hardware Installation” on page 7

•

“Troubleshooting” on page 8

•

“Locating Printed Memory Upgrade Instructions” on page 8

•

“Locating Online Memory Upgrade Instructions” on page 9
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Checking the Operating System Version
Before installing either the patches or the DIMMs, make sure you are running “IRIX 6.3
for O2 Including R10000” (or later). Follow the steps below to check your operating
system version.
1.

To check your workstation’s IRIX version, in a shell window, enter
uname -R

•

If you see 6.3 O2 R10000, you have the correct IRIX version. Go to “Installing
the Patches for IRIX 6.3 With More Than 256 MB of Memory” on page 3.

•

If you see 6.3 O2, you need to upgrade your workstation to “IRIX 6.3 for O2
Including R10000” before installing the patches and the hardware. This version
was mailed to all current O2 owners in December 1996. It is also available from
the following SGI Web site:
http://www.sgi.com/support/patch_intro.html

Caution: Do not install the patches until after the IRIX CDs are installed and you
have rebooted the workstation. If you install the patches without rebooting, the flash
PROM environment variables may become corrupt.
Read any letters or instructions that came with the “IRIX 6.3 for O2 Including
R10000” CD. Also read the online release notes. The booklet that comes with the CD
explains how to read release notes.
2. After installing “IRIX 6.3 for O2 Including R10000,” you must reboot the system
before installing any patches. From the toolchest, choose Restart System. Log in as
usual when you see the login screen.
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Installing the Patches for IRIX 6.3 With More Than 256 MB of Memory
Caution: It is important that you install the entire patch set. If you install less than the
complete set, you may not be able to boot your system. Also, if you have more current
patch versions installed, and patches on this CD are downgrades, keep the most current
versions. Do not install the downgrades.
Follow these instructions to install the patches.
1.

Insert the Patches CD in the CD-ROM drive. Wait a few seconds while the system
reads the CD, and then double-click the CD-ROM drive icon on the desktop. If you
have a root password set, you are prompted to enter it.

2. Read the Installation Startup Message that displays and click Dismiss.
3. Select /CDROM/dist/6.3_O2/ in the Software Manager window, and click Open.
4. Read the Installation Startup Script and click OK.
5. In the Software Manager window, click Start to begin auto-installation. When you
are asked in the Open Additional Distribution window if you want to install
additional software, click Done.
6. Follow the installation instructions that are displayed in Software Manager. When
the installation is complete, from the Software Manager File menu, choose Exit.
7. Place the cursor over the CD-ROM drive icon, right click the mouse, and choose
Eject CD-ROM.
8. From the Toolchest, choose System > Restart System.
Once you have installed the software, go to the next section to install the hardware.
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About DIMMs
Before you begin installing the DIMMs you received, read this section. The DIMMs are
color-coded to assist you in identifying what is already installed. Knowing what is
installed is important because the largest size DIMMs must be in the first bank. Several
other important rules also apply to installing DIMMs in your O2 workstation. These
rules follow the table in this section.
To determine which DIMMs are already installed, use the following illustration and
table.
Color code 1

Color code 2

Figure 1

Locating the Color Codes on the DIMM

DIMM color code 1 is located on the top corners of each DIMM. Color code 2 is located
in the middle of the top edge of the DIMM.
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Kit
(2 DIMMs per kit) DIMMs

SGI Part No.

Color Code 1
Single-Sided (SS)
DIMM
(by Size)
Color Code 2 or Double-Sided (DS) Type

32 MB

16 MB ea.

030-0881-xxx Purple

-

SS

A

64 MB

32 MB ea.

030-0876-xxx Yellow

-

DS

A

128 MB

64 MB ea.

030-1492-xxx Green

White

SS

B

256 MB

128 MB ea. 030-1080-xxx Silver

-

DS

A

256 MB

128 MB ea. 030-1473-xxx Silver

White

DS

B
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•

Color-coding relates to size. See the table on page 4 for a list of DIMM sizes and
color codes.

•

The DIMMs in slots 1 and 2 make up Bank A. DIMMs in slots 3 and 4 make up Bank
B, and so on. See Figure 2 on page 6.

•

A bank of two slots must have a DIMM in each slot or be empty (except for slots 1
and 2 which must always be populated.)

•

The two DIMMs in any bank must be of the same size, type, and color code.

•

The largest size DIMMs must be in Bank A.

•

DIMM banks must be filled sequentially, beginning with bank A.

•

Do not skip banks, or the memory is not recognized.

•

The maximum memory configuration in the O2 workstation is 1 GB.

Installing the DIMMs
This is an installation overview for more experienced users. For fully illustrated
instructions, see the section “Installing Memory Modules” in your printed O2
Workstation Owner’s Guide, part number 007-3282-004.
If you do not have your owner’s guide handy, it is available on the Internet in the SGI
Technical Publications Library at the following location:
http://techpubs.sgi.com/library/
(See “Locating Online Memory Upgrade Instructions”.)
1.

Turn off the workstation and remove the power cable from the exterior of the
chassis. There is no need to remove the cables attached to the system module,
although you may find the installation process easier if you do.

2. Pull down the lever of the system module and slide it out of the chassis. (The system
module is on the extreme left as you face the rear of the workstation.) Place it on a
clean, flat surface, such as your desktop.
3. Before touching any of the components, attach the wrist strap included in this
package to your wrist and to a metal part of the chassis.
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DIMM slots

12

34

56

78

Bank A
Bank B
Bank C
Bank D

Figure 2

Locating the Memory Banks

Caution: Memory modules are extremely sensitive to static electricity. Handle the
modules carefully, and wear the wrist strap while installing them.
4. Locate the memory banks in the system module (Figure 2). There are four banks
comprising eight sockets. The sockets are numbered 1 through 8. The numbers are
printed next to the DIMM socket as shown in Figure 2.
Two sockets form a bank. Socket 1 is closest to the CPU on the system board. Socket
8 is closest to the edge of the system module.
Caution: It is extremely important that you install the largest size memory modules
starting in the lowest-numbered slots. If you do not, you may not be able to reboot
your workstation.
5. Remove the existing memory modules by pushing down the latches on both sides to
release them.
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6. Install the largest size memory modules in bank A, slots 1 and 2.
•

Hold the DIMM over the socket without tilting it.

•

Lower the DIMM, pushing it straight down into the socket gently but firmly.
You hear a click as it is seated and the latches on each side snap up.

7. Reinstall the rest of the memory modules consecutively in groups of two, beginning
with the lowest open slot. Do not leave a slot or bank empty between banks.
8. Return the system module to its upright position and slide it into the chassis until
the lever engages. Push the module all the way in to seat it properly, and then push
the lever up to lock the module in place.
9. Reconnect the power cable and any other cables you removed.
10. Turn on the workstation by pressing the power button on the front.

Verifying the Hardware Installation
Follow these steps to verify that the system recognizes the new memory you just
installed.
1.

From the Toolchest on your desktop, choose System > System Manager > About
This System.

2. Check the amount of memory shown. It should equal the total amount of memory
you installed plus any memory that was already installed. For example, if you had
32 MB of memory when you started, and you installed another 256 MB, the total
shown should be 288 MB.
3. If the system does not show the total amount of memory, turn off the workstation,
remove the power cable, remove the system module, and check that each DIMM is
installed correctly. Here are a few tips. Look at the DIMMs from the side, and check
the following:
•

Make sure you have installed the largest size memory in the lowest-numbered
slots, starting with slot 1. Check that there are no empty slots between the
DIMMs.

•

The DIMMs should be absolutely vertical (no leaning). If one is leaning, it
probably is not seated all the way in the slot.
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•

The tops of the DIMMs in the same bank should be even. If one DIMM is higher
than the other one in the same bank, it probably is not seated all the way in the
slot.

•

The latches on the sides should fit snugly against the DIMM.

Troubleshooting
If after installing the additional memory, your system does not boot UNIX, follow these
steps:
1.

Turn off the O2 by pressing the power button on the front.

2. Disconnect the power cord.
3. Remove the system module.
4. Look at the DIMMs from the side to make sure they are seated all the way, and none
are leaning. Check that the largest size DIMMs are installed in the lowest slots, that
is, slots 1 and 2.
5. Read the installation instructions in this flier and the owner’s guide or reference
guide again to see if you missed a step.
6. If the system still does not boot IRIX, restart the workstation.
7. When you see the “Starting up the system” notifier, click Stop for Maintenance, or
press Esc. The System Maintenance Menu appears.
8. Choose “Run Diagnostics” to see if the DIMMs are faulty.
9. If the operating system still does not boot, call your authorized service provider.

Locating Printed Memory Upgrade Instructions
If the instructions in this note are not detailed enough, you can find complete instructions
with illustrations in the printed O2 Workstation Owner’s Guide that came with your
workstation. Find the chapter “Installing or Removing Memory and Option Boards” and
follow the instructions. If you do not have the printed Owner’s Guide handy, see the next
section, “Locating Online Memory Upgrade Instructions.”
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Locating Online Memory Upgrade Instructions
There are several ways you can view the online documentation.
•

If your system is running “IRIX 6.3 for O2 Including R10000, the O2 Workstation
Hardware Reference Guide is in the InSight Library on your system disk (unless it was
removed). See “Viewing the Book From the IRIS InSight Library” below.

•

If the book was removed from your O2 workstation’s system disk, see “Installing
the O2 Workstation Hardware Reference Guide From a CD” below.

•

If you have access to the Internet, you can view the O2 Workstation Hardware
Reference Guide in the SGI Technical Publications Library at the following location:
http://techpubs.sgi.com/library/
For instructions, see “Viewing the Book on the Internet” below.

Viewing the Book From the IRIS InSight Library
To locate the online book, from the Toolchest on your O2 desktop, choose Help > Online
Books > SGI End User > O2 Workstation Hardware Reference Guide.
Search for the chapter “Installing or Removing Memory and Option Boards.” You can
view the book online, or print the information you need. To print, from the Books menu
in IRIS InSight, choose Print.

Viewing the Book on the Internet
If you have access to the Internet, you can view the O2 Workstation Hardware Reference
Guide in the Technical Publications Library on the publications home page at
http://techpubs.sgi.com/library/
Search for O2 Workstation Hardware Reference Guide. Then choose “Installing or Removing
Memory and Option Boards.”
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Installing the O2 Workstation Hardware Reference Guide From a CD
If the online manual has been removed from your system disk, you can reinstall it from
the O2 IRIX 6.3 operating system CD. Follow these steps:
1.

Place the “IRIX 6.3 for O2 Including R10000” CD in the CD-ROM drive and
double-click the CD-ROM icon on your desktop. The Software Manager window
appears.

2. Click Customize Installation.
3. When the Open Additional Distribution dialog box appears, click Done.
4. From the Selected menu, choose Unmark All.
5. From the Selected menu, choose Find...
6. When the dialog box appears, enter Hardware Reference Guide, and click Search.
Software Manager highlights the O2 Hardware Reference Guide in its Software
Inventory Window.
7. Click in the Install check box to select the book for installation, and click Start to
begin the installation. When the installation is complete, you see a message
Installation and removals were successful. You may continue with
installation or quit now. Click OK.

8. Exit Software Manager by choosing Exit from the File menu.
9. To locate the online books, from the Toolchest choose Help > Online Books > SGI
End User > O2 Workstation Hardware Reference Guide.
10. If the book does not appear on the End User bookshelf, you may have to update the
InSight database. In a shell window, enter the commands below.
su
/usr/lib/infosearch/bin/booksAdmin -full -hwdi
/usr/share/Insight/library/SGI_bookshelves

10

Silicon Graphics® O2® Workstation Memory Installation Instructions

©1999, Silicon Graphics, Inc. All rights reserved.
Silicon Graphics, O2, and IRIX are registered trademarks, and SGI and IRIS InSight are trademarks of
Silicon Graphics, Inc.

12

